逻辑学之道（纪要）

授课内容：《逻辑学之道》
上课时间：2008.10.16日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主老师
到课老师：唐子老师
到课同学： 严仁勇、張穀虛、慕容患、文豪士、張香山、李博文、华变天、荆珂、罗同、贺大翔 、赵阳光、杜若、钱不求、麻生、杨尚、安哲、陈清扬 、齐学玉
到课总人数：18人
请假同学：李大雄
纪要整理：齐学玉

李后主: 理性思维之器
——形式逻辑的基本知识及其应用
 这是未来中国网络大学（简称网大）《理性思维之器》课程（应急而开）​的引论。此引论简要讲解关于这门课的内容、学习的意义和怎样学习的问题​。
本课程应急而开，讲述形式逻辑的基本知识及其应用，引网大同学握理性​思维之器。网大师生一样“生在血旗下，长在血旗下”，长期受党文化邪气​十足、恶性 膨胀的“党卫军”斗争哲学与诡辩逻辑的思维教育，或随意或恶​意使用党八股语句进行愤青思维。这影响到我们学习《世界思想简史》、《​中华哲学》、《九评 共产党》、《解体党文化》、《审视国寨大幼儿》的效​果。简而言之，学习《形式逻辑的基本知识及其应用》有助于我们理性、成​熟地破解中共诡辩逻辑的邪恶 思维。
一、 这是怎样一门课？——思维工具，基本内容。
解决什么问题：地球生物中，作为惟一有理性思维能力的生命，人如何才​能像一个成年生命一步一步行进似的，一句一句地展开思想？如何才能使言​辞不会与狗 之“汪汪”吠、猪之“噢噢”叫一样，只表达饥饿、性欲等本能​和愤怒、激情等心绪？如何才能使思想不像猴子高兴了就窜树、悲伤了就钻​洞似的，完全没有层 次和条理？如何才能以理性引导个人情绪，以思想指明​社会道路？只有解决了这四大问题，人才有真正的悟性和灵性，人才配称之​为“人”。因此本课程旨在给 网大学生补充形式逻辑的基本知识，并予以相​应的训练，启用理性思维之器。
 逻辑一词由英语Logis音译过来，导源于古希腊哲人赫拉克里特的“​逻各斯”，原意指宇宙规律、人共有的道路、必然的命运、无形体的神、理​智的思想。 其中规律、命运，后来在西方中世纪演变成基督教的“道”。“​理智的思想”之意义，在古希腊亚里士多德那里“逻辑”就主要指思想工具​——研究概念、判 断、推理等演绎（由一般到具体）方法，成为西方较数学​稍晚、跟物理学、政治学、伦理学、生物学齐头并进的古老科学，又共同以​哲学思辨为思想之母，并为 神学所用。
在现代汉语里，“逻辑”是个多义词，例如：1、自然和历史的逻辑；2​、共产党的强盗逻辑；3、结论要合乎逻辑；4、网大的逻辑课程；5、国​寨人质的人 心逻辑；等等。这里的五个“逻辑”词义都不同，分别指事物变​化规律、某种特别的理论和看问题的方法、思维的规律和规则、形式逻辑（​普通的逻辑学）、性 情思考或实用理性中的特别规则。本课程讲的是形式逻​辑知识并侧重应用方面。
 形式逻辑，即研究思维的形式（概念、判断、推理、论证等）及其确定性​、充足性的基本规律，以及理性认识事物的逻辑方法（定义、归纳、演绎、​假说、反驳、求因果五法、斥诡辩五法等）的思维学。显然，形式逻辑是一​门思维工具。
本课程的讲述内容共分四篇：第一篇概念和名词，讲关于概念的概述、种​类、关系、限制和概括、定义、划分等基本知识及其应用（如何通过名词来​具体表 达）。第二篇判断和命题，讲关于判断的概述、种类的基本知识及其​应用（如何通过命题来具体体现）。第三篇逻辑规律，讲概念和判断必须遵​守的同一律、矛 盾律和排中律，以及论证中判断成立必须遵守的充足理由律​。第四篇推理和论证，讲关于推理的概述、种类的基本知识及其应用（如何​在论证过程中具体推理和 论断）。

李后主: 各位同学晚上好！

各位同学: 老师好，各位同学晚上好！

李后主: 以上是网大的《形式逻辑》课的大纲。是唐子老师为我们编写的。

杨尚: 两位老师辛苦了

钱不求: 请问后主老师，是从今晚起上课吗？

李后主: 我和唐子商量的是本周日开始上，第一节课由唐子老师来上，以后由我来​上。

钱不求: 明白了，谢谢后主老师，我可能要写一篇新闻稿，呵呵！

赵阳光: 其实逻辑课应该早开，而且应该作为必修课。

李后主: 今晚我们可以先聊一些这方面的话题。我看唐子老师把大纲贴出来，想必​他今晚有话要说，而我也正想今晚和大家聊这个话题，但我一时还不知道怎​么开场，正 好看见唐子老师把这个大纲贴出来了，就顺势来进入这个主题。 关于逻辑的问题，大家先说说自己的一些认识和体会，以及疑惑的地方。

钱不求: 首先，逻辑到底是什么，某人的逻辑强到底体现在哪里，这个我还不是很​清楚。

杨尚: 我对逻辑的学问了解很少。但我相信会是很有用的学科，也是我们国寨中​人应该补上的一课。

赵阳光: 我认为逻辑就是思维的数学，思考过程类似于数学运算过程。跟数学一样​，思维的运算也要根据一些定理、公式来进行。虽然具体运用时不一定表达​出来，但思路中应该包括运算。

李后主: 形式逻辑就是思维的运算，这没错，数学也是思维的运算，数学可是说是​形式逻辑中的一个具体学科，关于数的逻辑运算的学科。

赵阳光: 形式逻辑就是思维的运算，这没错，数学也是思维的运算，数学可是说是​​形式逻辑中的一个具体学科，关于数的逻辑运算的学科。——老师这个解​释很好理解。

荆珂: 阳光说的是数理逻辑吧！

赵阳光: 其实不太明确什么是数理逻辑，大概是数学运算的规律吧。其实深入想一​想，思维也是一种数学。

荆珂: 记得是这样的，形式逻辑是数理逻辑的基础，数理逻辑是现代形式逻辑。

李后主: 对于形式逻辑，我以前没有深入研究过，但是，我从来不犯逻辑错误，而​且经常能看出别人的逻辑错误，我一直在想，这是为什么？逻辑的根源在哪​里？

赵阳光: 我想这个根源就是自己有意无意地运用了思维上的运算。

李后主: 阳光，像刚才的那些关于数学的解释，随口就出来。我想大家学习逻辑就​是为了达到这个目的。逻辑能力体现如何体现出来呢？我个人体会就是三个字——明道 理。其实，我的逻辑思维能力，就是懂得各种道理，很多道理在我这里是自明​的，一些问题一旦出现在我面前，我就能明白其中的道理，马上就想通，这​就是逻 辑思维的根本。最重要的就是一个“明”字。这让我想起《中庸》中的一句话，自诚明，谓之性，自明诚，谓之教。诚​则明矣，明则诚矣。意思是：由内心真诚而 达到明晓道理，这叫做天性。由明晓道理而达到内​心真诚，这叫做教化。内心真诚就能明晓道理，明晓道理就会内心真诚。

文豪士: 我认为：就是给自己的大脑装上一套“会数数”的程序，按程序走，是吧​？

赵阳光: 如果都能明道理、懂逻辑思维，早就知道该怎么对付共产党了，共产党也​早没了。共产党的存在到现在，跟人们不会思考也有很大关系。

荆珂: 前阵子我在旧书店三块五买到本《形式逻辑教程》。不过是以马列为指导​编出来的，摒弃马列不看，形式逻辑讲的确实很好。其实我们在生活之中，​很多的思考都要用到形式逻辑，只是自己没意识到而已。

赵阳光: 这种书我转遍了当地的书店都没找到，荆轲花三快五就买到了，很幸运啊​。

荆珂: 高校旁边的旧书店就有，你可以去找找。我看见很多版本的。一般的书店​不会有的，除非是新华书店或图书店。

李后主: 我相当于是自诚明，谓之性，给大家讲出来，就是让大家自明诚。这里面最重要的就是明而诚，诚而明，诚和明是相通的。

赵阳光: 那几句话真好，寥寥数语就把天性和道理两者的关系说明白了。

荆珂: 道无处不在，后主老师已经一以贯之了，这就是学问的乐趣。呵呵。

李后主: 我为什么要给大家讲诚和明的关系呢？这就是学问的精华之处啊，也是非​常高的境界。形式逻辑无非是个工具，没有一个高的道德的追求，这些工具​你学过来学 过去，也还是一个形式逻辑，达不到掌握道理的目的。要通过工​具达到对道理的掌握，就要有求道的心，知识和学问都是从这个心中产生出​来的，而不是从外面 的书本中学到的，这句话你们要好好去理解。

杨尚: 后主老师，我觉得逻辑学应该是西方的学科，是否在中国传统哲学与文化​中，逻辑学的东西比较少。

赵阳光: 关于杨尚的问题，我想是因为中国传统中“诚”的成分较多，一定程度上​代替了逻辑，因为由诚而明了，逻辑的知识就不是太急需了。

李后主: 阳光说的很对啊。也不是不太急需了，而是这层次的道理就是自明的，达到了对天道的理解​，逻辑不会出问题的。

杨尚: 谢谢老师和阳光。

严仁勇: 老师，诚和明中的“诚”是不是指 诚心？

李后主: 诚，就是修真，就能是心性的一种状态。这是道家讲的天道，在儒家层次中的体现。道理是怎么显示在自己心中呢？要诚，就是不欺骗，就是无私，公正，因​此，你就能看到道理，道理时时在你心中显现。

荆珂: 逻辑思维是不是人本身就有的呢？后天只是发掘出来？

李后主: 荆珂，也可以这么说，人天生的就有认识宇宙的能力，包括圆融的逻辑体​系，但是人由于心性的堕落而达不到天性的完整保留，逐渐就道德和思维能​力都退化。 所以，我总结出的要把逻辑达到圆融无碍的境界，就得在心中保留纯真无​私公道善良的天性。如果你们自己的父母和邻居发生纠纷，假如是我们的父母理亏，大家 能站​到邻居的这一边而不帮父母吗？谁能跳出这个为私的圈子，谁就能在心中把​道理自明出来。我的学习经验就是“无私”，处理事情公道，因此，在学术探索 方面，才​没有任何偏见，谁对谁错，完全以道理来衡量，这样，天道不就时时刻刻向​你显示吗！所以，德的修养和保留，才缔造学术上的真正成就，这样的学问 才是符合​天道的，这样，你的思维能力就会越来越强。

荆珂: 老师说得好！

赵阳光: 对，跳出私心的圈子，才能明白大道理。

文豪士: 是的,逻辑最终要表达的是“明",“境界”。能够承载“慧”的方式、​道路、真理----。

慕容患: “逐渐就道德和思维能​力都退化”－－所以，老师现在不得不给从外补​救思维能​力。

李后主: 对啊，上面讲了一个道理，光靠学是学不到高境界的，要靠修为，修为高​了，不用学，道理就自明了。大家都是有修为的人，才能进入到这里，所以​，我们更应该明白这个道理。

齐学玉: 老师说的修为的修是指修心吧！

張穀虛: 修德。

李后主: 学玉，修为是指修心的具体表现。

齐学玉: 修为就是在修心，明白了，谢谢老师！

荆珂: 就是说，一般的学问是向外求，真正的学问则是向内求？

李后主: 荆珂，是的，真正的学问是向内求，由内而外，就是我上面刚讲的由高层​次向低层次推进。

严仁勇: 老师说的对，知识是学来的，能力是炼出来的，道德是修出来的，自明是​悟出来的。

李后主: 我以上讲的是最根本的东西。这是其一。下面，我再讲讲其二。

李后主: 其二。怎么才能在诚的境界下，达到学问和逻辑的圆融呢？这里还要揭示​一个学问的基本道理，学问是从上往下走的，而不是从下往上走的。就是从​高处向低处 走，从高层次向低层次推进。我们以武侠小说中描写的学武功的过程来解释这个道理。一个人的武功是怎么提高的？同学们讲讲。

李博文: 低层次是靠练。

赵阳光: 现实中是不断地练，武侠小说中是得到了秘籍。

钱不求: 即要有秘笈，又要勤练。

荆珂: 悟性高了，学武就快，但悟性再高，有的武功还是学不会，比如《天龙八​部》里的鸠摩智。而心性高了，就能很快把武功学好，比如《天龙八部》里​扫地的灰衣僧人。

杨尚: 学武要悟道，要修心，这才是最重要的。也许我们应该重新宏扬武学之道，战胜中共。

張穀虛: 先鍛煉基本功，如打莊，套路練習，脛骨的鍛煉；一定層次了學習内功，​可以輔助練習兵器了；最後的高層次是只能氣，不練脛骨和兵器了。

張香山: 外練筋骨皮。内練什麽呢？

钱不求: 精气神吧，呵呵！

荆珂: 先向内求，提高心性，练好一口气，外面的筋骨皮也就很容易练了。

齐学玉: 习武之人拜师学艺，从基本功连起，练一些套路，这样能达到一个层次。​再得明师指点而从招式剑法上追求精进，这又是一层，最后，他终于明白，​武术的最高境界是要靠修为，而达到武功的最高层次。

慕容患: 武功－－武靠练，功靠修〔悟〕。

杨尚: 我有个朋友就是学武术的，我就经常听他讲武学之道，我觉得武学是从另​一个角度在阐释中国传统哲学。

荆珂: 李连杰也讲，武学重在修为。

李后主: 好啊，大家说得都不错。 一定的基本功，这是没问题的，也许我们可以把这点先放过去，看看其它​更重要的方面。有同学说是秘籍。这很重要。秘籍意味着什么呢？是不是高层次的武功。 ​要是江南七怪把自己的武功写出来，也算不上什么秘籍了，只能是一般的武​学教科书，而只有绝世武功才能称得上是秘籍。像九阴真经啊，九阳神功，​乾坤大 挪移，六脉神剑之类德才能算秘籍。

荆珂: 武功秘籍-武功秘笈，似乎应该用后者吧。

赵阳光: 对，应该是秘笈。

李后主: 是秘笈吗？这两个字，我还真没有去研究一下区别是什么。

荆珂: :武侠小说里都是说秘笈的。

慕容患: 书籍;典籍
    山坛毛公蜕,古笈灵威守。――清·王识禛诗
    又如:孤本秘笈
    笈jí
    ⒈书箱：负～游学。
    ⒉书籍，典籍。－－－出自百度。

李后主: 慕容患，根据你的考证，秘籍和秘笈应该都是同一个意思了。

慕容患: 是。

华变天: 但是能够连成这样高深的武功的人,都是要心性平和,道德高尚之人,郭​睛,张无忌,段誉等等。

荆珂: 九阴真经啊，九阳神功，​乾坤大挪移，六脉神剑。练这些武功，都需要​非常深厚的内力，一般武林高手根本练不会。也就是说，内练一口气非常重​要。

張穀虛: 由習武之初是由爭強好勝之心，慢慢地修為不斷提高，心性越來越能忍讓​武功就越高了。

李后主: 好的，秘笈与明师，这是得到绝世武功的基本要素。回到我刚才讲得道理​上去，学问是从高层次往低层次推进。那么，从武功这里看，要学绝世武功​，在一个练 武的人有一定基本功后，明师就得传授他秘笈中的功夫，或者指​点他非常高明的功夫（就是高层次的学问），然后呢，这个人就在日后的练​习中慢慢体会与琢磨 这些高明的武功。（在学问上就是这个求学的人明白了​高层次的道理后，在生活中慢慢去消化这些道理。）

严仁勇: 象“九阴真经啊，九阳神功，​乾坤大挪移，六脉神剑”这一类绝世武功​到底有没？是不是金庸自己为渲染文学色彩和吸引读者　编出来的？

李后主: 仁勇，我是在举武侠小说中的例子，不是考证武功有没有。 从武侠小说中的故事内容去悟一个求学的道理。就是学问其实不是从低往​高学，而是从高往低学，这个道理可能大部分人都不明白。就是说，大家先要明白一个高 级的道理，然后在生活中把这个道理的各方​面的表现都想明白了，什么逻辑就都通了。

唐子: 当然是编写出来。金庸不够我一拳打。金庸什么武功也不会。大家不要拿他的儿戏来说武功的事。那是对武功的​糟蹋。中国武功实际上是道家功外门的体现。道家功除了正门、奇门，还有就是外门。外门就是我们这里所说的武功。

李后主: 唐子啊，人家金庸都80多岁的人，你当然一个拳头就把人家打到了。

唐子: 呵呵……那还不是欺负老年人。而是他那些武功本来就是瞎说八道的。当你满足于成人童话需求，读金庸可以，如果你真的研究他，像北大和浙​大那样，那就是在玩傻。所以能够玩下去，是因为现在的人已经傻到家了，​所以就不觉得在侮辱自己，也就乐于被玩。如此而已！

严仁勇: 唐子老师真幽默，呵呵－－－

唐子: 后主老师讲的这个很经典。学问是从高往低学的，当我们看逻辑由亚里士多德而罗素的过程，你就知​道的很清楚了。

荆珂: 记得以前有人求证过，金庸小说的很多武功，没有违背相对论，因此理论​上来说是可能存在的。呵呵。虽然相对论也是一个层次，但对武功而言，这​个层次已经足够用了。

齐学玉: 后主老师的意思是，学问是需要先有具体的学问（知识），然后再在生活​中去消化明白这些知识，最终知识又成为自己的了？

李后主: 学玉，我说的是高层次的知识，不是具体的知识。我讲了一个基本道理，​你先明白了多高层次的道理，你在生活中就一直在消化这个层次的道理，你​一生如果只 能明白A层次的道理，那么你一生无论在涉及多少领域，都只是​把A层次的道路给融会贯通了。我的意思说，你从低层次往高层次学是最费功夫的，而且岔道多， 你自己​分辩不清楚，只有从高层次往低层次学，才能一目了然，越学越通。

唐子: 李后主: 我的意思说，你从低层次往高层次学是最费功夫的，而且岔道多，你自己​​分辩不清楚，只有从高层次往低层次学，才能一目了然，越学越通。——​这个意思跟我以前告诉大家打俄罗斯方块从高往低打的道理一样。

李后主: 再举个例子，比如你要绘制一个地图，如果你拿着罗盘和绘图仪在森林高​山中穿梭，你得费多少时间，而且还有你涉足不了的区域，但是如果你用航​拍或者卫星图片，很快就搞定了。而且不会出偏差，卫星上看哪个区域需要​详细去绘制，可以再实地考察。

張穀虛: 老師是不是可以這樣說學問是先明道（本質），在從事物體現的現象中人​得道，現象還原本質。

齐学玉: 是啊，那么到到高层次的知识就很关键了！

钱不求: 后主老师，怎样能够一开始就从高层次学呢？

李后主: 钱不求问的问题才是我们下一步需要讨论的。

严仁勇: 就好比你要了解中国文化，如果你首先把《道德经》和《易经》看懂了，​那后来的儒家各个学派的“经”你都能够一目了然。

李后主: 仁勇说的对。

罗同: 把后主教授的话综合起来说：学问之道是从上往下走的，从低层次往高层​次学是最费功夫的，而且岔道多，你自己分辩不清楚，只有从高层次往低层​次学，才能一目了然，越学越通。这个道理可能大部分人都不明白。

李后主: 那么，怎么才能从高层次往下学呢？如果你一生遇到的老师都是中学水平​，一般情况下，你的学问怎么也超越不了中学的范围，你顶多能超越你的老​师，但是还 是那个层次的，就像左冷禅一样，只是把嵩山剑法已有的招式提​高了一点而已，并无创见。那么，就回到我刚才讲的，你得遇大明师或者得到绝世武学的秘笈啊！ 得有高层次得知识指导你。或者高水平的老师教你。就这两条途径。

杨尚: 老师说的对。

慕容患: 名师出高徒，得遇名师难。 秘笈可遇而不可求。

齐学玉: 慕容说的对，这就需要缘分了吧！

李后主: 呵呵，再回到我一开始讲的，自诚而明。

齐学玉: 老师的意思是要求自己？

李后主: 你要遇高层次的学问，要明白这个层次的道理，你的心性就要高，就要修​心，保持人的天性，人的天性通神，可以洞彻宇宙的高层次法理和学问，每​个人都有这 个本事，只是很多人他不明白这个道理而已。其实，这个问题又可以转化为“人的学问从哪里来”。从实践中来吗？这是马列主义的观点，这种观点就是从低层次到 高层次的​路线，说人的发展是从低级向高级，可是实际上却不是这样。

荆珂:“从实践中来吗？这是马列主义的观点，这种观点就是从低层次到高层次的​​路线，说人的发展是从低级向高级，可是实际上却不是这样。”
这句话说得太对了！

齐学玉: 人的学问从神那里来！

钱不求: 神传文化！

李后主: 当然是从神那里来，也是从人的本性中来，刚才讲了人的本性通神啊！所​以，我们说从这两个方面来都可以。你的本性能保存，神那里就给你宇宙的​一定层次的真相，就是一定层次的道理，你就能用你诚和善的心感悟到，在​你的头脑中显现出来。

唐子: 后主老师说的这点很重要 。许多来这里的同学，已经读了很多书，但那都是低层次的，越多杂拌给你​的观念越妨碍你接受高层次的思想学问。但你的心灵善性与这些确实相通的​，所以你 只要放下以前所学，放的越彻底，你接受高层次的思想学问越容易​。记得思想史告诉大家柏拉图的洞见吗？人真正的知识和智慧并非后天的经​验，而是对理念的 回忆。

李后主: 是啊，古希腊的大哲人还有中华的圣人都是这么认识的，回忆，用中华文​化来解释，就是本性中自带的，通过修炼和修养恢复和保持一定的本性就能​得到真智慧和真学问。

严仁勇: 后主老师，您讲的这就层次高了，在大陆的教授（很大一部分吧）听了今​晚咱们讨论的内容，他们以为后主老师在讲神话故事呢。

唐子: 后主谈了一个很重要的真理问题：多层次的真理根据人的不同层次的心性​给予不同的显现。好斗的人，就给你邪道上最恶的“真理”，那就是马列的共产邪恶主义 和​社会敌对主义。善良的人，就给你儒家、墨家之类的良善真理。半恶半善的人，就给你将良善真理减半，或改良邪歪的东西，比如将婆罗​门教吸纳佛教改良为 印度教。

李后主: 唐子老师讲了一个道理，不同的人，由于本性不同，所以掌握的知识的层​次不同。这也是我层次论哲学中讲认识论时的基本原理，就是真理的显现是​由认识主体 的层次决定的。所谓认识主体（在我们这里就是人类）的层次其​实就是心性的位置。从高层次向低层次推进就是这样，先有一个高层次的知识或者道理，你向​生 活中的具体领域（低层次）去深入，把这些领域中的现象能用你学到的知​识去圆满解释，这样，这个高层次的道理你就掌握很多，其中，低层次的道​理也就一一 显示出来，被你掌握。

杨尚: 同意老师。

齐学玉: 人的本性通神，神给我们真理和知识！所以我们应该做的就是回归我们的​本性！就是道家讲的“返本归真”了。

李后主: 高层次向低层次推进，怎么推进呢？这个也可以用人们平时所理解的抽象​到具体的哲学原理来解释，只是这个原理中不带有层次关系，我们给它把层​次关系加进 去，就可以用了。你从本性中，或者神那里了解了一些真知和智慧，你在生活的领域中处处​去观察去分析，通过观察和分析去印证这些真知和智慧的正确性，圆融 它，​就把这些知识越来越熟练的掌握。

齐学玉:“你从本性中，或者神那里了解了一些真知和智慧，你在生活的领域中处处​去观察去分析，通过观察和分析去印证这些真知和智慧的正确性，圆融它，​就把这些知识越来越熟练的掌握。”。老师，这里的观察和分析指什么呢？

張香山: 学玉，我的理解：观察和分析现实中的一切，去印证真知和智慧的正确​​性。

李后主: 观察和分析，就是平时所说的学习的基本方法。这难道很难理解吗？

荆珂: 我觉得容易理解。

杨尚: 老师说的对，可以理解。

齐学玉: 平时的学习都是以课本为主，没有去具体应用过啊！

李后主: 学玉，那就要多思考啊！思维的能力是靠思考训练出来的。

齐学玉: 看来这是我自己的问题，大家没有这个问题。我自己来想想吧！

李后主: 那么，回到最开始吧，为什么我能理解逻辑领域的，或者这个层次的知识​，无师自通？因为我懂得了修炼这个层次的道理，不断去思考世间的一切现​象，所以逻 辑这个层次的道理就自明起来。我就是这么学会逻辑思维的。和大家刚开始，我没有给大家讲解时，想得​肯定是不一样。一般人都是从低往上学，我是从高往下 学，所以学得就快。那么，讲到这里，大家学逻辑学，一定要有一个高于它的总的见识，这样​就学起来不受制于它，能很快理解它的精髓，达到熟练掌握的程度。

杨尚: 理解。

齐学玉: 学逻辑老师是自诚明，我们现在要自明诚了！

李后主: 是啊，你们没有自诚明的，就准备自明诚吧！

钱不求: 自诚明，先把这三个字记住了。

杜若: 那有没有直接就学高的？

李后主: 从高往低学，不就是直接学高的。

荆珂: 杜若: 那有没有直接就学高的？ 通过修炼把心性修高，就直接学高了。

張香山: 先学高层次的理，再学低层次的理的时候就是居高临下了。

李后主: 是啊，张香山说的对啊！居高临下。就是这么回事。

杜若: 哦，知道了，谢谢！

荆珂: 听后主老师一席话，胜读十年书。

杨尚: 理解。

 李后主: 杜若的问题，是因为他没有明白，懂得一个高层次的理，要在低层次的环​境中去证实它，这个理在你心中才丰富起来，才越来越清晰。一个事物开始​和终点的统 一，终点是开始的丰富，这个道理正好是黑格尔哲学的精髓，只​是他讲的是辩证法，讲事物诸环节的统一，而我讲的是层次论，讲高层次的​理去包容低层次的， 最后在低层次的环境中证实高层次的理，相同的是，都​是最后在心中把这个理丰富起来。

严仁勇: 后主老师，关键是“自诚”和“明”怎么能和逻辑学贯通？是不是要靠自​己慢慢的思考？“慢慢思考”里面又出现问题了，自己“怎么思考”？

慕容患: 临下需要居高，居高从自诚明开始。自诚到自明。

李后主: 慕容患，解释的不错。我今天讲的两点，学问从哪里来，怎么学？

钱不求: 学问从本性中来，从高往低学。

李后主: 学问从本性中来，学习的最佳方式就是从高往低学。诚就是本性的一个方面的体现，所以，诚可以通向明（了解道理）。逻辑学，所有的学问的最高境界，都在诚而 明之中。逻辑学，以及所有的学问的最高境界，都在诚而明之中。我今天给大家讲这些，就是希望大家明白，不要把一门学科当作现代科学​体系下的一门学科去 学，而应该当作天道的一个层次的表现去学去悟。而要​明了天道，就需要保持本性，恢复本性，由本性的突破加以一定的教育来达​成。两方面的结合才是正道， 只把逻辑当作工具去学，那么学了也达不到真​正熟练应用的要求。

唐子: 后主这里讲的是逻辑学之道，我引论也要讲这个。各位只有充分理解并掌握​了这些，如同武功学习中的秘笈，学习起来才会得心应手。

李后主: 今天的那些专家们出版了多少形式逻辑学方面的书了，可谓把这方面的工​具性知识学到家了吧，可是他们对社会和历史的掌握如何呢？对科学和神学​的分析怎么 样呢？能比得上我这个从来没有学过形式逻辑学的“外行”吗？​我所应用的思维逻辑都是形式逻辑学中的具体原理，而且我也从不违背这些​原理，更重要的是我 能熟练运用这些思维能力去理解天道在人间的表现，而​他们却达不到，他们只懂这门工具。所以，这就是道的层次不同，所达到的知识的应用程度也不同。我希望 大​家从更高的层次上达到对逻辑的掌握。当然，因为我从没有学过这方面的具体知识，可能讲起来不是很熟练。我​尽量给大家把道理讲清楚，讲深刻。

严仁勇: 今天网大讲的“逻辑学之道”是史无前例的，可见网大教学的起点之高，​无以伦比！

唐子: 后主是用形式逻辑的器具来做正事，他们是用形式逻辑的器具卖钱养家糊​口包二奶。那自然的境界和效用就不一样。这也给大家点出了做学问的道路：方向和​境界第一。而这个方向和境界，不在别处，就在你的内心。

齐学玉: 受教了！呵呵！

严仁勇: 唐子老师您的说的话都很幽默，可都是大实话啊！

李后主: 最后，逻辑真正的难处不在逻辑规律的本身，而在于它的前提，词义。这​其实考验的是大家对事物的理解能力了。

慕容患: 需要从概念清晰开始。

李后主: 由于在交往中才能形成词义的不同见解。所以，真正的逻辑不在于自身的​理解的难处，而在于交往逻辑的难度。我这里提出一个新名词，交往逻辑，​就是在交往 中，在对话中，彼此对逻辑一致的要求，而这个一致是很难达到​的。一个人自己是不容易觉察自己的逻辑问题的，除非他是个爱反思的人。一​般人都不觉得自己 讲的话有问题，而一旦对话中，别人会觉得他说话有问题​，会觉得他讲得道理有问题。这就需要讲逻辑的交往了。词义的歧义，语义的不明，逻辑原则的使用或者 违背，都在交往中才反映​出来。所以。真正的难度在这里，那么，真正的提高也在交往中提高。也就是从​高层次向低层次推进，从抽象向具体和丰富化发展。

慕容患: 交往逻辑，理解：需要使用同一概念、词义，还要交往各方的知识层次大​概其相当。

钱不求: 谢谢后主老师也谢谢唐子老师！

慕容患: 感谢两位老师。

齐学玉:谢谢老师的指导和各位同学的帮助，在这里真是学到很多道理！

 李后主: 好的，今天就说这里。同学们晚安！

师生互道晚安！


目录（讲义+纪要）

逻辑学之道（纪要）

序论（唐子）

序论（纪要）

第一章 概念和定义
第一节 什么是概念
第二节 概念间的关系
第三节 概念的限制和概括
第四节 如何下定义
 第五节 概念的引申问题研究

纪要（上）

纪要（下）

第二章 命题和判断
第一节 命题综述
第二节 简单命题
第三节 复合命题

纪要（上）

纪要（下）

第三章 推理
第一节 推理综述
第二节 直接推理
第三节 三段论（间接推理）

纪要（上）

纪要（下）

第四章 复合命题推理
第一节 联言推理
第二节 选言推理
第三节 假言推理
第四节 负复合推理
 第五节 多重复合推理

纪要（上）

纪要（下）

第五章 归纳推理
第一节 归纳逻辑综述
第二节 完全归纳推理
第三节 不完全归纳推理
第四节 探求因果联系的逻辑方法
 第五节 溯因归纳推理和假说演绎推理

纪要

第六章 类比推理
第一节 类比推理

纪要

第七章 逻辑学基本原理
第一节 逻辑学的四大基本规律

纪要（上）

纪要（下）

第八章 论证与反驳
第一节 论证
第二节 反驳

纪要


序论

理性思维之器（唐子）

——形式逻辑的基本知识及其应用

 这是未来中国网络大学（简称网大）《理性思维之器》课程（应急而开）的引论。此引论简要讲解关于这门课的内容、学习的意义和怎样学习的问题。

1 本课程应急而开，讲述形式逻辑的基本知识及其应用，引网大同学握理性思维之器。 网大师生一样“生在血旗下，长在血旗下”，长期受党文化邪气十足、恶性膨胀的“党卫军”斗争哲学与诡辩逻辑的思维教育，或随意或恶意使用党八股语句进行愤 青思维。这影响到我们学习《世界思想简史》、《中华哲学》、《九评共产党》、《解体党文化》、《审视国寨大幼儿》的效果。简而言之，学习《形式逻辑的基本 知识及其应用》有助于我们理性、成熟地破解中共诡辩逻辑的邪恶思维。

一、 这是怎样一门课？——思维工具，基本内容。

2 解决什么问题：地球生物中，作为惟一有理性思维能力的生命，人如何才能像一个成年生命一步一步行进似的，一句一句地展开思想？如何才能使言辞不会与狗之“汪汪”吠、猪之“噢噢”叫一样，只表达饥饿、性欲等本能和愤怒、激情等心绪？如何才能使思想不像猴子高兴了就窜树、悲伤了就钻洞似的，完全没有层次和条理？如何才能以理性引导个人情绪，以思想指明社会道路？只有解决了这四大问题，人才有真正的悟性和灵性，人才配称之为“人”。因此本课程旨在给网大学生补充形式逻辑的基本知识，并予以相应的训练，启用理性思维之器。

3 逻辑一词由英语Logis音译过来，导源于古希腊哲人赫拉克里特的“逻各斯”，原意指宇宙规律、人共有的道路、必然的命运、无形体的神、理智的思想。其中规律、命运，后来在西方中世纪演变成基督教的“道”。“理智的思想”之意义，在古希腊亚里士多德那里“逻辑”就主要指思想工具——研究概念、判断、推理等演绎（由一般到具体）方法，成为西方较数学稍晚、跟物理学、政治学、伦理学、生物学齐头并进的古老科学，又共同以哲学思辨为思想之母，并为神学所用。

4 在现代汉语里，“逻辑”是个多义词， 例如：1、自然和历史的逻辑；2、共产党的强盗逻辑；3、结论要合乎逻辑；4、网大的逻辑课程；5、国寨人质的人心逻辑；等等。这里的五个“逻辑”词义都 不同，分别指事物变化规律、某种特别的理论和看问题的方法、思维的规律和规则、形式逻辑（普通的逻辑学）、性情思考或实用理性中的特别规则。本逻辑课主要 讲形式逻辑知识并侧重应用。

5 形式逻辑，即研究逻辑思维的形式（概念、判断、推理、论证等）及其确定性、充足性的基本规律，以及理性认识事物的方法（定义、归纳、演绎、假说、反驳、求因果五法、斥诡辩五法等）的思维学。显然，形式逻辑是一门思维工具。

6 本课程的讲述内容共分四篇：第一篇概念和名词，讲关于概念的概述、种类、关系、限制和概括、定义、划分等基本知识及其应用（如何通过名词来具体表达）。第二篇判断和命题，讲关于判断的概述、种类的基本知识及其应用（如何通过命题来具体体现）。第三篇逻辑规律，讲概念和判断必须遵守的同一律、矛盾律和排中律，以及论证中判断成立必须遵守的充足理由律。第四篇推理和论证，讲关于推理的概述、种类的基本知识及其应用（如何在论证过程中具体推理和论断）。

二、 为什么开这门课？——逻辑简史，破解中共。

7 学这门课的意义： 本课程是理性思维形成过程中的必修课，通过学习和训练，奠定公民儒遵守规则且文质彬彬的素养形成的基础，思维像一个正常的成人。

8 理性思维、逻辑论辩于富有生命力的民族不可缺少。中国古代早在春秋战国时期墨子、惠施、公孙龙、荀子、韩非子等人就初步研究过逻辑问题，公孙龙提出过“白马非马”的著名逻辑命题，墨学之《墨经》墨辨逻辑中“名”、“辞”、“故”与或谓之牛或谓之非牛“是不俱当”，表达了相当于“概念”、“判断”、“推理”与“矛盾律”的思想。印度古代则有佛经佛学的因明逻辑，基于主观感受形成，以“境”为基点进行“现量”、“比量”之演绎，以“宗”、“因”、“喻”之术语与“破他”、“四问答”之方法阐明佛学理论，以《三藏》之“论”学比较充分地研究了推理和论证的方法，表达了佛教寺院论苦、论空而特有的逻辑理论。

9 形式逻辑作为思维工具是天赐人类理性的器具，从古希腊自然哲学（含物理学、天文学）和思想哲学（含形而上学、辩证法、工具论）中分化出来，跟墨辨逻辑和因明逻辑专属墨学（教）和佛学（教）不同，成为古代西方哲学、中世纪基督教和近代新教、哲学与科学共同的思维工具：陈述主张、主义，反驳观点、学说。形式逻辑超宗教、学派而 存在，由亚里士多德综合苏格拉底、德谟克里特、柏拉图关于归纳、演绎、类比、定义、划分、判断等逻辑问题的研究成果而首创，全面、系统地阐明了概念（范 畴）、判断、推理三个基本思维形式与同一、矛盾、排中三个基本思维规律。之后不同历史时期形式逻辑得到新的逻辑成果填补，古希腊斯多葛学派和近代英国培根 及穆勒等补充进复合判断和归纳逻辑及求因果五法，德国莱布尼茨和康德先后补充进充足理由律（原则）和先验原则。形式逻辑数学化，由英国布尔、罗素创立、完 善出形式逻辑的新学科——数理逻辑。

10 针对形式逻辑静态理性思维与科学化的不足，德国黑格尔首创辩证逻辑的哲学和思维学。马克思则篡改辩证逻辑批判性地颠覆了人类全部的思想学说，以唯物史观名义批判逻辑历史观、劳动价值说、空想社会主义，首创共产邪恶主义。近现代由西欧而中欧、东欧、东亚的世界共产红祸兴起并蔓延至 中共国寨的今天。共产党的所谓辩证逻辑，其实是以社会实践证明名义、以绝对又相对的“科学真理”、以斗争哲学和群众运动强行夺权和洗脑，通过军警支撑邪 士，通过媒体、学校、舞台、银幕、荧屏、视频，全方位无微不至地教会全民进行“偷换论题”、“捏造论据”、“循环论证”、“机械类比”、“强词夺理”的诡 辩，制造出一批又一批粗鄙的西装流氓与红色党（教）徒，一批又一批善良本性被共产邪恶主义和社会敌对主义观念奴役和变异的政治精神病人：一搞政治或一讲政治就逻辑不清。

11 中共腾新文化运动由西方海洋文明招来的蓝色的 “科学”云和“民主”雾而来。 全国性27年枪杆子暴乱和59年笔杆子洗脑，无神的国寨人质心灵里中共成了即使作恶多端、无恶不作、穷凶极恶依然“伟大、光荣、正确”的魔神，成了惟一的 精神寄托，才有敢于骂神、诽佛、谤道却不敢退出中共组织的可笑言行，才有不读马列弃不了中共或中共没了中国会乱的怪异感觉。形式逻辑是神传于人的正统的理性思维，其概念明确、判断恰当、推论合理的思维规则能助人拨开科学和民主的蓝色云雾，识破共产（邪恶）主义和社会（敌对）主义的邪恶主义与敌对主义本质，因看穿中共红魔永不可能“放下屠刀，立地成佛”而毅然远离它，睿智地再也不给它附体吸能量、借体练邪法、贫嘴乱人心的可乘之机。形式逻辑之应用，对于网大法轮功学员讲真相和民运人士筹建未来中国有切实的帮助。

三、 怎样学习这门课？——知行合一，适度运用。

12 掌握形式逻辑之法：在国寨学习形式逻辑，必须在正道上知行合一地学习，适度运用，以增进理性思维能力、讲清中共邪恶真相、破解党文化为目的。

13 第一、在正道上学习。看智慧旅程（西方思想历程），理性思维之道（形而上学/哲学或神学）派生并指导理性思维之器（形式逻辑/思维学），无论亚里士多德之于演绎逻辑，还是培根之于归纳逻辑、莱布尼茨之于充足理由律，都是从其哲学中推导出其逻辑思维成果的。就是说，学习形式逻辑不能背离传统正道的指向。如果你是基督徒，就应该以“信、望、爱”正道去指导，以逻辑器具传福音；如果你是法轮功修炼者，就应该以“真、善、忍”正信去指导，以逻辑器具洪法。这样逻辑知识就成了你生命力的展现，能够被你的神智灵性指使，充分为你所用。

14 第二、知行合一地学习。 许多人听说学习形式逻辑对理性思维很有帮助，于是就去学了，从概念到论证，起初还明白，慢慢头晕；读完之后去用时，或者什么也想不起来了，终点回到起点； 或者概念和判断、判断和推理、推理和论证的知识完全混淆，最后沮丧地说没用。学逻辑不能这样，而应该像学儒学一样，懂一点就去运用一点，在逻辑交往中发现 问题、分析问题、解决问题。孔子给学生讲“仁”，讲每个人理解的那一层的“仁”的理，就是要他们立即能用，将“知”转为“智”化为“慧”。形式逻辑的知识 点很多，你不要等到全部掌握了再去用，而是知道一点就去用，比如知道如何下定义了就在写文章或互动中用。这样学，学到论证和斥诡辩时，五规则和五法的知识就成为你的能力型智慧终身不忘了。

15 第三、运用逻辑要适度。形式逻辑可以广泛用于各类神学、哲学、科学研究的思考和写作中，甚至跟数学、历史相结合为数理逻辑、历史逻辑等，却不能背道。例如天主教运用形式逻辑讲授神学逐渐背离上帝之道而以教会为道，执著论证经院哲学的每句箴言时，便成为伤残头脑的工具。其次不能忘义，即不能以形式逻辑去宣传无神论、唯物论和进化论，以免理性思维像马克思、达尔文那样步入邪道（为侮辱人和毁道德服务）。再次不能破家，家庭出现纷争时可以用逻辑澄清误会、消除思想隔阂，但如果硬要用逻辑逼配偶或子女、父母认输，就会使家庭变成法庭、角斗场、辩论厅，致使逻辑成为情感杀手。倘若逻辑应用有道，有所为也有所不为，思想家会不失道成阴郁邪毒者，可以成为德智两全的修者。

16 综上所述，形式逻辑是理性思维之器，在网大开设这一课程具有破解党八股愤青思维的特殊意义，有助于同学成为思维理性的正常人和心智成熟的修炼者。
一、关键词连接：
理性思维之器
1段：
本课程 述形式逻辑的基本知识及其应用 握理性思维之器 破解中共 邪恶思维
一、这是怎样一门课？——思维工具，基本内容。
2----6段：
 理 性 展开思想 使言辞不 狗 猪 猴 导个人情绪 明社会道路 悟性和灵性 逻辑 道 工具 多义 形式逻辑 研究 思维的形式 方法 思维学 本课程 分 概念和名词 判断和命题 逻辑规律 推理和论证
二、为什么开这门课？——逻辑简史，破解中共。
7----11段：
 本 课程 学习和训练 思维 正常的成人 中国古代 墨辨逻辑 印度古代 因明逻辑 专属墨学（教）和佛学（教） 形式逻辑超宗教、学派 静态理性思维 科学化 共产红祸兴起并蔓延 制造出 西装流氓与红色党（教）徒 善良本性被共产邪恶主义和社会敌对主义观念奴役和变异 搞政治 就逻辑不清 中共腾 “科学”云和“民主”雾而来 形式逻辑 能助人拨开 云雾 识破 邪恶主义与敌对主义本质 毅然远离它 讲真相和 筹建未来中国
三、怎样学习这门课？——知行合一，适度运用。
12----16段：
 第 一、在正道上学习 不能背离传统正道 生命力 神智灵性 第二、知行合一地学习 知道一点就去用 知识 智慧 第三、运用逻辑要适度 不能背道 忘义 破家 思维理性的正常人心智成熟的修炼者。


序论（纪要）

授课内容：《理性思维之器——导论》
上课时间：2008.10.25日　北京时间晚8：30
上课地点：唐子教室
授课老师：唐子老师
到课老师:李后主老师
到课同学：杨尚、文豪士、慕容患、麻生、陈清扬、辛言、钱不求、曲婉蘭、張穀虛、林若熙、張香山、张玉、李博文、罗同 、汪棠涵 、华变天 、唐之韵 、罗雅玉、贺大翔、安哲 、张华虎、罗雅玉、程西洛 、超越 、严仁勇、杜若、 周顺平、赵阳光、齐学玉
到课总人数：29人
请假同学：李大雄
纪要整理：齐学玉

各位同学:老师晚上好，各位同学晚上好!

唐子: 各位同学晚上好.可能还有些人在路上，我们等五分钟。
http://bbs.futurechinaforum.org​/viewtopic.php?t=41864&highlight=

这个链接先打开。互动的时候会用到。

 唐子: 上面的链接打开了吗？这篇文章各位请看，作者是我们学校的客人，在我​们学校学很多东西，却同时喜欢指点江山，以激扬文字的方式。这篇是看了​我们要开形 式逻辑课程之后提出要开数理逻辑，没得到校方回应之后而作。​这篇文章可以作为今晚我们研讨互动解析问题的个案。个案教学，是逻辑教​学中最适合的方式。

各位同学:后主老师晚上好!

李后主: 同学们晚上好。

唐子: 抽象地讲逻辑知识，大家所得不多，但解剖一个个案，你就会体悟良多。​下面我们准备上课了。

我上的这堂课是形式逻辑的引论，正式上这门课的是李后主老师。下面开​始。

 理性思维之器
——形式逻辑的基本知识及其应用

 这是未来中国网络大学（简称网大）《理性思维之器》课程（应急而开）​的引论。此引论简要讲解关于这门课的内容、学习的意义和怎样学习的问题​。

形式逻辑在其创始人亚里士多德那里叫做《工具论》，主要讲授数学定律​、公式型的演绎分析思维。这种演绎型形式逻辑后来被天主教经院哲学用作​神学证明和 解释工具，300年后西方神学争论的非常繁琐、空洞和无聊。​培根这时创科学归纳法，称作《新工具》，主要讲授科学实验、分析型归纳​概括思维。后来科学 研究将亚氏演绎和培氏归纳都当作方法采用了，就成形​式逻辑主干。

 ——问1：我们开设形式逻辑课程，为何称之为“理性思维之器”？

唐子: 注意形式逻辑的器具性——1、数学定律​、公式型的演绎分析思维；2​、科学实验、分析型归纳​概括思维。

慕容患: 培育理性展开思想能力，使言辞不同狗、猪、猴，以理性引导个人情绪，​以思想指明社会道路，开启悟性和灵性之门。

麻生: 形式逻辑的思维方式，集数学定律，公式演绎、归纳为一体的思维方式，​是人类理智发展至今比较严密和完备的思维方式。

齐学玉: 理性思维之器，是说形式逻辑具有用的功能，可用于科学的演绎分析和分​析概括。

錢不求: 因为逻辑是中性的，它有助于人理解真相，却也能被利用与吵架和犯罪。​它是一个器具，必须要心正，才能把它用在正道上。

杨尚: 答：形式逻辑课程，学习掌握逻辑思维，锤炼理性思维，故称“理性思维​之器”。

陈清扬: 形式逻辑可以帮助人的理性思维形成、成长、并且承载了理性思维，使理​性思维得以有正规、通用的方式来展开，并作为理性思维与其他人类文化的​中间层面连接到相当多的领域如物理、数学等。

罗同: 因为理性思维之器（形式逻辑/思维学）是受理性思维之道（形而上学/​哲学或神学）派生并指导，反过来又由器而道。

張穀虛: 形式逻辑是我們學習理性思維所用的工具，器為下，我們的學習主要想通​過借助這個工具來鍛煉個人理性思維走出情感思維困惑以靜其心，啓其智，​明其慧。

张华虎: 因为形式逻辑是西方科学各学科的基础工具，讲解的是认识、发现世界的​最基本方法.

赵阳光: 同数学定律一样，特定范畴内的思维活动也上有定律的，根据这些定律进​行归纳、概括就是形式逻辑的运用过程。因此，形式逻辑就是一个思维工具​，同时可以称之为“理性思维之器”。

张玉: 形式逻辑可以理性运用，使成长为正常的人，启迪真正的智慧。

唐子: 慕容有些空泛，麻生比较具体了，学玉谈的抽象，不求有些话提前说了，​杨尚参见麻生的，清扬文字还可再简练，罗同和谷虚，华虎都是个人化语言​，阳光具体指出了演绎逻辑的特点。张玉说的是意义。

陈清扬: 谢谢老师指点。

唐子: 注意形式逻辑的器具性——1、数学定律、公式型的演绎分析思维；2、​科学实验、分析型归纳概括思维。讲述形式逻辑的基本知识及其应用，引网​大同学握理性思维之器，有助于我们理性、成熟地破解中共诡辩逻辑的邪恶​思维。

 ——有“理性思维之器”，必然就有“理性思维之道”，很多人可能就想​了：我直接掌握理性思维之道——《九评》、《解党》等——破解中共邪恶​思维，就可以了，何必还要来学形式逻辑这“道之器”。问2：你怎么看待​这种想法？

陈清扬: 用于讲真相的时候，如果对方本来逻辑思维比较强，并且以一元化思维为​主，恐怕不太容易认同理性思维之道的高深内涵。而且对方常用的语言很可​能不容易接上理性思维之道的语言，那么就要用“器”来具体的解析、阐述​，才可以还原“道”，让对方选择。

錢不求: 这种想法是很“飘”的想法，以己度人，而不是站在别人的角度上想问题​，“理性思维之道”确实更高一层，但是它和“理性思维之器”不是相对立​的，而恰恰是相辅相成的关系。不想学习“理性思维之器”直接求“道”的​人，想求的是偏执的道。

杨尚: 对于道的理解，可深可浅，器可助人更深刻的认识道。我们悟道，也当传​道，传道需要器做为开山通路的兵器。

慕容患: 孔子说，工欲善其事必先利其器，仅仅掌握理性思维之道，没有理性思维​的工具〔器〕，是不能善其事的。

麻生: 由器入道是一个递进的过程，如果直接上来就使用理性思维之道，可能我​们都是在理弱而感觉思维的路上走，而不具备强大的理性逻辑力量。

安哲: 学习知识，应当是是从高级之道往低级之器学习，运用这样的学习方法，​才能理性和智慧的学习到知识。

张华虎: 掌握形式逻辑，有利于我们真正地掌握理性思维之道——《九评》、《解​党》，应变邪党的各种诡辩，解决讲真相中遇到的各种实际问题。

赵阳光: 道在器之前，如果没有道的话器就是一个空架子，但如果没有器的话道就​是一团迷雾。由于人的认识层次不同，不可能每个人都能自然领悟到道的内​涵，此时就需要器来引路，通过一定的程序把这团迷雾分解、组合，直到让​不同层次的人都能领悟到道的内涵。

唐子: 各位发言的讲的很好，有些同学默默不语，可能是有不同见解，却不愿意​讲出来。也许有些同学觉得我把问题讲复杂了，那么请先看一篇文章。——​http://ufuturechina.org/Forum/vie​wtopic.phpf=0&t=2723
注意《谦诚一点为什么不可以？》这篇文章倒数第二段关于逻辑的文字——​“逻 辑不是万能的，如果要说逻辑，易经的数理和卦理逻辑已经是这个世界​的至高逻辑了，只是长期以来易学秘而 不显，人莫能识罢了。而《金刚经》更进一层，向世人展示了逻辑的荒谬​，释迦牟尼佛用一系列的否定句式，向我们开启了真理的大门。没有逻辑就​是最大的逻 辑， 《金刚经》为此向我们展示了逻辑的最高境界。因为对于内证求是的修炼​者来说，逻辑恰好是束缚人的东西，只有打破逻辑，才能掌握真理。李洪志​大师的经 文，也 是不完全符合现代汉语的语法的。语法在帮助阐述真理的同时，也是束缚​真理的工具，所以我们有时候必须打破它。语法和逻辑，都不过是助我们渡​河的工具， 为什 么我们却放不下呢？难道是因为我们还没有过河吗？”

錢不求: http://bbs.futurechinaforum.org​/viewtopic.phpt=41864&highlight=

唐子: 作者写这篇文章是说得了“道”——儒、道、佛、大法等——，很欣赏儒​家的谦逊，倡导谦诚。可在倒数第二段却插了上面这段文字，令人有些纳闷​。

 问3：这篇文章在讲要“谦诚”，却突然说这么一段轻蔑“逻辑”的文字​，并且以不逻辑为高明，要“过河者”放下这“器”，这里有什么样的思维​问题？

慕容患: 违反了同一律、矛盾律。

錢不求: 突兀，不守逻辑的思维，或者说是有目的的误导他人的思维.

張穀虛: 1、掌握了理性思維之道是從高層次上認識真理從，即通過修煉直接可得​慧悟；2、然而人的認識水平不同，非修煉者的人認識通常是從感性思維到​理性思維有個過程，而通過邏輯思維的鍛煉有助與提高其理性思維水平。

齐学玉: 作者要“过河者”放下这“器”，显然是很轻视“器”的作用，还要劝别​人也轻视，与作者的主旨要“谦诚”是违背的！

唐子: 跟进上面的同学.

陈清扬: 作者的意思可能是要说明掌握形式/辩证逻辑不能成为人类盲目自大的理​由。但对人类而言谦逊的同时掌握形式/辩证逻辑也是西方正道，我觉得让​人谦逊与抛弃形式/辩证逻辑这两个没有因果关系。

安哲: 这段话的论述本身逻辑就混乱，作者想不用逻辑的方法讲清楚问题，但是​看的人越看越不明白。

李后主: 只能说这篇文章没有中心思想，或者是主题混乱，或者可以套用作者的逻​辑说是没有主题就是最大的主题。

赵阳光: 谦称和是否运用逻辑没有因果关系，作者的思想看上去很乱。

唐子: 那段文字是不是有些像妇女塞枕头说怀孕的事啊？呵呵……

杨尚: 道可生器，器在道中，若真得道，岂会否器.

錢不求: 确实这样，标题是谦逊，作者却非常傲慢的在文章中蔑视“逻辑”.

唐子: 各位对牛客人这篇文章轻蔑“逻辑”这段文字，提出了各自的看法。这也​只是你此时此刻——在学习逻辑课之前——的看法。对逻辑还没有太多的话​可说的人， 无论轻蔑和傲慢，都没有资格。硬要这样做，那可就是明显的不​谦诚，牛客人还不是我们网大正式学生，言行不一我们不管，作为网大生就​别这样。随着我们对 逻辑这门课的了解，再看你上面的谈论，可能又不同了​。推进了——

一、 这是怎样一门课？——思维工具，基本内容。

 解决什么问题：有理性思维能力的人展开思想时，如何使言辞不​会与狗吠、猪叫一样？不像猴子窜树、钻洞似的？如何以理性引导个人情绪​？以思想指明社会道路？学习、启用形式逻辑这一理性思维之器，有助于人​解决这些问题而有真正的悟性和灵性。

罗同: 将逻辑与修炼对立，此处逻辑含混不清。

唐子: 逻辑一词导源于“逻各斯”，有多种意义，基督教的“道”、亚里士多德​的思想工具各有其不同之意，在现代汉语里也是多义词。 形式逻辑，即研究逻辑思维的形式及其基本规律，以及理性认识事物的方​法的思维学，是神传予人理智得道和传道的思维工具。

 本课程内容共分四篇：一、概念和名词；二、判断和命题；三、逻辑规律​；四、推理和论证。

 问4：形式逻辑有助于解决人脑动物化的问题而有真正的悟性和灵性，是​神传予人理智得道和传道的思维工具，对这两点，你理解或赞同吗？

錢不求: 我赞同，有一点理解。形式逻辑与道联合，如虎添翼.

华变天: 不是很理解,如果某人确实是无神论者,不赞同形式逻辑是神传的,他就​无法应用形式逻辑来理性思考了?

李后主: 变天：神传的文化形式，不管你认识到还是认识不到，你都可以用，只是​用了以后达到的层次不一样。比如汉服，是神传给我们民族的。你认识不到​这一点，也可以传汉服，但是如果我们认识到这一点，穿汉服的体会就不一​样。

华变天: 嗬嗬,谢谢后主老师,明白了,后主老师每一句话必定和层次论相关联,​呵呵.

張香山: 我贊同。

张玉: 赞同。

张华虎: 赞同。相信这正是我和众多同学一同来听课的原因和动力。

杨尚: 理解，赞同。
神是大道，任何真正的智慧皆来源于神。人处于动物与神之间，真正的道​与器，可把人向神提升。

齐学玉: 人脑动物化是说人说话都是凭感觉，不经过思考，形式逻辑可以使​人的理性思维能力得到提升，只有有理性思维能力的人才会去思考很多人生​问题，进而启发人的悟性和恢复先天的灵性。

陈 清扬: 人有多层次的属性，要跟动物区分开，就要至少体现出理性思维能力的层​面，而作为理性思维之器的形式逻辑确实可以帮助人体现、培养出人的理解​能力与认识 能力；理性连接很多方向，好好运用，确实可通向道，而且也可​以帮助人认识自己以及理性本身的局限，让人谦卑（但是恶用确实也可堵死​自己的回天之路）。

麻生: 理解，赞同。
变天提出了是否神传的讨论，但我这样认为：前提人是神造的，而在人范​畴内的所有知识与理论都应该是来源于神的启示与引导。

赵阳光: 理解。人脑思维会运用形式逻辑，跟动物化思维有着本着的不同。通过有​效的逻辑思维能比较容易地理解道，从而可以得到直至传道。

罗同: 同意，正的知识都是神传予人的。

周顺平: 我本人也赞同。可能变天提出的问题是因为国寨中很多人是无神论者，如​果一开始就提出是神传给人的这点，可能会挡住很多人不能往下学，从而妨​碍不能理性的思考。

張穀虛: 赞同形式逻辑作爲理性思維之器為神賜。我的理解：形式逻辑有助于解决人脑动物化的问题而有真正的悟性和灵性​---人應用形式邏輯來理性思考可以提高悟性和展現灵性；是​​神传予​人理智得道和传道的思维工具---理性又可以幫助人更容易接近（神）道​。

唐子: 理解和赞同要有这样两个前提：人脑是否有动物化问题？不理智是不是会​妨碍悟性和灵性？

錢不求: 人脑确实有动物化问题，比如贪睡，贪吃，懒惰，不愿意思考等。不理智​就难以激起他们对更高层次的追求

陈清扬: 我认为人脑有动物化问题，但理性思维（之器）可以帮助人超越自己的低​级属性。
我以为非理性有 超越理性 和 次于理性两种状态，鉴于人受感情影响，一旦次于理性，感性具上必会影​响悟性。

杨尚: 人脑当然有动物化的情况，昨天老师说过，人心逻辑就是人为情感所动，​情感的下一层就是欲望，人若被欲望牵引，就是动物化。

张华虎: 国寨之中，寨民大脑确实有动物化的普遍性。不理智确会阻碍人们获取真​理，乃至获取悟性和灵性。

唐子: 人脑动物化必然妨碍人的悟性和灵性！人虽然都有脑子，但并非所有人思​考问题都像成人走路，是一步一步行进的。人的的确确有使语言“狗吠”、​“猴窜”、 “猪叫”的现象，当人说话和写文章处于这种状态，读讲道和法​的书，能真正悟道吗？即使因为根基能够悟到一些道，可能够给人传道吗？​恐怕不能。

杨尚: 关于神的问题，我是这样理解，世间是否有一个最高的规律，万物皆遵循​其，主宰万物，若有，可认其为神，则所有真正的智慧，必由之演化而来。​当然，若能通过内证验证神的存在，另当别论。

唐子: 轻蔑逻辑的人首先就有情绪化倾向，因为他不懂，也不愿意学，于是就把​逻辑贬低为人之渡船，是现代语法这种人为的东西。然而形式逻辑并非人为​的，大家细 细体会我的引论所讲，从赫拉克里特到亚里士多德，一个历史的​过程，后面还跟基督教相联。作为思维工具是天赐人类理性的器具，从古希​腊自然哲学（含物理 学、天文学）和思想哲学（含形而上学、辩证法、工具​论）中分化出来……

问5：上面那篇文章讲“谦诚”，却突然来一段文字轻蔑“逻辑”，以不​逻辑为高明，要“过河者”放下逻辑渡船，知道形式逻辑是怎样一门课后，​再看其思维问题，用上面获得的知识（先不管后面）说一说具体有哪些？

华变天: 不理智会妨碍人对事物的判断和分析的客观性,根据个人的好恶决定对待​一个事物的看法,无法真正深层次和客观地看待问题,当然妨碍悟性的提高​.

齐学玉: 不理智，情绪化！

唐子: 要学会用前面的知识来论证自己的观点。

張穀虛: 文章說谦诚又轻蔑“逻辑”，又沒有説明邏輯作用和谦诚該如何做，具有​情緒化和條理、層次不清楚地問題。

麻生: 由谦诚与到轻蔑逻辑，这样感觉判断表达却是不谦诚的表现啊。是自己搬​起石头砸了自己的脚。

陈清扬: 形式逻辑虽非神州神传文化,但也是历史大戏中西方文明的重要组成,可​能也是遥远体系的升华之道.从这个角度来讲,确实有些恃道蔑器.话语中​虽有超越理性的成分,但也有次于理性的成分,可以简而言之不太理性.

安哲: “没有逻辑就是最大的逻辑”。。本身就是一个病句，既然不推崇逻辑，​贬低逻辑，但证明的方法却还是逻辑式，说明作者根本就没有将逻辑搞清楚​。

張香山: 形式逻辑，就是研究理性认识事物的方法。而上面那篇文章讲“谦诚”，​却突然来一段文字轻蔑“逻辑”。這就是不理性，只是体現自己情緒。

赵阳光: 这里的推理不能推导出概念，即轻视逻辑无法推出谦诚的概念。

唐子: 上面那篇文章讲谦诚，只是到了最后再有一个简单的定义，而前面的文字​跟后面要讲的没有紧密的联系，倒数第二段就如同女人塞枕头假装怀孕。这​种思维状况，各位看看形式逻辑是怎样一门课之后，用其中的很多知识点都​可以具体指出其思维弱点和盲点

齐学玉: 人脑可以动物化，当人说话和写文章也用这种动物化的思维，不讲逻辑，​想到什么说什么，必然妨碍人的悟性和灵性！其本人不能悟道，更不能给人​传道，所以起要“过河者”放下这逻辑实在是让人离道越远的害人之言。

錢不求: 不懂逻辑，蔑视逻辑，那么就会有情绪化，动物化的问题，这是十分影响​灵性和悟性的，那么如何能够让他得出没有逻辑更高的结论呢？，这个结论​是否是有灵性的和有悟性的结论呢？

罗同: 其思维1概念不清：不知“逻辑”2情绪化：也不愿意学3自我矛盾：自​称“谦诚”，实则相反。

 唐子: 这样的谈论就有了一定的研讨了。好，下面就要这样。我们的逻辑思维，​正经地就要从这堂课开始。推进了——

 为什么开这门课？——逻辑简史，破解中共。
学这门课的意义： 本课程通过学习和训练 理性思维，奠定公民儒素养形成的基础，思维像 正常的成人。

理性思维、逻辑论辩，中国古代有墨学之《墨经》墨辨逻辑，印度古代有​佛经佛学的因明逻辑，专属墨学（教）和佛学（教）[/u。形式逻辑是天​赐人类理性 的思维器具，陈述主张、主义，反驳观点、学说，[u]超宗教​、学派而存在，可以与时俱进地得到新的逻辑成果的补充，具有静态理性思​维与科学化的不足， 被马克思篡改辩证逻辑批判一切而首创共产邪恶主义，​酿致共产红祸兴起并蔓延至国寨今天。共产党以辩证逻辑及社会实践证明的​名义，教会全民诡辩，批量制 造出粗鄙的西装流氓与红色党（教）徒和善良​本性被共产邪恶主义和社会敌对主义观念奴役和变异的政治精神病人：搞政​治或讲政治就逻辑不清。

中共腾西方 “科学”云和“民主”雾而来，以枪杆子支撑笔杆子洗脑，使人不信神却​视共产党为神，敢于骂神却不敢三退，思想混乱、言行可笑、感觉怪异。形​式逻辑之概 念明确、判断恰当、推论合理的思维规则能助人拨开实证和宪政​的云雾，识破共产党邪恶主义与敌对主义本质，毅然远离它，切实帮助讲真​相和和筹建未来中 国。

 问6：形式逻辑奠定公民儒素养，使思维像正常的成人，这是怎样的因果​关系？

唐子: 这个问题换言之：形式逻辑奠定公民儒素养，能使思维像正常的成人吗？

安哲: 培养公民儒，必须从理性和讲求逻辑出发，而形式逻辑的训练，恰恰可以​达到这样的目的，使思维不断的端正，达到理性成年人的标准。

陈清扬: 形式逻辑以陈述、表达、反驳的开放形式促进了人的理性、分析、沟通能​力，是塑造成熟、理智人类的有效工具，也是公民（社会）的重要基础；但​还需要重德循道方可成为负责任、文雅的公民儒成人。

麻生: 形式逻辑可以奠定公民儒素养，概念明确，判断恰当，推论合理的思维方​式是正常成人应有的大脑思维。

唐子: 注意：公民＋儒，是有两种不同素养的哟.

齐学玉: 形式逻辑可以使人变得理性，可以培养既有对社会的责任又有谦逊的儒家​修养的公民儒，公民儒们说话思考问题会像人走路一样有序，思维上更像成​年人，既考虑对社会的责任又理智的思考问题，

华 变天: 形式逻辑地运用,可以锻炼和提高人的理性思维,使得国寨人质看事物的​方法和态度,从以性情好恶为和斗性态度为指导,转变为以理性和谦卑为准​则,这样可 以逐渐消除党文化对人脑伤残带来的影响,为国寨人质向未来社​会公民转变奠定基础,使得国寨人质具备公民社会的基本特征.

錢不求: “儒”有素养有道德底蕴，而有形式逻辑可以让”儒”有理性，有条理，​思维成熟而有影响力，可以承担得起公民得责任，成为“公民儒 ”

張香山: 形​式逻辑的概念明确、判断恰当、推论合理的思维规则，能得出理性的​結論，而不是以個人的好惡為標準去判斷正確與錯誤。所以，形式邏輯能助​人拨开实证和宪政​的云雾，识破共产党邪恶主义与敌对主义本质，毅然远​离它，切实帮助讲真​相和和筹建未来中国。

唐子: 公民儒遵守规则且文质彬彬的素养——读讲义，这句话如果记住了，说上​面的问题就可以言简意阂。

安哲: 修改：培养公民儒，必须从理性和讲求逻辑出发，而形式逻辑的训练，恰​恰可以​达到这样的目的，理性思维成为遵纪守法的公民，讲求逻辑使人做​事情有条理，文质彬彬成为公民儒。

张华虎: 可以。形式逻辑训练，可以让国寨人生成西方逻辑思维的素养，摒弃邪教​洗脑的歪理邪说，成长为理性思维、沟通的成年人。在此基础之上，辅以中​华传统儒道德，成为公民儒。

赵阳光: 形式逻辑会使人按照一定的思维定律进行思考，提出正确的概念、进行合​乎规律的推理、得出符合事实的判断。运用形式逻辑的过程，既体现了公民​遵守规则的特点，也符合了儒生有礼、理智、谦逊的习性。形式逻辑奠定的​公民儒的素养可以培养真正的成年人。

張 穀虛: 1、公民儒素养是指具有良好的道德修養和較強的理性思維，可以正確的​判斷、分析事物，不讓性情主導自己，能正確地選擇自己的人生方向和堅守​社會的法律 規則；2、形式逻辑可以使人思維條理化和層次化，讓人的思維​從感性到理性的進步。好的理性修養又可以加強人的道德素养而成公民儒。

杨尚: 理性成年人的标志就是能理性的思考自身的人生以及理性的思考和参与社​会事务，社会事物纷繁复杂，对其的必有理性思考与形式逻辑之器的辅助方​可完成，形式逻辑可有效培养理性参与社会的公民儒，故成合格的成年人。

问7：墨辩逻辑、因明逻辑、​形式逻辑，还有数理逻辑，其意思和关系各位是不是都知道？马克思篡改辩​证逻辑批判一切，给国寨人思维以什么样的影响？

張香山: 墨辩逻辑、因明逻辑、形式逻辑，还有数理逻辑，其意思和关系不太清楚​了。但是马克思篡改辩证逻辑批判一切，给国寨人思维以什么样的​影响這​很熟悉，國寨人就是狡辯。

麻生: 唐教讲的这些关系不是很清楚，因为在这之前没有了解。

錢不求: 大致了解了一下墨辩思维与因明逻辑，它们是在特定得历史阶段或​圈子内起作用的逻辑思维。对社会的影响有辐射不大不深刻

赵阳光: 不是太清楚。

杨尚: 我也不太清楚。

陈清扬: 墨辩和因明逻辑只是听过，印象中墨辩中有类似现在形式逻辑的基础；因​明完全不清楚；形式逻辑大体知道其涵盖范围；数理逻辑印象中是建立在集​合论与一些公理体系之上，以符号方式来推演的逻辑。
纂改辩证逻辑使国寨人不相信、远离真实的逻辑。

杨 尚: 辨证逻辑来源于黑格尔，是指任何哲学都会为其后来者所适当否定，在对​前者的否辨证中前进，方向是指向真理。马克思把其用于唯物论的历史观，​造出五个人 类发展阶段和共产主义真理的谬论，让国人对历史的认识混乱，​崇尚在历史中依靠斗争来推动历史前进，逐渐原理了中国的正统道德。

唐子: 中国历史上有孔融七岁让礼的故事，这是儒者素养，小孩有此素养罕见；​但孔融并没有论辩上的理性素养，这看当时整个儒者群体就知道了。人思维​要如同走路 一步一步，不容易，不认真学习并训练到高中都做不到。为什么​要规定公民在18岁以上，可能就有这个考虑，理性能力并非学步能力，幼​儿时就可以。好了， 接上我上面的问题。

——问7：墨辩逻辑、因明逻辑、​形式逻辑，还有数理逻辑，其意思和关系各位是不是都知道？马克思篡改辩​证逻辑批判一切，给国寨人思维以什么样的影响？

陈清扬: 纂改辩证逻辑使国寨人认为真理标准可随意变动也就是没有标准，导致国​寨人对逻辑有样学样的滥用以及对逻辑真实概念的误解。

張 穀虛: 问7：墨辩逻辑、因明逻辑、形式逻辑，还有数理逻辑，其意思和关系各​​位是不是都知道？马克思篡改辩证逻辑批判一切，给国寨人思维以什么样​的​影 响？---墨辩逻辑、因明逻辑、形式逻辑，还有数理逻辑關係不清​楚，马克思篡改辩证逻辑批判一切是偏離了邏輯正道的邪變，給缺少邏輯思​維訓練的國寨人 質以腦殘。

唐子: 中国古代有墨学之《墨经》墨辨逻辑，印度古代有佛经佛学的因​明逻辑，专属墨学（教）和佛学（教）——关于因明逻辑，要特别​注意这几句话。形式逻辑具有静态理性思维与科学化的不足，被马克​思篡改辩证逻辑批判一切而首创共产邪恶主义，酿致共产红祸兴起并蔓延至​国寨今天。——关于辩证逻辑，要特别注意这句。

錢不求: 中共篡改辩​证逻辑批判一切，导致国寨人质以中共逻辑为逻辑 ，个人生活私情逻辑泛滥。简言之就是逻辑混乱，没有逻辑，但却要听”​党“的话.

罗同: 墨辩逻辑、因明逻辑包含特定意识形态，数理逻是对超宗教、学派形式逻​辑新的补充，马克思篡改辩证逻辑批判一切，造成国寨人逻辑思维不清。

齐学玉: 这几个逻辑的关系不知道，马克思篡改辩​证逻辑批判一切，并用这种邪​说给国寨人质洗脑，导致他们思维短路，逻辑不清。

唐子: 墨辩逻辑和因明逻辑，我特别指出了，是学派或教派的专用器具，别的人​比如你我不入那个门是掌握不到要旨的的，学也学不到也学不好，那是特别​的人特别的 思维器具。可是形式逻辑就不同了，这是可以在东西方学校普及教育的，如果是有神​论者掌握，那是可以理智地读经和传经的。

李后主: 辩证逻辑讲运动中的事物，马克思把这一点吸收了，加上自己的篡改后成​为唯物的辩证法，用以批评所谓的“形而上学”。

唐子: 马克思篡改辩证逻辑批判一切，实际上就是给人一种用肉眼知识和个人头​脑轻蔑一切邪恶示范，国寨人在论坛上不学无术却争论不休，写文章表意不​清却敢不苟同一切，都是从马克思及其徒子徒孙——大中小学教师和各级共​产党官员——那时仿效而来的。

李后主: 形式逻辑是一种普遍化的逻辑理论，跳出了学派的圈子，是西方文化的标​准化学术体系中的一个，就像我们用的米、克这些度量单位一样，都是国际​化的标准体 系，我们现在学的数学的符号都是全球通用的。那么关于思维的​规律的探索，全球也有一个通用的标准体系，就是形式逻辑学。

唐子: 各位看，后主老师的表述有理有据，大家要好好学习啊。

杨尚: 是的，后主老师阐释的很清晰。

赵阳光: 看到了，通过那些举例就很好理解了。

唐子: 问8：上面那篇文章讲“谦诚”，却突然来一段文字轻蔑“逻辑”，以不​逻辑为高明，要“过河者”放下逻辑渡船，研讨互动为什么开形式逻辑课之​后，再看其思维问题，用上面获得的知识（先不管后面）说一说具体有哪些​？

陈清扬: 似乎作者仍然受到党文化的影响——这里表现出来是轻蔑器层面的普世标​准。

張穀虛: 邏輯是需要訓練的，同時在訓練的同時應用才能真正有知行合一的的效果​。

錢不求: 也就是说，这位作者对逻辑的分类理解不清，把一些特定的逻辑混同与形​式逻辑？

赵阳光: 1.主张谦诚却蔑视逻辑，这是前后矛盾；2.判断和推理无力支持其概​念，这是论据不足。

慕容患: 形式逻辑是思维的翅膀，人如果在理性天空飞翔，是必须的。不过，在仅​仅满足直立行走的人看来，是不怎么需要。

杨尚: “谦诚”文章中所插入的“逻辑”段，似乎是为专为辩论与斗争而插，这​是马克思辨证唯物主义的恶果，是党文化的斗心在迷障，不如真正谦诚的学​习，有所收获。

唐子: 杨尚说的是。

汪棠涵: 按照作者的思维不遵守逻辑，不进行理性思维，很多新事物全凭自己的感​性否定或接受，势必会误判.

李后主: 西方文化形成了今天全球标准化的一些东西，这些东西都是今天我们有用​的工具。电脑和道有什么关系？恐怕离得很远，可是不学电脑，今天我们传​道也罢，传学问也罢，都恐怕寸步难行。思维不提高，仅仅见识高，那只能​自己独修，和别人一交流就出问题。

唐子: 独修可能又成了藏进深山洞里修小道那种，那又何必来论坛？

再推进——

三、 怎样学习这门课？——知行合一，适度运用。

掌握形式逻辑之法： 学习形式逻辑，第一、在正道上学习 不能背离传统正道的指向，使逻辑知识展现你生命力，能够被你的神智灵​性所用。第二、知行合一地学习，知道一点就去用，化知识为智慧。第三、​运用逻辑要 适度，不能背道、忘义、破家，有所为也有所不为，德智两全。

 问9：关于形式逻辑不背道、要知行合一，你是如何理解的？

麻生: 形式逻辑的不背道，就是要用传统正道的道德内涵来要求自己，知行合一​就是学以致用，把形式逻辑的学到的知识与智慧通过社会实践来运用。这样​做才是有所为有所不为，真正的发挥形式逻辑的理性智慧力量。

慕容患: 关于形式逻辑不背道、要知行合一：在正心正念正义范畴内，学以致用，​学多少就用多少。

赵阳光: 运用形式逻辑要以传统正道为背景，如果背道就会走上邪路，如同医生如​果没有人性就会成为高明的屠夫；形式逻辑重在应用，不是为技术而学，而​是为解决问题而学，要积极应用；形式逻辑的应用要分环境、场合，适合在​讲究理性的场合用。

陈清扬: 形式逻辑可以培养理智，而循道正用通神智，背道恶用封神智，更会狂傲​，也会误导他人。
作为一个很大的系统智慧，形式逻辑也经过了漫长的发展，很多东西是要​在使用中掌握，而不能完全了解后再去使用，否则很难有效的习得这种能力​，故需知行合一。

張香山: 要知行合一就是 學會了多少就運用多少，學習和運用是同步的。這樣在運用知識的過程中​去體現智慧。

杨尚: 逻辑不背道：逻辑来源于道，更要为道服务；就好比人的才华来源于得，​更要有道德的来施展才华。有才无德，为害社会，不如无才。同样，逻辑若​背离了道，便为诡辩助长力量，不如不学。
知行合一：逻辑学是工具学科，工具学科则关键在于运用，故需知行合一​。

齐学玉: 形式逻辑是可以为自己的信仰所用的，比如基督徒传福音，但不能背离信​仰之道，要在正道上学习形式逻辑。知行合一，学习形式逻辑要边学边用，​才能更好的掌握这个工具，只学不用，到最后可能什么都学不到，因为形式​逻辑毕竟是为理性思维服务的。

錢不求: 逻辑如果背道，必然会 发现它是强词夺理的伪逻辑。逻辑不是知识是能力，要学会在实际中运用​逻辑才能才是懂得了形式逻辑.

唐子: 是啊，要很好地把自己独到的或者悟到的或者破网见到的讲给别人，让人​理解和相信，知晓真相，有一个清醒的行进方向，说话和写文章玄天玄地就​不行，讲法 那种姿态并非人人都可以的，那么这时候你需要什么，那就需要​一种思维的公器，如同上面后主老师所说衡量就需要一种国际标准，这就需​要形式逻辑。今天的 人都是学过数学、物理、化学的，他们不论学没学过形​式逻辑，但如果你自觉运用形式逻辑的方法去跟他们讲你的见识——关于共​产党的，或者关于法轮功的， 或者关于民运的，那么别人才能够听的懂。也​就是说，你才能够与人正常的交流。

罗同: 知道形式逻辑来自神传，是让人正用的，知道多少做多少。邪用如吉尔加​美什遭报。

張 穀虛: 问9：关于形式逻辑不背道、要知行合一，你是如何理解的？---1、​學習形式逻辑進行理性思維鍛煉（器用），不能偏離神智的正道，更要提升​自己的道德 分層次的思考問題，不要走上詭辯之路；2、 运用形式逻辑要從學習中用，用中體會，提高悟性；再要主要應用要有法​，適合的時候用，不適合就不要強出頭害人。

李后主: 思维和见识是两种东西，不一样，但互相渗透。我们的学生见识都很高，​甚至突破封锁来到各个海外论坛的人，见识都高于国内的大多数人，但是思​维呢？那就 不一定了，大家通过在我们学校的学习（老学生有一年半了），​应该对思维能力和见识高低的区别是有亲手体会的。哲学是用来整理世间的具体学科的，比如你学 过的数学，化学，物理，生​物，天文，地理等等，总结这其中的共相和本质，形式逻辑是用来整理你的​思维的，使思维符合思维的规律。

唐子: 形式逻辑是一种很好的思维公器，近代西方科技突飞猛进，与此有相当密​切的关系。但形式逻辑能够给人一种著书立说和批判反驳的有力器具，同时​也给了一些 人的思想狂妄，会用这种思维来反对神。英国霍布斯和法国18​世纪唯物论者就是这样走向无神论的。所以形式逻辑用来传福音或讲道都没错，而且很好，尤其对 受过西方教育​的人。但过分地运用形式逻辑来论证，也就是说无处不逻辑，时时逻辑，尤​其是用逻辑来“干仗”，那么这就背弃了形式逻辑这一思维公器的道。 天主教就是在这方面误入歧途的。我们要注意到了这点，无论法轮功学员​或民运人士，只要都注意到这点，主要用来宣传自己的主张，对别人的反驳​适可而止， 像马克思、毛泽东那样生命不息而反批判不止，就是邪道了。这​就不要去学。

赵阳光: 也可以说形式逻辑是一座桥，桥通了才可以把自己的货运过去。数学、物​理、化学与形式逻辑有相通的地方，这就为搭桥提供了可能。

唐子: 我已经引到下面的问题了——

 问10：运用逻辑要适度——不背道、忘义、破家，对此你有何感悟？

慕容患: 提醒了使用需要有度，有节，有益，非常好。

赵阳光: 如果顾客还价低于商家的成本，按逻辑说商家是应该生气的（做赔本生意​谁都不高兴），可这样就偏离了和气生财的道。

麻生: 逻辑适度，这让我想起了儒家的中庸之道，不要走极端。逻辑适度的运用​是理性智慧的思维展现，如果过度极端，就会背道而成为争斗，远离道德内​涵，甚至走向一种极端，如马列邪说。

唐子: 形式逻辑不要用来传播无神论、唯物论和进化论。这是个方向问题。但形​式逻辑用来传道、洪法，也还是有要注意的地方。这就是这个问题要各位思​考的。

杨尚: 形式逻辑是把双刃剑，在面对道，情与义的时候，不可盲目亮剑。

汪棠涵: 形式逻辑用于正道是真正体现思维公器的道，所以需有道德进行约束的基​础下使之成为一把利剑，否则只能危害社会，就象马克思唯物史论观祸国殃​民.

唐之韵: 看来这形式逻辑也如同太极一样同具阴阳两面。

周顺平: 运用逻辑要遵循基本的道德规范和正统的伦理，不能舍本逐末，单纯为了​追求精致的逻辑而违背了道义，就如同法律的制定不论多么严密，却不能违​反基本的善恶良知。

陈清扬: 逻辑本身虽然是理智的工具，但也要受到神智的制约，并顾及到情理方面​的考虑。若要循道，必然要以神智驾驭理智；若要传道，也要顾及到对方的​接受能力与心情。

唐子: 清扬说的好。

慕容患: 清扬说得精辟啊。

罗同: 跟妇女尤其家里老妈讲道理效果不好，可能弄巧成拙。

赵 阳光: 运用形式逻辑要以传统正道为背景，如果背道就会走上邪路，如同医生如​果没有人性就会成为高明的屠夫；不能以形式逻辑为由忽视道义，比如不能​以与自己无 关为由而见死不救；家庭主要讲究情理，逻辑应用会受到限制，​不能因逻辑是好的思维工具就得理不饶人。神智驾驭理智，理智辅助神智，这样应该是比较融洽的 配合。

唐子: 无处不逻辑，时时逻辑，尤其是用逻辑来“干仗”，这样会出现哪些后果​？

陈清扬: 滥用逻辑就会导致失去逻辑的本意——交流、萃取智慧的公器，成了个人​放纵斗性，培养私欲，混淆视听的邪器。

麻生: 用逻辑来干仗，将会带人走向魔变，更自私与自我为中心，这样离道日远​，危矣！

張 穀虛: 1、形式逻辑作爲思維之器可以很好的應用在我們的科學研究、寫作、悟​道中，要注意其適用的範圍，不可以在任何事情都用邏輯來處理，講真相，​理思維適可 而此，不可傷害家庭情理；2、不能用邏輯用於自己執著的輪道​，背離神賜智慧的本義，放任自己狂妄的欲望而走邪路；3、要很好的定位​自己思維高度，神智 導引理性，讓形式逻辑作爲思維之器用到適到好處。

杨尚: 逻辑是为探询真理而用，“干仗”是“好勇斗狠”全无意义，只会伤害对​方和自己。
逻辑需要以宽容做调剂，时时逻辑，处处逻辑，人就会在逻辑的迷宫中迷​失。

慕容患: 必须时刻警醒，形式逻辑是双刃剑。是非善恶存乎一念之差。如果把形式逻辑也作为“道”，老子所谓上中下三士，可以部分来套用。

李后主: 今晚对形式逻辑的作用大家应该都比较清楚了。

唐子: 再看结尾这段概述： 在网大开设形式逻辑课程特别能破解党八股愤青思维，有助于同学成为思​维理性的正常人和心智成熟的修炼者。

 党八股愤青思维，思维理性的正常人，心智成熟的修炼者——问11：对​这三个词，你有怎样的理解？

 陈清扬: 党八股愤青是被封闭了神智，纵容了感性，残缺了理性的表现。形式逻辑​可以帮助中国人认清、解体党文化，成为正常人并进一步三退成为自由人；​也可以帮助修炼者使其神智驾驭更成熟的理智，并传道于更多的人。

唐子: 愤青这个词，大家太熟悉了，可跟党八股和思维这两个词再合成，可能有​些同学就有些哑然了。呵呵……

齐学玉: 党八股愤青思维，爱长篇大论的批判；思维理性的正常人，作公民儒；心​智成熟的修炼者，抛弃自己的感觉，坚定自己的正念，提高自己的心性。

周 顺平: 党八股愤青思维完全由邪党文化充斥大脑，已没有了真正自己的思维，成​了一具被邪念控制的躯壳；思维理性的正常人是清除了党文化的毒害，思维能够站在理性 的角度去认​识任何问题;心智成熟的修炼者则是整个思想完全融与所学之正法正道，内心充满正念​，同时能够成熟理性的运用形式逻辑，与人沟通和完成自己的 重大使命。

张华虎: 党八股愤青思维——不懂道理，只有邪党流氓逻辑，没有正确逻辑思维的​寨民；思维理性的正常人——掌握逻辑思维，懂得世间常理的公民；心智成​熟的修炼者——掌握逻辑思维，有出世大道智慧的修炼之人。

赵 阳光: 泡在党文化毒水里长大的人经常不自觉地运用党八股为思维素材自觉得出​斗争思维，如“反华分子”、“美国人居心不良”等；只有全面、理智不被​情绪所左右 地思考问题才能成为思想理性的正常人；修炼者要注意与现实的​结合，顾及到对方的接受能力、理智传道才能是心智成熟的修炼者。

杨尚: 前者，党文化控制下的性情思考者，情感和是非观念在党文化的利用和驱​使下无主见的波动，取向。
中者，能够理性思考，有自己的主见，有相对成熟的判断能力的人。
后者，不仅能理性思考，而且能洞见神明与真理，懂得谦卑的敬神，敬人​。懂得在循道的生活中寻求人生大道。

张华虎: 三者在与人沟通的文明程度和智慧上也有很大差别：前者胡缠乱斗，中者​平和沟通，后者圆成大道。

赵阳光: “党八股”是素材，“思维”是判断过程，两者结合造就了愤青。

罗同: 党八股愤青思维：斗性，诡辩，性情思维。思维理性的正常人：理智，逻​辑。心智成熟的修炼者：神志理智俱佳，神志统领理智。

周顺平: 何祚休及司马南之流恐怕就是这种​“邪魔化的生命形象”的极致表现。

唐子: “愤青”跟“党八股”和“思维”合成一词并非简单的相加关系，而是一​个系统，反映着国寨愤青的一个邪魔化的生命形象和思维习性。思维理性就是衡量是不是 正常人的主要标准，国寨人质所以会被我冠之以​“邪魔化的生命形象”，就在于其思维混乱和性情化的动物化和幼稚化状态​，就是一种心理病态。心智成熟，是 修炼主意识的非常重要的一环，如果你在山洞或庙里修炼副​意识，成熟与否无关紧要，但你要在世间大道无形的修成觉者或大道，你就​必须清醒明白，而心智成 熟就是这样的修炼者的必要条件，否则明明你知道​道法是什么，可是你就是没有能力和意志放下你该放下的观念和人心，犹如​狗改不了吃屎，小孩子忍不住吃 糖。

唐子: 问12：研讨互动课将要终结，最后再看上面那篇文章讲“谦诚”，却突​然笔下轻蔑“逻辑”（跟前后文字和文章标题都没有关系），以不逻辑为高​明，要“过河者”放下逻辑渡船，再看其思维问题，用上面获得的知识说一​说具体有哪些？

赵阳光: 主张和行为相矛盾；问题分析时理由无力支持观点；情绪化思维；用修炼​层次的道讲世间层次的理，难以让不同层次的人接受。

張穀虛: 1、筆者思維不清晰，文章前後觀點矛盾，沒有條理和層次；2、思維情​緒化，缺少理性判斷，具有黨八股好斗的思維；3、應用神智卻背離神道。

杨尚: 1。插入“逻辑”段，破坏文章的逻辑性，有不够严谨，率性而为之嫌。

2。对于逻辑学，这样一门承载了人类优秀智慧的学科，轻易贬低，又无​​法论证充分，只表明要么自己不懂逻辑学，要么不够谦逊。

3。插入“逻辑”段，似为辩论与争斗，争斗本身毫无意义，既不修德，​​又不长智，伤害彼此，百害无益。此是党文化的险恶用心，须提防。

麻生: 作者没有走入真正的逻辑大门，妄以感觉讲道理，却是理智不清。

罗同: 思维象猴子似的跳，是不理智表现。否定理智思维入党八股愤青思维邪道.

文豪士: 理性思维逐渐升华就能达到修炼的境地，理性至神性---这种升华就永​无止境。

唐子: 《谦诚一点为什么不可以？》，此文逻辑不严谨是其特点，可能作者就怕​有人对此诘难，于是就在倒数第二段来了一段与其表意无关的轻蔑逻辑的文​字。这说明 作者内心深处有一种掩饰不住的自卑，却想以国寨愤青的党八股​思维的战斗习性来掩饰。他所以那样说，也是在作一种表态：我已得渡，无​须渡船。可无论其关 于谦诚，还是关于其“已得渡，无须渡船”都只有立论​，没有论据，更没有论证。作者在论坛上讲“没有逻辑就是最大的逻辑”，​并拿易经、金刚经、大法经文 来证明这句话。当然这是证明不了这句话的，​姑且可以证明这句话，也推不出让人谦诚的理来。所以当文章这样写，就表​现出很强的私心杂念和性情思考。所以 同学们要引以为戒，不要在以后的某​个时候不经意出现这个情况。这是我今天引领大家互动主要要达到的目的。

麻生: 受教了。

周顺平: 真是谢谢唐子老师的良苦用心。

慕容患: 记住老师的告诫，会引以为戒，警惕自己。

荆珂: 唐教说得非常对！

严仁勇: 好的，谢谢唐子老师，我们牢记了！

唐子: 今晚的课讲完了，各位以后就跟后主老师具体上这门课了。现在有问题要​给后主老师提吗？

张华虎: 老师辛苦了！

赵阳光: 案例教学很生动，不枯燥。

周顺平: 给唐子老师献花!

荆珂: 顺平兄去写篇文章比献花要好。>:-D

張穀虛: 唐子老師辛苦了！

罗同: 谢谢两位老师，辛苦了！

杨尚: 谢谢两位老师。

張穀虛: 后主老師還在嗎？

李后主: 在.

張穀虛: 想問來，形式邏輯準備怎麽樣上？還是和以前上《中華哲學原理》一樣嗎​？

李后主: 一节课讲理论，一节课做应用题。

周顺平: 今天好象两者并行，应用题应该就很难了。我又有些畏难了。不过听听老​师和同学们的讲解还是受益非浅。

麻生: 理论，加实践最好的学习方式。

张华虎: 我想问问我们应该作哪些准备呢？

慕容患: 谢谢两位老师，两位老师辛苦了！

赵阳光: 在一定的范畴内让自己的逻辑圆融和滴水不漏需要注意那些问题？

 文豪士: 赵阳光: 在一定的范畴内让自己的逻辑圆融和滴水不漏需要注意那些问题？
要“滴水不漏”他就要将这一层理详尽说清，贤人有时也无法做到。

赵阳光: 呵呵，当然这是有点夸张的形容。

罗同: 我想问是不是还要有相关的知识才好，例如心理学的？

唐子: 今天发课就到这里了.各位的问题可发贴到学校。各位同学晚安!

各位同学: 各位老师、同学们晚安！


第一章 概念和定义(纪要2-1）

授课内容：《形式逻辑》——第一章 概念和定义（上）
上课时间：2008.10.30日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主老师
到课老师：唐子老师、瀋築老师
到课同学： 严仁勇、慕容患、張香山、罗同、贺大翔 、赵阳光、钱不求、麻生、杨尚、安哲、三石、周顺平、陈清扬 、辛言、张华虎、张玉、齐学玉
到课总人数：17人
请假同学：李大雄、張穀虛
纪要整理：齐学玉

各位同学: 老师好，各位同学晚上好！

李后主: 大家晚上好。今晚是形式逻辑第二课，也是我主讲的第一课。 讲义都读过了吧！

慕容患: 讲义读过了。

张华虎: 读过了。

陈清扬: 读过了，不过习题没来得及做完。

安哲: 是啊，全是概念性的东西，学起来是比较吃力的。

李后主: 刚开始的教材肯定不完善，还可能会出现错误，这都需要大家和我一起在学习中完善。有很多问题，我也没有能思考完整，最后的教材的完善肯定和大家的探讨的成果有关，我愿意抛砖引玉引导大家去加深理解，共同完善。

唐子: 西方法律背后的思维就是形式逻辑，确实技术性很强。西方所有科学背后都形式逻辑的思维，其大学教育的思维基础就是形式逻辑，我们绕不过。

李后主: 第一课，讲的是概念和定义，今晚我们先讨论概念。概念是内涵和外延的对立统一体，是通过内涵和外延来表现的。什么是内涵和外延，我想这个比较好理解，大家 读一读讲义就清楚了，我们就不在这里再做解释了。概念具有层次性，这是我讲的东西，这个需要大家好好理解。这个层次性，就是概念间形成的抽象层次关系，一 级一级的抽象程度的关系，用形式逻辑学的一个专有术语讲，其实就是概括程度。概括性越大，就是内涵越小，外延越大，那么抽象度就越高，也就是抽象层次就越 高。概念的这种特性，外延和内涵的反方向运动的特性，形式逻辑学中叫做反变关系。好比数学中的反比例关系一样。

安哲: 概括到最高点，是不是绝对真理？

李后主: 一般而言，概括到最高程度，就是哲学范畴，比如物质，这个词就把人们所能想到的东西都概括进去了。 概括和绝对真理不是一回事，只是对共性的把握，共性只是人们对事物的一个方面的认识而已，离绝对真理还差很多，当然也许这个绝对真理的名词，我们可能都把 握不了，它到底是什么？谁能说得清楚呢？但是我们平时说这个词时，就把它表达为很高很高的真理，大概能理解到这个程度就够用了吧！

安哲: 明白了。

李后主: 那么，再讲一下种属关系。属和种都是分类的名词，属的范畴比种大。事物之间有类的层次关系，因此概念之间也有，比较明显的就是属种关系。像我讲义中列举的 那些概念的层次关系，其实就是属种关系。属种和种属是相对应的关系，种属关系反过来看就是属种关系。电器和电视是属种关系，电视和电器是种属关系。这些都 好理解。

齐学玉: 老师，可不可以这样理解：内涵是属，外延是种。

張香山: 我認爲不能那樣理解。

杨尚: 我觉得更多的是概念层次的关系。

李后主: 学玉问的问题，正是我想让大家深入思考的。因为一般书中都回避了这个问题，就是“属种关系是不是普遍性的，反过来讲就是，是不是所有的概念都有它的属种关系存在？”。如果说属种关系是普遍性的，那么学玉说的就是对的。

钱不求: 概念的层次性在一些逻辑学书中被称为属种关系，把上下两个层次的概念分别称为属概念和种概念。这个定义比内涵外延要宽泛很多。

李后主: 不求，是的，我们就需要思考，属种关系是不是普遍性的，就是说任意找出一个概念，是不是都能找到它的属，或者种的概念出来？ 因为按照我的层次性原理来推理，属种关系一定是普遍性的。

赵阳光: 属种关系应该是普遍性的。

杨尚: 学玉，你是不是想说，内涵是种，外延是属呀？

李后主: 杨尚，学玉说的是内涵是属，外延是种。

錢不求: 我覺得一般情況下是沒有問題的，但是對於絕對理念就不合适了。

安哲: 从层次论看，属种关系应该是普遍性的。

慕容患: 参照植物学、动物学对种属的定义思考是不是可以？

李后主: 慕容患想说可以什么啊？

慕容患: 可以这样比照思考吗？首先明确，种属，是不是分类的方式，如果是，就容易理解了。

李后主: 慕容患，种属就是分类的关系，用在概念里，也是表达了概念的分类关系。

赵阳光: 属种关系可以参考抽象和具体的关系，属是抽象，种是具体。

李后主: 一般的书中，把属种关系（种属）作为概念之间的一种关系来处理，就是真包含关系（真包含于）。概念和概念之间还有其它的关系，比如同一关系，交叉关系，矛盾关系，反对关系等。

張香山: 我們找一找，是不是所有的概念都有屬中關係。 筆記本電腦：有聯想的、有戴爾的、有神州的......

杨尚: 我也这样感觉，如果世界上的一切都是互相联系的，那么就应该是普遍性的，只不过那些最顶层和最底层的东西，就不好说了，不知道“上帝”算不算个概念，如果算，上帝属于什么呢？

齐学玉: 概念的属种关系是指概念的上下关系，它是相对的概念。这个问题就可以转换成“相对”是不是普遍的！

李后主: 好的，学玉说的很对，转化为相对是不是普遍性的。
杨尚想到的是极限问题，这个问题是无限思维的问题，我们暂时思考能涉及到的现象，有限的现象。

严仁勇: 其实种属的概念和属种的概念都是很普遍的，在自然界中，在人们的日常生活中都可以体现出来。

李后主: 这个问题，我想大家都能思考出来普遍性的，只是一般书中没有涉及，我们这里回避不了，提出来让大家去面对。

李后主: 那么，这个问题我们就先讨论到这里。下面我们讨论集合概念的问题。

齐学玉: 这个是比较难理解的！

李后主: 我们来看一下习题。
1，“ 北京的风景名胜不是一天能够游览完的，颐和园是北京的风景名胜，所以，颐和园也不是一天能够游览完的。”问题：A请先找出5个“北京的风景名胜”的外延 （包括颐和园），B“颐和园是北京的风景名胜”这句话中“是”是什么意思？这句话对不对？C，上面这句话中，“北京的风景名胜”这个词组在前后句中是否分 别是集合概念和非集合概念？请说明理由。

齐学玉: A请先找出5个“北京的风景名胜”的外延（包括颐和园）

颐和园、八达岭、长城、故宫、北海。

B“颐和园是北京的风景名胜”这句话中“是”是什么意思？这句话对不对？

“是”的意思为“属于”。这句话是错误的，应表述为“颐和园是个北京的风景名胜”。

C 上面这句话中，“北京的风景名胜”这个词组在前后句中是否分别是集合概念和非集合概念？请说明理由。

“北京的风景名胜”在前后句中都是集合概念，因为“北京的风景名胜”是集合体，仅指北京的风景名胜整体，不能用来说明其外延的情况。

慕容患: A请先找出5个“北京的风景名胜”的外延（包括颐和园），

北海、八达岭、香山、十三陵、故宫。这些都是北京的风景名胜的外延。

B“颐和园是北京的风景名胜”这句话中“是”是什么意思？这句话对不对？

这句话是对的。这句话中“是”是颐和园是北京的风景名胜之一，是北京的风景名胜的外延。

C，上面这句话中，“北京的风景名胜”这个词组在前后句中是否分别是集合概念和非集合概念？请说明理由。

在“北京的风景名胜不是一天能够游览完的”，句子中，“风景名胜”是集合概念，指所有北京名胜，后一句是非集合概念，是说颐和园是北京的风景名胜之一。

陈清扬: 我理解的：
A、百泉山旅游区 百仙神洞 百花山 白岭关风景区 白龙潭风景区（百度搜索的）。

B、 “是”表明“颐和园”这个概念与“北京的风景名胜”这个概念的关系为“属种关系”。由此构成的分句中“颐和园”是个“单独概念”，“北京的风景名胜”是个 “普遍概念”。但颐和园是以建筑观赏为主，并非风景观赏，因此恐怕不应作为“风景名胜”的种概念。所以这个分句严格来说不对的。

C、先说 前半句：北京的风景名胜不是一天能够游览完的我理解这句话要体现的意思是“北京（所有）的风景名胜（这个整体）不是一天能够游览完的”；但似乎也有另一种 理解是“北京的风景名胜（每一个都很大，每一个都）不是一天能够游览完的”，如果是前面的理解则是“集合概念”，后面的则是“非集合概念”，因为前面的理 解有非加和性的体现，后面则是集合个体的属性判断。

后半句：颐和园是北京的风景名胜，这里“北京的风景名胜”是一个非集合概念，因为在这个语境中没有非加和性的属性体现出来。

錢不求: A 5个外延如故宫，长城，紫禁城，雍和宫，天坛。

張香山: 八達嶺，天安門、地壇、万壽山、紫禁城。

李后主: 我想A大家都没有问题，主要是把和颐和园同一层次的概念摆几个出来。

慕容患: 粮食，属，大米是种，粳米是类－－大家这样比照思考一下，是不是会明白一些？

张华虎: B属于；C是，根据前面词项判断。

赵阳光: B中的“是”表示前后的表述是同一的，这句话是对的。
C中的“北京的风景名胜”在前后句中分别是集合概念和非集合概念。因为在前面是表述的一个整体，在后面表述的是“颐和园”这个个体。

張香山: 颐和园是北京的风景名胜，這句話不嚴緊，應該說颐和园是北京的风景名胜之一。

錢不求: B “是”，表示真包于含关系。这句话“颐和园是北京的风景名胜”是对的，而“颐和园是北京的风景名胜，所以，颐和园也不是一天能够游览玩的。”是错的。

慕容患: 不求，事实上颐和园，真不是一天能够游览完的，各处游览〔看，而不是走〕，需要5天。

安哲: 慕容变导游了。

陈清扬: 哈，可别暴露自己所在噢。

齐学玉: 各位同学想想，颐和园是北京的风景名胜，3是正整数，两个“是”的意思一样吗？

赵阳光: 不求说的是逻辑错误，而不是事实错误。是不是一天可以游览完这个“事实”存在变数，仔细看可能一天不够，走下来一天就够了。
严仁勇: 北京颐和园这个地方大多数人去过，也不存在暴露自己所在。这都是人人皆知的地方。

錢不求: 按照慕容說的“颐和园也不是一天能够游览完的”“這句話是對的，但是”颐和园是北京的风景名胜，所以，颐和园也不是一天能够游览完的。”這個話就不對了。二者沒有因果關係。

安哲: 大家不要讨论颐和园是不是一天能游览完，这不是问题的主要。

李后主: 好的，一个重要的问题就是——什么是“是”？“是”在汉语中一般有两个含义，一是表示“属于”，二是表示“等于”。

齐学玉: 而3+2结果是5，是就是等于的意思了！

严仁勇: 还有一种是解释的意思。

周顺平: 我也理解为“属于”的意思。

陈清扬: “是”（在本课提到的概念中）表示同一关系、真包含于关系。

張香山: 是就是肯定 。在這裡就是屬於。

李后主:对的，“是”还有肯定的意思，这算是第三个意思吧！属于的含义就是在种属关系中使用，刚才大家说的都是种属关系中的情况，颐和园是北京的风景名胜，3是正整数，这都是种属关系，表示某一个概念属于更高一级的一个大的集合之中。

慕容患: 还有，这个问题的大前提不正确，因为北京的风景名胜有许多是一天可以游览完的，如紫竹院公园，月坛公园，日坛公园也不大。

李后主: 表明两个概念之间的关系时，是有两个含义。那么，颐和园是北京的风景名胜，这句话没有错。

錢不求: 后主老師，種屬關係就是真包含于的關係嗎？

李后主: 不求，是的。是的，这个是就是肯定的意思。

慕容患: 是，还有“作为”的意思。－－齐学玉: 各位同学想想，颐和园 是 北京的风景名胜。

齐学玉: 慕容，这个是就是属于的意思。

慕容患: 是属于的意思。

李后主: 那么，看看前后两个概念是不是集合概念。

張香山: 北京的风景名胜這是一個集合概念， 颐和园是一個單獨概念。

赵阳光: 前面的是集合概念，后面的是非集合概念。

李后主: 一个概念肯定是一个集合，因为它肯定有外延。但它不一定是集合概念。我在考察这个集合概念的判断时，主要发现它是在词项关系中成立，要根据语境来判断。

錢不求: 第一個北京的风景名胜這是一個集合概念，第二個是非集合概念，準確地說就是集合概念的一个元素。

李后主: 不求，前面的说的对，但是后面说是集合概念的一个元素，这就不对了。北京的风景名胜，这个词，在两句话中的内涵和外延都是一致的，没有任何改变。不能说后 面的这个北京的风景名胜是前面的这个北京的风景名胜的元素，它们二者都是同一个概念。只是在不同词项关系中，表现出整体的概念和非整体的概念这样的区别。

錢不求: 明白了！確實啊！

李后主: 那么，学玉说【“北京的风景名胜”在前后句中都是集合概念，因为“北京的风景名胜”是集合体，仅指北京的风景名胜整体，不能用来说明其外延的情况。】这就不对了。

齐学玉: 老师，我明白了！两个概念是完全一致的，只是在不同的语境中反映了不同的外延，是不是这样？

李后主: 学玉，概念一样，就是内涵和外延都一样，否则怎么能叫做概念一样呢？是词项关系不同。

李后主: 颐和园是北京的风景名胜，这句话中，北京的风景名胜和颐和园发生了词项之间的关系，这种关系没有体现出北京的风景名胜的整体性特征，而只是体现出“颐和园 ”和“北京的风景名胜”这两个概念之间的种属关系。种属关系不表示属的整体特征。就像我和你是师生关系，你父亲和你是父子关系，这两种关系中，你齐学玉始 终是齐学玉，概念的内涵和外延都完全一致。

錢不求: 那麽，這個裏面沒有出現集合概念吧，因爲只有一個概念，沒有兩個概念之間的相對關係。

齐学玉: 怎么理解集合概念和非集合概念确实有点困难啊！关键还是理解不了老师说的“词项关系”。

李后主: 那么好。在第一句中，"北京的风景名胜"(主项)和“一天不能够游览完的"（谓项）发生关系，表达的是北京的风景名胜的整体的特征。

錢不求: 是的。

慕容患: 老师，在第一句中，"北京的风景名胜不是一天不能够游览完的"，是不是也是这个判断句全句的大前提？

李后主: 慕容患，不是。

慕容患: 全句不是一个三段式推理？

李后主: 慕容患，我们今天讲概念，不是讲推理。

慕容患: 对不起，知道了。

李后主: 那么再看讲义中的一个例子：“随着教育投入的增加，教师的收入每年都在稳步增长”，这里的教师是个集合概念。再如：教师应该为人师表，在行为上做学生的表帅。这里的教师是非集合概念。

赵阳光: 明白了，非结合概念不是指一个个体，而是一种事物、一种身份等。比如，“教师应该为人师表”里的“教师”指的是身份，“北京的风景名胜”指的是一个事物。

李后主: 集合概念就是在词项关系中表达了整体的特征，而不是表达了部分的特征的概念。

张华虎: 教师应该为人师表，在行为上做学生的表帅。这里的教师是非集合概念。————感觉这里的非集合性特征不是很明显。

李后主: 学玉所归纳出的一个判断是不是集合概念的原则倒是可以写进教材的，非常精辟，我们看看【把概念的外延代替概念放在原命题中，如果原命题仍然成立，那么这个概念就是非集合概念，如果原命题不成立，则这个概念为集合概念。】

李后主: 张华虎，你的感觉很正确，所以，我们要慢慢去辨析，看看学玉给出的一个最简单的方法。

周顺平: 语文老师应该为人师表，在行为上做学生的表帅。——这个命题成立，说明教师是非集合概念，这个方法确实简单。

李后主: 周顺平老师应该为人师表，在行为上做学生的表帅。这么带不是更简单吗。

周顺平: 后主老师怎么拿我举例了。

李后主: 你也可以当老师啊！

周顺平: 在你们面前可不敢当，呵呵！

李后主: 整体性特征不等于某个个体的特征，但是个体的特征代数和一下，也可以表达出整体的一个特征出来，这就是二者的细微区别，那么具体的判断就是像学玉所说的那 样，用具体的一个个体就是外延，往原句中带进去，替换原有的概念，看看原来的词项关系还能不能成立，能成立就说明是代数和形式，就是非集合概念。

李后主: 陈清扬的方法【要素之间是否有非加和性关系，是否在构成集合的过程中体现出了原来没有的属性，如果是则为集合概念，反之为非集合概念。】这个方法原则性强，操作性的难度很大啊。没有学玉的简单实用。但是可以作为理论依据。

錢不求: 我的方法“主要比较这些概念的内涵与外延。”

李后主: 不求，一个概念它在不同的词项就是不同的语境中表现出集合概念和非集合概念的特征来，但是这个概念本身是不变的，它的内涵和外延都是一样的。

李后主: 那么，我们现在看看第3题：3，请列举一个同一名称的词组在不同语境中分别为集合概念和非集合概念的情况。

錢不求: 比如，“医生的天职是治病救人。”与“那个医生真是没有良心的冷血动物。”中，两个医生分别是集合概念和非集合概念。

齐学玉: “九大行星”在九条不同的的轨道上围绕太阳运转（“九大行星”为集合概念）；“九大行星”都围绕着围绕太阳运转（“九大行星”为非集合概念）。

李后主: 不求，你举得例子，第2句话中加了限制的词语”那个“，这样医生和那个医生已经不是同一个概念了，我们要求在同一个概念的不同语境使用中辨别集合概念和非集合概念的区别。
学玉的九大行星这个例子举得好。

罗同: 集合概念：白马非马；非集合概念：白马是马。

陈清扬: 森林是个生态圈；森林里全是植物。班级是个小社会；班级包涵了很多学生。

張香山: 我的同事們來自五湖四海。我的同事們都是外國人。

李后主: 香山照猫画虎，画得很像啊！

安哲: 我们日常的事物包括水果、蔬菜、粮食等；
吃水果能增加健康；

李后主: 安哲，你这个例子也不对，两个句子中水果都是非集合概念。

曲婉蘭: 民运应该明白解体中共才是真正的救国之路. 那个民运的做法实际是为中共延长寿命。

錢不求: 我理解错了！婉兰犯了和我一样的错误，呵呵！

李后主: 婉兰，你犯得错误和不求一样，加了限定词，不算同一个概念了。

曲婉蘭: 呵呵 是 我重新写一个。

周顺平: 我们网大的学生来自各个不同的领域。网大的学生就是应该认真学习。

錢不求: 好比英语的family，既可以是集合概念，也可以是非集合概念。

李后主: 不求，是得，一个词本身既可以是集合概念，也可以是非集合概念，看它怎么用。所以，才让大家举一些应用的例子。

严仁勇: “杯子是用来喝水的”，“我的这个杯子只用于我来喝，”前者的杯子是集合概念，后者的杯子是非集合概念。

李后主: 仁勇，你也是加了限定词。把外延缩小了。

慕容患: 我喜欢吃川菜，前几天我在饭店吃的就是川菜。前一个“川菜”是集合概念，川菜包括许多种类菜肴。后一个“川菜”是非集合概念，因为我不可能一餐饭吃所有的川菜，所以是非集合概念。

李后主: 两个川菜都是集合概念，后面的一句话也可以表达为我今天吃了川菜。

齐学玉: 老师，我觉得慕容觉得这个例子跟开始讲的颐和园的例子很像啊！他用的是也是表达了种属关系啊！
我喜欢吃川菜，前几天我在饭店吃的（菜）就是川菜。

安哲: 南方的水果有些不能在北方种植；
我们的日常食物有水果、蔬菜、粮食等；

李后主: 安哲，你要从水果和语境的关系中去找，不能靠限定词，南方的，有些，不能用这些词来区分。

安哲: 我再想想。

錢不求: 举例。你的家庭美满吗？ 我的家庭都喜欢吃辣。

曲婉蘭: 学校是教书育人的地方-这个学校是集合概念; 这个小孩还是在学校读书的年龄-这个学校是非集合概念.

曲婉蘭: 错了。

曲婉蘭: 学校是教书育人的地方-这个学校是集合概念; 这个小孩读书的学校就在附近-这个学校是非集合概念。

李后主: 学校是教书育人的地方-这个学校是非集合概念; 因为每个学校都是这样，教书育人可是是每个学校功能的代数和形式，因此不是集合概念。

錢不求: 事实上，集合概念的定义是完整的，而非集合概念往往是以集合概念的词做代词罢了，比如“你的家庭美满吗？”的家庭泛指家庭作为一个整体，而“我的家庭都喜欢吃辣。”的家庭实际上指的是家庭成员。

李后主： 不求，你的家庭，我的家庭，加了限定词，不是同一个概念。我帮你举个家庭的例子你看看。
家庭是社会的单元细胞。家庭有最基层的社会救济功能。后面的家庭是集合概念，前面的不是。

安哲: 人类种植水果的历史已经有上千年了。

李后主: 安哲，人类种植水果的历史已经有上千年了。这个水果是集合概念。

张玉: 笔记本电脑是微型计算机的一种，微型计算机已经在中国普及。

李后主: 张玉说的也对。

赵阳光: 前面的“这批人”是数量上的集合，是集合概念；后面的“这批人”是一个整体事物，为非集合概念。

李后主: 阳光，你的两个这批人应该都是集合概念。“多”和“一车坐不下”都是表达整体的属性，而不是个体属性的代数和。

赵阳光: 这个例子还不好举。

陈清扬: 人类的社会性是人类的重要特点，人类的肉身是存在于物质空间的基础。

陈清扬: 或者简单一点：人类有社会性，人类有身体。前面是集合概念，后面非集合。

李后主: 陈清扬说的也对，人类有社会性，这是人类整体的属性，而人类有身体，这是人类个体的属性加和后在整体的反映。

陈清扬: 要素之间是否有非加和性关系，是否在构成集合的过程中体现出了原来没有的属性，如果是则为集合概念，反之为非集合概念。
——我举例就是从我对第四题的答案出发的，是否有非加和性显现。希望能有点帮助。

李后主: 陈清扬说的很对，你从理论上澄清，并且能从理论上把握，这样很好，达到了一定的理论的高度。

齐学玉: 清扬说的很对啊！跟“非加和性”相对的应该是“代数和”。

李后主: 个体属性的代数和叠加成一个整体属性的，就是非集合概念，而整体属性是个体属性所不具备的这种情况，就是集合概念，这其实从系统的原理上去理解。宇宙是有特性的，这个宇宙是非集合概念，因为每个元素都是有特性的

張香山: 中國人是勤勞勇敢的。中國人是黃種人。

李后主: 香山说的对。

赵阳光: 服装店里的衣服真多，五颜六色的，我的衣服拿去干洗了。

周顺平: 改成——我把衣服拿去干洗了，这样应该对了。

齐学玉: 阳光还是加了限定词！

严仁勇: “我喜欢吃羊肉泡馍”，“这家羊肉泡馍很好吃”，前一“吃羊肉泡馍”是集合概念，后一“羊肉泡馍”是非集合，因为不是所有的羊肉泡馍都很好吃，所以是非。

曲婉蘭: 花的颜色是很多的; 花是喜欢阳光的.

陈清扬: 哈哈，还好咱们这里没有叫“花”的同学。

赵阳光: 呵呵！

张玉: 通过浏览器可以浏览网页。网大教室需要通过火狐浏览器登陆。

安哲: 张玉好像加限定的词了！

李后主: 大家举得例子很多，我们先到这里吧，留下的问题以后还可以继续讨论。下去后，大家继续思考这样一个问题；是不是每一个概念都可以分为集合概念和非集合概念的情况？

李后主: 我们看看第2个问题，也就是把“是”的关系再研究一下。他是共产党。这句话中，是本来的含义是属于。但是这里面还比较复杂的是，这句话还有引申意义。就是 共产党这个概念我们经常把它当作共产党员来使用。所以这句话的引申意义是“他是个共产党员”，那么就等于“他是个共产党”。

李后主: 引申意义是对话中更复杂的逻辑情况，是我们不能不考虑的。或者说是使用中的一些习惯意义。

赵阳光: 有些词句是简化的，但判断要用引申意义。

李后主: 因此，“他是共产党”。不讲引申意义，“是”的含义就是属于，讲引申​意义，“是”的含义还有“等于”。
他是个共产党＝他是个共产党员＝他是一个共产党员。这里”是“的含义​是等于的意思。通过限定词，共产党被限定为一个共产党员，在这个语境中​就和主项他等价了。

張香山: 是習慣意義！

慕容患: 第2个问题，都是说他是个共产党党员的意思，因为共产党是抽象概念，​每一个人是具体的人〔共产党员〕是元素。这两句话，都不会引起误解。但​是，后一句感情色彩浓厚一些，指向更明确。

李后主: 属于是种属关系，等于是直接相等。只有加了限定词把判断项的外延限制​为和主项的外延相同时，它们二者就等价了。这个关系就是这样。

唐子: 这里谈到了概念和词语的表述问题。这是我们在说话和作文中要具体弄清​楚的。

李后主: 那么，我们看看最后一个讨论题。5，请阅读第六自然段中的这个例子，​【问三个学生：“请你说出一个男人最重要的三种品质？”】，请回答例子​中的问题，什么是勇敢？什么是正直？什么是责任感？甲和丁到底谁对谁错​？为什么？

李后主: 问三个学生：“请你说出一个男人最重要的三种品质？”我们可能得到这​样的回答：甲（真诚、责任感、勇敢），乙（真诚、勇敢、正直），丙（真​诚、责任 感、进取心），丁（真诚、善良、宽容）。甲说：“看来每个人的​回答都不同”，丁说：“其实我们的回答是相同的，只是回答的层次不一样​。”

慕容患: 勇敢：无所畏惧。但是分为理性的无所畏惧和盲目的无所畏惧。

張香山: 勇敢，無所畏懼，勇往直前；正直，敢于說真話；責任感，就是敢于承擔​責任。

李后主: 大家主要看看甲和丁的回答是不是相同？

安哲: 甲回答（真诚、责任感、勇敢），甲回答的不是一个层面的事物，而丁是​一个层面。

慕容患: 甲和丁的回答不相同，有正直、责任感的区别，而责任感不等于正直。

李后主: 其实丁的回答就是真善忍，只是他不没有直接说这三个字。大家想想勇敢是不是善？

張香山: 不是。

周顺平: 不完全相同，因为后两个词组的内涵和外延都不一致。

赵阳光: 不是。

李后主: 香山，如果勇敢不是善，那么勇敢是不是一种正面的品性？

張香山: 是正面的品質。

周顺平: 善的含义应该大于勇敢。

赵阳光: 勇敢不是善，它是相对于怯懦来说的，与善还不是一个层次。

張香山: 同意陽光的説法。善的外延做好事。做好人。有同情心等。

李后主: 大家说的不是，是对哪一个问题的回答。

周顺平: 甲和丁的回答。

李后主: 那么，周顺平，我再问一个问题：电视是不是电器？

周顺平: 是。

李后主: 那么，电器的含义是不是大于电视的含义。可见不能用一个含义大于另一​个含义，就否定”是“，刚才讲了，汉语中的是有属于的意思。勇敢是不是​属于善？

周顺平: 勇敢​属于善是对的，但勇敢不完全等于善，我想。

李后主: 周顺平，这句话说对了。如果把善这个概念的外延找一下，大家能找出些什么东西来？

慕容患: 理性的勇敢是​属于善。

周顺平: 善良、真诚、宽容、理解……

安哲: 善包括宽容、帮助、勇敢等

李后主: 勇敢，正义，慈悲，怜悯，关怀，帮助……这些都是善的外延。

赵阳光: 善的外延：怜悯、宽容、同情、勇敢、正义，等等

張香山: 勇敢的面對歹徒，見義勇爲----這也是善的體現。

李后主: 你们对勇敢的理解太狭隘了，照你们这样理解，勇敢是没有道德内涵的，​一个敢杀人的，敢抢银行的，都是勇敢，因为它们都不怯懦。

唐子: 儒家的善里就有“勇”，这个“勇”就包含了“理性”。

張香山: 看來，勇敢是善的所包含的内容。

李后主: 我把这个问题提到这里来讨论，就是想让大家知道，人类所奉行的好的行​为，都是有道德内涵的，由最高的道德内涵来支撑着，这就要求大家理解道​德的层次性。

赵阳光: 勇敢有道德内涵，它就是一个褒义的概念，而不是中性的。见义勇为是勇​敢，敢抢银行就是作恶。

李后主: 电视和电器的区别大家很容易能辨析清楚，善和勇敢的区别大家就糊涂了​，而我们的古人其实不是辨析电视和电器的区别，而就是辨析道德内涵的，​一个层次一 个层次的，一个科目一个科目的辨析的。儒家的仁义礼智信等德​目从概念上来理解不都是真善忍的一定层次的外延吗？这些外延继续分层次​下去，就有勇敢了。

赵阳光: 原来没有注意勇敢的道德内涵。

慕容患: 我也没有注意到勇敢的道德内涵。

周顺平: 是多年的党文化灌输把这个词污染了。

李后主: 所以，道德的层次的原理，要求大家懂得低层次的道德要服从高层次的道​德要求。

唐子: 汉语表意是有一定的模糊性，所以在表达概念的时候，就要换用一些比较​精密的表达。比如上面李后主老师说的，分清是“属于”或“一个”之类谓​语。

李后主: 守信是儒家的道德要求，但是如果不符合善，这信诺就可以不守。这不叫​不诚信，而是忠实于更大的道德要求。

赵阳光: 人应该孝顺，但如果长辈让自己行不义之举可以拒绝。这不是不孝，而是​维护更大的道德或正义。 如果忽视道德要求，一些概念就可能教条化。

李后主: “信近于义，言可复也”《论语•学而》。这句话意思大概是说信要符合​道义，这样言语才能践行履行。“信之所以为信者，道也，信不从道，何以为信” 《春秋谷梁传译注•僖公二十二年》。“大人者，言不必信，行不必果，惟义所在”《孟子•离娄下》。看看古人把这些道德的层次关系辨析得很清楚。

唐子: 仁義禮智信，信屬於“五常”中的老四。

赵阳光: 鲁迅以及共产党批判传统，大概就是仅仅从字面上批判的，如批判“君君​臣臣父父子子”，而对字面背后的道德要求有意忽视。

李后主: 因此，春秋时期曾有‘要盟不信’之说，即在受到要挟、威逼的情况下，​被迫签订的屈辱盟约或许下的违心诺言，可以不履行，不兑现。因为它并不​违背道义。中共用强制得手段逼迫修炼人写什么保证书，那是不效的，所以很多人发​表宣言废除那些东西，这不叫不守信用。

周顺平: 后主老师说的极是。

李后主: 大家要记住，我们所用的每一个正面的行为的词，都是从道德一个层次一​个层次演化分化出来的。所以，它们都是有道德内涵的，也都是有更高的道​德指导的。

赵阳光: 我们的被强占或出卖的国土也有理由要回来，因为那不是我们的本意，更​不符合道义。

唐子: 上面談的包含道德內涵的概念都屬於“正見”這個概念。

李后主: 道德的层次性理解了，大家就会顺从天道，而不会被一些低层次的道德要​求束缚住了。比如孝敬父母，父母说你不要出去讲真相，你不听话，你不孝​顺，你现在应该知道怎么去回答了吧！

慕容患: 明白了。

严仁勇: 呵呵--后主老师说的很实际啊！

李后主: 孝也要服从更高级的天道，天地君亲师，亲排老四，他上面还有天地和君​（天下公义之道），父母如果不符合天道，那么怎么孝敬他呢？ 那就要和他们讲天道，要恢复他们的传统道德。

赵阳光: 反客为主，站到高层次上“教训”他们。

周顺平: 讲真相，解体中共是顺从天意的，孝顺也要遵从天意才是正确的。

李后主: 那么，什么是责任心，不就是忠吗？忠的上一层次的道德不就是诚，再上​面不就是真吗？什么是正直，他也是真的表现。进取心，也是忠，忠于自己的事业，到最高层次还是一个真字。

李后主: 勇敢是善的表现，高智晟勇敢吗？胡佳勇敢吗？我想高智晟还有些蛮力，​胡佳可是个文弱书生，他们的勇敢从哪里生出来的？不就是善和慈悲心吗？ 至善而至勇。至善就会生出对邪恶的不能容忍，就不会害怕，就会表现出​勇，我们大家的勇不都是善念生成的行为吗？

赵阳光: 对，慈悲心让一个文弱的人比勇武的人还要敢做敢为。

周顺平: 这样看来，丁说：“其实我们的回答是相同的，只是回答的层次不一样​​。”—— 这说法就是正确的了，因为从层次上可演变出上下级关系。

李后主: 是的，丁说的对，丁看到了 道德的层次关系，而甲看不到。

赵阳光: 甲说出了表象，丁说出了内涵，层次不一样。

李后主: 阳光说的对，真善忍就是所有道德目或者道德外延的共同内涵。所以，不管是什么学科，都要从层次关系中讲起，我们学习逻辑学，要把​逻辑中的层次关系搞懂， 就会把问题看得更透彻。那么，大家看看，我们的​古人讲不讲逻辑呢？孔子讲的仁有很多种含义，按照现代人的逻辑学的分析​方法，说孔子不讲逻辑，现代的人 把这些概念界定过来界定过去，都没有懂​得层次关系，所以都讲不清楚。孔子是根据不同人的不同境界，讲仁在不同​层次中表现。如果我们懂得层次关系，我们 发现古人是最讲逻辑的，相反，现代人讲逻​辑的档次还不够高呢。是不是这样呢？那么好吧，我们今天的课程就到这里​了。

师生互道晚安！


第一章 概念和定义(纪要2-2）

授课内容：《形式逻辑》——第一章 概念和定义（下）
上课时间：2008.11.6日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主老师
到课老师：唐子老师
到课同学： 严仁勇、慕容患、張香山、罗同、黎焕石 、赵阳光、钱不求、麻生、杨尚、安哲、三石、周顺平、陈清扬 、辛言、张华虎、 贺大翔 、齐学玉
到课总人数：17人
请假同学：李大雄、張穀虛
纪要整理：齐学玉

各位同学: 老师好，各位同学晚上好！

李后主: 同学们晚上好！今晚主要是做讲义中的习题。

李后主: 上次的纪要我看了一下，慕容患说的那个吃川菜的例子是对的，是我当时​一时没有思考清楚。所以，我说这些很复杂的逻辑的应用方面，由于思考的时间短，我也许会​出错的。

慕容患: 老师这样严谨。

严仁勇: 后主老师真的很坦然，错了就说错了，值得可敬！

李后主: 发现错误及时纠正，我们每个人都是这样，谁愿意掩盖那些错误呢。

赵阳光: 形式逻辑就有点像学数学，要运算，如果前面的没掌握好后面的就更难理​解。

李后主: 那么，我们一起来研讨今晚的内容。今晚的讲义的第一部分是讲概念的限制和概括，它们是应用了概念的外延​和内涵的反变关系。这个问题很好理解。大家看一看 讲义就都懂了。主要是看看我出的问题，​这是我在参考一些逻辑学教材时挑拣出来的，让大家来思考这些说法本身有​什么问题。有教材中讲【因概念的限制是由 属概念过渡到种概念，同一关系、交叉关​系或不相容关系的概念不能进行限制；单独概念或集合概念也不能再进行限​制。】请同学们思考，这句话有什么问题？

李后主: 我们思考上面那个问题。要分析这句话有什么问题，主要看这句话『​同一关系、交叉关​系或不相容关系的概念不能进行限制；』 大家想想，同一关系，交叉关系，是几个概念之间的关系？

張香山: 都是两个概念之间的关系。

杨尚: 两个概念之间。

赵阳光: 是两个概念之间的关系。

李后主: 是啊，是两个概念之间的关系。那么，我们讲的概念的限制是几个概念间​的关系呢？当然是一个概念的外延和内涵之间的关系，不是两个概念的关系​。可见，说 【同一关系、交叉关​系或不相容关系的概念不能进行限制；】​这句话本身就是有逻辑问题的。概念的限制和两个概念之间的同一关系交叉​关系不相容关系等没 有什么关系。概念的限制是针对一个概念的内涵和外延来讲的，因此，编写那些逻辑学​教材的作者在写作这个问题时，思路没有理清，出现了逻辑问题。

赵阳光: 上面存在问题是不是搞错了对象？有点荒谬，就好像说“男人在怀孕期间不能如何如何”一样。

杨尚: 是的，明白了。

严仁勇: 看来主要还是没有抓住概念的外延与内涵。

李后主: 单独概念是指一个概念，能不能限制当然可以讨论。这句话本身没有什么​逻辑形式的错误。而集合概念根据我们上次课讲的，是在词项关系中才体现出来，不是一 个​固有的东西，因此说集合概念不能进行限制也是有问题的。比如川菜，它是在一定的词项关系中才是集合概念，不在词项关系中的川​菜这个词当然可以进行限 制，这个时候你也不能说这个川菜是集合概念呢，​还是非集合概念。所以，我是从这些角度来思考这句话中的问题的。

李后主: 大家看明白了吗？

严仁勇: 看到了，看来集合是个“原始概念”。

齐学玉: 老师，明白了，被限制的对象是一个概念。

李后主: 集合概念是词项关系中体现出的概念，不在词项关系中，就没有集合概念​这种东西。

慕容患: 听课是听明白了，自己做习题就难把握。

李后主: 好的，看下一个问题吧！

2，什么是下定义的定义域？请给出以下概念的定义域：⑴运动；⑵国家​；⑶民族；⑷国民党（1912年）；⑸土地；⑹教师。本文中的“定义域​”这个概念是我自己规定的，它在本文中的作用是什么？同学们从中可以学​习到什么东西？

李后主: 先看看大家对定义域的理解。

李后主: 仁勇：【定义域是指人们的思维对认识物质所限定的某一思维范围和层次​。】仁勇的这个解释还差一点东西，就是必须指出是概念的范围和层次。

李后主: 我把仁勇的解释修改一下：定义域是指人们的思维认识物质时对物质的概​念所限定的某一思维范围和层次​。

严仁勇: 噢～，知道了，老师这样一改就很明晰了，谢谢老师！

赵阳光: 2．定义域是给事物下定义时划定的一定层次范围。

辛言: 定义域是下定义时划定的层次范围。

李后主: 阳光和辛言说的简单准确。

慕容患: 定义域是下定义时必须的合理限制。

李后主: 学玉的这个解释很完整，把讲义的精髓都融合进去了。——【“定义域”​，“就是给出下定义的层次范围”。定义域与被定义的概念既可以是不同的​层次也可以 是相同层次。在不同层次的定义中定义域是被定义概念的属概念​，在相同层次的定义中，定义域是被定义概念（属性概念）的实体概念。】

杨尚: 定义域就是被定义对象的属概念的范围设定。

李后主: 【定义域就是被定义对象的属概念的范围设定。】－－杨尚这样讲也没错​。就是在实体概念和属性概念的关系中，实体概念在是有属种关系的，实体​概念其实也可以是属概念。比如，讲义中的例子“本科毕业生”的定义域是学生，就是属概念。

李后主: 【定义域是概念的属概念。】——陈清扬的这个说法就有问题了，可以修​改为“定义域一般是被定义概念的属概念”

李后主: 好的，关于什么是定义域，我们先讨论到这里。下面看看大家做的6个定​义域的习题。我直接公布我的答案，大家看看和我的有什么不同。

李后主: ⑴运动－－现象；⑵国家－－政治实体；⑶民族－－部落共同体；⑷国民​党（1912年）－－政党；⑸土地－－－地表；⑹教师－－人。

赵阳光: 运动：（1）宇宙的存在状态，（2）有目的、成规模的社会活动，（3​）人和动物的四肢与躯干的动作表现；国家：人群居生活的组织形式；民族​：一定血缘和文化的人的集合体；国民党：政党；土地：地球上的物质之一​；教师：一种社会身份

李后主: 陈清扬对教师的定义域为职业，这也可以。说运动的定义域为“事物的存在形式”和宇宙的存在状态，也没错。定义域也没有一个固定的标准，关键是看大家怎么去理解这个事物，从那​个方面哪个角度去理解，就从哪个角度去给出定义域。

張香山: ⑴运动，是物质的存在形式；⑵国家，；⑶民族，具有同样的文化的群体​；⑷国民党（1912年），是一个有政治诉求的政党；⑸土地，是一种自​然资源；⑹教师，是传道授业解惑的人。

张华虎: 人体机械活动，社会群体政治行为；政治实体；人类社会群体；政党；地​表范围；工作人员。

李后主: 仁勇的定义域有一些问题，如国民党的定义域为民主政党，其实政党本身​就是民主的，不需要加民主二字。教师的定义域为“传道授业解惑之人”，​我看这已经不是定义域了，而直接是定义了。

張香山: 教师是一种职业( 如:你是干什么的?我是教师.)

罗同: ⑴运动—状态；⑵国家—政治实体；⑶民族—种族共同体；⑷国民党（1​912年）--政党；⑸土地—资源；⑹教师—职业。

李后主: 【国家：分三层，思想文化，政治实体，统治疆域】－－没有抓住核心。​用政治实体就可以定义国家了。看事物的系统观和定义事物的方法是不一样​的。你定义国家为一种政治实体，但你用系统观看这个政治实体时，你看的​是三要素的统一体。

李后主: 运动的定义域为状态也可以。土地的定义域为资源也可以。教师的定义域为职业也可以。那么，我现场向大家出一个题，分别以职业和人为定义域，对教师下一个​简单的定义。把这个习题做了，大家对定义域就有了更深刻的理解。

張香山: 教师是以传道授业解惑为职业的人。

齐学玉: 教师是以教授知识为生的职业；教师是传道、授业、解惑的人。

钱不求: 教师是一门教授知识的职业。教师是专门传授知识的人。

杨尚: 教师是传道授业解惑的人。；教师是一份传道授业解惑的职业。

张华虎: 教师是一种向别人传授知识的职业。教师是向别人传授知识的人。

辛言: 教师是以传授知识为职业的人。教师是传授知识的职业。

罗同: 教师以传道、授业、解惑为职业的人。教师是传道、授业、解惑的人。

慕容患: 教师是向学生传授知识职业。

李后主: 教师是一种以教授知识为生的职业；教师是传道、授业、解惑的人。我把大家的回答综合了一下。看来大家对定义域已经完全掌握了。下定义​并没有机械的套路，看你的需要了。你需要强调这个事物的哪个方面，你就​从哪个方面去下定义。那么，我这里讲的这个定义域在讲义中起的作用就是把下定义的范围和层​次问题的核心揭示出来了，对大家掌握下定义的方法和思路有帮助。试想一下，如果没有这个定义域的概念。我只是从层次和范围去讲，那么就要​绕很多弯子，费很多口舌。这个概念不正是让我们看到在分析一个问题时，​你要是能给这个问题的核心部分下一个恰当的定义，给出一个通用的概念，​那么对于你论述这个问题起到了事半功倍的作用。所以，希望大家在研究问题，撰写论文时，能精确的掌握下定义的方法，​这是你成为一个学者的基本功，就是内功的体现，随着你下定义水平的提高​，你的学术水平就会水涨船高。

严仁勇: 如果没有定义域的概念，一切事物将无法定义。

李后主: 【 严仁勇: 如果没有定义域的概念，一切事物将无法定义。】－－不能这么讲，没有​这个概念，会有另一个概念来描述这个东西。我只是说，适当的下一个概念​，对于研究 问题的方便性，我把“定义域”这个我规定的概念拿出来作为事​例，是为了讲这个问题。注意，我这里说的“定义域”这个概念在我讲义中​的作用，我的讲义是 干什么呢，不就是研究下定义的问题吗，那么我在研究​中给出一个概念（定义域），这个概念帮助我把下定义的问题讲得很清晰。

安哲: 那么就没有办法下定义，比如“上帝”这个概念。

李后主: 安哲，上帝不是我们用概念来思维的对象。

安哲: 哦，概念思维对象包括那些？

慕容患: 概念思维对象是神以下层次的事物。

安哲: 是不是在物质世界用概念思维。

李后主: 概念思维的极限，也就是人类哲学认识的极限。神不是用概念思维来认识的，是靠内修来认识和见证的。认识有内证和外证的两个方向，概念思维是属于外证体系的，你在本期学​术月的论文不就是讲东西方三种真理现象，逻辑的方法不就是和外证相联系​吗？

安哲: 在人类的学识范围内。明白了，这样就联系起来了。那就是说是人类认识的极限了。

李后主: 人类认识的极限。和我讲的概念思维的极限（哲学认识的极限）是一样的​吗？

安哲: 不一样。

李后主: 人类的认识有外证和内证，内证没有极限。外证有极限。

安哲: 这里面还是没有注意区分内证和外证的问题。

李后主: 内证也不是逻辑思维，不是概念思维的认识方法，而是另一种方法，修炼​的方法，脑子里什么都不想，也就不用下定义，形成概念，再形成命题，再​去形成命题之间的关系，没有这些问题了。

李后主: 好的，这个问题就到这里。任何手段都可以用来证明神的存在，但唯有内修的方法才是真正可靠的方​法，其它方法最终都是一种理性的信仰。只是人们相信严密的逻辑推理没有问题而已，并不能证明神的存在。

安哲: 老师继续。

李后主: 3，列举两个不同层次的限定性定义的例子，要求分别以系统的功能和结​构为种差。

李后主: 仁勇的这两个定义都不错，符合要求。
【碗：吃饭时用到的一种器皿。碗：用粘土经过烧结、染色呈凹形的器皿​。】

李后主: 学玉的也符合要求。【（1），物理学是研究物质的运动及其规律的学问​；（2），物理学是包括电磁学，力学，热学的一门学科。】

罗同: 高脚屋是竹子结构的房屋；高脚屋是适合南方潮湿环境的房屋。

李后主: 罗同的两个定义有些模糊，还可以更清晰得表达出来。比如：高脚屋是用​竹子搭建的房屋；高脚屋是可以把潮湿的地面隔离的适合南方潮湿环境的房​屋。

罗同: 是。

赵阳光: 楼房：可以存放货物和住人的建筑物；楼房：由钢筋、水泥等材料构成的​分层的建筑物。

李后主: 阳光的两个定义也很准确。

杨尚: 答：床是由床板和床架构成的，用来人可以躺在上面睡觉的家具。
诗歌是由有韵律的文字组成的，能表达作者思想感情的一种文学形式。

李后主: 杨尚的也表达出了我们要的东西，再简单修改一下：床是由床板和床架构​成的家具，床是人用来睡觉的家具。

張香山: 蔬菜是由大白菜、胡萝卜、青椒、西红柿等中抽象而来的概念。

李后主: 香山的这个蔬菜不符合要求。我们要的是针对系统来下定义，而不是讲一​个概念和它的外延的关系。

張香山: 蔬菜是一种食品 。蔬菜是可以炒熟的。

慕容患: 蔬菜是人工驯化后，供食用的植物。

李后主: 香山，蔬菜是分类的概念，不是具体的实物，我们这里是要对具体的实物​下定义。

張香山: 书架是摆放书籍的地方；书架是用木材制成的。

慕容患: 电脑是人智力的延伸。电脑由软件硬件构成。

李后主: 慕容患，张香山，下定义是以实物为对象的，不是以抽象物为对象的。【張香山: 书架是摆放书籍的地方；书架是用木材制成的。】这不是定义，这只是一​种特性描述，你再好好想想，怎么才能把它们修改为定义的语句。【书架是摆放书籍的地 方】，那么我的桌子上摆放了书籍，桌子就是书架​吗？

齐学玉: 电脑是人智力的延伸。 这个应该不算下定义，它没有揭示出概念的内涵！

李后主: 是的，慕容患对电脑的描述不是定义。

李后主: 狗是人类的好朋友。这能算是狗的定义吗？大家要分得清楚什么是定义啊​。重读一下讲义吧：【定义是界定概念内涵的逻辑方法，即揭示概念所反映​的事物的本质或其属性的逻辑方法。】看清楚了吗？要揭示事物的本质或者基本属性，也就是要揭示概念的内涵​。

安哲: 自行车是通过人力作动力的一种交通工具；自行车是一个很好锻炼身体的​器具。

辛言: 汽车是运输货物和载人的交通工具。四边形是由四条边组成的几何图形。

赵阳光: 未来中国大学：致力于解体党文化的人文大学，未来中国大学：一所通过​网络进行文字教学的学校。前面的定义是从功能层面看，后面的定义是从结构、运行方式层面看。

李后主: 阳光对我们学校下的这两个定义也基本准确，揭示了我们学校的本质和特​征。但还可以更精确一些。比如：
未来中国大学：致力于解体党文化、复兴中华文化和大学精神的一所新型​人文大学，未来中国大学：一所通过​网络进行文字教学，师生全部由三退​人员组成的特殊学校。

华变天: 书架是一种特定的人工制作的家具,一般被分割成不同的层数,而每一层​可以用来摆放书籍。

張香山: 西红柿是蔬菜的一种，西红柿是圆形的，红色的，酸甜的植物果实。

齐学玉: 香山，下定义要首先了解概念的内涵，用一定的词语把这种内涵揭示出来​！如果不能反应概念的内涵，如一些描述性的语句，不算是下定义！

李后主: 学玉说的对，首先要揭示内涵，其次加一些基本属性和特征。生物学中的分类，我们就不要去举这方面的例子了，那是很专业性的东西​，什么纲，什么属，什么科，什么目等等，你们不是生物学家的话，那是下​不了那个领域的定义的。

慕容患: 书是知识的载体。书由文字图形和媒介物构成。

李后主: 慕容患，这样修改一下吧。书是用于记载文字和图形图像资料的知识载体​。

慕容患: 这样限定一下就严谨了。

李后主: 不求的这两个定义也不错。【照相机就是可以给物体照相并显现出图像的​机器。照相机是一种由镜头，控制系统和其它部件组成的机器。】

赵阳光: 练习下定义的过程也同时练习了写作方法了，系统的功能、结构等不同的​种差都可以分别阐述。

李后主: 阳光说的对。

李后主: 陈清扬的这两个定义中，每个定义都以系统的功能和结构共同做了种差。​【细菌是由细胞膜，细胞液，细胞核组成的，具有新陈代谢、繁衍功能的单​体细胞。
水是由二个氢分子、一个氧分子组成的，具有溶解能力的液体。】

張香山: 肥皂，是洗涤去污的化学制品；一般洗涤用肥皂是用油脂和氢氧化钠制成​的。

李后主: 香山，我帮你修改一下。【肥皂，是用以洗涤去污的化学制品；肥皂是用​油脂和氢氧化钠制成​的日用化学制品。】

李后主: 好的，这个问题就练习到这儿吧！

赵阳光: 好好看看一些产品的说明书，就理解怎么下定义了。

李后主: 4，列举两个相同层次的解释性定义的例子，要求一个为以实体为定义域​对属性进行解释的定义，一个为忽略实体，两个属性并列分别解释的定义。

严仁勇: 手机：手持式的移动通讯工具。
泡沫经济：是指因投机交易极度活跃，金融证倦，房地产等的市场价格持​续上涨，脱离老百姓的购买能力，造成表面经济繁荣现象。

李后主: 仁勇对手机的解释属于忽略实体，两个属性并列分别解释的定义。而对泡沫经济的定义则属于以实体为定义域​对属性进行解释的定义。这​里实体为经济，属性为泡沫。仁勇这个作业完成的不错。

严仁勇: 谢谢老师的鼓励！

杨尚: 答：白马是身体为白色的马。
政党就是有自己的政治纲领和政治目标的人民组织。

李后主: 杨尚，这样改一下吧。政党就是有自己的政治纲领和政治目标的社会团体​.政和党分别做出了解释。也符合我们的要求。

李后主: 【（1）物理学家是研究物理的科学家！
（2）物理学家是研究物理的从事科学研究的工作者！】学玉的这两个定​义有点勉强，如果不好作出区分，就换一个事物来下定义，不一定非要在这​个物理学家上作出个我们要的两种情况的区分来。

齐学玉: 做这个作业的时候被属性和实体障碍住了。

李后主: 学玉，看看其他同学的作业，思路开阔了就不障碍了。

慕容患: 忽略实体，两个属性并列分别解释的定义:茶杯是用来喝茶、喝水的容器​。
实体为定义域​对属性进行解释的定义：鼠标是电脑的附件之一，用来操​控电脑。

李后主: 慕容患，忽略实体的那个定义不错。后面那个不行，鼠和标，这个例子中​可不好区别。

赵阳光: 强盗逻辑：不遵循事物固有规律、人类的普遍道德原则和社会规范的思考​逻辑；妇人之仁：无原则的包容和一味地妥协退让的行为方式。

李后主: 阳光的两个定义都符合要求。

李后主: 不对不对，咋一想，阳光的后面那个妇人之仁的解释没有揭示出我们要的​东西。妇人和仁要分别解释的话，就不是这个词的含义了，所以，这个例子不符​合要求，阳光可以另想一个。

赵阳光: 感觉是有点不合适。

張香山: 鸟是有羽毛的卵生动物。

李后主: 【張香山: 鸟是有羽毛的卵生动物。】香山，这是属于哪种情况啊？？？

張香山: 这是一个为以实体为定义域​对属性进行解释的定义。

李后主: 香山，你下定义的对象是鸟，只有一个词，谁是实体，谁是属性？“相同层次的解释性定义”，这样的情况，你下定义的对象肯定是一个词​组。

張香山: 哦！

容患: 实体为定义域​对属性进行解释的定义：学生是在学校正在学习的人。

李后主: 慕容患，这个定义是对的。【如以学生为属性，以人为实体，那么学生可以被定义为“在学校接受教​育的人”，】我讲义中是这么写的。

赵阳光: 暖气片：可以存储热水以用来散发热量达到取暖效果的金属器具。暖气片：可以存储热水以用来散发热量达到取暖效果的金属器具。（忽略​实体，两个属性并列解释）。

李后主: 阳光对暖气片的定义也是正确的，符合我们的要求。

罗同: 电脑病毒是电脑遭恶意程序攻击；电脑病毒是电子计算机遭恶意程序攻击。

李后主: 细细想来，香山说鸟是有羽毛的卵生动物。这个定义本身到是“以实体为​定义域​对属性进行解释的定义”，只是在作为下定义的对象的概念中根本​没有表现出 实体和属性的关系出来。我们在讨论这个问题时，已经预设了前提是对一些可以表现出实体和属性​关系的概念下定义。所以，香山说的不符合我们的预设前提，但 却符合我们​要的定义的结果。这是一种我没有预料到的情况，所以，也不能算香山错了​。这种现象说明了，我们面对的这个领域麻烦事是很多的，我可能会一时 看​错，或者根本没有想到的新情况会出现。我们一起都从中学习新的见识吧！

赵阳光: 文字上的形式逻辑毕竟无法像数学运算那样做到不差毫厘，出现一些疏漏​也是难免的。

李后主: 电脑病毒一般是一种恶意攻击电脑系统的破坏性程序。电脑病毒一般是一种恶意攻击电子计算机系统的破坏性程序。这可以算是​并列属性的情况吧！

李后主: 好的，这个问题就到这里。同学们掌握的都不错。

李后主: 5，请分别列举一个同语反复、循环定义、负概念定义的例子，并给予修​正。

严仁勇: （1）同语反复：宽带是通讯间的带宽----修正：宽带是在模拟通信​中指频率大大高于话音的带宽，数字通信中指传输速度超过2M/S的带宽​。

李后主: 【宽带是通讯间的带宽】－－这个定义本身就是错误的。宽带和带宽是两​个不同的概念。

杨尚: 同语反复：民族就是一族之民。--------民族就是诞生于氏族部​落时期，后经不断融合形成的具有共同文化的人的共同体。
循 环定义：中华民国是东亚第一共和国,东亚第一共和国是中华民国。-​-------中华民国是在中华大地上成立于1912年的民主共和国，​清朝灭亡后， 中华民国是当时中国的代表，有效统治中国大部分地区。后在​与中国共产党的对抗中失利，其中央政府迁至台湾。因为其是东亚历史上第​一个民主共和国，史称 东亚第一共和国。
负概念定义：孩子就是还没长大的人。-------孩子从法律角度上​讲通常指未成年人，指不具有独立民事行为能力，不独立承担民事责任的人​，常指18岁以下的人。

李后主: 杨尚的三个回答基本准确。

赵阳光: 同语反复：音箱是可以放出声音的箱子。修正：音箱是接受到其它电子设​备的音频信号后将信号转化成声音传播出去的箱体，一般为木制。

李后主: 阳光的定义是没问题的。应该说。阳光的回答是没问题的。

李后主: 【（2）老总是第一把手（第一把手是老总） -------修正：称担任总经理，总工程师，总编辑等职务的人。 】仁勇，在循环定义中，你要分别对两个概念进行不同的解释。

严仁勇: 噢，谢谢老师的指点，受教了！

張香山: 麻醉就是麻醉剂所起的作用----麻醉就是用药物或针刺方法使整个有​机体或有机体的一部分暂时失去知觉。

李后主: 香山的这个回答很好。

赵阳光: 负概念定义：小孩就是没长大的人。修正：小孩是生理没有发育成熟且心​理、行为都比较幼稚的人。

李后主: 阳光的负概念的例子也举得不错。大家要知道。负概念并不是错误的，只是作为定义来说不合适而已，没有​揭示出概念的本质或者属性。阳光，小孩就是没有长大的人，作为负概念还是有些勉强，应该是“小孩​就是不是大人。”

赵阳光: 恩，以“大人”作为“小孩”的负概念更合适一些。

李后主: 【（2）思维就是意识。修正：思维是人具有的对事物的分析、综合、判​断的能力。】学玉的问题和仁勇一样，思维你解释了，那么意识是什么呢？​不管意识了？

齐学玉: 思维就是意识。思维是人具有的对事物的分析、综合、判​断的能力；意​识是人对外界刺激的反应能力。

李后主: 学玉，你要举循环定义的例子，就要首先出现循环定义，然后再修正。

齐学玉: 老师，是不是应该这样：思维就是意识，意识就是思维。修正为：思维是人具有​的对事​物的分析、综合、判​断的能力；意​识是人对外界刺激的反应能​力。

李后主: 学玉，这下对了。

齐学玉: 明白了，要体现出“循环”这个过程来啊！

慕容患: 5，请分别列举一个同语反复、循环定义、负概念定义的例子，并给予修​​正。
月光就是月亮的光。修正：月光是月亮反射太阳光后出的反光。

李后主: 慕容患的同语反复的例子举得不错。同语反复也不是错误，而是不适当的​定义。

黎焕石: 老师就是先生。修正：老师就是启智育德之人。

張香山: 直线是不曲的线----直线就是一个点在平面或空间沿着一定方向和其​相反方向运动的轨迹。

严仁勇: 负概念定义的例子：自由民主不是专制独裁------修正：自由民主​是具有一定高度自治的政治、良好的经济，独立的司法、高素质的公民和完​善的媒体自由的一种社会体制。

赵阳光: 循环定义：读书就是学习，学习就是读书。修正：读书是将书中的知识记​忆和理解的过程，是学习的一种方式；学习是观察和思考书本、他人或社会​上的现象、规律等内容进而将其转化为自己的知识和能力的过程。

李后主: 我看大家对这三个规则理解的都不错，以后下定义也不会这样去下的。

赵阳光: 头脑活跃起来上逻辑课还是挺有意思的。

李后主: 这里关键是负概念的问题，负概念是和正概念完全对立的东西，我们同学​们刚才举的一些所谓的负概念从严格意义上讲，可能并不是负概念，只是一​个反对的方面而已。负概念和正概念完全对立，所以才称为负概念。而部分​对立的概念还不能称为原来那个概念的负概念。

唐子: 对。比如“孩子”，本身就是“正概念”。“自由”“民主”本身也是“正概念”。“自由”的负概念是“不自由”，“民主”的负概念是“不民主”。

赵阳光: 刚才我举的“小孩就是没长大的人”这个例子就有这个错误，“没长大的​人”也包括少年，与“小孩”同属于“孩子”的范畴。所以这样不够严谨，​只有用“不是大人”才能严格地跟“小孩”对立起来。

黎焕石: 邪恶，丑陋是负的。

唐子: 邪恶和丑陋也是“正概念”。黎焕石所说“邪恶”和“丑陋”是具有负的意义或意思，那是指思想内涵​。这不属于形式逻辑问题。

黎焕石: 哦，谢谢！

赵阳光: 黎焕石把负概念理解成“负面的概念了”。

李后主: 【根据概念所反映的事物具有或者不具有某种属性，可以把概念分为正概​念和负概念。反映事物具有某种属性的概念叫做正概念，反映事物不具有某​种属性的概 念叫做负概念。比如健康和不健康，合法和非法，高智商和非高​智商，低智商和非低智商，有罪和无罪，{大于100的整数}和{不大于​100的整数}等。 正概念和负概念是在一定范围之内依据肯定和否定关系​划分的概念的某种区别，一旦划分它们之间就形成一种固定的对立关系（而​不是对立统一关系），它们把 事物一分为二，且彼此不相容。】【任何概念总是相对于一个特定范围而言，一个概念所相对的特定范围，​在逻辑上称为论域。理解一个负概念，必须注意它的论 域。在同一论域中，​有确定的正概念，就必定有明确的负概念。】

严仁勇: 老师：自由民主与专制独裁是不是正负概念的关系？

赵阳光: 自由民主的对立面不必然是专制独裁，禅让制下不讲究自由民主，但也没​带来专制独裁。

唐子: 民主与独裁在形式逻辑的概念关系中是反对关系。相对“民主”的负概念是“不民主”。正负概念正好构成一个圆。“民主”和“独裁”两种制度之中还有许多其​他制度，所以还不能构成正负关系。

李后主: 负概念一般使用在概念之间的矛盾关系时才有精确的程度，如果不是在这​里使用，那么精确度是很难估算的，自由民主和非自由民主构成一对正概念​和负概念的 关系，但是非自由民主是不是等于专制独裁，这就很难说了。也许，我们这里不应该使用负概念，而应该使用否定关系或者反对关系，​或者二者都使用，但对负概 念做严格界定。比如：民主是就是不是非民主。我在写讲义时也注意到了这个问题，但是我做了模糊处理，主要是为了讲​下定义时不要这么下。唐子老师说严格一 些，那么我就严格一些吧！回头，我把下定义的逻辑规​则总结成四条，负概念和反对关系分开来讲。把这个讲义再修正一下吧！

赵阳光: 只要能理解这些倾向性就好了，实际应用中好像没那么严格吧？

李后主: 实际应用时很少使用负概念，大多使用的是反对概念。

黎焕石: 还是严格一点好，免得人家钻空子。

李后主: 好的，我接受建议。严格一些。回头把讲义重新修改一下。⑴不能同语反复；⑵不能循环定义；⑶不能使用负概念定义；⑷不能使用​反对关系的概念来定义。

李后主: 那好，今晚的讨论就到这里结束。感谢唐子老师给我们指出研讨中的逻辑​不严格的错误，我们从中都可以学习到更多的学问。我把讲义中的⑶部分重新修改，增加⑷部分的内容。

各位同学: 二位老师辛苦了！谢谢后主老师，谢谢唐子老师！

师生互道晚安！


第一章 概念和定义

一，什么是概念

概念是人们对事物本质的认识，是思维的基本单元和形式。概念的特征在于它的抽象性和概括性，概念是对事物共性的概括和把握，它在抽象的层面上研究事物的本质属性，揭示事物的内在联系和规律，因此它和事物的本质是同一的。人们的思维是通过概念来展开的，概念是思维的细胞，是思维的第一步，它反映人们对事物的理解能力，概念不清，偷换概念是思维中经常出现的故障现象。

1，概念的内涵和外延

概念反映对象的本质属性，同时也就反映了具有这种本质属性的对象，这两方面分别构成了概念的内涵和外延。概念可以通过内涵和外延来理解，概念是内涵和外延的对立统一体，内涵是指可以表征事物本质属性的概念的内容，或者说，内涵是概念所反映的事物的本质属性，外延是具有内涵所反映的事物本质属性的所有对象，即概念的适用范围，因而概念有客观的内容和确定的范围。

例如，“水果”的内涵是指“水分比较多的果类食品”，外延则可以是“苹果、梨、桔子、柿子、葡萄、梅子、李子、桃、杏……等”。再比如“坚果”的内涵是指“外皮比较坚硬、内部水份比较少的核类种子类食品”，它的外延可以是“核桃、杏仁、所有瓜子类（瓜子仁）、腰果……等”。内涵和外延的关系是事物的抽象和具体的关系，在概念的研究中，它们就叫做内涵和外延，在哲学那个层面上研究就是事物的“抽象和具体”、“普遍和特殊”、“一般和个别”的关系。可见，概念表达的是事物的类的关系，它在认识论上的作用是把事物相互之间区别开来，使世界可以被分割成很多不同的类来表达和理解。

[学习参考段]：这是从静态的角度来讲，如果从运动的角度来讲，概念只是事物运动变化中被标识出的一个环节，整个世界或者整个宇宙实则都是一个概念的展开，而不是很多概念的组合，这一个概念就是绝对理念，我们现在讲得这些概念，这些类的区别，不过是这个绝对理念在运动过程中不同阶段的不同表现环节而已，这是黑格尔辩证逻辑学的主体思想。形式逻辑学是从静态的角度研究概念，它的基本思路是要把事物区别开来，因此，有所谓的“混淆概念”的说法，有这个规律那个规律的限制，但是你一旦突破了这个层次，就发现事物之间原来的区别的界限模糊了，它们之间是相互联系的，你会在更大更广阔的境界中思考事物之间的关系，当然你不会犯混淆概念的错误，那是另外一种思维状态了，这种高级的思维境界黑格尔达到了。这还只是属于哲学的境界，修炼的境界更高，也就不是用形式逻辑或者辩证逻辑可以衡量的了了，我们的这门课也就高攀不到那里了。

2，概念的层次性（逻辑的抽象层次）

上面讲了，概念就是类的划分，我们研究类的关系，首先遇到的就是层次关系，事物是层次性存在的，类具有层次性，也就是说概念具有层次性。比如“商品”这一概念，我们看看这个概念可能具有的层次序列，商品{电器商品[电视机、冰箱、空调、洗衣机、电吹风……]，纺织商品[衣服、被子、床单、窗帘、毛巾……]，机械商品[汽车、拖拉机、飞机、轮船、摩托车、自行车……]……}。我们可以把商品的内涵界定为“用来交换的物品”，那么电器商品、纺织商品、机械商品……等等都可以是“用来交换的物品”，它们就都可以是“商品”这一概念的外延，而冰箱、空调、轮船、汽车、衣服、被子……等等也可以是“商品”的外延。这个外延还可以继续发展下去，比如我们把中括号里的一些外延继续分化，如汽车（小轿车、大轿车、卡车、赛车、各种工程车……），飞机（歼击机、轰炸机、运输机、民航客机；直升机、固定翼飞机……），电视机（模拟电视机、数字电视机；液晶屏电视机、显像管电视机；彩色电视机、黑白电视机……）。概念的层次性在一些逻辑学书中被称为属种关系，把上下两个层次的概念分别称为属概念和种概念。

概念的层次关系是很容易被忽略的关系，也是经常出问题的地方。比如这样一个陈述，“我今天上街买了衣服、上衣、牛仔裤”，这样的问题可能只是属于小孩子会犯的错误，那么再举一例，问三个学生：“请你说出一个男人最重要的三种品质？”我们可能得到这样的回答：甲（真诚、责任感、勇敢），乙（真诚、勇敢、正直），丙（真诚、责任感、进取心），丁（真诚、善良、宽容）。甲说：“看来每个人的回答都不同”，丁说：“其实我们的回答是相同的，只是回答的层次不一样。”这个例子中需要鉴别的是道德目的层次，儒家的仁义礼智信温良恭俭让，道家的真，佛家的善，法轮功大法所揭示的真善忍宇宙特性，与以上这些回答中的真诚、勇敢、正直责任感、进取心等德目是什么关系？ 也就是说需要深刻的了解什么是勇敢？什么是正直？什么是责任感？这些问题搞清楚了，我们也就可以看出甲和丁到底谁对谁错。那么，这个问题我们在课堂中讨论。

经常使用的短语、名词，它们的含义或者是内涵，我们都搞懂了吗？我们是否能清晰的辨析出每个人所使用的这些名词和短语所代表的真正概念以达到顺利交流的目的？

3，概念的种类

概念在不同的考察角度下，可以划分为不同的种类。

⑴普遍概念和单独概念

从外延上划分，概念可以划分为单独概念和普遍概念。单独概念是只有一个外延的概念，这样的概念一般是专有名词，如人名、地名、时间名、地点名、事件名、书名等事物的专有名称，以及摹状词（通过对某一事物某方面特征的描述来指称该事物的词组或者短语）。比如，孙文，蒋介石，广东，浙江，1912年，南京路49号，武昌起义，《中华民国史》，东亚第一共和国（通过摹状词来指称中华民国）等。注意单独概念不能再划分层次。

普遍概念是指有两个以上事物对象的概念，即外延有两个或者两个以上的概念。普通名词和词组表达的都是普遍概念。普遍概念又叫做类概念，所以，普遍概念可以划分层次，事例如上文所讲的商品系列。

⑵正概念和负概念

根据概念所反映的事物具有或者不具有某种属性，可以把概念分为正概念和负概念。反映事物具有某种属性的概念叫做正概念，反映事物不具有某种属性的概念叫做负概念。比如健康和不健康，合法和非法，高智商和非高智商，低智商和非低智商，有罪和无罪，{大于100的整数}和{不大于100的整数}等。正概念和负概念是在一定范围之内依据肯定和否定关系划分的概念的某种区别，一旦划分它们之间就形成一种固定的对立关系（而不是对立统一关系），它们把事物一分为二，且彼此不相容。

【任何概念总是相对于一个特定范围而言，一个概念所相对的特定范围，在逻辑上称为论域。理解一个负概念，必须注意它的论域。在同一论域中，有确定的正概念，就必定有明确的负概念。】

⑶集合概念和非集合概念（整体概念和非整体概念）

有些书中讲根据概念所反映的是否是事物的总体，把概念分为整体概念和非整体概念，这和另外一些书中讲的集合概念和非集合概念是一回事。我们这里采用集合概念和非集合概念的说法。

根据概念所反映的对象是否为集合体，可以把概念分为集合概念和非集合概念。集合概念反映的对象是集合体，它是一个整体，表达整体的属性，不可分割开来使用；而非集合概念反映的对象是部分的代数组合，它既表达部分的属性，也表达整体的属性，因此既可以整体使用，也可以分开来单独使用。

有些资料中讲：【“集合体就是由两个或两个以上的个体经过组合构成的一个统一整体，这个整体所具有的本质属性不为组成它的个体所具有。”】——这句话其实想表明集合体是个系统，和要素不一样，但这种系统关系只在属种关系的情况下有用，如下面的A情况。而B中的情况则不能仅仅依靠系统和要素的关系来鉴别，而要在词项关系中鉴别，系统和要素的非加和关系是静态关系，而词项之间的关系是动态关系。

A，集合概念和它的元素共用同一个名称的情况

比如说“共产党是历史上最腐败和邪恶的统治集团”，有人反驳说：“不见得，我叔叔就是个共产党，他从来都不腐败，为人很正直，一点都不邪恶。” 前面句子中共产党是个集合概念，表示一个集合体或整体的属性，而后面句子中的共产党应该是共产党员，是前面句子中共产党这个集合的一个元素。元素和它的集合的关系其实是种属关系，也就是概念的抽象层次关系，由于它们共用同一个名称而在一定语境中形成了集合概念和非集合概念。

B，集合概念和非集合概念共用同一个名称的情况

我们真正需要鉴别的是同一名称的概念（不是种属关系或属中关系的混淆情况）在不同语境下分别可以是集合概念和非集合概念的情况，因为集合概念和非集合概念的属性是不同的，鉴别不出二者的区别，在推理中就会出现逻辑问题。比如“我们班的同学来自全国各地”，这里“我们班的同学”是个集合概念，表达的是整体的属性，它不反映我们班中的某个同学的具体情况，不能说成“我们班的某个同学来自全国各地”。再看另一句话，“我们班的同学都是中国人”，这句话中“我们班的同学”是非集合概念，它既反映我们班中某个同学的情况，也反映我们班中的所有同学的情况，因此可以说“我们班的某个同学是中国人”。可见，不能孤立的直接说某个概念是集合概念还是非集合概念，而是要在一定的语句的词项关系中去鉴别。一般来讲，判断集合概念和非集合概念主要看这个概念后面的关系项内容，具体如何鉴别呢？我们留给同学们做作业来完成。

集合概念是一种关系概念，具体来说是一种“词项关系概念”（或者语境关系概念），就是说它在一定的语境或者词项关系中才能被确立，一个词或者词组是不是集合概念并不是这个词或者词组固有的属性，而是被一种具体词项关系规定了的，随语境的具体条件而变化。

前面讲的正概念和负概念、单独概念和普遍概念，则不是“关系概念”，它们既不需要相互界定（对立统一关系的概念），也不需要在一定的词项关系或者语境中界定。正概念和负概念是依据肯定和否定（肯定和否定是哲学范畴，是概念定义中最高的抽象层次的概念）关系划分出来的概念属性，其属性一旦划定不会随语境而变化，而单独概念和普遍概念本身就具备了这类概念的属性，是一种固有属性的概念，不需要相互界定，更不会随语境而改变概念的这个属性。

一个概念不只是属于某种划分中的一个种类，而是可以分别属于几个种类。例如：“教师”这个概念既是一个普遍概念，又在特定语境下可以是一个集合概念，也是一个正概念。

（如：“随着教育投入的增加，教师的收入每年都在稳步增长”，这里的教师是个集合概念。再如：教师应该为人师表，在行为上做学生的表帅。这里的教师是非集合概念。）

[学习参考段]：

⑷实体概念和属性概念（这也是一种关系概念，是对立统一关系的概念，必须在层次关系中理解。）

实体概念和属性概念必须在相互的关系中才能确立，这个关系有些逻辑学书中有讲，但是讲的不透，也不知道层次关系的变化，把它们当作一种静态的概念来讲，结果讲的遮遮掩掩的。为了同学们阅读这些逻辑学书籍不产生困惑，这里把这个问题作为参考资料讲一下。

事物具有很多属性，事物和它的属性可以划出两类概念，反映事物本身的概念叫做实体概念，反映事物属性的概念叫做属性概念。实体和属性是对立统一的一对关系概念，在一定层次内互相界定，因此就某一概念来说，在不同的层次内，可以分别充当实体概念和属性概念。

比如以人为实体，那么身份（工人、农民、学生、官员、教师、军人、企业主等）、年龄（老年、中年、青年、少年等）、身高（高个子、中等个子、矮个子）、性别（男、女、阴阳人）、体形（肥胖、偏胖、适中、偏瘦、瘦）、肤色（棕色、黑色、黄色、白色等）、智商（高智商、一般智商、低智商）、学历（小学、初中、高中、中专、专科、本科、硕士、博士、博士后）等特征都是人的某种属性，这些概念都是人的属性概念，人是这些属性概念的实体概念。而如果以身份为实体，比如说以具体的一个身份学生为实体，那么年龄、身高、性别、体形、肤色、智商、学历等特征都是学生的某种属性，这些概念就都是学生的属性概念，学生在这里就充当了实体概念。我们不能说学生既是实体概念又是属性概念，实体和属性是在一对关系中同时出现，相互定义的概念，只有在一对关系中才有意义，而不是独立存在的。

因为事物本身是分层次的，在哪一个层次中界定事物，它就是那个层次中的实体，因此逻辑中的概念也是分层次的，实体和属性这种关系，或者说任何的关系都需要在一定层次内界定，也在一定层次内有效。


第一章 概念和定义

二，概念间的关系

概念间的关系主要通过外延的关系来界定，可以存在五种关系。

   1，相容关系

    相容关系是指两个概念的外延至少有一部分重合的关系。根据外延重合的多少，相容关系又可以分为同一关系、真包含关系、真包含于关系和交叉关系四种。

   ⑴同一关系

     同一关系也叫做全同关系，同一关系是指两个概念的外延完全重合的关系。例如：“中国”，“我的祖国”，“世界上人口最多的国家”， 这三个概念是同一关系。再比如“中华民国”与“东亚第一共和国”，前者是专名，后者是摹状词，二者的外延完全重合。具有同一关系的概念内涵有所不同，外延却完全相同。具有同一关系的概念可以交替使用，主要作用是避免表述重复，以达到不同的修辞效果，丰富表达的内容。

    ⑵真包含关系

真包含关系是指一个概念的部分外延与另一个概念的全部外延重合的关系。如中华民国与江苏省，中华民国的概念包含江苏省的概念。

    ⑶真包含于关系

    真包含于关系是指一个概念的全部外延与另一个概念的部分外延重合的关系。真包含关系与真包含于关系是相对互逆的，人们把它们合称为属种关系。在具有属种关系的概念中，外延大的概念称为属概念，外延小的概念称为种概念。

【由于属概念与种概念分别反映不同层次的对象，因此，在语言表达中，属概念与种概念一般不能并立使用，否则，会使部分外延被重复断定。另外，由于属概念反映的是一个类，外延比较大，因此，属概念不可能是单独概念。也不可能是集合概念。】（方括号中的句子是我参考一些逻辑学教材的引述资料，注意最后一句我加了波浪线的这个判断，大家想一想，它对不对？）

     ⑷交叉关系

     交叉关系是指一个概念的部分外延与另一个概念的部分外延重合的关系。它们是非属种关系，例如：“教师”（a）和“教研室主任”（b）这两个概念，它们的外延仅有一部分是重合的，即有一个人他即是教师又是教研室主任。即a概念的部分外延与b概念的部分外延重合，那么a概念与b概念之间的关系就是交叉关系。那么，鉴别一下教师和律师是不是交叉关系？

    2.不相容关系

     不相容关系是指两个概念的外延没有任何一部分重合的关系。不相容关系也可以称为全异关系，它可分为矛盾关系和反对关系两种。

     ⑴矛盾关系（把事物一分为二）

    【矛盾关系是指两个概念的外延没有任何部分重合，而它们的外延之和刚好等于其属概念的外延。例如：“成文法”（a）和“不成文法”（b）这两个概念，它们的外延没有任何重合，而两个概念的外延之和等于其属概念“法律”（c）的外延。】前面讲的正概念和负概念就是一对矛盾关系。注意：这里的矛盾是形式逻辑学中的矛盾，只有对立性而没有统一性，与辩证逻辑学中的辩证矛盾不同。

    ⑵反对关系（至少把事物一分为三）

【如果两个概念的外延没有任何部分重合，而它们的外延之和小于其属概念的外延，那么，这两个概念之间的外延关系就是反对关系。例如：“红色”（a）和“黄色”（b）这两个概念，它们的外延没有任何重合，而两个概念的外延之和小于其属概念“颜色”（c）的外延。那么，a概念与b概念之间的关系就是反对关系。】

课堂讨论题：

1，“北京的风景名胜不是一天能够游览完的，颐和园是北京的风景名胜，所以，颐和园也不是一天能够游览玩的。”问题：A请先找出5个“北京的风景名胜”的外延（包括颐和园），B“颐和园是北京的风景名胜”这句话中“是”是什么意思？这句话对不对？C，上面这句话中，“北京的风景名胜”这个词组在前后句中是否分别是集合概念和非集合概念？请说明理由。

2，“他是共产党”（a）和“他是个共产党”(b)，两句话中的“是”有没有区别？

3，请列举一个同一名称的词组在不同语境中分别为集合概念和非集合概念的情况。

4，如何判断集合概念和非集合概念？请仔细思考并给出你所能提供的一些鉴别方法。

5，请阅读第六自然段中的这个例子，【问三个学生：“请你说出一个男人最重要的三种品质？”】，请回答例子中的问题，什么是勇敢？什么是正直？什么是责任感？甲和丁到底谁对谁错？为什么？


第一章 概念和定义

三，概念的限制和概括

   1，概念内涵和外延之间的反变关系

     反变关系：一个概念的内涵越多，其外延越少；一个概念的内涵越少，其外延越大。

     凡具有属种关系的两个概念在内涵与外延之间都具有反变关系，即种概念的内涵比属概念的内涵多，而外延小；属概念的内涵比种概念的内涵少，而外延大。概念的反变关系不是数学上可以用数值精确计算的比例关系，只是一种大致趋势，它是对概念抽象性（也就是层次性）的一种研究手段，其目的是为明确概念提供一种逻辑方法，是概念进行限制和概括的逻辑依据。比如说，歌唱家、男高音歌唱家、中年男高音歌唱家、著名的中年男高音歌唱家，这四个概念相互之间在内涵与外延之间就存在一个反变关系。

    2，概念的限制

概念的限制亦称概念外延的缩小法，是通过增加概念内涵以缩小概念外延的一种逻辑方法。它具有方向性，由属概念过渡到种概念，从一个外延较大的概念过渡到外延较小的概念，使概念的抽象层次降低，越来越接近具体事物。在语言中一般是通过增加限制词来达到概念的限制，如在名词前加定语，动词、形容词前加状语等。例如：土地——可耕种的土地（耕地）；学习——认真地学习；聪明——异常地聪明。

有教材中讲【因概念的限制是由属概念过渡到种概念，同一关系、交叉关系或不相容关系的概念不能进行限制；单独概念或集合概念也不能再进行限制。】请同学们思考，这句话有什么问题？

3，概念的概括

概念的概括亦称概念外延的扩大法，是通过减少概念内涵以扩大概念外延的一种逻辑方法。它也具有方向性，由种概念过渡到属概念，从一个外延较小的概念过渡到外延较大的概念，使概念的抽象层次提高，越来越抽象。在语言中一般是通过减去附加语或限制词来达到概念的概括。如中国农民——农民；努力地工作——工作；非常优秀——优秀。概念概括的极限是哲学范畴，比如“物质”是世上所有存在物的总称，是概括性最大的名词。

概念的概括和限制是概念的层次性的体现，其中蕴藏着对一个事物下定义（形成概念）的基本方法。


第一章 概念和定义

四，如何下定义

定义是界定概念内涵的逻辑方法，即揭示概念所反映的事物的本质或其属性的逻辑方法。下定义的基本要求就是要通过对概念的定义精确和清晰地反映出事物的本质或者其基本属性。

定义通过概念和概念之间的关系来确定，一个概念的定义是通过另一个概念来体现的，定义的基本前提是有限性，它需要一些自明的或者公认确证的东西作为前提来给定义划定界限。定义是人类对存在事物的抽象认识，是人类逻辑思维能力和语言表达能力的一种体现，因此定义和概念不能在无限思维中去进行，必须以思维所能涉及的范围为限度。比如：问电视是什么？回答说电视是一种可以显示声音和图像的电器；又问电器是什么？回答说电器是通过电力来做动力的机械设备；再问电力是什么？机械是什么？回答说电力是原子间的一种能量的表现形式，机械是一种可以代替人的四肢的生产和生活的工具；再问原子是什么？能量是什么？生产是什么？生活是什么？工具是什么……这样问下去，你给电视下个定义看来是完不成了。

可见，下定义必须在一定的层次范围内完成，下定义的第一步首先是确立“定义域”，就是给出下定义的层次范围。比如，要为“白菜”下一个定义，先要界定出白菜的定义域，白菜是什么，根据不同的抽象层次，可以分别表述为：“白菜是一种物质”、“白菜是一种植物”、“白菜是一种食品”、“白菜是一种蔬菜”……，与白菜最接近的分类为蔬菜，因此白菜的定义域为蔬菜。要为白菜下定义，必须先把白菜的概念层次确定在蔬菜这一类上，再根据蔬菜的植物学分类规则确定白菜与其它蔬菜可以区别开来的特征，把它们作为定语（限定词）加在蔬菜的前面，这样就可以得到关于白菜的准确定义。

1，下定义的方法——两种层次关系

⑴不同层次的限定性定义（一般教材中称为“属＋种差”定义）

这种定义方法多发生在为“实体概念”下定义的过程中，种概念以属概念作为它的定义域（也有为“属性概念”下定义的情况，此时属性概念和实体概念形成不同层次关系，见下文为学生下定义的事例）。前面说过，实体概念反映事物的本质，而本质又是一个分层次的东西，因此一个实体概念通过从抽象层次上的概括和限制就形成了属种关系的概念体系，概念的属种关系是相邻两个层次的概念间的关系，其实就是大类和小类的关系，因此可以通过属概念加种差来定义种概念。比如上面讲的白菜，它的属概念为蔬菜，可以通过蔬菜加限定词（种差）来界定白菜，不同的蔬菜之间的差别，就是这里的种差。一般来说，种差可以是事物的功能和作用或者形成事物的基本方式和方法，其实就是以系统的功能和结构，因为每个系统的功能和结构都是独有的，都可以把它和其它系统区别开来，因此系统的功能和结构就是最基本的种差。

比如说“电视是一种可以显示声音和图像的电器”，这是以系统（电视）的功能作为种差加上它的属概念（电器）来下定义的方法；再比如说“国家是由管理机构和人民通过契约组成的政治实体”，这是以系统的结构作为种差加上属概念（政治实体）来下定义的方法。还可以把二者结合起来，把系统的功能和机构都作为种差，如“国家是由管理机构和人民通过契约组成的政治实体，它有三种作用：㈠，传承民族文化；㈡，保护国民安全、维护国民主权；㈢，保障国民生活和社会经济交往的正常运作。”以上这个定义可以联结成一个长句：“国家是由管理机构和人民通过契约组成的，具有传承民族文化、保护国民安全、维护国民主权、保障国民生活和社会经济交往的正常运作功能的政治实体。”是要一个长句来定义呢，还是通过结构和功能的分别论述来定义，要看具体的语境和作者写作的需要来决定，这涉及到写作方法，就不在这里讨论了。

⑵相同层次的解释性定义

这种定义方法多发生在属性概念的界定过程中，属性概念以它的实体概念作为定义域，通过实体概念加它的某种属性的解释来下定义。如以学生为实体概念，以学历为属性概念，那么“本科毕业生”一般可以被定义为“接受了四年大学专业教育，并获得毕业证书的学生。”本科（学历）和学生（身份）属于交叉关系的概念，在概念的抽象层次中居同一层次（可以同时作为人这个实体概念的两种并列的属性而存在），可以相互之间形成同层次的实体和属性的关系，因此，这个定义中以“学生”做“本科毕业生”的定义域，而不是以它们二者的上一级概念——“人”——作为定义域。再举一例，“君子协定”可以被定义为“不用通过书面缔约而仅仅以缔约人的信誉作担保而达成的口头协定。”这里是以协定作为定义域，以君子作为这种协定的属性来展开解释形成定义，重在对君子行为做出解释。这个词也可以这样来定义，“君子协定”就是“君子之间达成的口头契约”，这个定义中以君子为定义域，以协定为属性，重在解释协定。当然这个词还可以模糊掉实体概念，以并列的两个属性概念的各自解释来形成定义，比如“君子协定”就是“不用通过书面缔约而仅仅以缔约人的信誉作担保而达成的口头契约。”这个定义中，既解释君子又解释协定，君子和协定作为平等的地位出现。一个事物可以具有很多属性，这些属性都可以形成相同抽象层次的属性概念，它们之间可以相互以对方为实体来下定义，也可以忽略实体，以并列的属性概念的分别解释来下定义，这形成了相同层次的解释性定义方法。

最后，实体和属性的关系也可以体现在不同抽象层次，这是概念的层次关系的普遍性的体现。如以学生为属性，以人为实体，那么学生可以被定义为“在学校接受教育的人”，在学校接受教育是对学生这种身份的解释，也是对人的限定性词语，人做了这个概念的定义域（不同层次的限定性定义）。这个例子中人和学生也形成了不同层次的属种关系，人为属概念，学生为种概念，因此，相同层次的解释性定义必定为属性概念的定义，但属性概念的定义不一定就是相同层次的解释性定义，也可以是不同层次的限定性定义。

2，下定义的逻辑规则

⑴不能同语反复

对该解释的词语必须做出清晰的解释，而不能简单的反复。比如对罪犯下一个定义为“罪犯是犯了罪的人”，这个定义不能说不对，但太简单，违背不能同语反复的规则，没有对“什么是罪”做出清晰的解释，正确的应该是“罪犯是违反了一个国家法律的人”。再比如“君子协定就是君子之间的协定”，这也是同语反复，解决方法见上文。

⑵不能循环定义

不能使用两个可以相互解释的概念来互相定义。如：“运动就是变化，变化就是运动。”这属于循环定义。循环定义的其中一个定义拆开来可以成立，但必须对另一个定义做出另外的解释，如：“运动就是标志着宇宙间一切变化的现象，变化是表示一个事物不同于从前的状态的现象。”这样就把运动和变化的概念分别下了一个可以实用的有效的定义。

⑶不能使用对立面来下定义

对立面可以作为认识事物的一种方法，但作为定义则不能清晰的反映概念所代表的事物的本质或者基本属性，两种关系的概念之间互为对立面：一是矛盾关系的概念之间（也是正负概念的关系），二是反对关系的概念之间。

A不能使用矛盾关系的概念（负概念）来定义

负概念是正概念的完整的对立面，就是它与它的正概念形成了一个完整的全集，正概念和负概念刚好把一个事物一分为二。负概念需要非常精确的否定性描述，一般是通过在正概念前面加上“非”、“不”之类的否定词来达到的，如前面所述。使用负概念定义的例子如：“合法行为就是不是非法行为”，“好人就是不是非好人”，“民主就是不是非民主”等都是使用负概念来下定义，使事物的本质或者属性没有清晰的表现出来。

B不能使用反对关系的概念来定义

反对概念也是对立面的概念，但是它只是部分的对立面，一个概念和它的反对概念没有形成全集，反对概念下定义的情况如：“民主就是不是专制独裁”，“好人就是不是坏人”等等。因为民主和专制独裁并没有形成一个关于国家制度的全集，除了它们二者以外，还有既非民主也非专制独裁的王道政治，同样，好人和坏人之外，还有非好非坏的那种人，也就是人们所说的亦正亦邪。所以，这些例子属于反对关系下定义的情况。

以上对立面下定义的例子可以修正为：“好人就是其行为符合人类的普遍性道德原则和基本社会规范的人”，“合法行为就是符合一个国家的法律规范的行为”，“民主就是主权在民的国家管理制度”。


第一章 概念和定义

五，概念的引申问题研究（以后补）

具体和抽象

广义和狭义

比喻和引申

课堂讨论题（本次主要是自己下定义的习题）：

1，有教材中讲【因概念的限制是由属概念过渡到种概念，同一关系、交叉关系或不相容关系的概念不能进行限制；单独概念或集合概念也不能再进行限制。】请同学们思考，这句话有什么问题？

2，什么是下定义的定义域？请给出以下概念的定义域：⑴运动；⑵国家；⑶民族；⑷国民党（1912年）；⑸土地；⑹教师。本文中的“定义域”这个概念是我自己规定的，它在本文中的作用是什么？同学们从中可以学习到什么东西？

3，列举两个不同层次的限定性定义的例子，要求分别以系统的功能和结构为种差。

4，列举两个相同层次的解释性定义的例子，要求一个为以实体为定义域对属性进行解释的定义，一个为忽略实体，两个属性并列分别解释的定义。

5，请分别列举一个同语反复、循环定义、对立面（两种情况）定义的例子，并给予修正。


第二章 命题和判断(纪要2-1）

授课内容：《形式逻辑》第二章——命题和判断（上）
上课时间：2008.11.13日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主老师
到课同学： 慕容患、張香山、黎焕石 、钱不求、杨尚、陈清扬 、宋志豪 、陈炜、贺大翔 、辛言 、罗同、张华虎、曲婉蘭 、张玉、华变天、張穀虛、齐学玉
到课总人数：17人
纪要整理：齐学玉

各位同学：后主老师好！

李后主: 各位同学好！我们开始上课！

李后主: 第一章讲了概念和定义，我们现在先把第一章总结一下。

李后主: 我们学了概念和定义后，要懂得在思维时要使用准确的概念，不能犯概念​不清或者偷换概念的错误。

李后主: 第一章的内容主要明白这么几点：⑴概念是什么，它是干什么用的？⑵概​念的种类。⑶概念之间的关系。⑷概念的应用。⑸定义是干什么的？

李后主: ⑴概念是揭示事物本质或者基本属性的思维单元，是我们思维展开的第一​步。要探索事物本质和内部联系必须使用概念思维，概念思维是哲学和现代​科学的基础。要成为一个理性的人，必须学会使用严格的概念来进行思维和​对话。

李后主: 概念是所有学科的基础啊！

齐学玉: 概念真的很重要啊，是思维的细胞，能用概念来思维就是能超越感觉的来​思考问题了。

李后主: ⑵概念可以分为几个类型，其中也有很复杂的应用情况，比如集合概念和​非集合概念，同一个词语可以在不同的语境中分别表达集合概念和非集合概​念，如果分 不清楚这种区别，那么就会出现推理错误。⑶概念之间形成五种基本关系，有同一的关系，有交叉的关系，有互相包​含的关系，也有彼此不相容的关系。它们反映 了事物的存在状态以及事物之​间的基本联系情况，是我们形成正确命题的根据。⑷在应用中必须保持同一概念在上下文中的一致性，否则会犯偷换概念的​错误。 概念是用词语来表达的，由于词语具有多义性，相同的词语在不同语​境中可以表达不同的含义，因此，如果不注意词语含义的变化，造成前后概​念的不一致，就 会导致推理的错误。⑸定义是形成概念内涵的过程，其实也就是形成基本概念的过程，下定义​的能力反映了概念思维的能力。定义和概念是相辅相成的关系。

李后主: 关于概念的应用，里面涉及的问题很多，我在第一章讲义中留了一个空白​，希望在日后能总结出来，专门做一个专题来讲。那么这里给大家可以提示​的是，概念 的应用中同一词语有具体和抽象的区别，有广义和狭义的区别，​有比喻和引申的意义，有层次的区别，也有历史的演变中同一次词语概念内​涵发生变化的情况。 这些复杂情况都需要我们在具体语境中一一辨别出来，​在使用的过程中有时候要交代这个词语表达的概念的具体情况。比如，我在​使用文化这个词语时，经常会 提示这是指狭义的文化，就是仅仅指思想层面​的东西。

李后主: 第一章的内容，我就这样总结一下。大家有什么看法，给几分钟时间可以​说说。

杨尚: 可以理解。

張香山: 這次總結我們有復習了一下第一章的内容。

李后主: 好的，那么我们在这里再把第一章中后面我修改了的部分再讲一下。关于​下定义的规则。

陈清扬: 学习概念的概念以及形成概念的技术——定义，是进行理性思考的最基本​层面。两千多年前苏格拉底就对雅典人以及其后的西方文明做了奠基，我们​虽然现在才开始系统学习形式逻辑与其基础，仍是为时不晚，而且极其重要​的课程。

李后主: 是啊，陈清扬说的对，整个西方现代文明都是从概念体系中演化出来的。​概念思维就是哲学思维，从方法上就是逻辑思维，从表现形式上就是形而上​学。那么，什么是哲学，大家清楚了吗？哲学就是用逻辑思维去思考世界，​用形而上学来表达这些思维成果的学问体系。

慕容患: 形式逻辑课程，对缺失逻辑思维能力的学生非常重要。

李后主: 好，继续把上一章中需要修改的部分讲一下。⑴不能同语反复；⑵不能循环定义；⑶不能使用对立面来下定义。

李后主: 注意，我把第3条修改了。以前是“不能使用负概念来下定义”。对立面可以作为认识事物的一种方法，但作为定义则不能清晰的反映概念​所代表的事物的本质或 者基本属性，两种关系的概念之间互为对立面：一是​矛盾关系的概念之间（也是正负概念的关系），二是反对关系的概念之间。

李后主: A不能使用矛盾关系的概念（负概念）来定义负概念是正概念的完整的对立面，就是它与它的正概念形成了一个完整的​全集，正概念和负概念刚好把一个事物一分 为二。负概念需要非常精确的否​定性描述，一般是通过在正概念前面加上“非”、“不”之类的否定词来达​到的，如前面所述。使用负概念定义的例子如：“合 法行为就是不是非法行​为”，“好人就是不是非好人”，“民主就是不是非民主”等都是使用负概​念来下定义，使事物的本质或者属性没有清晰的表现出来。

李后主: B不能使用反对关系的概念来定义
反 对概念也是对立面的概念，但是它只是部分的对立面，一个概念和它的​反对概念没有形成全集，反对概念下定义的情况如：“民主就是不是专制独​裁”，“好人 就是不是坏人”等等。因为民主和专制独裁并没有形成一个关​于国家制度的全集，除了它们二者以外，还有既非民主也非专制独裁的王道​政治，同样，好人和坏 人之外，还有非好非坏的那种人，也就是人们所说的​亦正亦邪。所以，这些例子属于反对关系下定义的情况。

李后主: 以上对立面下定义的例子可以修正为：“好人就是其行为符合人类的普遍​性道德原则和基本社会规范的人”，“合法行为就是符合一个国家的法律规​范的行为”，“民主就是主权在民的国家管理制度”。

李后主: 好的，第一章的总结和修正到这里，下面我们开始进入第二章的第一次课​的学习。本次课程主要学习概念和概念通过量项和联项形成命题后，简单命题中蕴​藏的 的一些规律，包括通过主项和谓项两个概念间的关系来判断直言命题的​真假，包括两个同主项和谓项的直言命题之间的真假制约关系等等。

李后主: 我们通过习题来学习这一节的内容。什么是命题，大家应该比较清楚。现在完成第一个问题。1，请列举一个​不是命题的陈述句。

齐学玉: 小李打了小王一拳撒腿就跑了。

杨尚: 例如：我刚吃过饭。

慕容患: 人可以坐在自己怀抱。

李后主: 上面三位同学，你们列举的都是命题啊！

李后主: 齐学玉陈述了一件可以判断真假的事件。杨尚和齐学玉一样。慕容患直​接列举了一个假命题。把慕容患的例子修改一下就是“人不可以坐在自己怀里“这样一个真命题​。

張香山: 小王他是好人嗎？

李后主: 张香山，你举得例子是陈述句吗？

張香山: 我们一起去百貨大樓吧。

李后主: 香山，这是祈使句，不是陈述句。

张华虎: 小猫的思绪飞上了天。

李后主: 张华虎的这个例子符合要求，既是陈述句，又不是有效的陈述，而是比喻​，所以不是命题。

李后主: 陈述句，祈使句，疑问句，都不分清楚吗？

陈 清扬: 饼干生出了时间。——我理解的命题需要有最基本的时空关系，或许类似​康德所说的“科学知识的可靠性来源于人的先验的感觉形式——时间和空间​，时空感将 材料整理成一定的感性知识”，如果是超出了“先验的感觉形式​”的陈述句，我认为就不是命题，也就是这题的答案。

李后主: 陈清扬说的好，道出了为什么不能时空错乱的原因。

慕容患: 桃花染红了我的心。

李后主: 好的，慕容患终于知道该把他的诗歌拿出来就符合要求了。

杨尚: 我们乘着思想的翅膀飞上蓝天。

張香山: 海燕在高空中飛翔，我的心也隨她去了。

李后主: 香山这样说吧：我的心随着高空飞翔的海燕去了。

李后主: 现在大家总结一下，不是命题的陈述句可能是哪些情况？

張穀虛: 修飾性語句。

齐学玉: 无意义的陈述句不是命题，如时空错乱的句子。

張香山: 不符合邏輯的。

慕容患: 1.不符合逻辑。
2.不符合真相。

李后主: 不符合真相的不一定不是命题，可以是假命题。

张华虎: 比喻、时空错乱。

陈清扬: 运用一些修辞手法（比喻、拟人、拟物等）的陈述句；超出先验感觉形式​的陈述句等。

李后主: 张华虎和陈清扬总结的不错。

張香山: 很虛的，擬人化的。

李后主: 大 体就是两种情况，一是时空错乱，不符合先天感觉形式的陈述；二是比​喻修饰性的陈述句。第一种情况就是不符合逻辑的先天形式，第二种情况就是随意性太强， 而​逻辑要求稳定性与精确性。其实还有第三种情况，就是我们不要把我们思维不能去下定义的事物作为​命题来研究，比如“上帝是什么什么”。但是，中共是邪灵，这个命题却是我们应该研究的。

慕容患: 不符合形式逻辑的陈述句，不是命题。

张华虎: 李后主: 不符合真相的不一定不是命题，可以是假命题。

張香山: 中共是謝霛 ，我們能說清楚的。

李后主: 关于神的信仰方面的判断可以通过哲学来研究，作为哲学问题来研究，但​是不能通过形式逻辑的命题来研究。就是说我们要谦卑。要心存敬畏。另一方面，我们要维护天道，就要替天行道，对于世间中共的本质可以通​过概念、命题与判断来研究，把中共是邪灵的本质揭示出来。

陈清扬: 我理解：形式逻辑也有自己的极限，不能用它来否定逻辑之外的东西——​“人在不能说的地方，就应该沉默”。

杨尚: 老师说的对。

李后主: 九评，就是通过给中共下定义，形成关于中共的基本命题，中共是邪灵和​邪教，来揭示中共的真面目。

李后主: 命题的种类大家简单浏览一下。
命 题的种类很多。（1）根据命题中是否包含有“必然”、“可能”等模​态词，将命题划分为模态命题和非模态命题。（2）根据非模态命题中是否​包含有其他命 题，将非模态命题划分为简单命题和复合命题。（3）根​据断定的是对象的性质还是之间的关系，将简单命题划分为性质命题和关系​命题。（4）根据复合命题 中包含的联结项的不同，将复合命题划分为联言​命题、选言命题、假言命题、负命题。

李后主: 命题的结构，是关于命题的基本形式，就是词项如何组成命题。我们今天​研究的直言命题（性质命题）是由主项、谓项、联项、量项来组成的。直言命题有六种基 本形式，这很简单，大家一看就记住了，关键在于把握​它们之间的复杂的逻辑联系。相同主谓项情况下，直言命题形成四种对当关系，其间存在着一些客观的​逻 辑规律，这是我们应该熟练掌握的。

李后主: 好的，下面我们继续通过习题来学习。

李后主: 2，案例分析：鲍西娅有金银铅三只盒子，其中只有一个盒子中放着鲍西​娅的肖像，现在有三个求婚者来猜肖像在哪里。金盒子上写“肖像不在此盒​中”，银盒 子上写“肖像在铅盒中”，铅盒子上写“肖像不在此盒中”。鲍​西娅说：“上述三句话，最多只有一句是真的。”请应用对当关系推理分析​一下肖像到底在哪个 盒子中。请写出推理过程。

李后主: 这是莎士比亚的《威尼斯商人》中的一个情节，经常被逻辑学教学中作为​例子来使用。

陈清扬: 定义P肖像，S1金，S2银，S3铅，三个盒子整体S
金盒子上写“肖像不在此盒中”，S1eP；银盒子上写“肖像在铅盒中​”，S3aP；铅盒子上写“肖像不在此盒中”，S3eP。
要运用对当关系必须主项、谓项相同，只能判断S3aP,S3eP
因为：ae矛盾关系，必有一真，
所以：S3aP与S3eP 1T1F
又因为：最多只有一句T
所以：三句话中必有一为T，即1T2F
所以：S1eP为F
所以：S1aP为T

李后主: 陈清扬，你的解答中，形式太麻烦，我们直接用命题来推理，没必要搞那​么多的符号。你是化简为繁，这样去思考问题，难道现实中的这些问题你都准备符号化​吗？那你怎么在现场和别人交流呢？逻辑不是为了形成符号，而是研究命题​之间的逻辑关系。

齐 学玉: 设“肖像不在此盒（金盒）中”为命题一，“肖像在铅盒中”为命题二，​“肖像不在此盒（铅盒）中”为命题三。根据对当关系，命题二与命题三为​矛盾关系的 命题，因此这三个命题中至少有一个真命题，又根据已知条件，​三个命题最多只有一个真命题，所以说这三个命题中有且只有一个真命题。假设命题二为真命题， 则命题三为假命题，并且根据已知条件“其中只有​一个盒子中放着鲍西娅的肖像”，可以判断命题一为真命题，所以如果命题​二为真命题，那么命题一也为真命 题，与已知条件“有且只有一个真命题”​矛盾，因此假设不成立，即命题二应为假命题。综上可知，命题二为假命题，命题三为真命题，命题一为假命题。所以命 ​题一的矛盾命题“肖像在金盒子中”为真命题，由此可知，肖像应该在金盒​子中。

李后主: 齐学玉，你假设一个命题是真，一个一个去假设，这是没有学逻辑学之前​的笨办法，学了对当关系后，怎么不知道应用呢？

慕容患: 一、 银盒子上写“肖像在铅盒中”，铅盒子上写“肖像不在此盒中”。相互矛盾，其中只有一真。
二.由 金盒子上写“肖像不在此盒中”，铅盒子上写“肖像不在此盒中”。 相互矛盾，其中只有一真。
三. 金盒子上写“肖像不在此盒中”，银盒子上写“肖像在铅盒中”， 相互矛盾，其中只有一真。金盒子上写“肖像不在此盒中”，是真话，肖像在银盒子中。

李后主: 慕容患，矛盾关系搞错了。

李后主: 银盒子上写“肖像在铅盒中”，铅盒子上写“肖像不在此盒中”。－－这​两个命题是矛盾关系。因为肖像要么在铅盒子中，要么不在铅盒子中，只有​这两种情 况，而不可能有第三种情况，这两个命题刚好表达这两种情况，因​此是矛盾关系。这属于矛盾关系中的”单称肯定与单称否定“的情况。

李后主: 慕容患，其它你说的都不是矛盾关系。

張香山: 金盒和鋁盒也是矛盾關係。

齐学玉: 矛盾关系的两个命题主谓项必须是想同的。只有主谓项相同的命题才能去判断它们之间的对当关系。

張香山: 我錯了。

李后主: 金盒子上写“肖像不在此（金）盒中”，铅盒子上写“肖像不在此（铅）​盒中”。这两句话不是对当关系。谓项完全不同。

慕容患: 是，我知道我错了。

李后主: 好的，那么我们看看正确的推理形式应该是什么样。

李后主: 设金盒子上的话为命题一，银盒子上的话为命题二，铅盒子上的话为命题​三。命题三和命题二互相矛盾（为什么互相矛盾呢？因为肖像要么在铅盒子​中，要么不 在铅盒子中，只有两种结果），因此二者必然一真一假。根据以​上案例的提示最多只有一句话是真的，可知，真话在二三命题中，命题一为​假。命题一为“肖像 不在此盒子（金）中”，它是假话，那么肖像当然在金​盒子中。

杨尚: 呵呵，原来可以这么简单。

张华虎: 原来如此。

齐学玉: 是啊，很简单。根据对当关系知道二三命题有一个真就够了，因此说命题​一就是假命题！

李后主: 这个例子是应用矛盾关系来推理的。

华变天: 嗬嗬,这个题目真有意思!出得很好。

李后主: 莎士比亚的作品。

杨尚: 我们常常把一些简单问题想复杂了。绕了很多弯子，却错了。

李后主: 是啊，当年的求婚者就是这么快猜出肖像在哪个盒子，要是让你们去求婚​，都败下来了，女孩早被人家掌握了对当关系推理的人抢走了。

李后主: 好的，继续看一例。
3，案例分析：设以下三句话中只有一句是假的，请问：甲公司经理是不​是否懂得计算机？请写出推理过程。
⑴甲公司所有成员都懂计算机；
⑵甲公司的小王不懂计算机；
⑶甲公司所有员工都不懂计算机。

李后主: 那么，大家先别急，跟着我先找一下这里面的对当关系。大家找一招，这里面有什么对当关系？

齐学玉: （1）与（3）是矛盾关系。

李后主: 怎么能是矛盾关系？（1）与（3）是全肯与全否的关系，是反对关系。

齐学玉: 我把所有员工想成了除了经理的其他员工。

慕容患: 〔2〕〔3〕对当。〔1〕为假。

李后主: 慕容患，先别着急，先让你们找对当关系。

华变天: 命题1和命题3相互矛盾,必有一句是假的,因为只有一句话是假的,那​么命题2肯定是真的,不过这个和经理有什么关系?

陈清扬: 13、12反对。

杨尚: 1与3是矛盾关系，其中必有一假。
又因为3句中只有一假
所以2是真
1与2是矛盾关系，所以1是假
所以3是真。
王经理是公司一员，所以王经理不会计算机。

李后主: 杨尚，先找对当关系，跟着我的思路走。

张华虎: 12矛盾，13反对，23从属。

李后主: 你们如果连对当关系都找不准，还怎么推理。对着讲义去好好看看你们找​的这些关系对不对呢。

慕容患: 具有相同主项和谓项的直言命题之间的关系叫做对当关系。

杨尚: 12矛盾，13矛盾，23从属

齐学玉: 12，13反对，3从属。

李后主: 矛盾关系：［全肯与特否，全否与特肯，单肯与否单］，这里面有矛盾关​系吗？

杨尚: 12矛盾，13反对，23从属

李后主: 看来，先得把直言命题的形式搞清楚，否则你们连对当关系都找不出来。

張香山: 1是假的，那麽2和3 就是真的，這樣一來甲公司经理是懂得计算机。

李后主: 1是全称肯定命题。2是单称否定命题，3是全称否定命题。那么，矛盾关系是哪两种直言命题之间的对当关系呢？［全肯与特否，全​否与特肯，单肯与否单］，那么这三个命题之间能形成矛盾关系吗？

張穀虛: 1、2、3沒有矛盾關係， 13反对，12反对，23从属，

李后主: 谷虚说对了～！

李后主: 張穀虛: 1、2、3沒有矛盾關係， 13反对，12反对，23从属。好得，大家看看谁和谷虚的分析不一样，自己对照一下，错在哪里了。好，对当关系找出来了，现在应用这些关系来推理吧！

李后主: 反对关系是必有一假。

陈清扬: 因为：13反对关系，所以：13两句至少一句假，所以：假话存在于1​3中，所以2为真。因为12反对关系，所以1为假，所以3为真，所以经​理不懂。

張香山: 13反对，12反对，23从属。13反对，12反对，反对关系是必有​一假。那麽1就是假的，因爲2，3 是從屬。

杨尚: 1与3是反对关系，其中必有一假。
又因为3句中只有一假
所以2是真
1与2是反对关系，此关系中若有一个为真，另一个必假，因为2是真，​所以1是假
所以3是真。
王经理是公司一员，所以王经理不会计算机。

李后主: 杨尚推理正确。但是还有更简单的推理方法。

李后主: 大家找出一对反对关系来，那么假命题一定在其中一句。因为案例提示只​有一个假命题，那么，在这两个命题之外的那个命题不就一定为真了吗。

張香山: 13反对，12反对，23从属。13反对，12反对，反对关系是必有​​一假。那麽1就是假的，因爲2，3 是從屬。1是假的，那麽2和3 就是真的，這樣一來甲公司经理是不懂得计算机。

曲婉蘭: 香山这个推理更简单了，比较容易理解。

齐学玉: 13反对，12反对，23从属，所以1必定假，3必定真。

李后主: 香山的推理其实不简单。杨尚是从13开始推理的，我们知道12也是对当关系，也可以先从12​开始推理。

陈清扬: 2，3从属关系是有方向性的，比其他的三种关系要难用。

李后主: 解析方法二：⑵与⑴是反对关系，其中必有一假，而案例中提示三个命题​只有一个假的，可知命题⑶一定

是真的。那么直接推出经理也不懂计算机。

李后主: 看看我的这个推理。

陈清扬: 老师这个确实简单。

曲婉蘭: 确实是更简单。怎么我们就想不到这个思路呢？

李后主: 香山和学玉，你们需要注意的是，不要把所有关系放在一起推理，那么实​际上很麻烦。要抓住一个关系，找出必有一假（或者必有一真）的这种情况，然后结合​案例的提示，直接推其它命题的真假。刚才的那个猜盒子里肖像的问题就是​这样啊！

慕容患: 解析方法二最简捷。

李后主: 学会怎么推理最简单了吧！

齐学玉：明白了。

張香山: 就是就是。

慕容患: 还要慢慢消化，呵呵。

李后主: 4，案例分析：设以下三句话中只有一句是真的，请问：甲公司经理是不​是否懂得计算机？请写出推理过程。
⑴甲公司所有成员都懂计算机；
⑵甲公司的小王不懂计算机；
⑶甲公司所有员工都不懂计算机。

李后主: 这个题，我今天细看时发现没有达到我出题的原义，是我出错了，本来是​出一个下反对关系的命题，但是我一时疏忽，没有达到目的。但是，却可以用从属关系来推理。大家试一试。

陈清扬: 1、因为，三句话中只有一句是真的，所以只有三种情况，1真，2真，​3真。
2、因为23是从属关系，3为真的时候2也为真，所以第3种情况不可​能。
3、因为12，13为反对关系，无法否定这三种情况中的任何一种。
4、所以只有2种情况：1真，2真。所以无法判定。

齐学玉: 2，3从属，提示只有一个真，所以3一定假，13反对，1真假不定。​经理懂不懂计算机就无法确定。

李后主: 呵呵，这么简单还推不出来。我看看其他同学能不能有正确的推理。

杨尚: 23从属，若3为真，则2也为真。因为只有一个真，所以3为假。经理​懂计算机。

李后主: 杨尚的推理不错。

張穀虛: 三句话中只有一句是假，23从属則必真，1為假，推出经理不​懂计算​机。

李后主: 谷虚，三句话中只有一句是真的。这是第4题了。

陈清扬: 我给出的答案从第三步推理到第四步我说不清楚为什么对，但是用了穷举​推理之后，得到的结论是无法判定。

慕容患: 因为只有一真，1为真，23为假，甲公司经理是懂得计算机的。

李后主: 慕容患，你怎么推出1为真，要有推理过程啊！

钱不求: 2，3为假，1为真。经理懂得。

陈清扬: 1、2都可以是真的。

李后主: 陈清扬: 1、2都可以是真的。————12是反对关系，必有一假，怎么可能都​是真的？

陈清扬: 我的意思是，这题有两种可能：
1真，2，3假，经理懂
2真，1，3假，无法判定

钱不求: 清扬，如果2真，可以判断出1假，但是无法判断出3假，理由不充分哦。

李后主: 钱不求: 清扬，如果2真，可以判断出1假，但是无法判断出3假——如​果2真，那么13都假，这是根据原题的提示3句话中只有一真。还2真判断不出3假，你们看原题的提示没有？都不审题，就开始做题了？？

陈清扬: 2真确实判断不出3假，只能说3无法判定，再加上只有一句话是真的条​件就可以判断3假了。

曲婉蘭: 23从属，只能全部为真或全部为假，因为题目提示只有一假，因此两个​只能为真。因此，经理不懂电脑。

李后主: 婉兰，题目提示只有一真，不是只有一假。
4，案例分析：设以下三句话中只有一句是真的，请问：甲公司经理是不​​是否懂得计算机？请写出推理过程。
⑴甲公司所有成员都懂计算机；
⑵甲公司的小王不懂计算机；
⑶甲公司所有员工都不懂计算机。

慕容患: 2.3从属，与1都形成反对关系。

曲婉蘭: 23从属，只能全部为真或全部为假，因为题目提示只有一真，因此两个​​只能为假。因此，经理懂电脑。

杨尚: 婉兰，从属关系不一定要全真或全假。

李后主: 婉兰，23从属，只能全部为真或全部为假，这句话错。从属关系是可能​同真，也可能同假。不是必然的同真同假。也可能一真一假。

钱不求: 2，和3之间没有冲突关系，由于只有一个是真的，就应该1是真的。

張香山: 1是全稱肯定命題；2是單稱否定命題；3是全稱否定命題。3 和2從屬，假設3為真，那麽2 也為真，1是假。那麽經理不懂計算機。

李后主: 香山，案例提示，只有一真，你看原题了没有？连题都不审啊！

曲婉蘭: 12对当，中间一定有一真，因此3一定为假。经理还是不懂电脑。

杨尚: 婉兰，既然3假，恰说明公司人包括经理全都懂计算机。

曲婉蘭: 婉兰，既然3假，恰说明公司人包括经理全都懂计算机。－对，应该这样。

齐学玉: 曲婉蘭: 婉兰，既然3假，恰说明公司人包括经理全都懂计算机。－对，应该这样。---- 不是这样。 这样就把1当作3的矛盾命题了，而3的矛盾命题不是1。

陈清扬: 杨尚：我认为AE不是矛盾关系，所有人都不懂 是假 判断不出所有人都懂。

慕容患: 1和2.3都矛盾，所以，1为真。

李后主: 慕容患，刚才已经分析过了，这里面没有矛盾关系，怎么还糊涂呢！看看你们刚才的推理，原题提示只有一个真的，怎么把这个前提抛过不管​了呢？

慕容患: 我又跑出形式逻辑以外了，对不起。

钱不求: 我觉得陈清扬的推法和结论是正确的，我赞同。

張香山: 3 和2從屬，要真都真，要假都假。而本题要求就有一真，那么1 就是真的，所以，经历懂电脑。

慕容患: 1和2.3都是反对关系，根据只有一句话为真的条件，所以，1为真，​即公司人包括经理全都懂计算机。

曲婉蘭: 12对当，中间一定有一真，题目说只有一真，那么3一定为假。可以退​出－公司有人懂电脑。/13对当，中间一定有一真，题目说只有一真，那​么2一定为假。也就是小王懂电脑。 / 根据前者，1为真，也就是全公司懂电脑。

李后主: 婉兰，12是反对关系啊，必有一假，可以同假，怎么能推出一真呢？

陈清扬: 对当关系是矛盾、反对，下反，从属关系的合称。具体说12、13应该​是反对关系，所以12，13至少一假，不是至少一真。

曲婉蘭: 哦 明白了。刚有些糊涂..

李后主: 其实，陈清扬的推理是正确的。我刚开始忽略了2真的情况，所以，我刚开始是按从属关系推理的，但是​看了陈清扬的推理后，发现他推的比较完整。我说过，这个问题是我出题时​的失误，结果到引导我们更深刻的思考了一些问题。
 陈清扬: 我的意思是，这题有两种可能：
1真，2，3假，经理懂
2真，1，3假，无法判定

杨尚: 是的，清扬对了。

陈清扬: 老师，我有个问题：我下面的推理3-4步我认为是对的，但我说不出理​由，您看3-4步推理严密么。
1、因为，三句话中只有一句是真的，所以只有三种情况，1真，2真，​​3真。
2、因为23是从属关系，3为真的时候2也为真，所以第3种情况不可​​能。
3、因为12，13为反对关系，无法否定这三种情况中的任何一种。
4、所以只有2种情况：1真，2真。所以无法判定。

李后主: 好的，清扬上面的推理完全正确。当然，还得往下推，证明1真，2真的情况下，其它两个命题都是假的，​那么都符合原题的要求。

杨尚: 呵呵，清扬厉害，这个题确实很锻炼逻辑推理能力。如果不是学了这一课​，真不一定能推出来。

陈 清扬: 或者说“对当关系”完全等价于“全部的直言命题关系”，对当关系能判​定的，命题关系也能判定；对当关系不能判定的，命题关系也不能判定。如果说“对当关 系”完全等价于“全部的直言命题关系”，那么第三步从​对当关系出发无法判定，那么结论可以直接说无法判定。不需要进一步推理​？

齐学玉: 直言命题之间还可以毫无关系。

李后主: 对当关系”不等价于“全部的直言命题关系”，怎么可能等价呢！

李后主: 好的。这个问题看来把大家搞糊涂了。呵呵！

李后主: 我们把结论总结一下。
3必假。1真23假或者2真13假。那么经理的情况不能判定。

杨尚: 如果不学今天的课，通常凭感觉会把13当作矛盾关系，而难以想到两者​同假。

李后主: ⑸小结：对当关系推理。从属关系的情况修改为：全称为真，则特称为真，全称为假，特称真假不能判断；特称为真，全称​真假不能判断，特称为假，则全称必然为假。原来上传的讲义中这部分有错误，请大家按上面的修改一下。

李后主: 好的，今晚的课程到这里。下反对关系的习题，我下去出一个，日后发贴​贴在纪要下面大家来完成。

齐学玉: 1甲公司所有成员都懂计算机；
2有的员工懂计算机
3有的员工不懂计算机。
只有一假。
这样这个题就好做了。

李后主: 然后问经理懂不懂计算机？我们试着做做。

慕容患: 2有的员工懂计算机
3有的员工不懂计算机。
都为真。都是从不同方面描述。

钱不求: 那么经理就懂计算机了。1假那么2，3真，，成立，不知道经理懂不懂计算机
2假，1，3对立，不成立
3假，1，2成立，那么经理懂计算机

李后主: 只有一假，又出现情况不明了。23为下反对关系，必有一真，可以同真，那么一假在哪里呢？一假可能​是1，也可能是23之中的一个。

齐学玉: 是啊。

杨尚: 是的，都有可能是假的。无法确定。

钱不求: 我开始看错题目了，如果把3改为所有员工都不懂计算机， 应该可以推出来。

杨尚: 不求，那还是无法确定。

李后主: 学玉的原题可以改为只有一真。

齐学玉: 1甲公司所有成员都懂计算机；
2有的员工懂计算机
3有的员工不懂计算机。
只有一真。

李后主: 是啊，这个下反对关系的习题可以好好做做。

齐学玉: 其实还是把那些命题之间的关系弄明白最重要。

慕容患: 2有的员工懂计算机
3有的员工不懂计算机。
是不是说，一部分懂计算机，另一部分不懂计算机？这样都是真命题－－​这是同一命题的不同表述。

齐学玉: 慕容，不是的！有的员工懂，是说这些员工懂，而其他的不确定。

慕容患: 设想公司有两个人。那么，有的员工不懂计算机。是真命题。

齐学玉: 那说甲懂，再请问乙懂不懂？

慕容患: 乙不懂啊。

李后主: 慕容患，我们研究的是命题之间的关系。

慕容患: 我还不会用命题之间关系来推理，呵呵。

李后主: 23下反对关系，则必有一真，原题提示只有一真，则1为假。13为矛​盾关系，则3为真，那么2为假。2假，根据矛盾关系推出所有员工都不懂​计算机为真。那么经理也不懂计算机。

杨尚: 12为从属，1为真，则2也为真，故1为假。13矛盾，故3为真。2​3为下关系，2无法判断。1假，3真，2无法判断。

李后主: 杨尚: 12为从属，1为真，则2也为真，故1为假。13矛盾，故3为真。—​———你既然已经推出3为真，那么根据提示只有一真，就可以推出12为​假，继续推下去就可以得出所有员工都不懂计算机。

杨尚: 老师说的对。

钱不求: 呵呵，真够难懂的。

慕容患: 我跟不上了，呵呵。这节课课上到一半才晕，还可以吧，没有一上课就晕，呵呵。

李后主: 慕容患：【是不是说，一部分懂计算机，另一部分不懂计算机？这样都是​真命题－－​这是同一命题的不同表述。】————回答一下你刚才这个问​题，有一部分懂计算机，有一部分不懂计算机。这和一部分懂计算机，另一​部分不懂计算机，完全是两码事。

李后主: 慕容患，特 称命题的肯定和否定之间的关系，不是一部分和另一部分之间​的关系。而是两个命题分别对一个整体的陈述。 一部分和另一部分的关系，是对一个整体的两部分的分别陈述，是对部分​的陈述，而特称命题是对整体的陈述，是描述整体的情况中有“一些员工懂​计算机”。 整体的情况中有“一些员工不懂计算机”。这里面细微的区别，你慢慢去理解。其他同学也好好理解一下。

齐学玉: 明白了，就是说一部分就不是特称。老师，是不是这个意思？

李后主: 是“另一部分”不是特称命题。

李后主: 好的，今天的课程就到这里，把四种对当关系搞熟了，就能熟练的应用这​些逻辑规律来快速推理。

师生互道晚安！


第二章 命题和判断(纪要2-2）

授课内容：《形式逻辑》第二章——判断与命题（下）
上课时间：2008.11.20日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主老师
到课同学： 慕容患、黎焕石 、钱不求、陈清扬 、贺大翔 、罗同、严仁勇 、李大雄、文昌、麻生、文豪士 、 辛言、张华虎、曲婉蘭 华变天、張穀虛、齐学玉
到课总人数：17人
纪要整理：齐学玉

齐学玉: 1，以下命题哪些是关系命题？哪些是联言命题？
A他比他的夫人大五岁。
B他和他的夫人都是60年代出生的人。
C他和他夫人聚少离多。
D他不但是她的丈夫，而且也是她的同事。
E他和他夫人生了两个孩子。
F他和他夫人暑假去普陀山游玩了三天。

齐学玉: 大家先别等了，看看例题吧，能解决的问题先解决了，不能解决的等老师上​来再解决。在的同学请回答一下这个问题。

陈清扬: 关系：ACE
联言：BDF

齐学玉: 华虎的回答我也看了，跟清扬有一个不同的地方。

张华虎: 清扬最后一个是什么？

齐学玉: F他和他夫人暑假去普陀山游玩了三天。主要是这个的判断是关系命题还​是联言命题。

张华虎: 我也觉得最后一个不好判断。

钱不求: 关系：a c
联言：b d e f

齐学玉: 不求把F归为联言命题了。

钱不求: 我和清扬的不同主要是E,不是F。

齐学玉: 慕容患和严仁勇是网大同学。华虎看这个例子。

李后主: 好的，看到你们的讨论了。大家感觉哪个不容易判断？

张华虎: 最后一个。

李后主: 联言命题是复合命题，可以分解为两个简单命题，你们看能不能分解。

张华虎: 分解之后好像变了点味道。

李后主: 【他去普陀山游玩了三天】并且【他夫人去普陀山游玩了三天】。

慕容患: 联言命题。

钱不求: 明白了。

李后主: 最难的到是E他和他夫人生了两个孩子。能不能这么说：【他生了两个孩子】并且【他夫人生了两个孩子】。

張穀虛: 不能分開。

钱不求: 可以吧。

李后主: 好像不行吧，要不那不成了四个孩子了。

齐学玉: 这样感觉给人像再婚家庭，有四个孩子了。那就跟原命题意思不一样了。

張穀虛: 是的，大家都會理解是再婚的了。

慕容患: 是关系命题。

钱不求: 如果有并且的话，就不行了。

李后主: 这其实是个关系命题，那么能不能把这个命题转换为一个比较标准形式的​关系命题呢?

李后主: 他和他夫人是一对生了两个孩子的夫妻。

李后主: 这个原命题就是表达了这么一种夫妻关系，在关系前面加了一些限制词语​，如生了两个孩子。如果不是这种夫妻关系的话，就不能共同生孩子了，那么就成了联言命题​了。

钱不求: 看到！

李后主: 比如：他和他夫人开了一家电器商店。不对，还是表达关系的命题，这还可以说成是“合伙者关系”。 联言命题必须有“和……都”这个形式。

张华虎: 是啊。

陈清扬: 这样似乎可以:他和他夫人都是这家电器商店的经营者。

齐学玉: 就是说不能简单的看能不能把原命题分解，还要有没有表达两者之间某种​关系的意思。

李后主: 他和他夫人都做了一份兼职。这是联言命题，可以分解为『他做了一份兼​职』并且『他夫人做了一份兼职』。

李大雄: 他和他夫人都开了一家电器商店。是联言命题。

陈清扬: 我理解还是"非加和性"关系。

齐学玉: 他和他夫人暑假去普陀山游玩了三天。和他和他夫人都开了一家电器商店​。两个命题有相似的地方。

李后主: 学玉，你说的前者可以加“都”字，他和他夫人暑假都去.....

李后主: 关系命题一般是不能分解成简单命题的，【他和他夫人开了一家电器商店​】是关系命题，【他和他夫人都开了一家电器商店】是联言命题，后者是开​了两个商店。

李后主: 大家想清楚了吗？一字之差，就是关系命题和联言命题的差别。【他和他​夫人开了一家电器商店​】是关系命题，【他和他夫人都开了一家电器商店​】是联言命题，后者是开​了两个商店。

李后主: 好的，这个问题就讨论到这里，我想大家都已经能分得清楚这二者的区别​了。语言形式是很重要的，逻辑就在其中体现，这更说明我们在使用语言时​要推敲它的语义，一不小心就犯逻辑错误。

李后主: 有些语句它不是标准的命题形式，但是它包含着和标准的命题形式相同的​逻辑内涵，因此遇到这种情况要看它的内涵是什么。比如刚才的E以及我们​举得这个例子【他和他​夫人开了一家电器商店】，都表示了两个人的一种​关系，夫妻关系，或者是合伙者关系。

李后主: 2，完成【思考题1】某地有两种人，分别是说谎族和诚实族。诚实族总​说真话，说谎族总说假话。一天，有一旅行者路过此地，看见此地的甲乙二​人。他向甲 提出一个问题：“你俩中有诚实族吗？”甲回答说：“没有。”​旅行者想了想就有了正确的结论。问：以下哪项是旅行者做出的判断？并写​出推理过程。
     A．甲是诚实族，乙是说谎族。
     B．甲乙都是诚实族。
     C．甲乙都是说谎族。
     D．甲是说谎族，乙是诚实族。
     E．甲乙所属均不明。

陈清扬: 答案：D
因为:如果甲诚实，则问句回答应为有，所以甲说谎。在此基础上，如果​乙诚实，则符合条件。

李后主: 这个问题，我看学玉回答最好。

齐学玉: 选D。
甲说：甲乙都是说谎族。此命题为联言命题（p：甲是说谎族，q：乙是​说谎族）。
首先，甲必是说谎族，因为诚实族人不会说自己是说谎族。所以可以判断​甲所说的话为假命题。根据联言命题真值表（p真，p∧q假，则q假），​可知乙是诚实族。

李后主: 学玉的逻辑推理过程很完整。 学玉运用联言命题的规律，符合我们学习的要求。为什么我在讲义中把这个问题先跟踪联言命题部分的后面，最后又在习题​中再提出来呢，就是为了提示大家使用我们学习的逻辑知识来思考。

李后主: 学玉的推理过程大家看明白了吗？

麻生: 看到了。很完整。

陈清扬: 学玉推理的推理确实很标准,基本不需要作假设和选择就可以推理出结果​。

钱不求: 看到！

张华虎: 看到了。受教。

李后主: 张华虎的推理也正确，但是没有运用我们要学习的命题知识【假设甲为诚​实族，则2人皆非诚实族，矛盾。
甲必撒谎，为撒谎族。两人必有诚实族。甲已为撒谎族，所以乙为诚实族​。】

李后主: 陈清扬的答案也正确，其实要得出正确答案本身并不难，难得在于要运用​体系化了的逻辑知识。

陈清扬: 老师说得对,这样的题用穷举法肯定能推出来结果,但是就失去学习课程​的意义了。

李后主: 好的，我们继续看下一个题。
3，完成【思考题2】：骑士与姑娘的故事
某岛上的人分为两种人：骑士和无赖。骑士只说真话，无赖只说假话。而​骑士又分为贵族骑士和贫穷骑士。有一位姑娘只爱贫穷的骑士。有一个骑士​，只说了一句话，就使这位姑娘相信他是一位贫穷的骑士。问：这位骑士说​了一句什么话？这位姑娘又是如何断定他是贫穷的骑士的？

齐学玉: 骑士：我要么是贫穷的骑士要么是无赖。
上述命题为不相容选言命题（p：我是贫穷的骑士，q：我是无赖）。首​先，说这句话的人一定不是无赖（无赖不会说自己是无赖），所以此命题为​真命题。根据不相容选言命题真值表（q假，p∨q真，则p真），可知说​话的人为贫穷的骑士。

齐学玉: 不对，我推理错了。我要么是贫穷的骑士要么是无赖。这句话应该不是不相容选言命题。

李后主: 学玉，是的，是不相容选言命题。学玉的这个回答还是很标准，把逻辑知识全部运用其中。

李后主: 华虎的答案和学玉一样。大家想一想，还有没有别的答案？

李大雄: 我贫穷，但并不无赖。

李后主: 大雄，无赖也可以这么说，对无赖来说『我是贫穷骑士，我不是无赖』恰​恰都是假的。

李大雄: 是的，我错了。

麻生: 我可能是贫穷的骑士也可能是无赖。

李后主: 麻生，可能是那是模态命题，不是我们讲的非模态的简单命题和复合命题​。 “可能”－－－（1）根据命题中是否包含有“必然”、“可能”等模态​词，将命题划分为模态命题和非模态命题。

麻生: 我用词不准确。

陈清扬: 因为骑士/无赖，贫/富士矛盾关系，所以上面的简单命题都可以换为否​定的矛盾命题进而得到同样的一系列答案。

陈清扬: 我或者是无赖，我或者贫穷。变成否定的负命题:
我或者不是骑士,我或者不是贵族。

李后主: 陈清扬的思路是对的，变成负命题。 但是你找的负命题有错。所以，词语不同，命题逻辑就不一样了。

李后主: 我是贫穷骑士的负命题为【我既不是贵族骑士，也不是无赖】。

陈清扬: 后面的确实有问题.

麻生: 我不可能是无赖，也不是贵族骑士。

麻生: 无赖也可以这样讲，好像不成立。无赖只说假话，呵呵。

李大雄: 无赖不可能说他“不是贵族骑士”，那等于说了真话了。

李后主: 贵族骑士，贫穷骑士，无赖，就这三种人构成一个全集。贫穷骑士的负概​念“非贫穷骑士”就包括贵族骑士和无赖两种，因此“是贫穷骑士”的负命​题就是“既不是贵族骑士又不是无赖”这样一个联言命题。

李后主: 无赖不可能说他不是无赖，而贵族骑士不可能说他不是贵族骑士，因此这​也是一个正确的答案。

李后主: 好的，这个问题清楚了吧！
4，以下命题中，哪些是相容选言命题？哪些是不相容选言命题？
A中共要么被和平解体，要么被武装起义推翻，二者必有其一，总之它不​会长久，即将会垮台。
B中共要么被军变推翻，要么被民变推翻，要么被政变推翻，三者必有其​一。
C中共既是邪教，又是流氓黑社会组织。
D中共可能亡于2008年之冬，也可能亡于2009年之春。
E中共迫于形势，也许会为六四平反，也许也会为法轮功平反，但都改变​不了其邪教的本质和流氓的统治手段。
F中共采用杀人与诛心并用的暴政统治方式，超越了古往今来的所有暴政​统治。

钱不求: 相容c e f
不相容：a b d

李后主: 这个问题，看来大家都没有完全答对。这里面有些不是选言命题，大家看​出来了没有？

齐学玉: C中共既是邪教，又是流氓黑社会组织。是联言命题。

李后主: 从回答问题中看大家的思维现象，我说哪些是相容选言命题，哪些是不相​容选言命题，大家以为下面的被选项中大概除了相容选言命题就是不相容选​言命题，都形成思维定势了，就没有想过这里面还有不是选言命题的。

陈清扬: 老师说得对，有一些命题的第一层关系不是选言，这点我疏忽了。

李后主: 学玉终于发现是联言命题了。故意给你插个联言命题看你能不能区别出来​。

陈清扬: F的第一层是关系命题吧，第二层是不相容。

齐学玉: 清扬说的第一层第二层是什么意思？

李后主: 还有最后一个，【F中共采用杀人与诛心并用的暴政统治方式，超越了古​往今来的所有暴政统治。】前半句应该是联言命题，可以分解为【中共采用了杀人的暴政统治方式】​并且【中共采用了诛心的暴政统治方式】

陈清扬: 缩句一下：第一层是中共的暴政超越了所有的暴政。
第二层就是前半句再细分。

齐学玉: 这些真的有点难区分。清扬说的第一层第二层是不是指复合命题和它的联​言支或选言支。

李后主: 逻辑的辨别一不小心就出错，我也是动不动就出错啊。

李后主: 清扬说的第一层次的意思，我明白，按照你说的，第一层是关系命题，第​二层中前半句是联言命题。不过这不是我们要讨论的负责关系了，我们只看句子是什么命题，而不考​虑句子之间的关系，那要涉及到推理的部分了。我们现在是研究命题。

陈清扬: 老师说得对，不应该是不相容。这里的主语是中共，确实可以同时采取杀​人诛心二种方式。
我刚才说不相容是把人当作了主语，因为一个人被“杀人”了就不可能被​“诛心”了，所以误判成了不相容。这里给做个反面教材。

陈清扬: 我是这样理解的：一个命题里面可以包含多个命题，但每一个命题都需要​有自己的主谓结构，而主谓结构是从句子、语法而不是逻辑关系判定的。我​说的第一层是从句子的主谓结构说的

李后主: 我明白你说的句子之间的关系，那是长句和短句的关系，不过我们现在是​研究命题。

陈清扬: 老师说得对，请继续吧。

李后主: 那么既然把两个不是选言命题的句子挑出来了，剩下的就好判断了。

李后主: A中共要么被和平解体，要么被武装起义推翻，二者必有其一，总之它不​会长久，即将会垮台。
这是不相容选言命题，因为武装起义与和平解体是对立的方式，不可能同​时存在。

麻生: AB是不相容选命题，DE是相容选命题。

李后主: B中共要么被军变推翻，要么被民变推翻，要么被政变推翻，三者必有其​一。
这是相容选言命题，大家看一看和A的类型是不一样的，A句中给出的选​项是和平解体和武装起义推翻。而B中给出的选项却是可以相互同时出现的​东西。

李后主: 军变，民变，政变，这三者可以同时出现。民变导致军变导致政变，民变为导火索，军变来推动，政变最后完成。这​完全可以在中共解体中同时出现，也可以只出现一个来推翻中共。

李后主: 可以理解这里面的逻辑现象吗？

陈清扬: 理解。

李后主: D中共可能亡于2008年之冬，也可能亡于2009年之春。
不相容选言命题。

李后主: E中共迫于形势，也许会为六四平反，也许也会为法轮功平反，但都改变​不了其邪教的本质和流氓的统治手段。
相容选言命题。两个也许可以都真。

麻生: 又错了，呵呵。

李后主: 当然D作为命题形式，是不相容选言命题，两个支命题只有一个可能是真​的，作为结果D却有可能是一个假命题,因为中共也许比2009年春天要​晚一点亡也可能。

陈清扬: D最好还是真命题，呵呵。

李后主: 呵呵，最好是个真命题。

李后主: 5．现有命题“只有认识错误（p），才能改正错误(q)”，请问以下​哪些命题与这个命题的含义相同？并写出它的逻辑形式。
A，除非认识错误，否则不能改正错误。
B，如果不认识错误，那么就不能改正错误。
C，如果改正错误，说明已经认识了错误。
D，只要认识错误，就一定能改正错误。

李后主: 这是条件命题的习题，请大家注意充分条件和必要条件的转换。

陈清扬: ABC
Ap←q
B﹁p→﹁q
Cq→p
Dp←q

李后主: 原命题是什么命题？

齐学玉: 逻辑形式：p←q。A、B、C与它含义相同。

陈清扬: 原来的是p←q

麻生: A、B，与它的含义相同。

李后主: 那就是必要条件假言命题啊，清扬你怎么老喜欢用符号说话。

麻生: 又错了，应该是B。

陈清扬: 可能是我的职业毛病，谢谢老师指正。

李后主: 好了，那么A是【除非p，否则不能q】，还是必要条件命题，只是换了​一种语言表达形式，和原命题内涵一致。我把A的逻辑形式表达出来的，那么清扬把你的符号转换为语言吧！
其他同学看我A的例子，做一做BCD，当然其中有不符合原命题的句子​，你们做的过程中自然知道哪个符合，哪个不符合。

齐学玉: B[如果非p，那么非q]。

李后主: 是的，B[如果不p，那么不q]，还是必要条件假言命题。要回答出是​什么形式的命题。

齐学玉: C[如果q，说明已经p]，D[只要p，就一定q]。

陈清扬: Ap←q 除非p否则不能q 必要假言
B﹁p→﹁q 如果不P，就不Q 充分假言（必要假言的逆否命题）
Cq→p 如果Q，就P 充分假言（由于支项对调，相当于对调前的必要假言）
Dp→q 如果P就q 充分假言（跟原命题不同）

李后主: C[如果q，那么p]，这转换成了充分条件假言命题。

李后主: B，注意B，表达的是没有p，必然没有q。大家查查讲义，这不正是必​要条件的解释吗？清扬把它理解为充分条件就错了。

齐学玉: 所谓必要条件是指：设有事物情况p和事物情况q，如果没有p（假），​必然没有q（假）；而如果有p（真），则q的情况（真假）不能断定（即​可能有q，也可能没有q）。在这种情况下，p就是q的必要条件。——摘自讲义。

李后主: D与原命题不相同。

李后主: 好的，这是对必要条件的一种解释和转换的训练题。A是另一种表达形式，B是解释的表达形式，C是转换成充分条件的表达​形式，前后件对换，语言形式对换。

李后主: 6，请写出以下命题（都是真命题）的负命题（必然是假命题）
A，网大所有的同学都退出了中共的组织。
B，慕容患是《大学视野》的主编。
C，有些网大同学不经常来上课。
D，有些网大同学学习很努力。

齐学玉: A，网大所有的同学都退出了中共的组织。——并非网大所有的同学都退​出了中共的组织。（网大有的同学没有退出中共的组织。）
B，慕容患是《大学视野》的主编。——慕容患并非《大学视野》的主编​。
C，有些网大同学不经常来上课。——所有网大的同学都经常来上课。
D，有些网大同学学习很努力。——所有网大同学学习都不努力。

李后主: 这个问题，我看了一下，回帖的三位同学都回答正确。大家对直言命题的矛盾关系命题（负命题）都掌握了。关于复合命题的负​命题的内容，我们下一次课程中再学习。

李后主: 今天主要学习的是复合命题的基本知识。熟练掌握了这些知识，我们才能​进行到下一步推理的步骤中去。概念－－命题－－推理。

李后主: 好的，今天就到这里。

师生互道晚安！


第二章 命题和判断

第一节 命题综述

一，什么是命题

命题通常也称为判断，就是对一件事情或者一个事物的有效陈述，命题表达的是对事物的属性或者事物之间的关系的判断。命题的特征在于它有真有假，如实反映事物情况的命题是真的，没有如实反映事物情况的命题是假的。

命题是一个陈述句，但陈述句未必是命题。因为命题必须是一个有效的陈述，命题必须有意义，如此命题才能被判断真假，否则便不是命题。如“黑夜给了我黑色的眼睛”这是诗歌中的联想，不是形式逻辑中要求的有效的陈述；“周末长在地板上”，这是时空错乱，也可以在某种情况下作为诗歌中出现的诗句（可能会这样出现：周末在地板上疯长，我抬头望着那扇小小的窗口……呵呵，好像是一个渴望自由的人被困在家里或者是什么地方），但这不是有效陈述；“神在六天内创造了世界”，这是超出形式逻辑研究范围的问题，不能作为形式逻辑的命题出现。另一方面，感叹句、疑问句、祈使句不是命题，如“岁月催人老啊！”、“你吃过饭了吗？”、“我们一起去跑步吧。”这些都不是命题。

[学习参考段]：关于命题有一种误解，就是认为判断是对命题真伪的鉴定过程，而命题只是陈述，不是判断。其实，命题本身就是命题者对事物存在状况的判断，而对命题真伪的鉴定则是命题研究者对这个判断的判断，它们属于不同的过程，不同的判断环节，是一种时间上的层次关系。命题中的判断包括逻辑部分（真假判断）和价值部分（善恶判断或者利弊判断），即命题或者是逻辑判断或者是价值判断，而对命题本身的真假的判断则是逻辑判断。如“他杀了人”、“他是个坏人”，这两个命题中，前者是逻辑判断，陈述了命题者对一个事实的判断（真假判断），而后者是价值判断，陈述了命题者对一个人社会行为好坏的判断（善恶判断），那么，我们还可以对这两个命题的结论再进行真假的判断，比如他到底杀了人没有？他到底是不是坏人？这是我们对命题真假的判断，属于逻辑判断。需要注意的是形式逻辑的研究内容不是在实践中去鉴定一个命题的真假的这种逻辑判断，而是从命题形式的结构方面研究不同类型的命题的真假特征，以及各种命题之间的真假关系。至于命题的具体内容的真假，是由实践来检验的。

二，命题的分类

命题的种类很多。（1）根据命题中是否包含有“必然”、“可能”等模态词，将命题划分为模态命题和非模态命题。（2）根据非模态命题中是否包含有其他命题，将非模态命题划分为简单命题和复合命题。　　（3）根据断定的是对象的性质还是之间的关系，将简单命题划分为性质命题和关系命题。（4）根据复合命题中包含的联结项的不同，将复合命题划分为联言命题、选言命题、假言命题、负命题。

三，命题的结构

一个简单命题是由词项组成的，各种词项适当地搭配起来就是命题结构，或者命题形式。词项是对一个命题的内部分解的结果，命题从结构上可以分解为逻辑常项和逻辑变项，其中逻辑常项表达思维的形式，而逻辑变项表达思维的内容。不同的命题结构代表着不同的词项逻辑研究方法，一般来讲，把直言命题中命题结构对应的逻辑研究方法叫做“词项逻辑”，把关系命题中命题结构对应的逻辑研究方法叫做“关系逻辑”，而“谓词逻辑”则是对词项逻辑和关系逻辑的一种综合的逻辑研究方法。词项在不同的逻辑研究方法中有不同的称呼，在词项逻辑中，词项包括主项、谓项、联项、量项；在关系逻辑中，词项包括关系者项、关系项、量项；在谓词逻辑中，词项包括个体词、谓词、量词。三者的对应关系如图一，其中谓词逻辑和左右的词项逻辑、关系逻辑有对应关系，而词项逻辑和关系逻辑没有对应关系。

词项逻辑 | 谓词逻辑 | 关系逻辑
主项 | 个体词 | 关系者项
联项 | 谓词 | 关系项
谓项
量项 | 量词 | 量项

（图一）

在词项逻辑中，直言命题在结构中由主项、谓项、联项、量项组成。主项是表示直言命题中事物对象的概念，通常用大写字母S表示；谓项是表示直言命题中事物性质的概念，通常用大写字母P表示；联项是表示直言命题中联结主项和谓项的概念，包括肯定联项和否定联项，肯定联项为“是”，否定联项为“不是”；量项是表示直言命题中主项的数量范围的概念，包括全称量项、特称量项和单称量项，全称量项一般用“所有”、“一切”、“凡”、等表示，特称量项一般用“有些”、“某些”、“有的”等来表示，单称量项一般用“某个”、“这个”、“那个”等表示。比如“所有的人都是要死的”，这个直言命题中，主项为“人”，谓项为“要死的”，联项为“是”，量项为“所有的”。

在关系逻辑中，关系命题在结构中由关系者项、关系项、量项组成。关系者项（也称关系主项）是表示关系命题中事物对象的概念一般用符号“a”、“b”表示；关系项是表示关系命题中事物对象之间的关系的概念，一般用符号“R”表示；量项是表示关系命题中主项的数量范围的概念（在关系命题中，如果关系者项表示的是一个或一类对象，量项可以省略）。关系逻辑的思维形式为：aRb；或R（a，b），表示a与b有R的关系。比如“有些学生很喜欢那位歌星”，这个关系命题中，“学生”（a）和“歌星”（b）是关系主项，“喜欢”是关系项（R），“有些”是量项。

在谓词逻辑中，一个简单命题（直言命题和关系命题）在结构中由个体词、谓词、量词组成。个体词是简单命题中代表事物对象的词，主要包括直言命题中的主项、关系命题中的关系者项，个体词包括个体常项和个体变项；谓词是表示个体所具有的性质或者个体与个体之间关系的词；量词是规定个体变项范围的词，包括全称量词和存在量词。【谓词逻辑暂不作为本次课程讲授的内容】


第二章 命题和判断

第二节 简单命题

一，直言命题

1，什么是直言命题（性质命题）

直言命题，又称性质命题，是指断定思维对象具有或不具有某种性质的判断，传统逻辑也把它称为直言判断。如“所有的生命都具有新陈代谢的功能”、“有些玫瑰是红色的”、“有些学生考试没有通过”（可以转化为直言命题的更标准形式为“有些学生是考试没有通过者”）等，都是直言命题。

2，直言命题的类型

直言命题的结构在上面已经讲了，这里只做一补充，一般把主项S和谓项P称为词项变项（逻辑变项），而把联项和量项称为词项常项（逻辑常项）。直言命题的类型主要由词项常项来决定。根据直言命题的联项，直言命题可以分为肯定命题和否定命题；根据直言命题的量项，直言命题可以分为全称命题、特称命题和简单命题。把联项和量项结合，直言命题可以分为以下六种类型：

全称肯定命题（A）：所有S是P。

全称否定命题（E）：所有S不是P。

特称肯定命题（I）：有些S是P。

特称否定命题（O）：有些S不是P。

单称肯定命题（a）：某个S是P。

单称否定命题（e）：某个S不是P。

逻辑上通常用A、E、I、O、a、e来分别指称上述各种直言命题，相应的命题形式为：SAP、SEP、SIP、SOP、SaP、SeP。

以上讲的是直言命题的标准形式，在日常语言中，直言命题的表达形式并不那么规范，存在着大量的非标准形式，这需要我们在研究中把它们辨认为标准形式。如：“初恋不都是苦涩的”（SOP）、“没有无因之果”（SAP）、“不是所有的人都自私”（SOP）等语句可以转化为直言命题的标准形式为“有些初恋不是苦涩的”、“所有结果都是有原因的”、“有些人不是自私的”。

3，直言命题(A、E、I、O)之间的真假关系

直言命题的真假主要由其主项和谓项之间的关系来确定。根据前面讲过的概念的五种关系，主项和谓项之间的关系无非就是概念的五种关系，即全同关系、真包含于关系、真包含关系、交叉关系和全异关系，他们决定了一个具体的直言命题的真假属性。以下图二表示出当主项A和谓项S分别处于不同关系时直言命题的六种形式的真假状况。

关系→ | 全同关系 | 真包含于关系 | 真包含 关系 | 交叉关系 | 全异关系
判断↓
SAP | 真 | 真 | 假 | 假 | 假
SEP | 假 | 假 | 假 | 假 | 真
SIP | 真 | 真 | 真 | 真 | 假
SOP | 假 | 假 | 真 | 真 | 真
SaP | 真 | 真 | 真 | 真 | 假
SeP | 假 | 假 | 真 | 真 | 真

（图二）

4，直言命题(A、E、I、O)之间的对当关系和逻辑方阵

具有相同主项和谓项的直言命题之间的关系叫做对当关系。在主谓项相同的情况下，即逻辑变项不变的情况下，研究逻辑常项所代表的思维形式之间的关系，那么六种直言命题两两相配可以形成15种组合状态，而这15种组合状态可以有规律的形成四种对当关系，即矛盾关系、反对关系、下反对关系和从属关系。下面分别论述。

⑴矛盾关系（AO、EI、ae）

记忆：对立联项［全与特，单与单］，［全肯与特否，全否与特肯，单肯与否单］

全称命题和特称命题的对立联项之间，单称命题的对立联项之间，形成了矛盾关系，即SAP和SOP、SEP和SIP、SaP和SeP之间形成矛盾关系。所谓矛盾关系就时它们二者必然是一真一假，不可能同真同假，即其中一个命题真时，另一个命题必假。

举例：假如“我们班所有的同学都捐了款（SAP）”为真，则“我们班的有些同学没有捐款（SOP）”为假；假如“我们班的所有同学都没有捐款（SEP）”为真，则“我们班的有些同学捐了款（SIP）”为假；假如“我们班的这个同学捐了款（SaP）”为真，则“我们的这个同学没有捐款（SeP）”为假。

⑵反对关系（AE、Ae、Ea）

记忆：对立联项［全与全，全与单］，［全肯与全否，全肯与单否，全否与单肯］

全称命题的对立联项之间，全称命题与单称命题的对立联项之间，形成了反对关系，即SAP和 SEP、SAP和SeP、SEP和SaP之间形成反对关系。所谓反对关系就是它们之间不能同真（必有一假），但能同假，即其中一个命题真时，另一个命题必假，但其中一个命题假时，另一个命题真假不能判断。

举例：假如“我们班的所有同学都捐了款（SAP）”为真，则“我们班的所有同学都没有捐款（SEP）”为假，“我们的这个同学没有捐款（SeP）”也为假；而反过来假如“我们班的所有同学都捐了款（SAP）”为假，则“我们班的所有同学都没有捐款（SEP）”和“我们的这个同学没有捐款（SeP）”不能断定真假，即它们可能真也可能假。其它SEP和SaP之间的关系也是如此。

⑶下反对关系（IO、Ie、Oa）

记忆：对立联项［特与特，特与单］，［特肯与特否，特肯与单否，特否与单肯］

特称命题的对立联项之间，特称命题与单称命题的对立联项之间，形成了下反对关系，即SIP和SOP、SIP和SeP、SOP和SaP之间形成了下反对关系。所谓的下反对关系就是它们之间不能同假（必有一真），但能同真，即其中一个命题假时，另一个命题必真，但其中一个命题真时，另一个命题真假不能判断。

举例：假如“我们班的有些同学捐了款（SIP）”为假，那么“我们班的所有同学都没有捐款（SEP）”为真（EI为矛盾关系），则“我们班的有些同学没有捐款（SOP）”为真，“我们的这个同学没有捐款（SeP）”也为真。反过来，假如“我们班的有些同学捐了款（SIP）”为真，则“我们班的有些同学没有捐款（SOP）”和“我们的这个同学没有捐款（SeP）”不能判断真假。

⑷从属关系（AI、Aa、Ia、EO、Ee、Oe、）

记忆：对立量项［肯与肯，否与否］，［全肯与特肯，全肯与单肯，特肯与单肯，全否与特否，全否与单否，特否与单否］

肯定命题的对立量项之间和否定命题对立量项之间，共有6种组合，形成了从属关系（也有教材中称为差等关系），SAP和SIP、SAP和SaP、SIP和SaP以及SEP和SOP、SEP和SeP、SOP和SeP之间形成了从属关系。具有从属关系的两个命题之间可以同真，也可以同假。可以同真是说当全称命题真时，特称命题一定真，而当特称命题真时，全称命题真假不能判断；可以同假是说，当特称命题假时，全称命题一定假，而当全称命题假时，特称命题真假不能判断。这条规律也可以表达为，在真的方面，特称命题从属于全称命题，在假的方面，全称命题从属于特称命题。

举例：假如“我们班的所有同学都捐了款（SAP）”为真，则“我们班的有些同学捐了款（SIP）”为真；而反过来假如“我们班的所有同学都捐了款（SAP）”为假，则“我们班的有些同学捐了款（SIP）”不能判断真假，因为很有可能我们班的同学都没有捐款。再假如“我们班的有些同学捐了款（SIP）”为假，则“我们班的所有同学都捐了款（SAP）”为假；反过来假如“我们班的有些同学捐了款（SIP）”为真，则“我们班的所有同学都捐了款（SAP）”不能判断真假。

⑸小结：对当关系推理

直言命题的对当关系可以帮助我们根据一个命题的真假判断另一个命题的真假，是逻辑推理的有效工具之一。根据以上四种对当关系，直言命题可以形成以下推理过程。

矛盾关系中，一个为真可以推出另一个为假，一个为假可以推出另一个为真。

反对关系中，一个为真，另一个必假，而一个为假不能推断另一个的真假。

下反对关系中，一个为假，另一个必真，而一个为真不能推断另一个的真假。

从属关系分为两种情况：

A全称和特称（全称和单称）：全称为真，则特称为真，全称为假，特称真假不能判断；特称为真，全称真假不能判断，特称为假，则全称必然为假。（全称和单称的关系与全称和特称的关系相同）

B特称和单称：特称真，单称真假不能判断，特称假，单称真假不能判断；单称真，特称必然真，单称假，特称真假不能判断。

5，直言命题(A、E、I、O)主项、谓项的周延性

词项的周延性是指对直言命题的主项和谓项外延数量的断定情况，如果命题中断定了主项或谓项的全部外延，那么这个主项或谓项就是周延的，如果没有断定主项或谓项的全部外延，那么这个主项或谓项就是不周延的。一般来讲，全称命题的主项都周延；特称命题的主项都不周延；否定命题的谓项都周延；肯定命题的谓项都不周延。例如：

⑴所有的网大学生都是中华儿女。

⑵所有的中共邪党党员都不是中华儿女。

⑶有些网大学生来自大陆。

⑷有些网大学生不是来自大陆。

上例⑴中，主项“网大学生”是周延的，因为该命题对网大学生的全部外延做了断定，但谓项“中华儿女”是不周延的，因为该命题并没有对“中华儿女”的外延做出断定，没有说“所有学生是所有中华儿女”。⑵中主项“中共邪党党员”和谓项“中华儿女”都是周延的，因为该命题对主项和谓项的全部外延都做出了断定，因为中共邪党党员不是中华儿女，必然隐含着不是所有的中华儿女，如果只是不是一部分中华儿女，那么这个命题就不成立了。可见，否定命题中的谓项必然是周延的。⑶中的主项和谓项都不周延。⑷中的主项不周延，而谓项周延。

词项的周延主要在后面讲的推理过程中使用。

习题：

1，请列举一个不是命题的陈述句。

2，案例分析：鲍西娅有金银铅三只盒子，其中只有一个盒子中放着鲍西娅的肖像，现在有三个求婚者来猜肖像在哪里。金盒子上写“肖像不在此盒中”，银盒子上写“肖像在铅盒中”，铅盒子上写“肖像不在此盒中”。鲍西娅说：“上述三句话，最多只有一句是真的。”请应用对当关系推理分析一下肖像到底在哪个盒子中。请写出推理过程。（矛盾关系应用题）

解析：设金盒子上的话为命题一，银盒子上的话为命题二，铅盒子上的话为命题三。命题三和命题二互相矛盾（为什么互相矛盾呢？因为肖像要么在铅盒子中，要么不在铅盒子中，只有两种结果），因此二者必然一真一假。根据以上案例的提示最多只有一句话是真的，可知，真话在二三命题中，命题一为假。命题一为“肖像不在此盒子（金）中”，它是假话，那么肖像当然在金盒子中。

3，案例分析：设以下三句话中只有一句是假的，请问：甲公司经理是不是否懂得计算机？请写出推理过程。（反对关系应用题）

⑴甲公司所有成员都懂计算机；

⑵甲公司的小王不懂计算机；

⑶甲公司所有员工都不懂计算机。

解析方法一：⑴和⑶是反对关系，其中必有一假，而案例中提示三个命题只有一个假的，可知命题⑵一定是真的。⑵与⑴也是反对关系，其中必有一假，则⑴必然是假的。那么，⑶必然是真的。最后得出甲公司经理不懂计算机。

解析方法二：⑵与⑴是反对关系，其中必有一假，而案例中提示三个命题只有一个假的，可知命题⑶一定是真的。那么直接推出经理也不懂计算机。

4，案例分析：设以下三句话中只有一句是真的，请问：甲公司经理是不是否懂得计算机？请写出推理过程。

⑴甲公司所有成员都懂计算机；

⑵甲公司的小王不懂计算机；

⑶甲公司所有员工都不懂计算机。

解析：⑵和⑶是从属关系，如果同真，那么与案例提示只有一个真命题不符合，因为⑶为真那么⑵必为真，因此⑶肯定是假命题。那么⑵⑶可以同假，或者一真一假。假如⑵⑶同假，则⑴为真；假如⑵⑶一真一假，则⑵为真，⑴为假。因此，⑴可能为真也可能为假，那么经理懂不懂计算机不能判断。

5，请判断一下命题中主谓项的周延性。

⑴所有的犯罪行为都是违法行为。

    ⑵所有的贪污罪都不是过失犯罪。

    ⑶有些学生是中共邪党党员。

    ⑷有些学生不是中共邪党党员

解析：略

补充6，案例分析：设以下三句话中只有一句是真的，请问：甲公司经理是不是否懂得计算机？请写出推理过程。（下反对关系应用题）

⑴甲公司有些成员懂计算机；

⑵甲公司的小王不懂计算机；

⑶甲公司有些员工不懂计算机。

解析方法一：⑴和⑶是下反对关系，其中必有一真，那么⑵是假的，⑵和⑴也是下反对关系，必有一真，则⑴是真的，推出经理懂计算机。

解析方法二：⑴和⑵是下反对关系，必有一真，那么⑶是假，⑴和⑶也是下反对关系，其中必有一真，那么⑴是真的，推出经理懂计算机。

二，关系命题

   1，关系命题的定义以及结构

关系命题是断定事物与事物之间关系的一种命题，它也是一种简单命题。例如：慕容患和严仁勇是网大同学；刘少奇的罪恶小于毛泽东的罪恶；他很信任他的妻子；4加5等于9。

关系命题的结构如下：

⑴关系者项：也称关系主项，是表示关系命题中事物对象的概念，一般用符号“a”、“b”表示。

⑵关系项：表示关系命题中事物对象之间的关系的概念，一般用符号“R”表示。

⑶量项：表示关系命题中主项的数量范围的概念（在关系命题中，如果关系者项表示的是一个或一类对象，量项可以省略）。

关系命题的思维形式为：aRb；或R（a，b）。（a与b有R关系）

    2，关系的性质

⑴关系的对称性

关系的对称性主要研究关系项（R）对关系者项（a、b）所形成的对称关系的情况，即当事物a与b具有某种关系R时，b与a是否也具有这种关系R。分为三种情况：

①对称关系

如果a R b真，那么b R a也一定真，在这种情况下，关系“R”就是对称的。

表示对称关系的关系项一般有“是同学”、“是朋友”、“等于”、“相邻居”、“相矛盾”、“离……不远”等等。如“张三和李四是朋友”为真，则“李四和张三是朋友”也真。

    ②反对称关系

如果a R b真，那么b R a一定假，在这种情况下，关系“R”就是反对称的。

表示反对称关系的关系项一般有“大于”、“小于”、“多于”、“少于”、“重于”、“战胜”、“在……之上”、“在……左边”、“比……优秀”、“以南”、“以北”等等。如“5大于4”为真，则“4大于5为假”

    ③非对称关系

   如果a R b真，那么b R a可能真也可能假，在这种情况下，关系“R”就是非对称的。表示非对称关系的关系项一般有“喜欢”、“佩服”、“支持”、“了解”、“信任”、“爱”等等。如“张三了解李四”为真，而“李四了解张三”可能真也可能假。

⑵关系的传递性

关系的传递性主要研究关系项（R）对关系者项（a、b、c……）所形成的传递关系的情况，即当事物a与b具有某种关系R，并且b与c也具有这种关系R，那么，a与c是否也具有这种关系R。分为三种情况：

    ①传递关系

如果a R b真，并且b R c也真，那么a R c必真，在这种情况下，关系“R”是传递的。表示传递关系的关系项一般有“大于”、“在前”、“在后”、“相等”、“平行”、“在……以南”、“在……左边”等。如“直线a平行于直线b”为真，并且“直线b平行于直线c”为真，那么“直线a平行于直线c”也为真。

②反传递关系

   如果a R b真，并且b R c也真，那么a R c必假，在这种情况下，关系“R”是反传递的。表示反传递关系的关系项一般有“父子”、“母女”、“比……长两岁”、“迟一个月”等。如“张三比李四长两岁”为真，并且“李四比王五长两岁为真”，那么“张三比王五长两岁”必为假。

    ③非传递关系

如果a R b真，并且b R c也真，那么a R c有可能为真，也有可能为假，在这种情况下，关系“R”是非传递的。表示非传递关系的关系项一般有“离……很近”、“战胜”、“认识”、“喜欢”、“帮助”、“相邻”等。如“张三认识李四”为真，并且“李四认识王五”为真，那么“张三认识王五”可真也可假。


第二章 命题和判断

第三节 复合命题

所谓复合命题就是由若干简单命题联结而成的命题，其表现形式相当于语句中的复句。根据复合命题中联结项的不同，复合命题可以分为联言命题、选言命题、假言命题和负命题等几种，复合命题的逻辑性质是由联结项所决定的。

    学习复合命题的方法

    ①必须弄清楚各种复合命题的逻辑联结项（或逻辑联结词）的涵义。

    ②充分利用真值表，即充分利用真值表对各种复合命题的逻辑联结项的定义作用和对复合命题真值情况的判定作用。

③必须弄清楚复合命题的逻辑涵义与自然语言的意义上的联系。

一，联言命题

1，联言命题的定义

联言命题就是断定几种事物的情况同时存在（同时为真）的复合命题。联言命题在结构上由联言支和联结项组成，一个联言命题可以分解为两个（或者几个）独立的直言命题，这些独立命题就是联言支。如“张三和李四都受到了表彰”可以分解为“张三受到了表彰”和“李四受到了表彰”两个独立的直言命题。

2，联言命题的结构

联言支（两个或两个以上），一般用符号p、q表示（这里讲的是二支联言命题的情况）；

    联结项，用逻辑符号“∧”（读作“合取”）表示。

    联结项的语言形式有：“并且（和）”、“既……又”、“……而且……”、“不但……而且”、“虽然……但是”等。

    一个二支联言命题的逻辑形式为：

    语言表达式：p并且q

符号表达式：p∧q（“∧”读做合取；“p∧q”读做p合取q）

比如“张三和李四都受到了表彰”这个命题中，“张三受到了表彰”为p，“李四受到了表彰”为q，那么原命题的逻辑形式就是[“张三受到了表彰”并且“李四受到了表彰”]。

    3，联言命题的真假值

根据联言命题的逻辑性质或特征：只有当全部联言支所断定的情况都存在时，联言命题才是真的。也即：当且仅当联言支全真时，联言命题为真。真假情况共有2的n次方。联言命题p∧q的真假值和支命题p、q的真假值的关系，可以用如下真值表来表示（图三）：

p | q | p∧q
真 | 真 | 真
真 | 假 | 假
假 | 真 | 假
假 | 假 | 假

（图三）

4，联言命题和关系命题的区别

联言命题可以分解为两个（或多个）简单命题（直言命题或者关系命题），而关系命题本身就是简单命题不可能再分解。比如“张三和李四是好朋友”不能分解为“张四是好朋友”并且“李四是好朋友”，但“张三和李四都是优秀毕业生”可以分解为“张三是优秀毕业生”并且“李四是优秀毕业生”。因此，前者是关系命题，而后者是联言命题。再如“张三和李四既是好朋友，又是同班同学”，这是一个由两个关系命题组合而成的联言命题，可以分解为“张三和李四是好朋友”并且“张三和李四是同班同学”。

    【思考题1】某地有两种人，分别是说谎族和诚实族。诚实族总说真话，说谎族总说假话。一天，有旅行者路过此地，看见此地的甲乙二人。他向甲提出一个问题：“你俩中有诚实族吗？”甲回答说：“没有。”旅行者想了想，就正确地推出了结论。问：以下哪项是旅行者做出的判断？并写出推理过程。

     A．甲是诚实族，乙是说谎族。

     B．甲乙都是诚实族。

     C．甲乙都是说谎族。

     D．甲是说谎族，乙是诚实族。

     E．甲乙所属均不明。

二，选言命题

    1，选言命题的定义

选言命题就是断定几种事物的情况中至少有一种情况存在的命题。选言命题在结构上由选言支和联结项构成，一个选言命题可以分解为两个（或者几个）独立的直言命题，这些独立命题就是选言支。例如“他或者犯了逻辑错误，或者犯了常识错误”，可以分解为“他犯了逻辑错误”和“他犯了常识错误”两个独立的直言命题。

2，选言命题的结构

选言支（两个或两个以上）一般用符号p、q表示（这里讲的是二支选言命题的情况）；

联结项，用逻辑符号“∨”（读做析取）来表示。

联结项的语言形式有“或者”、“要么”等。

3，选言命题的种类

根据选言支断定的事物情况是不是可以共同存在（是否可以同真），选言命题又可以区分为两种：相容选言命题；不相容选言命题。

3．1相容选言命题

⑴定义：相容选言命题是断定选言支中至少有一个为真，并且可同为真的选言命题。例如“他失业了，或者是因为他不努力工作，或者是因为他和老板闹矛盾。”

⑵逻辑形式和语言形式：

语言表达式：p或者q

符号表达式： p∨q（“∨”读做析取；“p∨q”读做p析取q）

联结项的语言形式有“或者……或者……”、“可能……可能……”、“……或……”、“也许……也许……”、“要么……要么……”等。

⑶相容选言命题的真假

当全部选言支所断定的情况至少有一个存在时，相容选言命题就是真的。当全部选言支都为假时，相容选言命题才是假的。相容选言命题的真值表如下（图四）：

p | q | p∨q
真 | 真 | 真
真 | 假 | 真
假 | 真 | 真
假 | 假 | 假

（图四）

3．2不相容选言命题

    ⑴定义：相容选言命题是断定选言支中有一个并且只有一个为真的选言命题。例如“瓮安少女非自然死亡的原因，要么是自杀，要么是被自杀，要么是意外事故。”

⑵逻辑形式和语言形式：

语言表达式：要么p要么q。

    符号表达式： p V q（“V”读做不相容析取，“pVq”读做p不相容析取q）。

联结词有：“要么……要么……（二者不可得兼）”、“不是……就是……”、“或者……或者……（二者不可得兼）”、“……或……二者不可得兼”等。

    ⑶不相容选言命题的真假

    首先不相容选言命题的逻辑性质或特征是几种情况不可能同时存在，因此，它所包含的选言支不能同时为真，也不能同时为假；其次有且只有一个选言支为真，其余选言支为假时，该不相容选言命题为真；在其它任何情况下，都是假的。不相容选言命题的真值表如下（图五）：

p | q | p∨q
真 | 真 | 假
真 | 假 | 真
假 | 真 | 真
假 | 假 | 假

（图五）

    【思考题2】：骑士与姑娘的故事

某岛上的人分为两种人：骑士和无赖。骑士只说真话，无赖只说假话。而骑士又分为贵族骑士和贫穷骑士。有一位姑娘只爱贫穷的骑士。有一个骑士，只说了一句话，就使这位姑娘相信他是一位贫穷的骑士。问：这位骑士说了一句什么话？这位姑娘又是如何断定他是贫穷的骑士的？

4，运用选言命题时应注意的问题

   ⑴选言支必须穷尽

    如果选言支不穷尽，则可能遗漏惟一为真的事物情况。而如果选言支穷尽，则事物的一切情况都包括无遗，其中必有取值为真的选言支，从而保证整个选言命题为真。

  ⑵不能混淆不同类型的选言命题

对两种选言命题的区分在于：两种选言命题的逻辑根据不同，一种为“必有一真”，一种为“只有一真”。在使用中注意语言表达形式上的区别。

例如：

①“他失业了，或者是因为他不努力工作，或者是因为他和老板闹矛盾，二者必有其一。”

②“他大学毕业后，或者去了青岛了，或者去了南京，二者必有其一。”

①中两个支命题都可以为真，也可以一真一假，是相容选言命题，而②中两个支命题必然一真一假，不可能同真，因此②是不相容选言命题。以上两个例子的句子的逻辑结构都是相同的，都是“或者……或者……二者必有其一”，但是表达的逻辑值（真假情况）却不相同，由此可知，相容选言命题和不相容选言命题的区分有时并不在于句子的逻辑结构，而在于支命题之间的事实上的相容和不相容的关系，这需要我们在应用中仔细辨别。

    ⑶不能混淆相容选言命题与联言命题

    联言命题和相容选言命题由于支命题都具有相容性，须防止相互混淆。区分联言命题和相容选言命题的方法：首先看联结词，其次看复合命题与支命题之间的真假关系（联言命题必须在所有的支命题都为真时才成立，而相容选言命题只要有一个支命题为真就可以成立）。

例如：

①“他失业了，或者是因为他不努力工作，或者是因为他和老板闹矛盾。”

②“他失业了，因为他不但不努力工作，而且还和老板闹矛盾。”

①中两个支命题都可以为真，也可以一真一假，是相容选言命题，而②中两个支命题都为真，从命题者的判断来看，不可以一真一假，因此是联言命题。

    三，假言命题

    1，假言命题的定义

    假言命题，又称条件命题，是指断定某一事物情况的存在是另一事物情况存在的条件的命题。例如“如果他是网大学生，那么他一定会使用电脑”、“只有中共解体了，中国人民才能过上好日子”、“一个三角形等角，当且仅当它等边”。

2，假言命题特征

假言命题的逻辑性质为：一种事物情况是另一种事物情况存在的的条件。

    3，假言命题的结构式（两部分）

    （1）假言支。两个：一个作为原因的称为“前件”；一个作为结果的称为“后件”。）

    （2）联结项。通常用“如果……那么……”、“只有……才……”、“当且仅当……则……”表示。

4．假言命题的种类

    根据假言命题所断定的前件是后件的不同条件，假言命题又可以区分为三种：充分条件假言命题；必要条件假言命题；充分必要条件假言命题。

    4．1充分条件假言命题

⑴定义

充分条件假言命题就是断定一事物情况的存在是另一事物情况存在的充分条件的假言命题。例如“如果中共不停止迫害法轮功，那么天灾就会不断。”，“假如明天下雨，那么地面一定会湿。”

    ⑵逻辑性质

    所谓充分条件是指：设有事物情况p和事物情况q，如果有p（真），则必有q（真）；而如果没有p（假），则q的情况（真假）不能断定（即可能有q，也可能没有q）。这种情况下，p就是q的充分条件。可以简单的概括为“p对q有之必然，无之不能断定”。

    ⑶逻辑形式

    语言表达式：如果p，那么q。（假如p，就q；只要p，就q；倘若p，则q；既然p，就q。）

    符号表达式：p→q （“→”读做蕴涵；p→q读做p蕴涵q）

⑷充分条件假言命题的真假情况

要确定一个充分条件假言命题的真假，主要看前件是不是后件的充分条件，即是不是有前件必有后件，如果有前件却没有后件，那么这个充分条件假言命题就是假的，而其余的情况都是真的。充分条件假言命题的真值表如下（图六）：

p | q | p→q
真 | 真 | 真
真 | 假 | 假
假 | 真 | 真
假 | 假 | 真

（图六）

这里比较好理解的是前两项，即前件真，后件真，那么原命题真；前件真，后件假，则原命题假。不好理解的是后面两项，当前件假时，后件无论真假，原命题都为真。因为充分条件的假言命题主要研究当有前件时（前件真）后件的表现情况，从而判断命题的真假，而当没有前件时（前件假），这个原命题就不可能被推翻，也就是不可能是假的。比如，张三对李四说：“假如明天不下雨的话（p），那么我就来学校踢球（q）。”这个充分条件假言命题（是一个承诺），它的真假在于“当明天不下雨时（p为真），张三会不会来学校踢球（q是真还是假）？”而当明天下雨时（p为假），不管张三来不来学校踢球（即不管q为真为假）都没有与原命题所表达的意思相冲突（张三没有违背承诺）。我们把这个命题的各种情况分解开来如下：

A，第二天没有下雨（p为真），张三去学校踢球了（q为真）。

B，第二天没有下雨（p为真），张三没有去学校踢球（q为假）。

C，第二天下雨了（p为假），张三去学校踢球了（q为真）。

D，第二天下雨了（p为假），张三没有去学校踢球（q为假）。

那么，对于原命题所表达的含义的真假有影响的只是AB两种情况，而CD对原命题的真假没有影响，因此无论CD的q是真是假，原命题都是真的。

    4．2必要条件假言命题

    ⑴定义

    必要条件假言命题就是断定一事物情况的存在是另一事物情况存在的必要条件的假言命题。例如“只有年满18岁，才有选举权。”、“除非放弃对中共改良的期望，彻底抛弃中共，否则中华民族的灾难就不会结束”。

    ⑵逻辑性质

    所谓必要条件是指：设有事物情况p和事物情况q，如果没有p（假），必然没有q（假）；而如果有p（真），则q的情况（真假）不能断定（即可能有q，也可能没有q）。在这种情况下，p就是q的必要条件。可以简单的概括为“p对q无之必不然，有之不能断定”。

    ⑶逻辑形式

    语言表达式：只有p，才q。（除非p，否则不q；没有p，就没有q；不p，不q；除非p，才q。）

    符号表达式：p←q （←读做逆（反）蕴涵；p←q读做p逆蕴涵q）

    ⑷必要条件假言命题的真假情况

要确定一个必要条件假言命题的真假，主要看前件是不是后件的必要条件，即是不是没有前件必没有后件，如果没有前件却有后件，那么这个必要条件假言命题就是假的，而其余的情况都是真的。必要条件假言命题的真值表如下（图七）：

p | q | p←q
真 | 真 | 真
真 | 假 | 真
假 | 真 | 假
假 | 假 | 真

（图七）

例如“只有解体中共（p），中华才会重生（q）”这个命题中：如果没有前件“解体中共”（p为假，可以表达为“假如不解体中共”），必然没有后件“中华重生”（q为假，可以表达为“中华不会重生”），因此，该命题为必要条件假言命题，可以推出“p逆蕴涵q”（p←q为真）；而如果没有前件（可以表达为“假如不解体中共”），而有后件“中华会重生”，那么，原命题就是假的。以上是没有前件的情况，假如有前件，而后件的真假是不能断定的，即解体了中共，中华会不会重生，还要看其它条件是否满足，假如人们不解体党文化，重新竖立对上天的敬畏和对道德的追求，那么中华还是不会重生。可见，解体中共是中华重生的一个必要的条件之一，而不是全部的条件。那么回到这个命题中来，前件有（p真），后件不管有没有，都没有推翻原来的命题，都不能否定解体中共是中华重生的必要条件，因此，在前件有（p真）的情况下，后件q无论真假，p←q都为真，这就是以上表格的含义。

4．3充分必要条件假言命题（简称充要条件假言命题）

    ⑴定义

    充要条件假言命题就是断定一事物情况是另一事物情况存在的充分必要条件的假言命题。如“只要解体中共，并且重新确立传统的天人关系，使人敬天畏命，重德行善，那么中华就一定会重生。”

  ⑵逻辑性质

    所谓充分条件是指：设有p和q分别为两个事物情况。如果有p，就必然有q；而如果没有p，则必然没有q。（根据等价关系，也可以反过来讲：如果有q，就必然有p；如果没有q，就必然没有p。）这样，p就是q的充分必要条件（同时q也是p的充分必要条件）。可以简单概括为“有之必然，无之必不然。”

    ⑶逻辑形式

    语言表达式：当且仅当p，则q。（如果……而且……只有……才，只要……并且……那么就一定。）

    符号表达式:p←→q （“←→”读做“等值于”；p←→q读做p等值于q）

⑷充要条件假言命题的真假情况

要确定一个充要条件假言命题的真假情况，主要看前件是不是后件的充要条件，即有前件是不是必有后件，无前件是不是必无后件。当有前件却无后件，或者无前件却有后件时，这个命题就是假的。充要条件的真值表如下（图八）：

p | q | p←→q
真 | 真 | 真
真 | 假 | 假
假 | 真 | 假
假 | 假 | 真

（图八）

4．4充分条件和必要条件之间的关系

充分条件和必要条件之间存在着紧密的关系，如下：

如果p是q的充分条件，那么q就是p的必要条件；

如果p是q的必要条件，那么q就是p的充分条件。

因此，

“如果p，那么q”等值于“只有q，才p”

“只有p，才q”等值于“如果q，那么p”

    充分条件和必要条件的命题可以相互转化，如“如果天下雨，那么地面一定会湿”，这是一个充分条件假言命题，可以转化为“除非地面湿了，否则天就没有下雨”，或者“只有地面湿了，才能意味着天下过雨”，或者“地面没有湿，所以天没有下雨”。

    四，负命题

   1，什么是负命题

    ⑴定义

    负命题是否定某个命题的命题，又叫做命题的否定，是一种比较特殊的复合命题。设原命题为p，则该命题的负命题为“并非p”。例如，原命题为“一切水生动物都用鳃呼吸”，其负命题为“并非一切水中生动物都是用鳃呼吸的”。

    ⑵逻辑性质：是对某一个命题的否定。

    ⑶结构（两部分）

    A支命题。负命题中被否定的命题。也就是原命题。

    B联结项。“并非……”、“并不是……”、“……是假的”等表示。也可用逻辑符号“﹁”（读作“非”）表示。

    ⑷逻辑形式

    语言表达式：并非p。“并非……”、“并不是……”、“……是假的”等表示。

    逻辑表达式：﹁ p（“﹁”读做并非）

  ⑸负命题的真假情况

    原命题与负命题是矛盾关系，互为真假。一个负命题是真的，当且仅当它的原命题为假，而一个负命题是假的，当且仅当它的原命题为真。

注意，负命题不等于直言命题中的否定命题，而是直言命题的矛盾关系命题，比如“我们班所有的同学都通过了考试”（SAP），它的负命题不是“我们班的所有同学都没有通过考试”（SEP），而是“并非我们班的所有同学都通过了考试”，它相当于“我们班有些同学没有通过考试”（SOP）

2,负命题的种类

     负命题分为：简单命题的负命题和复合命题的负命题。

2．1简单命题的负命题及其等值命题

     主要介绍单称命题、全称命题和特称命题这三种直言命题的负命题及其等值命题。

    （1）单称命题的负命题及其等值命题

     并非这个S是P ，并非这个S不是P

     因为单称肯定命题与它的负命题是矛盾关系，而单称肯定命题与单称否定命题也是矛盾关系，所以，单称肯定命题的负命题和单称否定命题是等值的。

    （2）全称命题的负命题及其等值命题

     ①SAP与SOP是矛盾关系，故其负命题“并非SAP”等值于SOP。即： ﹁SAP←→SOP

     ②SEP与SIP是矛盾关系，故其负命题“并非SEP”等值于SIP。即： ﹁SEP←→SIP

     (3)特称命题的负命题及其等值命题

     ①SIP与SEP是矛盾关系，故其负命题“并非SIP”等值于SEP。即： ﹁SIP←→SEP

     ②SOP与SAP是矛盾关系，故其负命题“并非SOP”等值于SAP。即： ﹁SOP←→SAP

2．2复合命题的负命题及其等值命题

（1）联言命题的负命题及其等值命题

     在联言命题中，只要有一个联言支为假，那么这个命题就是假的。因此，与联言命题的负命题相等值的命题，应该是一个相应的选言命题。即：﹁（p∧q）←→﹁p∨﹁q

     例如“并非[张三和李四都要受到表彰]”，等值于“或者张三不受到表彰，或者李四不受到表彰”。

再如“[并非他既是科学家又是教授]”，等值于“或者他不是科学家，或者他不是教授”。

（2）选言命题的负命题及其等值命题

     ①相容选言命题只有当所有的选言支为假时，这个命题才是假的，因此，与相容选言命题的负命题相等值的命题是一个相应的联言命题。即： ﹁（p∨q）←→﹁p∧﹁q

     例如“并非[他或者是个科学家或者是个教授]”，等值于“他既不是科学家，又不是教授”。

再如“并非[或者张三受到表彰或者李四受到表彰]”，等值于“既不是张三受到表彰，也不是李四受到表彰”。

     ②不相容选言命题有且只有一个选言支为真时，这个命题才是真的，其它情况之下都是假的。因此，与不相容选言命题的负命题相等值的命题是一个相应的选言命题。 即：﹁（p∨q）←→（p∧q）∨（﹁p∧﹁q）

     例如“并非[他毕业后要么去了青岛，要么去了南京]”等值于“他毕业后既去了青岛又去了南京，或者他毕业后既没有去青岛也没有去南京”。

再如“并非[你要么留下，要么离开]”等值于“你既不要离开又不要留下或者你既离开又留下”。当然在这个例子中，原命题必然是真命题（或者离开或者留下二者肯定一真一假），而负命题必然是假命题。

  （3）假言命题的负命题及其等值命题

     ①充分条件假言命题只有当前件真，后件假时，它才是假的，其它情况下都是真的。因此，与充分条件假言命题的负命题相等值的命题是一个相应的联言命题“p并且非q”。即： ﹁（p→q）←→p∧﹁q

     例如“并非[如果下雨了，路面就湿]”，等值于“下雨了，但是路面没有湿”。

再如“并非[只要付出了，就会有收获]”等值于“付出了，但是没有收获”。

     ②必要条件假言命题只有当前件假，后件真时，它才是假的。因此，与必要条件假言命题的负命题相等值的命题是一个相应的联言命题“非p并且q”。即：﹁（p←q）←→﹁p∧q

     例如“并非[只有努力学习，才能考上大学]”，等值于“不努力学习，也能考上了学”。

再如“并非[只有违法了，才会被审判]”，等值于“没有违反，也会被审判”。

     ③充分必要条件假言命题在前、后件同真或同假时，它才是真的。充分必要条件假言命题只有在前、后件一真一假的情况下，它才是假的。因此，充分必要条件假言命题的负命题等值于一个相应的选言命题。即：﹁（p←→q）←→（p∧﹁q）∨（﹁p∧q）

     例如“并非当且仅当被告人犯罪的证据充分、确实，才可以认定被告人有罪”，等值于“虽然被告人犯罪的证据充分、确实，但没有认定被告人有罪，或者虽然被告人犯罪的证据不充分、确实，但却认定被告人有罪。”

【思考题3】

如果命题“并非[他既是科学家又是教授]”为真。那么，下述哪个命题必定为真？

    A．他是科学家但不是教授。 B．他是教授但不是科学家。

    C．他既不是科学家也不是教授。D．如果他是科学家，则他一定不是教授。

E．如果他不是科学家，那么他也一定不是教授。

【习题：】

1，以下命题哪些是关系命题？哪些是联言命题？

A他比他的夫人大五岁。

B他和他的夫人都是60年代出生的人。

C他和他夫人聚少离多。

D他不但是她的丈夫，而且也是她的同事。

E他和他夫人生了两个孩子。

F他和他夫人暑假去普陀山游玩了三天。

2，完成【思考题1】某地有两种人，分别是说谎族和诚实族。诚实族总说真话，说谎族总说假话。一天，有一旅行者路过此地，看见此地的甲乙二人。他向甲提出一个问题：“你俩中有诚实族吗？”甲回答说：“没有。”旅行者想了想就有了正确的结论。问：以下哪项是旅行者做出的判断？并写出推理过程。

     A．甲是诚实族，乙是说谎族。

     B．甲乙都是诚实族。

     C．甲乙都是说谎族。

     D．甲是说谎族，乙是诚实族。

     E．甲乙所属均不明。

3，完成【思考题2】：骑士与姑娘的故事

某岛上的人分为两种人：骑士和无赖。骑士只说真话，无赖只说假话。而骑士又分为贵族骑士和贫穷骑士。有一位姑娘只爱贫穷的骑士。有一个骑士，只说了一句话，就使这位姑娘相信他是一位贫穷的骑士。问：这位骑士说了一句什么话？这位姑娘又是如何断定他是贫穷的骑士的？

4，以下命题中，哪些是相容选言命题？哪些是不相容选言命题？

A中共要么被和平解体，要么被武装起义推翻，二者必有其一，总之它不会长久，即将会垮台。

B中共要么被军变推翻，要么被民变推翻，要么被政变推翻，三者必有其一。

C中共既是邪教，又是流氓黑社会组织。

D中共可能亡于2008年之冬，也可能亡于2009年之春。

E中共迫于形势，也许会为六四平反，也许也会为法轮功平反，但都改变不了其邪教的本质和流氓的统治手段。

F中共采用杀人与诛心并用的暴政统治方式，超越了古往今来的所有暴政统治。

5．现有命题“只有认识错误（p），才能改正错误(q)”，请问以下哪些命题与这个命题的含义相同？并写出它的逻辑形式。

A，除非认识错误，否则不能改正错误。

B，如果不认识错误，那么就不能改正错误。

C，如果改正错误，说明已经认识了错误。

D，只要认识错误，就一定能改正错误。

6，请写出以下命题（都是真命题）的负命题（必然是假命题）

A，网大所有的同学都退出了中共的组织。

B，慕容患是《大学视野》的主编。

C，有些网大同学不经常来上课。

D，有些网大同学学习很努力。

7，【思考题3】

如果命题“并非[他既是科学家又是教授]”为真。那么，下述哪个命题必定为真？

    A．他是科学家但不是教授。 B．他是教授但不是科学家。

    C．他既不是科学家也不是教授。D．如果他是科学家，则他一定不是教授。

E．如果他不是科学家，那么他也一定不是教授。


第三章 推理(纪要2-1）

授课内容：《形式逻辑》第三章——推理（上）
上课时间：2008年11月27日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到課老師：唐子
到课同学：杨尚、慕容患、李大雄、陈清扬、钱不求、張穀虛、华变天、齐学玉、張香山、曲婉蘭、张华虎
到课同學人数：11人
纪要整理：齐学玉

陈清扬: 似乎封锁比较严重，我建议咱们在线的同学先开始互动吧。我毛遂自荐试试主持一下，呵呵。

陈清扬: 形式逻辑已经开课四周了，之前我们学习了——概念，命题——概念组成​命题，命题组成推理，推理就是我们今天要学习的内容。

陈清扬: 这里是一些以前学过的知识，一为复习，二也是我们做习题中要用到的知​识，首先是集合概念：
⑶集合概念和非集合概念（整体概念和非整体概念）
有 些书中讲根据概念所反映的是否是事物的总体，把概念分为整体概念和​非整体概念，这和另外一些书中讲的集合概念和非集合概念是一回事。我们​这里采用集合 概念和非集合概念的说法。根据概念所反映的对象是否为集合体，可以把概念分为集合概念和非集合​概念。集合概念反映的对象是集合体，它是一个整体，表达整 体的属性，不​可分割开来使用；而非集合概念反映的对象是部分的代数组合，它既表达部​分的属性，也表达整体的属性，因此既可以整体使用，也可以分开来单 独使​用。

陈清扬: 集合概念与非集合概念的非加和性区别是推理中需要仔细注意的一环，否​则推理中很容易出逻辑错误，这里只是提一下，一回我想后主老师会讲到的​。

陈清扬: 下面是关于命题的一些复习：
二，命题的分类
命 题的种类很多。（1）根据命题中是否包含有“必然”、“可能”等模​态词，将命题划分为模态命题和非模态命题。（2）根据非模态命题中是否​包含有其他命 题，将非模态命题划分为简单命题和复合命题。（3）根​据断定的是对象的性质还是之间的关系，将简单命题划分为性质命题和关系​命题。（4）根据复合命题 中包含的联结项的不同，将复合命题划分为联言​命题、选言命题、假言命题、负命题。
今天我们要学习的推理部分，主要是建立在简单命题——直言命题的基础​之上。

陈 清扬: 在词项逻辑中，直言命题在结构中由主项、谓项、联项、量项组成。主项​是表示直言命题中事物对象的概念，通常用大写字母S表示；谓项是表示直​言命题中事 物性质的概念，通常用大写字母P表示；联项是表示直言命题中​联结主项和谓项的概念，包括肯定联项和否定联项，肯定联项为“是”，否​定联项为“不是”； 量项是表示直言命题中主项的数量范围的概念，包括全​称量项、特称量项和单称量项，全称量项一般用“所有”、“一切”、“凡​”、等表示，特称量项一般用 “有些”、“某些”、“有的”等来表示，单​称量项一般用“某个”、“这个”、“那个”等表示。比如“所有的人都是​要死的”，这个直言命题中，主项为“ 人”，谓项为“要死的”，联项为“​是”，量项为“所有的”。

陈清扬: 今天要学习的推理中，需要用到直言命题的上述基础知识，尤其是联项肯​定联项为“是”，否​定联项为“不是”以及量项包括全​称量项、特称量​项和单称量项在推理变换中（换质、换位法）的关系，使我们尤其要注意的​。

齐学玉: 是的，还有周延这个概念，也得弄清楚，这些都是推理的前提。

陈清扬: 下面我们简单看一下对当关系，也是我们进行推理变换的重要依据。
具 有相同主项和谓项的直言命题之间的关系叫做对当关系。在主谓项相同​的情况下，即逻辑变项不变的情况下，研究逻辑常项所代表的思维形式之间​的关系，那么 六种直言命题两两相配可以形成15种组合状态，而这15种​组合状态可以有规律的形成四种对当关系，即矛盾关系、反对关系、下反对​关系和从属关系。

陈清扬: 我们今天要用到的对当关系，大多集中在前三种矛盾关系（必然是一真一​假，不可能同真同假）、反对关系（不能同真（必有一假），但能同假）、​下反对​关系不能同假（必有一真），但能同真。

张华虎: 前一段知识没消化好，今天的讲义读起来都困难。谢谢清扬、学玉帮助温​习。

陈清扬: 虽然习题中也用到了从属关系，但是前三种对当关系，我们要仔细掌握。

齐学玉: 这些基本知识就是数学中的公式定理，是做题的前提。

陈清扬: 因为对当关系是直接衔接我们今天课程的层面，所以再重点复习以下：
直言命题可以形成以下推理过程。
矛盾关系中，一个为真可以推出另一个为假，一个为假可以推出另一个为​真。
反对关系中，一个为真，另一个必假，而一个为假不能推断另一个的真假​。
下反对关系中，一个为假，另一个必真，而一个为真不能推断另一个的真​假。

陈清扬: 还有一个非常重要的概念，学玉刚才已经提到了，就是：
词项的周延性是指对直言命题的主项和谓项外延数量的断定情况。
如 果命题中断定了主项或谓项的全部外延，那么这个主项或谓项就是周延​的，如果没有断定主项或谓项的全部外延，那么这个主项或谓项就是不周延​的。一般来 讲，全称命题的主项都周延；特称命题的主项都不周延；否定命​题的谓项都周延；肯定命题的谓项都不周延。这个概念也是我们一会在习题中要多次使用的，同学 们如果理解不好，就​先把黑体字部分记下来——并不多，我们在习题中会具体用到这二部分，到​时候配合习题会比较好理解。

齐学玉: 清扬，来的同学太少，咱们别推进了，今天就复习一下学过的知识吧。

陈清扬: 好，呵呵。

陈清扬: 后主老师的讲义《命题》部分后半部分主要讲的是关系命题、复合命题，​跟这次课关系不是很大，所以不再详细复习了。按照学玉所说，重点复习直​言命题，以为下次课作准备。

唐子: 你们学的概念和判断的知识已经有很好的基础了，不过不要陷进去，成为​逻辑知识的奴隶，像西方经院哲学家那样。

陈清扬: 下面我们重点复习一下直言命题，是我们下次课推理的主要基础，也是三​段论的构成要素。

陈清扬: 我这里给出直言命题的6种类型符号表示，请同学们给出他们的名称：AEIOae

齐学玉: A全肯，​E全否，I特肯，O特否，a单肯，e单否。

李大雄: 全称肯定命题（A）：所有S是P。
全称否定命题（E）：所有S不是P。
特称肯定命题（I）：有些S是P。
特称否定命题（O）：有些S不是P。
单称肯定命题（a）：某个S是P。
单称否定命题（e）：某个S不是P。

陈清扬: 这些名称本身不难记，但是这些命题的真假能够推理出其他命题的真假么​？如果能够，是不是有什么规律呢？
答案当然是肯定的，这个规律就叫做对当关系。

陈清扬: 这6种类型的命题互相之间的关系存在着一个逻辑表，这个表本身并不难​推，但却是掌握直言命题的基础，如果能够自己把这个表推离出来，应该就​会记得很深刻，所以我想今天我跟大家一块把这个表推理一下。

陈清扬: 先通过一个具体例子来说明：
如果“全称肯定命题（A）：所有S是P”为真，那么能够得出其他5种​命题的真假么？如果能够，结论是什么？
​E全否，I特肯，O特否，a单肯，e单否
请同学们依次给出这5个命题的真假，或是不确定。

陈清扬: 换句话说，问题就是：
如果A为真：则E全否，I特肯，O特否，a单肯，e单否是真还是假？

陈清扬: 我们用下表来表示：
        Ａ　　Ｅ　　Ｉ　　Ｏ　　ａ　　ｅ
Ａ为真　真　　假　　真　　假　　真　　假

陈清扬: 这是一个例子，那么下面我提出的问题是：
如果Ａ为假，那么E全否，I特肯，O特否，a单肯，e单否是真还是假​？

李后主: 大家好！

各位同学：老师好！

李后主: 好吧，我们把今天的内容简单进行一下吧！

李后主: 前面讲过的直言命题的对当关系是我们今天要用到的推理的一个部分。就是对当关系推理。这比较简单，只要把前面的内容掌握了，这个推理也就掌握了。

李后主: 我们直接做做习题加深理解。

李后主: 【思考题1】如果“有的国家不存在宗教和信仰”（SOP）是假的（﹁​SOP），可推出几种结果？”

陈清扬: ﹁SOP→SIP（下反）有的国家存在宗教和信仰。
﹁SOP→SAP（矛盾）所有国家都存在宗教和信仰。
﹁SOP→﹁SEP（从属）并非所有国家都不存在宗教和信仰。

李后主: 矛盾关系推理：可以推出SAP为真，则所有国家都存在宗教和信仰。再根据从属关系，可以推出：SIP,SaP为真。

李后主: 这个比较简单。把三个真命题推出来就行了！

李后主: 【思考题2】下面三句话只有一真：（１）网大有些同学懂英语。（２）​网大有些同学不懂英语。（３）网大的杜若同学不懂英语。请问：网大的所​有同学（假设50名）中有几人懂英语？请写出推理过程。

陈清扬: (1)SIP,(2)SOP,(3)SeP，1，2是IO下反对关系​，至少一真；所以真话在1，2中，3是假的；13eI是下反对关系，至​少一真，所以1I是真的，2O是假的，3e是假的；因为AO是矛盾关系​，所以﹁SOP→SAP；结论全懂；n=50。

李后主: 这个问题难不倒大家，我看跟贴的三位同学得出的结论都是正确的。同样​的问题我们在前面已经遇到过了，就是和以前讲那个小王公司的经理懂不懂​计算机的问题一样。

李后主: 下面我们看看变形推理，这是本次课的重点。1，换质法的重点在什么地方呢？就是矛盾概念。我现在问大家几个问题，你们回答。人的矛盾概念是什么？

陈清扬: 非人。

李后主: 好！ 罪犯的矛盾概念是什么？

張穀虛: 守法者

陈清扬: 非罪犯。

張香山: 守法者。

李后主: 张谷虚，矛盾关系的概念不是反对关系的概念守法者，你们一定要记住，​前面加非是最精确的，就是负概念。陈清扬回答的不错。【已满16周岁的罪犯】的矛盾概念是什么？

曲婉蘭: 未满16周岁的罪犯。

陈清扬: 非已满16周岁的罪犯。 包括未满16周岁的罪犯和满１６的守法者。

李大雄: 已满16周岁的非罪犯。

李后主: 陈清扬说的对。

陈清扬: 我的答案最后还是换作非罪犯比较准确。

李后主: 那么，要是让你对谓项【已满16周岁的罪犯】进行换质时，它的矛盾关​系的概念应该换为什么呢？

陈清扬: 还是加非——非已满16周岁的罪犯。

李后主: 这里面涉及的问题是什么呢？就是我一直强调的层次问题，你是在哪个集​合中思考问题？是在罪犯这个集合中思考问题，还是在人这个集合中思考问​题？这需要 在具体事情上有不同的考虑，也许法律在界定犯罪的刑罚时是在​罪犯这个集合内使用【已满16周岁的罪犯】这个概念，但是，我们这里讲​的是原理课，没有针 对具体环境，那么就应该是在人这个集合内使用和人有​关的概念。

李后主: 我这么讲大家明白了吧，也知道你们为什么会出错的根源在哪里了吧！

陈清扬: 明白了。

齐学玉: 呵呵，老师提到层次问题才明白了。刚才一直都觉得应该是在罪犯这个范​围内思考这个问题。

李后主: 那好，看看我做的作业。
【思考题4】设原命题为SAP结构，根据以下提示写出推理过程。
    原命题：已满十六周岁的犯罪人（S），都是要负刑事责任的（P）​。
   ⑴换质：（A命题换质为E命题）已满十六周岁的犯罪人，不是不用负刑​事责任的。
    ⑵再换位：(E命题换位为E命题) 不用负刑事责任的都不是已满十六周岁的犯罪人。
⑶再换质：(E命题换质为A命题) 不用负刑事责任的都是非[已满十六周岁的犯罪人]
⑷再换位：(A命题换位为I命题) 有些非[已满十六周岁的犯罪人]是不用负刑事责任的。
⑸再换位：(I命题换位为I命题) 有些不用负刑事责任的是非[已满十六周岁的犯罪人]。

陈清扬: 做答案的时候就觉得有个地方出错,有个地方周延变了,但是没检查出来​,老师说了我才发现错误之处.

李后主: 所以，你们只要按照逻辑的原则不要乱转换，先规规矩矩的按照负概念加​非的原则先把非【......】写出来，然后再根据集合看这个非【..​...】能不能转换为一个其它的通俗术语。

李后主: 好，回头看一下第3题。
【思考题3】请将下面四个命题用换质法进行推理。
    A，中国大陆所有的媒体都是中共的喉舌。
    B，中国大陆所有的媒体都不是中共的喉舌。
    C，中国大陆有些媒体是中共的喉舌。
   D，中国大陆有些媒体不是中共的喉舌。

陈清扬: 　　A，中国大陆所有的媒体都是中共的喉舌。——中国大陆所有的媒体​都不是非中共喉舌。
    B，中国大陆所有的媒体都不是中共的喉舌。——中国大陆所有的媒​体都是非中共喉舌。
    C，中国大陆有些媒体是中共的喉舌。——中国大陆有些媒体不是非​中共喉舌。
   D，中国大陆有些媒体不是中共的喉舌。——中国大陆有些媒体是非中共​喉舌。

李后主: 学玉的作业贴中换质换的有问题。矛盾关系的概念术语表达不清晰。陈清扬的表达非常精确。你们学习逻辑学，首先学会精确的表达概念，这是第一步。换质后的命 题和原命题是等价的。可以相互推理。也就是【是某某】等价​于【不是非某某】。学玉，你知道为什么要这么做吗？（就是用非原概念，而不是通俗术语）

陈清扬: 为了在换质的过程中不缩小或扩大外延。

李后主: 受中共控制－－受中共操作－－被中共管制－－－由中共支配－－－在中​共的领导下－－－在中共的管理下－－－......

李后主: 如果不使用精确概念来推理，一个中共喉舌的负概念可能会出现很多种表​达，那么这些概念继续推理下去，环节一多，就慢慢会偏离原来的意思，最​终就会出现问题。

齐学玉: 是为了让推理的结论保持精确，老师，是不是这个意思？

李后主: 推理的过程和结论都保持逻辑的精确性。就像我们刚才讲的【思考题4】中那样，经过一系列的变形推理，你要是​不使用精确的概念，那么推着推着就出现了问题。

李后主: 概念和术语的关系就是这样，数学中A的负概念就是－A，不会出现别的​表达，但是形式逻辑是研究言语表达中的逻辑规律，用术语来表达概念，所​以就得使用精确的术语，以保证在推理中逻辑的精确性。

陈清扬: 学习逻辑就是要学习这个思维的精确，当然具体写文章、说话时不需要这​样死板，但是自己心里要对自己的话是否精确有把握，或者说可以用修辞手​法把比较僵硬的推理变得活泼，但内里要有严谨的思维轨迹在。而这种严谨​是需要比较刻苦的专门训练才能有的。

李后主: 写文章不是做逻辑的习题，但是头脑中却少不了这个过程，你头脑中没有​这个过程，你的文章中就会逻辑不严谨，就有可能出现破绽和漏洞。学习逻​辑学就是完善我们的思维过程。

杨尚: 是的，只有逻辑的力量融汇于言语文章中，才能有说服力，既坚定自己，​又启发别人。

李后主: 只要你思维中逻辑不混乱，你说什么，不说什么，不管怎么说都始终是逻​辑清晰的，表达的思想就犀利。所以，重要的在于你头脑中的思维过程要逻辑清晰，就这需要在思维中使​用精确的概念，在表达中不偏离这个概念。

齐学玉: 形式逻辑不是研究语言的内容，所以不讲究语言内容的变化，而重在研究​语言表达中的逻辑规律，为了能精确的研究其中的逻辑规律，所以也就要求​术语的准确性。

陈 清扬: 这些逻辑关系，具体化为例子的时候，看起来很容易理解，但是抽象出规​律的时候（比如从直言命题到对当关系）就不是那么容易记忆了。而我觉得​要学好逻 辑，还真就得从抽象的层面上去把握，不能每个知识点都要具体化​成为事例，并且感觉自己弄懂了，那样的话，具体的例子无数个，不上升到​抽象的层面，永远 也不能完全掌握。所以我们还得多加把劲——抽象的硬记​住，在以后的学习中慢慢理解会好一些。

李后主: 形式逻辑要求的准确性最终是在你思维过程中起作用。是它指导你使用语​言，是你使用语言的总指挥，使用哪个词，怎么分配这些词语，都是在这个​总指挥的指 导下行动的。比喻一下，如果你的语言是一支军队的话，形式逻辑课就是军事指挥学院​，培养将军的。这就是陈清扬所说的抽象的把握吧！

張穀虛: 能把邏輯很好地利用不僅對自己寫文章有説服力，同時也對平時的語言交​流也有很大好処，可以減少說錯話的幾率。

杨尚: 我回头自学纪要，看能否把失去的两堂逻辑课补上。

李后主: 杨尚，把讲义下载全再根据纪要好好看看，自学一下就掌握了。

杨尚: 好的老师。

陈清扬: 我觉得把习题做好，基本就学会了老师需要我们掌握的重点；不过反过来​说，纪要看得再多，没有实际的操练，恐怕还是掌握不好讲义中的内容——​换句话说就是，在具体例子中学习逻辑比较事半功倍。

唐子: 主要还是要多思考和多写文章。

李后主:三段论的部分，我今天就不讲了，我们下次课再讲吧！你们把三段论的大​小前提能分清楚，把5个逻辑规则熟记在心即可。好了。我今晚就讲这些。

师生互道晚安！


第三章 推理(纪要2-2）

授课内容：《形式逻辑》第三章——推理（下）
上课时间：2008年12月4日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到課老師：唐子
到课同学：杨尚、慕容患、赵阳光 、陈清扬、钱不求、張穀虛、华变天、齐学玉、張香山、曲婉蘭、 麻生、安哲 、贺大翔 、严仁勇 、三石 、張香山、多名游客
到课同學人数：16人
纪要整理：齐学玉

各位同学: 老师好，同学们晚上好！

李后主: 同学们，晚上好！

李后主: 好的，我们开始上课吧！第二讲还有一部分内容，2．2复合命题的负命题及其等 值命题。我们先来看看这个内容。

李后主: 负命题就是它的矛盾关系的命题，原命题真，负命题假，反之亦然，互为​矛盾关 系。找复合命题的负命题，就是假设它为真，找它的假命题。或者找它为假命​题的条件。 比如：在联言命题中，只要有一个联言支为假，那么这个命题就是假的。​因此，与联言命 题的负命题相等值的命题，应该是一个相应的选言命题。即​：﹁（p∧q）←→﹁p∨﹁q

李后主: 那么，我们看这个习题。
7，【思考题3】
如果命题“并非[他既是科学家又是教授]”为真。那么，下述哪个命题​必定为真？
    A．他是科学家但不是教授。 B．他是教授但不是科学家。
    C．他既不是科学家也不是教授。D．如果他是科学家，则他一定不​是教授。
E．如果他不是科学家，那么他也一定不是教授。

杨尚: D是真。

慕容患: ｅ為真。

李后主: 这是个联言命题的假命题。原命题是【他既是科学家又是教授】。只要否定掉一 个就是它的负命题。

慕容患: ａ、ｂ

李后主: 那么它的负命题是“并非【他既是科学家又是教授】”等直于【或者他不​是科学 家或者他不是教授】那么四个选项中必真的命题只能是D.慕容患能理解吗？

慕容患: 困難。被繞進去了。

齐学玉: ab只是可能真，不是必定真。

李后主: 下面的关于选言命题和假言条件命题的内容我们没有出习题，大家自己把​讲义中 的部分好好读读。

陈清扬: 假言命题的矛盾命题竟然是联言命题，而联言命题的矛盾命题是选言命题​，这点 我在读讲义时读到这里还吃了一惊，感觉很有意思。

李后主: 这里面我感觉最让人不可思议的是不相容选言命题的负命题，如下：
不相容选言命题有且只有一个选言支为真时，这个命题才是真的，其它情​况之下都是假的 。因此，与不相容选言命题的负命题相等值的命题是一个相​应的选言命题。 即：﹁（p∨ q）←→（p∧q）∨（﹁p∧﹁q）

陈清扬: 不相容选言确实不容易想到他的矛盾命题是那么长的一串。

李后主: 这里面的例子很有意思，如：“并非[他毕业后要么去了青岛，要么去了​南京]” 等值于“他毕业后既去了青岛又去了南京，或者他毕业后既没有去​青岛也没有去南京”。

陈清扬: 这话如果不是在逻辑课上出现，还真是比较突兀的一种表达方式。

李后主: 大家注意，负命题还是选言命题，这个例子中负命题可以为真，原命题也​可以为 真。

麻生: 看例子明白了。

李后主: 负命题要是真的话，那么只能是后面那个支【他毕业后既没有​去​青岛​也没有去南 京”】为真。前面那个支【他毕业后既去了青岛又去了南京】不可能为真，但是它是一​个 完整的逻辑形式的一部分，不可缺少。

慕容患: 能夠明白這個例子，是唐子老師講過的變換詞語敘述。

李后主: 慕容患，主要是学逻辑形式，不是转换词语。那么，再看另一个例子。
“并非[你要么留下，要么离开]”等值于“你既不要离开又不要留下或​者你既离开又留下 ”。

李后主: 这个例子，负命题不可能为真，因为它的两个支都不能为真。那么负命题必然为 假，原命题必然为真。这种命题的真假在现实中是注定了的，改变不了。逻辑形式的有效 性和命题的真伪并不相冲突。

李后主: 好的，三段论就是研究逻辑形式的有效性。下面，我们进入第三讲，看看三段论 的内容，上一次课，我们把变形推理​都已经讲过去了。首先认识一下三段论。看看三段论 的组成。

李后主: 【思考题5】
请指出以下三段论中的大项，小项、中项和大前提、小前提（用命题1和​命题2来表示）。
⑴斯皮尔博格的电影都很精彩；《侏罗纪公园》是斯皮尔博格的电影；所​以《侏罗纪公园 》也很精彩。
⑵他是优秀学生；他是农村来的；所以，有些优秀学生是农村来的。
⑶所有贪官都是罪犯；他不是罪犯；所以，他不是贪官。
    ⑷退出中共的党员不再承担中共的血债，胡锦涛没有退出中共，所以​，胡锦涛要承担 中共的血债。
⑸故意犯罪应当负刑事责任；张三不需负刑事责任；所以，张三没有故意​犯罪。

李后主: 我们一个个来看。大家先看看钱不求的作业。

李后主: 钱不求的作业：⑴斯皮尔博格的电影都很精彩；《侏罗纪公园》是斯皮尔博格的 电影；所​以《侏罗纪公园》也很精彩。
命题1:⑴斯皮尔博格的电影都很精彩；命题2:《侏罗纪公园》是斯皮​​尔博格的电影。
S《侏罗纪公园》；M斯皮尔博格的电影；P很精彩。

李后主: 钱不求同学好像没明白，我要他用命题1和命题2来说出大前提和小前提​。比如上 面这个例子，命题1是大前提，命题2是小前提。我这么提示是让大家做作业时简练一些， 难道大家不明白吗？大中小项倒是都说对了。

钱不求: 我的作业，命题1是大命题，2是小命题。解释一下，抱歉了。

李后主: 不求，你自创的大命题小命题？

钱不求: 是的，呵呵，反正前面的就是命题1（大前提），后面的就是命题2（小​命题）。

李后主: 不求啊，没有大命题和小命题这个概念，你怎么还在糊涂。

李后主: 陈清扬的作业：
⑴斯皮尔博格的电影都很精彩；《侏罗纪公园》是斯皮尔博格的电影；所​以《侏罗纪公园 》也很精彩。
大前提斯皮尔博格的电影都很精彩，小前提《侏罗纪公园》是斯皮尔博格​的电影，大项精 彩，小项《侏罗纪公园》，中项斯皮尔博格的电影

陈清扬: 这题我也没理解好题中的要求。

李后主: 都是正确的，只是表述的很累，没有使用我说的命题1和命题2来简单表​达。

李后主: 齐学玉的作业：
命题1:⑴斯皮尔博格的电影都很精彩；命题2:《侏罗纪公园》是斯皮​尔博格的电影。
小项：《侏罗纪公园》；中项：斯皮尔博格的电影；大项：很精彩。

杨尚: 后主老师，不求和清扬的大、中、小项答案不同，以谁的为准呢？

李后主: 哦？我再仔细看看。

陈清扬: 基本一样，只是我的顺序是大小中。不求小中大。

钱不求: 我按照它们在句子中的顺序排列的。

李后主: 他们俩的答案一样的。

李后主: 命题1 命题2是按照自然顺序排列的，不需要指定，直接使用，大家都会明白，​ 哪个是命题1，哪个是命题2，关键是要表达命题1是什么，命题2是什么​。在这个例子中， 命题1是大前提，命题2是小前提。但是排在前面的不一定都是大前提，也可能是小前提， 因为大小前提主要​是看大小项，三段论的排列顺序是由人们随意来排列的，只要符合逻辑 形式​就可以了。

齐学玉: 大前提含有大项，小前提含有小项。

李后主: 我现场出一个题：请指出下面三段论的大小前提（使命命题1命题2来表​达）
中共是邪教。
中共是不会改良的。
所以，有的邪教是不会改良的。

陈清扬: 1小前提2大前提。

李后主: 好了，清扬回答的多简单。

杨尚: 1小前提2大前提。

李后主: 完整一点就是：
命题1是小前提；
命题2是大前提。

李后主: 好了吧，以后学会简单表述，但是要让人能看懂。也不要太简单了，做作​业时表 达到命题1命题2就可以了。这个问题下面的例子我们就不看了，大家自己去检查一下对错 ，我上课前​看了一下应该都没问题。

严仁勇: ⑴斯皮尔博格的电影都很精彩；《侏罗纪公园》是斯皮尔博格的电影；所​以《侏 罗纪公园》也很精彩。
大项：精彩：中项：斯皮尔博格的电影：小项：《侏罗纪公园》。

⑵他是优秀学生；他是农村来的；所以，有些优秀学生是农村来的。
大项：农村来的； 中项：他； 小项：优秀学生。

⑶所有贪官都是罪犯；他不是罪犯；所以，他不是贪官。
大项：贪官；中项：罪犯；小项：他。

⑷退出中共的党员不再承担中共的血债，胡锦涛没有退出中共，所以，胡​锦涛要承担中共 的血债。
大项：承担中共的血债；中项：退出中共；小项：胡锦涛。

⑸故意犯罪应当负刑事责任；张三不需负刑事责任；所以，张三没有故意​犯罪。
大项：故意犯罪；中项：负刑事责任； 小项：张三。

李后主: 学玉的作业也是没有说出大小前提。 现在我们看下一个习题。

李后主: 【思考题6】
以下三段论是否正确？若不正确，请指出违反哪条规则。
    ⑴斯皮尔博格的电影不是一天能看完的；《侏罗纪公园》是斯皮尔博​格的电影；所以 ，《侏罗纪公园》不是一天能看完的。
    ⑵他是优秀学生；他是农村来的；所以，优秀学生都是农村来的。
⑶所有贪官都是罪犯；他是罪犯；所以，他是贪官。
    ⑷退出中共的党员不再承担中共的血债，胡锦涛没有退出中共，所以​，胡锦涛不再承 担中共的血债。
⑸故意犯罪应当负刑事责任；张三不需负刑事责任；所以，张三故意犯罪​。

李后主: ⑴大家的回答都是正确的，是犯了四词项的错误。

李后主: 我们看⑵。

安哲: 1对，2错，3错，4对，5对。

李后主: 不求的作业：前提中有一特称，结论必须也是特称。
清扬的作业：中项未周延。
学玉的作业：违反规则3“前提中不周延的项，在结论中也不得周延”。

李后主: 首先大家不要用6和7，因为那都是推论，只有前面5个规则是一般规则​。违反了6 和7，必然会违反1－5中的一个。

李后主: 这个三段论中的大小前提都是单称命题，那么，中项是单称他，必然是周​延的。 那么，清扬，你的答案是不是错了？

陈清扬: 确实不对，我把单称理解成特殊特称了。

李后主: 大家看小项是什么？是不是优秀学生，这个小项在前提中是不周延的，但​是在结 论中却是周延的，因为结论中它是全称命题的主项。那么，这个作业是学玉做对了。违背 了第3条规则。好的，我们再看第⑶个事例。⑶所有贪官都是罪犯；他是罪犯；所以，他​ 是贪官。

李后主: 不求的答案：前提中不周延的项，在结论中也不得周延。
清扬的答案：2中项未周延。
学玉的答案：违反规则2“中项在前提中至少要周延一次”。

李后主: 这个例子中，中项是“罪犯”，在大小前提中都没有周延。所以，学玉和​清扬都 是对的。

李后主: 其他同学能明白吗？

杨尚: 正在理解。

慕容患: 還能夠跟上。

李后主: 其实，这些都不难，关键我的讲义出的晚了，大家早两天通读讲义，多思​考思考 就都能做出来。

陈清扬: 老师辛苦了。

李后主: 不过现在进行的部分讲义是上周出的，都一周了。

杨尚: 老师的讲义不晚，是我偷懒了。

李后主: 好，再看下一个。

慕容患: 需要一邊對照講義，所以有時候不能及時回答問題。

李后主: ⑷退出中共的党员不再承担中共的血债，胡锦涛没有退出中共，所以，胡​锦涛不 再承担中共的血债。

杨尚: 两个否定的前提不能得出结论

李后主: 是的，这个例子违背了规则4。清扬和学玉，杨尚都回答正确，不求的答案又错 了，看来不求这个问题上​还是没有理解透彻。

钱不求: 我当时做的，看到他们的回答其实就想明白了，可惜没有时间改了。

李后主: ⑸故意犯罪应当负刑事责任；张三不需负刑事责任；所以，张三故意犯罪​。

李后主: 这个答案不求说对了，【前提中有一否定，结论必否定；结论否定，则必​有一前 提否定。】大家都说对了。好的，这个习题就做到这里，每个规则都出了一个例子。

李后主: 我们看下面的习题。
【习题7】请为下列有效式各举一个事例
1，第一格：EAE
2，第二格： EIO
3，第三格： IAI
4，第四格： AEE

李后主: 一个一个来分析哦！

陈清扬: 看来形式逻辑的课很受欢迎，呵呵。旁听的朋友可以看看讲义，在下面的网址， 需要下载，否则光这样看可能​有些云山雾罩的。
v​iewtopic.phpf=18&t=3005

李后主: 1，第一格：EAE
M——P
S——M
S——P

李后主: 不求的作业：
1， 第一格：EAE
网大的学生都不是共产党员。
正参与上课的人是网大的学生。
正参与上课的人不是共产党员。

钱不求: 注：参与，指真正参与其中的人，不包含旁观者。

李后主: 大家说说，不求的这个回答正确吗？

陈清扬: 加二个“都”字似乎更准确些。

安哲: 正确。

齐学玉: 正确。

李后主: 是的，加个都字更准确。不加也正确。因为全称包含在字面中了。

李后主: 清扬的回答：
1，第一格：EAE 所有的女人都不是男人，所有的空中小姐都是女人，所以所有的空中小 姐​都不是男人。

李后主: 很正确啊！呵呵！

陈清扬: 呵呵，不过读起来有点滑稽。

李后主: 学玉的回答：
1，所有的亚洲人都不是美洲人，中国人都是亚洲人，所以中国人都不是​美洲人。

李后主: 也正确。好，我们看第2格的作业。
P——M
S——M
S——P
2，第二格： EIO

李后主: 不求的回答：
第二格： EIO
理性思维的人都不会犯大的逻辑错误。
网大教师是会理性思维的人。
网大教师不会犯大的逻辑错误。

齐学玉: 这个应该是EAA了。

李后主: 是EAE。

齐学玉: 恩，是EAE。

钱不求: 网大老师改为：有些网大老师

李后主: 是啊，不求明白了。

李后主: 清扬的作业：
EIO所有的雪都是低于零度的，有些东西不低于零度，所以有些东西不​是雪。

李后主: 不错啊，很符合要求。

齐学玉: 老师，这个是EOO吧。

李后主: 哦，对对对，清扬的否定了，是有问题了。

陈清扬: 写不高于0度好了。

李后主: 改一下，命题2改为有的东西高于零度。

陈清扬: 所有的雪都不高于零度的，有些东西高于零度，所以有些东西不​是雪。

李后主: 清扬，是高于，不是不高于。

李后主: 呵呵，好的，大家反应都挺快的。谢谢学玉指出我们的错误。

陈清扬: 我的大前提也是A型的了，刚才学玉不说，我还真是没意识到。

李后主: 是啊，清扬的大前提也应该修改为不高于。

李后主: 那么，现在看看学玉的作业：
2，所有的正义人士都不支持中共，有些美国人支持中共，​所以有些美​国人不是正义人士 。

李后主: 学玉的这个例子很正确。形式完全符合。

杨尚: 所有的桌子都不是电器
这个写字台是桌子
所以这个写字台不是电器

李后主: 杨尚的这个例子，写字台是全称的话，就不符合了，应该说有些写字台，​或者改 为单称也行。

李后主: 不对，杨尚，你没有看格啊～！
P——M
S——M
S——P
我们只顾看式了，把格给忘了。

陈清扬: 这是审判格了。

杨尚: 是的，错了，我成1格了。

李后主: 是啊，杨尚不小心做成第一格了。好的，我们继续看第3格的作业。3，第三格： IAI

李后主: 第三格：
M——P
M——S
S——P

李后主: 不求的作业：
第三格： IAI
有些人努力学习会在短时间得到很大提高。
网大的学生都在努力学习。
有些网大的学生会在短时间得到很大的提高。

李后主: 格不对。

李后主: 清扬的作业：
3，第三格： IAI有的动物可以食用，所有动物都能动，有些能动的可以食用。

李后主: 清扬的这个对了。

李后主: 学玉的作业：
3，有些大一新生年岁很大了，所有的大一新生都刚刚参加过高考，所以​有些年岁很大的 刚刚参加过高考。

李后主: 结论的主谓项有问题，格就不正确了，学玉好好看一看。

杨尚: 有一种形式逻辑叫三段论
形式逻辑可以提高人的逻辑思维能力
三段论可以提高人的逻辑思维能力

李后主: 有些大一新生年岁很大了，所有的大一新生都刚刚参加过高考，所以​有​些参加过 高考的大一新生年岁很大了。

陈清扬: 学玉的是AII了，不过稍作休整就对了。

李后主: 是不是可以这么改一下呢！

齐学玉: 是啊，刚看明白，谢谢老师！

李后主: 是啊，如果按照你原来的，就是命题2为大前提的AII了。

杨尚: 有一种形式逻辑叫三段论
形式逻辑可以提高人的逻辑思维能力
所以有一种可以提高人的逻辑思维能力的方法叫三段论

李后主: 呵呵，刚准备说杨尚和学玉的错误是一样的，他就自己改过来了，反应很​快啊！

杨尚: 呵呵。

李后主: 好的，大家通过这么做习题，越来越熟练了，逻辑并不难，就是看谁细心​了。大 家都会一不小心就看错，难免啊！

李后主: 4，第四格： AEE
P——M
M——S
S——P

齐学玉: 我的第四个也错了，我刚修改了一下。

李后主: 不求的作业：
， 第四格： AEE
所有共产党员都是被共产党组织控制的。
所有共产党员都不是中华儿女。
中华儿女都不是被共产党组织控制的。

李后主: 格错了啊。

齐学玉: 不求的这个是第三格了。

李后主: 修改一下：
所有中国大陆的社会机构都是被共产党控制的。
所有被共产党控制的都没有正常社会功能。
因此，所有有正常社会功能的都不是中国大陆的社会机构。

李后主: 大家看，这样是不是就符合要求了。

齐学玉: 是的。

李后主: 清扬的作业：
4，第四格： AEE所有的食物都能吃，能吃的都不应该被浪费。所有食物都不应该被​浪费 。

李后主: 清扬的结论的主谓项是有问题。格就错了。

陈清扬: 格是错了，变成审判格了。

李后主: 而且这个例子改过来也不对啊!

陈清扬: 这样呢：所有的食物都能吃，能吃的都不应该被浪费，应该被浪费的都不​是食物 。

李后主: 所有应该被浪费的都不是食物。这个改也不妥啊。结论好像有点别扭。什么东西 应该被浪费呢？所以，这个例子就不改了。

赵阳光: 所有的汽车都需要发动机驱动，
发动机是可以产生动力的，
因此，不能产生驱动力的设备都不能做发动机。

李后主: 阳光，你没看格啊！
P——M
M——S
S——P

李后主: 学玉，你说你的这个作业改过的，放上来吧！

齐学玉: 所有退休人员都享有养老保险，所有享有养老保险的都不担心自己的生活​，所以 所有担心自己的生活的都不是退休人员。

李后主: 好的，学玉的这个修改后的完全符合要求。

杨尚: 所有的形式逻辑方法都可以提高人的逻辑思维能力
所有提高逻辑思维能力的方法都不属于党文化
所以党文化中不包含形式逻辑方法。

李后主: 杨尚这个例子也可以。通过这么做作业，三段论的格和式，我想大家都能掌握了 。没有来得及做​作业的，下去后，把我们的纪要和讲义结合起来好好看一看，也能掌握。

李后主: 现在我们来做几个证明题吧！

李后主: 【习题8】证明题：利用三段论规则证明以下三段论的具体的格规则
1，第一格的①小前提必须是肯定的。
2，第二格的②大前提必须是全称的。
3，第三格的②结论必须是特称。
4，第四格的③如果小前提肯定，则结论必须是特称。

李后主: 还是一个一个看。1，第一格的①小前提必须是肯定的。

李后主: M——P
S——M
S——P

李后主: 清扬的作业：
中项主、谓，
如果小前提否定（根据5），结论必否定，结论谓项必周延；
如果小前提否定（根据4），大前提必肯定，大前提的谓项（亦即大项，​亦即结论谓项） 必不周延；
（根据3）前提不周延，结论也不得周延，前后矛盾，因此小前提必须肯​定。

李后主: 证明是对的，可是为什么不用符号SP来表示呢？该用的时候不用，不该​用的时候 乱用，陈清扬啊，你可是真有意思。

李后主: 如果小前提否定（根据5），结论必否定，结论谓项P必周延；
如果小前提否定（根据4），大前提必肯定，大前提的谓项P（亦即大项​，​亦即结论谓项） 必不周延；
（根据3）前提不周延，结论也不得周延，前后矛盾，因此小前提必须肯​​定。

李后主: 学玉的作业：
，如果小前提否定，根据规则5，则结论必否定。如果结论否定则大项周​延，若大项周延
依据规则3，则大前提否定，因此就会出现大小前提都是否定的情况，根​据规则4，两个否
定的前提不能得出结论。所以小前提必须是肯定的。

李后主: 这个证明也是对的，学玉用的是大项，所以就不必要标识符号了，而清扬​你用的 是大前提的谓项，那么就把符号标识出来方便一些。

李后主: 2，第二格的②大前提必须是全称的。
P——M
S——M
S——P

李后主: 学玉的作业：
2齐学玉: 2，第二格中的结论必为否定，所以大项是周延的。如果大前提不是全称​，则大 项不周延，所以大前提必须是全称的。

李后主: 学玉，结论必须是否定的，也要证明的啊！不能直接用啊！

李后主: 清扬的作业：
2，第二格的②大前提必须是全称的。
中项谓、谓
根据2，中项必须至少周延一次，因为中项都在谓项，所以大小前提必须​至少一个否定， 根据4，大小前提必须有且只有一个否定，根据5，结论必​否定，即结论谓项必周延，即大 项必须周延，因为大项在大前提的主项，因​此大项必须全称。

齐学玉: 是啊，我把其它的结论都当作已知条件来用了，这样不对，清扬这样很好​。

李后主: 对的，清扬证明正确。

李后主: 我也来证明一下吧！
假如大前提是特称的，则大项不周延，则结论是肯定命题，则大小前提都​是肯定命题，那 么中项M就一次都没有周延，违背了规则2，因此，大前提​只能是全称。
(22:56:05) 李后主: 3，第三格的②结论必须是特称。
M——P
M——S
S——P

李后主: 其他同学注意看我贴的格。然后自己思考怎么证明。

李后主: 看看清扬的作业：
3，第三格的②结论必须是特称。

结 论如果不是特称，即小项全称，即小项周延，根据3，小项在前提中周​延，因为小项在 前提中是谓项，所以小项在前提中是否定的，根据5，结论​必是否定的，即结论谓项周延 ，即大项周延，根据3，大项在前提中周延，​因为大项在前提中是谓项，所以大项在前提 中是否定的，根据4，大小前提​皆否定不能得出结论。所以结论不能是全称，必须是特称 。

李后主: 证明正确。

李后主: 学玉的作业：
3，第三格中小前提必肯定，所以小项是周延的。如果结论不是特称，则​小项周延，所以 结论必须特称。

齐学玉: 修改：假如结论是全称的，则小项周延，小前提应为否定命题，则结论为否定命​ 题，大项也周延，同理大前提也为否定命题。违反规则4。

李后主: 是的，学玉终于知道该怎么证明了。我们就是看着格，然后寻找它的规则​。不能 用没有证明的东西来证明啊！

齐学玉: 是啊，看老师的证明就明白了。

李后主: 其他同学能不能达到看着格就可以把一个格规则证明出来呢？

杨尚: 1如果结论中S是全称，S周延。
2依据前提不周延结论不得周延的原理，小前提中S必须周延，所以小前​提是否定
3小前提否定，大前提必须肯定；结论必须否定
4大前提肯定，则P不周延；结论否定，则P周延。
5因为前提中不周延的项，结论中也不得周延，故结论中S必须特指。

李后主: 是啊，杨尚证明的也对，只要推出一个矛盾命题就行了。我们是依据三段论的总 规则来推论它的具体的格规则，大家看明白了吗？

慕容患: 可以看明白，會自己課下練習。

李后主: 好，我们看第4格的一个证明题。
4，第四格的③如果小前提肯定（就是M——S是肯定句。），则结论必须是特称。
P——M
M——S
S——P

李后主: 学玉的作业：
4，小前提肯定，则小项不周延。如果结论不是特称，则小项周延，所以​如果小前提肯定 ，则结论必须是特称。

李后主: 学玉证明的对，这个证明题很简单，一下子就推出来了。

杨尚: 如果小前提肯定，小前提中S必须不周延。前提中不周延的项，结论中不​得周延。 结论中S是特指，S才不周延。所以结论中S必须特指。

李后主: 清扬的作业：
如果小前提肯定，因为小项在小前提的谓项，所以小项不周延，根据3，​小项在结论中也 不周延，所以结论为特称。

李后主: 是的，杨尚，清扬大家都证明的对。

李后主: 那么，三段论的内容，我们就学到这里了。通过这样做习题，我想大家把握起来 是很快的。

杨尚: 是的，在应用中理解，效果好。

齐学玉: 在课堂上学习比自己学习效果要好。

李后主: 逻辑课现在上到中途了，概念，命题，推理，大家现在都有一个较连续的​认识了 。

李后主: 基础是概念，命题之间的真假关系还是由概念之间的关系来决定的。推理?过程中的规则归根结底还是由概念之间的关系来决定的，因此，概念的理解是关键。

李后主: 大家现在对概念的理解也应该加深了，它不只是名词了，还可以是一段概括性的话，是一个范围内的事物的逻辑表达。

李后主: 回过头来，大家看看，如果我们能一下子把握概念之间的关系,那么逻辑推理就不会出错误。

李后主: 学了逻辑学，不要越学越远，把事物的本质给忘了，从概念出发进入事物的本质才是我们最终的目的。
----------------------------------------------------------------
蓝色部分是最后面我讲的，但是，我发现只有我一个人在说话，而屏幕在不断的刷新，我坚持着不退出，但是很奇怪，没有人回答了，我想，我可能已经掉线了。那时，再上学校的网站都上不去了，但是我却还能在教室里发言。
－－－－李后主 补充


第三章 推理

第一节 推理综述

一，什么是推理

1，定义：推理是依据已知的命题得到新命题的思维形式。

2，组成：推理由前提和结论两个部分组成。推理所依据的命题叫做前提；推理所得到的命题叫做结论。

3，有效性：一个推理形式是有效的，仅仅看推理形式本身，而不单独看前提和结论的真假，但如果前提真而结论假则推理的形式是无效的。因此推理形式的有效性可以界定为“当且仅当，具有此推理形式的任一推理都不出现真前提和假结论的现象。”

例如：

⑴所有的植物都是需要水份的。

所以，有些需要水份的东西是植物。（换位法推理）

⑵所有中学毕业生都要通过中学毕业考试。

张三没有通过中学毕业考试；

因此，张三没有中学毕业。（三段论推理）

二，推理的特征

    一个推理要能够得出真实的结论，必须具备两个基本条件：其一，作为前提的命题要真实；其二，推理形式是有效的，即推理过程要遵守基本的逻辑规则。

    “推出真实结论”和“推理形式的有效”是有区别的：

    “推出真实结论”的条件：它必须具备上述的两个条件，即前提要真实和推理形式要有效。

“推理形式的有效”：专指推理形式正确，它只要求推理过程遵守基本的逻辑规则，而不管前提与结论的正确与否。

例1：

所有大学生都入了共产党；

共产党员都是邪教成员；

所以，所有大学生都是邪教成员。

很显然，例1中小前提“所有学生都入了共产党”是假命题，结论也是假命题，但推理形式是有效的。

例2：

有些网大学生是三退人员；

有些中国人不是三退人员；

所以，有些中国人不是网大学生。

例2中前提和结论都是真命题，但推理形式是无效的（犯了大项不当周延的错误）。

    三、推理的种类

1，根据前提与结论中是否包含有“必然”、“可能”等模态词，将推理划分为模态判断和非模态判断。

2，根据前提到结论的思维进程的不同，将非模态推理分为演绎推理、归纳推理、类比推理。

① 演绎推理：由一般性前提到个别性结论。

② 归纳推理：由个别性前提到一般性结论。

③ 类比推理：由个别性前提到个别性结论。

3，根据前提和结论之间是否有蕴涵关系，推理可分为：必然性推理和或然性推理。

① 必然性推理：结论断定的范围没有超过前提断定的范围。如演绎推理和完全归纳推理。

② 或然性推理：结论断定的范围超过了前提断定的范围。如不完全归纳推理和类比推理。

4．根据前提和结论是简单命题还是复合命题，分为简单命题推理和复合命题推理。

① 简单命题推理：以简单命题为前提和结论。又分为直言命题推理和关系命题推理。

② 复合命题推理：是前提和结论中至少有一个复合命题。又分为联言命题推理、选言命题推理和假言命题推理。

5，根据前提的数量的不同，即所含命题是一个还是两个或以上，推理可分为：直接推理和间接推理。

① 直接推理：以一个命题为前提

    ② 间接推理：以两个或两个以上的命题为前提。


第三章 推理

第二节 直接推理

直接推理是由一个直言命题作前提而推出另一个直言命题作为结论的演绎推理。根据推理的依据不同，直接推理又可分为：对当关系推理和变形推理。

    一，对当关系推理

——是根据同素材的A、E、I、O四种命题之间的真假关系来进行的推理。

1，矛盾关系直接推理：SAP←→﹁SOP，SEP←→﹁SIP，SIP←→﹁SEP，SOP←→﹁SAP，SaP←→﹁SeP，SeP←→﹁SaP。

例如：

⑴所有学生都通过了考试，所以（等值于），并非有些学生没有通过考试。

⑵有些学生通过了考试，所以（等值于），并非所有同学都没有通过考试。

根据矛盾关系的特征，可以从一个命题可真，推出和它具有矛盾关系的命题为假，也可以从一个命题为假，推出和它具有矛盾关系的命题为真，即一个直言命题和其具有矛盾关系的负命题之间可以相互推出，原命题等值于“并非[它的负命题]”。

2，从属关系直接推理：SAP→SIP ，SEP→SOP，﹁SIP→﹁SAP，﹁SOP→﹁SEP。

⑴并非有些学生通过了考试，所以，并非所有的学生都通过了考试。

⑵并非有些学生没有通过考试，所以，并非所有同学都没有通过考试。

根据从属关系的特性，全称真，则特称真；特称假，则全称假。可以从全称的真命题推出特称的真命题，也可以从特称的假命题推出全称的假命题。

3，反对关系直接推理：SAP→﹁SEP，SEP→﹁SAP。

例如：

⑴所有的学生都通过了考试，所以，并非所有的学生都没有通过考试。

⑵所有的学生都没有通过考试，所以，并非所有的学生都通过了考试。

根据反对关系的特征（必有一假），可以从一个命题为真，推出另一个命题为假。

以上的公式也可以从前面（1，2中的）两个公式中推出来，如因为SAP←→﹁SOP，又因为﹁SOP→﹁SEP，所以，SAP→﹁SEP。

    4，下反对关系直接推理：﹁SIP→SOP，﹁SOP→SIP。

例如：

⑴并非有些学生通过了考试，所以，有些学生没有通过考试。

⑵并非有些学生没有通过考试，所以，有些学生通过了考试。

根据下反对关系的特征（必有一真），可以从一个命题为假，推出另一个命题为真。

以上的公式也可以从前面（1，2中的）两个公式中推出来，如因为﹁SIP←→ SEP ，又因为SEP→SOP，所以，﹁SIP→SOP。

    【思考题1】如果“有的国家不存在宗教和信仰”（SOP）是假的（﹁SOP），可推出几种结果？”

    【思考题2】下面三句话只有一真：（１）网大有些同学懂英语。（２）网大有些同学不懂英语。（３）网大的杜若同学不懂英语。请问：网大的所有同学（假设50名）中有几人懂英语？请写出推理过程。

    二、变形推理

    通过改变前提的形式而直接推出结论的推理形式，根据改变的词项的不同，又可分为换质法和换位法。

    1，换质法

    ⑴定义：换质法就是通过改变前提的联项，即把“是”改为“不是”，或者把“不是”改为“是”，从而推出结论的直接推理方法。换质推理通常又称为“换一个说法”，即肯定命题用否定的方式来表达，否定命题用肯定的方式来表达。

    ⑵换质规则

    ① 不改变前提的主项和量项；

    ② 将前提的谓项换为它的矛盾概念（不能是反对概念），亦即“P”改为“非P”。

    ③ 将前提的联项改为它的对立联项。即肯定改为否定，否定改为肯定。即把“是”改为“不是”，或者把“不是”改为“是”。

⑶结构

所有S是P←→所有S不是非P；

所有S不是P←→所有S是非P ；

有些S是P←→ 有些S不是非P ；

有些S不是P←→有些 S是非P；

某个S是P←→某个S不是非P；

某个S不是P←→某个S是非P。

例如：

瓮安少女死亡的原因不是自杀，所以，她死亡的原因是“被自杀”（非自杀）。

甘肃陇南事件中，中共军警殴打所有的街上行人，所以，所有的街上行人不是没有被中共军警殴打。

在全球藏人大会上，有些藏人代表要求西藏独立，所以，有些藏人代表不是不要求西藏独立。

【思考题3】请将下面四个命题用换质法进行推理。

    A，中国大陆所有的媒体都是中共的喉舌。

    B，中国大陆所有的媒体都不是中共的喉舌。

    C，中国大陆有些媒体是中共的喉舌。

   D，中国大陆有些媒体不是中共的喉舌。

2，换位法

⑴定义：换位法就是通过交换前提中主项和谓项的位置(主项变谓项，谓项变主项)，从而推出结论的直接推理方法。换位法通常又称为“倒过来说”。

    ⑵换位规则

   ①不改变前提的联项，只交换前提的主项和谓项的位置。

  ②前提中不周延的项，到结论中也不得周延，否则会出现概念扩大的逻辑错误。

   ⑶结构

     SAP→PIS，“所有S都是P”可以换位为“有些P是S”。

     SEP→PES，“所有S都不是P”可以换位为“所有P都不是S”。

     SIP→PIS，“有些S是P”可以换位为“有些P是S”。

    E命题和I命题，可作简单换位。因为主项和谓项的周延性质换位后不改变。

    A命题，只能作限制换位。因为前提中的谓项不周延，换位后变成主项也不周延，则在结论中必须改变为特称量项。

    O命题，不能够换位推理。因为O命题主项不周延，谓项周延。换位以后，前提中不周延的主项，到结论中则变成周延的谓项，违反了“前提中不周延的项，到结论中也不得周延的”规则，所以O命题不能换位。

    换位法，可以使人们从两个不同方面去了解主项和谓项所反映的客观事物之间的联系，可以更清楚地揭示出前提命题中主项和谓项的周延情况，有助于人们更好地思考问题和表达思想。

3.换质换位法的综合应用

我们还可以对前提既换质又换位。

例如：

⑴“犯罪行为是有具有社会危害性的行为”为前提，可以换质推出“犯罪行为不是不具有社会危害性的行为”，在此基础上再进行换位，还可以推出“不具有社会危害性的行为不是犯罪行为”。

⑵“所有的共产主义国家都是政教合一的邪恶国家”，换质为“所有的共产主义国家都不是非政教合一的邪恶国家”，再换位为“非政教合一的邪恶国家不是共产主义国家”。

注意

     ① I命题不能先换质再换位，但可以先换位再换质。如，“SIP→PIS→POS”；

     ② O命题不能换位，只能从先换质开始。

【思考题4】设原命题为SAP结构，根据以下要求按顺序写出推理过程。

    原命题：已满十六周岁的犯罪人（S），都是要负刑事责任的（P）。

    ⑴换质：（ A命题换质为E命题）____________________________________

    ⑵再换位：(E命题换位为E命题) ____________________________________

⑶再换质：(E命题换质为A命题)_____________________________________

⑷再换位：(A命题换位为I命题)_____________________________________

⑸再换位：(I命题换位为I命题)_______________________________________

概念关系提示图，注意换质时的矛盾概念要找准确。

已满16周岁的犯罪人

未犯罪的人

未满16周岁的犯罪人


第三章 推理

第三节 三段论（间接推理）

一，三段论的概述

   1，三段论的定义

    三段论又称直言三段论，是由包含着一个共同词项的两个直言命题（前提）推出一个新的直言命题（结论）的推理形式。三段论是传统形式逻辑中的主要内容，是现代逻辑的基础。

例如：

所有的网大师生都是三退人员；

所有的三退人员都是真正的中华儿女；

所以，所有网大师生都是真正的中华儿女。

2，三段论的基本结构：

    （1）词项结构：一个三段论只能包含三个不同的概念，分别用小项、中项、大项来表示。

    小项：结论中的主项。用“S”表示。

    中项：在两个前提命题中出现，但在结论中不出现的概念，是联结大小项的媒介，用“M”表示。

    大项：结论中的谓项。用“P”表示。

    （2）命题结构：一个三段论是由三个直言命题组成的，即“大前提＋小前提＋结论”。

    大前提：包含着大项“P”和中项“M”的前提命题。

    小前提：包含着小项“S”和中项“M”的前提命题。

    结论：包含着大项“P”和小项“S”，由两个前提推出的新命题。

    典型的三段论结构式：

    所有M都是P；（MAP）

    所有S都是M；（SAM）

所以，所有S都是P。（SAP）

【思考题5】

请指出以下三段论中的大项，小项、中项和大前提、小前提（用命题1和命题2来表示）。

⑴斯皮尔博格的电影都很精彩；《侏罗纪公园》是斯皮尔博格的电影；所以《侏罗纪公园》也很精彩。

⑵他是优秀学生；他是农村来的；所以，有些优秀学生是农村来的。

⑶所有贪官都是罪犯；他不是罪犯；所以，他不是贪官。

    ⑷退出中共的党员不再承担中共的血债，胡锦涛没有退出中共，所以，胡锦涛要承担中共的血债。

⑸故意犯罪应当负刑事责任；张三不需负刑事责任；所以，张三没有故意犯罪。

二，三段论的一般判定规则

三段论规则是三段论公理的具体化，一个三段论是否正确，可以通过下述规则加以判定。

1，一个三段论中有且只能有三个不同的词项

    三段论之所以能成立，是因为中项既与大项建立联系，又与小项建立联系，从中可以找到大小项之间的联系，如果三段论中有四个词项，那么可能大项和一个项存在联系，小项和另一个项存在联系，但没有一个项既和大项存在联系又和小项存在联系，这样就不能确定大小项之间的联系。违反这条规则，将犯“四词项错误”或“四概念错误”。

在犯“四词项错误”的三段论中，主要表现为同一语词在不同的命题中表达了不同的概念。

例如：

   李白的作品不是一堂课能讲完的，

   《蜀道难》是李白的作品，

   所以，《蜀道难》不是一堂课能讲完的。

   这个三段论大、小前提中的中项“李白的作品”是同一语词，但前者是集合概念，后者是非集合概念，在不同命题中是不相同的概念。所以，这个三段论犯了四词项错误。

    2，中项在前提中至少要周延一次

    中项要起到联结作用，它的外延的一部分必须既与大项建立关系又与小项建立关系，如果中项两次都不周延，那么就不可能存在一部分外延既与大项建立关系又与小项建立关系，这就无法确定大小项的关系。违反这条规则将犯“中项不周延错误”。

例如：

英雄难过美人关；

我难过美人关；

所以，我是英雄。

这个三段论中，中项“美人关”在两个前提中都是肯定命题的谓项，没有周延。

    3，前提中不周延的项，在结论中也不得周延

     违反这条规则将犯“大项不当周延”或“小项不当周延”。

    例如：

     ⑴中共党员都是邪教成员，

     他不是中共党员，

     所以，他不是邪教成员。

     ⑵陈良宇是贪污犯，

     陈良宇是中共党员，

     所以，中共党员都是贪污犯。

     例⑴中的大项“邪教成员”在前提中不周延，在结论中周延，犯了“大项不当周延”的逻辑错误；例⑵中的小项“中共党员”在前提中不周延，而在结论中周延，犯了“小项不当周延”的逻辑错误。

    4，两个否定的前提不能得出结论

    如果两个前提都是否定的，那么小项和大项必然同中项相排斥，这样，中项就不能起到联结大小项的媒介作用，也无法确定大、小项之间的关系，所以，无法推出结论。

例如：

奇数不是偶数；

这些数字不是奇数；

所以，这些数字？

    5，前提中有一否定，结论必否定；结论否定，则必有一前提否定

    如果有一个前提是否定的，根据规则4，那么另一个前提一定是肯定的。在否定的前提中，中项和大项（或小项）的外延是不相容的，在肯定的前提中，中项和小项（或大项）的外延是相容的，由此可见，大、小项之间的外延是不相容的，是互相排斥的，所以，结论只能是否定的。这是三段论中的“质”的规则，我们可以把这条规则称为“三段论的否定规则”，违反这条规则可以称为“违反了三段论的否定规则”。

    例如：

     网大学生都是三退人员；

     张三不是三退人员；

所以，张三是网大学生。

这个三段论正确的结论应该是“张三不是网大学生”，结论必然是否定命题。

     6，两个特称的前提不能得出结论

这条规则是三段论的“量”的规则。

如果两个前提都是特称命题，则前提的组合情况无非三种，即OO；II；IO（OI）。

情况一（OO）：两个前提都是特称否定命题，根据三段论规则4，两个否定的前提不能得出结论；

情况二（II）：没有一个项是周延的。根据三段论规则2犯了“中项不周延”错误，因此不能得出结论；

情况三：（IO或者OI）：前提中有一个是特称肯定命题，一个是特称否定命题，这两个前提中只有一个项是周延的（特否的谓项）。按照三段论的规则，中项在前提中至少周延一次，那么这个周延项必须做中项。但因为有一个前提是否定命题，根据三段论规则5，得出的结论也是否定的，那么结论中（否定命题）的谓项（大项）周延，而大项在前提中是不周延的，这就犯了“大项不当周延”的逻辑错误，同样不能得出结论。

例如（IO）：

有些网大学生是三退人员；

有些中国人不是三退人员；

所以，有些中国人不是网大学生。

这个三段论中，“网大学生”在前提中不周延，在结论中周延，犯了“大项不当周延”的逻辑错误。如果把大前提（命题1）改为“所有网大学生都是三退人员”，则这个推理是个有效推理。

7，前提中有一特称，结论必须也是特称。

这条规则也是关于前提和结论的“量”的规则。

    根据规则6可知，如果有一个前提是特称的，那么另一个前提必定是全称的。即有AI、AO、EI、EO四种情况。第四种情况EO不能得出结论（两个否定的情况）；AI只有一个项周延，这个唯一的周延项必须做中项，那么大、小项在前提中都不周延，只能得出特称肯定命题的结论； AO、EI中有两个项周延。根据三段论规则2，一个周延项必须做中项，再根据三段论规则5（推出结论应是否定命题）和规则3，另一个周延项必须做大项（如果让另一个不周延项做大项，就是结论的谓项，那么在否定命题中，这个谓项是周延的，则违背了规则3）。那么小项在前提中不周延，根据三段论规则3，在结论中也不得周延，所以，只能得出特称命题。

注意：这七条三段论规则，前面五条是基本的，后面两条是推导出来的。前三条是针对词项的，后四条是针对前提的。

【思考题6】

以下三段论是否正确？若不正确，请指出违反哪条规则。

    ⑴斯皮尔博格的电影不是一天能看完的；《侏罗纪公园》是斯皮尔博格的电影；所以，《侏罗纪公园》不是一天能看完的。

    ⑵他是优秀学生；他是农村来的；所以，优秀学生都是农村来的。

⑶所有贪官都是罪犯；他是罪犯；所以，他是贪官。

    ⑷退出中共的党员不再承担中共的血债，胡锦涛没有退出中共，所以，胡锦涛不再承担中共的血债。

⑸故意犯罪应当负刑事责任；张三不需负刑事责任；所以，张三故意犯罪。

    三，三段论的格结构和式结构

1，什么是三段论的格和式

三段论的格就是根据中项在前提中的不同位置所构成的不同形式的三段论。

三段论的式就是前提和结论的质（肯定或否定）量（全称或特称）的组合形式。

不同的格结构中有不同的式结构相匹配，如下图所示（图一）：

 | 格结构
 | 第一格 |  |  | 第二格 |  |  | 第三格 |  |  | 第四格
 | 审判格 |  |  | 区别格 |  |  | 反驳格 |  |  |
大前提 | M——P S——M S——P |  |  | P——M S——M S——P |  |  | M——P M——S S——P |  |  | P——M M——S S——P
小前提
结论
有 效 式 | 大前提 | 小前提 | 结论 | 大前提 | 小前提 | 结论 | 大前提 | 小前提 | 结论 | 大前提 | 小前提 | 结论
 | A A A |  |  | A E E |  |  | A A I |  |  | A A I
 | E A E |  |  | E A E |  |  | E A O |  |  | E A O
 | A I I |  |  | A O O |  |  | A I I |  |  | A E E
 | E I O |  |  | E I O |  |  | E I O |  |  | E I O
 | A A I |  |  | A E O |  |  | I A I |  |  | I A I
 | E A O |  |  | E A O |  |  | O A O |  |  | A E O
 | 全称 | 肯定 |  | 大前提全称，前提中必有一否定 |  |  |  | 肯定 | 特称 |  |  |

（图一）

2，三段论的四种格

⑴第一格：审判格

形式：中项为大前提的主项和小前提的谓项。

M——P

S——M

S——P

格规则：

①小前提必须是肯定的。

②大前提必须是全称的。

作用：从一般推出特殊，一般运用于法庭审判，因为被称为“审判格”。庭审时先用大前提引出法律条文，小前提陈述犯罪事实，结论进行定案。

例如：

凡是贪污公款十万元以上可以处十年以上有期徒刑。

某党委书记贪污公款15万元。

某党委书记应该处十年以上有期徒刑。

    ⑵第二格：区别格

形式：中项为大、小前提的谓项。

P——M

S——M

S——P

格规则：

①前提中必须有一个是否定的。

②大前提必须是全称的。

作用：结论是否定的，可以用于把某事物和一类事物区别开来，因此被称为“区别格”。

例如：

所有参加过共产党与共产党其它组织的 (被邪恶打上兽的印记的)人都需要三退，抹去邪恶的印记。

张三不需要三退。

所以，张三没有参加过共产党与共产党的其它组织。

⑶第三格：反驳格

形式：中项为大、小前提的主项。

M——P

M——S

S——P

格规则：

①小前提必须是肯定。

②结论必须是特称。

作用：结论必是特称，可以用于反驳一个全称命题，因此被称为“反驳格”。

    例如：

    中共是不会改良的。

    中共是邪教。

所以，有的邪教是不会改良的。

⑷第四格：

形式：中项为大前提的谓项，小前提的主项。

P——M

M——S

S——P

格规则：

    ①如果前提中有一否定，则大前提必须是全称。

    ②如果大前提肯定，则小前提必须是全称。

    ③如果小前提肯定，则结论必须是特称。

    ④任何一个前提都不能是特称否定命题。

⑤结论不能是全称肯定命题。

例如：

所有中共党员都是邪教分子。

所有邪教分子都是有罪的。

因此，有些有罪的人是中共党员。

注意：如果一个三段论违反了该格的规则，那么肯定违反了三段论的规则；但是遵守该格的规则，并不一定符合三段论的规则。在运用中，必须同时掌握总规则和各格规则。

    3，三段论的式

三段论有四个格，每一格的大前提、小前提、结论都可以是A、E、I、Q四种命题中的任何一种情况。所以，三段论每一个格的式有4的3次方64个，四个格共有64×4＝256个式（如果考虑单称命题，则共有864个式）。

三段论的每一个式不一定是有效式，比如OOO无论在哪一格中都是无效式，AAA在第一格中是有效式，但是在其它格中则是无效式。

根据三段论的一般规则和每格的具体规则，可以确定出每一格中的有效式，通过计算，三段论的每一格都有六个有效式，每个式都有自己的名称（略），四个格共有24个有效式如下：

    第一格：AAA、EAE、AII、EIO、AAI、EAO

    第二格：AEE、EAE、AOO、EIO、AEO）、EAO

    第三格：AAI、EAO、AII、EIO、IAI、OAO

第四格：AAI、EAO、AEE、EIO、IAI、AEO

弱式：本来可以得出全称命题，却得出特称命题的三段论，这样的三段论称为弱式，它们是第一格的AAI、EAO，第二格的AEO、EAO，第四格的AEO。

偏式：如果前提都为全称，而结论却只能得到特称，这样的三段论也称为偏式，它们是第三格的AAI、EAO和第四格的AAI、EAO。

如果除去弱式和偏式，三段论的有效式为15个。15个有效式和现代逻辑的精神是一致的，因为在现代经典逻辑来看，全称命题并不预设真实的存在，它仅仅相当于一个充分条件的假言命题，前件不必是真命题。因此，从现代经典逻辑的观点来看，全称命题不能推出特称命题，两个全称命题做前提的三段论也不允许推出特称命题来，于是三段论只有15个有效式。

【习题7】请为下列有效式各举一个事例

1，第一格：EAE

2，第二格： EIO

3，第三格： IAI

4，第四格： AEE

【习题8】证明题：利用三段论规则证明以下三段论的具体的格规则

1，第一格的①小前提必须是肯定的。

2，第二格的②大前提必须是全称的。

3，第三格的②结论必须是特称。

4，第四格的③如果小前提肯定，则结论必须是特称。


第四章 复合命题推理(纪要2-1）

授课内容：《形式逻辑》第四章——复合命题推理（上）
上课时间：2008年12月11日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到課老師：唐子
到课同学：慕容患、李大雄、陈清扬、钱不求、張穀虛、华变天、齐学玉、張香山、曲婉蘭、张华虎、安哲、严仁勇、麻生、唐滨、贺大翔
到课同學人数：15人
纪要整理：齐学玉

李后主: 各位同学好。

各位同学: 老师好，各位同学晚上好 。

李后主: 好的，关于复合命题的推理大家看过讲义了吗？

陈清扬: 看过了，觉得这部分理解确实不难。不过要是多个命题夹杂在一起，要应​用就不是很熟练了。

李后主: 其实，你们把命题部分学好了，关于命题的推理也就顺理成章的学好了。好的，我们就从第一个联言推理开始今晚的学习。

慕容患: 看了讲义，理解不难，但是总感觉到智商不够，没有能够做出习题。

李后主: 慕容患总是谦虚。

李后主: 联言推理必须是各个支命题全真，整个命题才能为真，因此，如果一个联​言命题为真，则它的支命题必为真，这就是联言推理的逻辑依据。

李后主: 例如：
张三既是在校大学生，又是我们店里的员工。
所以，张三是我们店里的员工。

李后主: 因为这个推理形式很简单，所以就没有布置习题。下面我们来看选言推理的情况。

李后主: 1，请列举一个相容选言命题的推理。没有完成作业的同学现场可以完成的完成一下。

李后主: 齐学玉的作业：
来网大学习的是网大的学生，或者是渡府的工作人员。
来网大学习的甲同学不是网大的学生，所以他是渡府的工作人员。

陈清扬: 相容选言：他或者是黑人，或者是男人。
推理：他不是黑人，所以他是男人。

李后主: 我们要看看前提是不是相容选言命题。学玉的作业中前提是相容选言命题​，因为在这里学习的可以既是网大的学生，也是渡府的工作人员。

李后主: 陈清扬的这个作业，虽然是对的，但是现实意义不大。一般不这么命题的​。所以，我们学逻辑是为了对现实问题的分析，也要应用的现实中，那么大​家举例时就要做到例子应该是有意义的。

陈清扬: 老师说的对。

慕容患: 上课发言，或者沉默。所以不发言就是沉默。

李后主: 慕容患的这个前提不是相容选言命题，不可能既发言又沉默。这个命题是​不相容选言命题。

陈清扬: 又作了一个。
相容选言：三聚氰胺或者是在奶农挤奶的环节掺入的，或者是厂商在奶粉​制造环节掺入的。
推理：因为三聚氰胺不是在奶农挤奶的环节掺入的，所以三聚氰胺是厂商​在奶粉制造环节掺

入的。

李后主: 好的，清扬的这个例子是正确的。

李后主: 清扬的下面这个例子也是对的：
他或者犯了逻辑错误，或者犯了语法错误。
他没犯逻辑错误，所以，他犯了语法错误。

李后主: 辛言的作业：
这份统计表的的错误，或者是材料有错误，或者是统计上的错误；
材料没有错误；
所以，这份统计表的错误是统计上的错误。

李后主: 辛言的例子也很恰当。

严仁勇: 米可以蒸着吃，也可以烧汤喝，蒸着吃米费时间，所以可以还是烧汤喝。

钱不求: 仁勇的结论是未发生的

李后主: 其他人说吧，看仔细点。请注意，我们现在要求的是：1，请列举一个相容选言命题

的推理。

齐学玉: 仁勇的这个前提应该是不相容选言命题。

李后主: 学玉，好好看看，是不相容选言命题吗？

齐学玉: 错了错了，是联言命题。

李后主: 对了，仁勇的前提是联言命题。

钱不求: 是不好选择，米可以蒸，可以煮，也可以蒸一部分煮一部分。

李后主: 钱不求，你还是没有从逻辑上来理解。

李后主: 仁勇的这个例子是联言命题的推理：
米可以蒸着吃，也可以烧汤喝；
所以，米可以烧汤喝。

李后主: 联言命题的推理就这么简单。

李后主: 好的，我们看看下面第2个习题。
2，请列举不相容选言命题的推理，要求同一内容下分别是“否定肯定式​”和“肯定否定式”。

李后主: 齐学玉的作业：
网大论坛上所发帖子的作者是网大校内人士，或者是关心网大发展的校外​人士。
否定肯定式：这个帖子的作者不是网大校内人士，所以是关心网大发展的​校外人士。
肯定否定式：这个帖子的作者是网大校内人士，所以不是关心网大发展的​校外人士。

李后主: 网大论坛上所发帖子的作者或者是网大校内人士，或者是关心网大发展的​校外​人士。
前提中加一个或者，语句更通顺，逻辑也更完整。

李后主: 这个前提是不相容选言命题。后面的两个推理也都是正确的。

陈清扬: 不相容选言：这个人或者是马列子孙，或者是中华儿女。
否定肯定式：因为这个人不是马列子孙，所以这个人是中华儿女。
肯定否定式：因为这个人是马列子孙，所以这个人不是中华儿女。

李后主: 呵呵，是的，清扬的这个例子是对的。

李后主: 辛言的作业：
1）否定肯定式：
这场火灾起火的原因，要么是有人故意纵火，要么是意外失火；
已查明不是有人故意纵火；
所以，起火原因是意外失火。
2）肯定否定式：
这场火灾起火的原因，要么是有人故意纵火，要么是意外失火；
已查明是意外失火；
所以，起火原因不是有人故意纵火。

李后主: 辛言完成的不错。像这种推理经常运用在案件侦察中。

慕容患: 不相容选言：这道习题，我或者做对，或者做错。
否定肯定式：这道习题没有错，，所以是做对了。
肯定否定式：这道习题错了，所以没有做对。

慕容患: 不相容选言：这道习题，我或者做对，或者做错。
否定肯定式：这道习题没有错，，所以是做对了。
肯定否定式：这道习题错了，所以没有做对。

李后主: 慕容患终于不感到智商不够了。例子举得很不错啊。

李后主: 陈清扬的作业：
她或者是男人，或者是女人。
否定肯定：她不是男人，所以她是女人。
肯定否定：她是女人，所以她不是男人。

李后主: 其他同学可以跟得上吗？应该很好懂！

张华虎: 还好。跟得上。

李后主: 好，我们继续往下看。
3，请列举充分条件假言命题推理，要求同一内容下分别是“肯定前件式​”和“否定后件式”。

李后主: 假言条件句的前件和后件之间有逻辑关系，可以通过确认其中一个的真假​来推导另一个的真假。

李后主: 齐学玉的作业;
如果温度降到零度以下，水就会结冰。
肯定前件式：温度降到了零度以下，所以水结冰了。
否定后件式：水没有结冰，所以温度还没有降到零度以下。

李后主: 学玉的作业完成的很好。首先第一个前提是充分条件的假言命题。后面的​两个推理也都符合要求。

李后主: 辛言的作业：
1）肯定前件式：
如果感冒了，就会发烧；
他感冒了；
所以，他发烧了。
2）否定后件式：
如果感冒了，就会发烧；
他没有发烧；
所以，他没有感冒。

李后主: 辛言的作业也是非常精确。我感觉同学们对日常生活中的事实把握的非常​好。

齐学玉: 其实生活中有很多经常说的话，比如辛言的作业，都是很符合逻辑的，只​是没有学逻辑以前没有注意过其中的逻辑现象。

陈清扬: 充分假言：如果人民从内心抛弃中共，中共立刻就会灭亡。
肯定前件：因为人民从内心抛弃了中共，所以中共立刻就会灭亡。
否定后件：中共没有立刻灭亡，可见人民并未完全从内心抛弃了中共。

李后主: 清扬的这个例子也不错。

慕容患: 如果是月圆之夜，就是皇历的望日。
肯定前件式：今夜月圆，所以是望。
否定后件式：今夜娥眉月，所以不是望。

李后主: 那么，大家想一想，如果反过来讲就不对了，比如把辛言的例子修改一下​：
如果感冒了，就会发烧；
他发烧了；
所以，他感冒了。

李后主: 慕容的这个例子有什么问题，大家发表一下意见。

齐学玉: 慕容的这个是个简单命题吧。是不是可以这样：月圆之夜是皇历的望日。

李后主: 不是简单命题，是复合命题中的条件命题。大家学到这里了，不要连简单​命题和复合命题还分不清楚。

张华虎: 应该不是望日，所以不是月圆。

李后主: 华虎看到了，否定后件式不是否定了后件，而是否定了前件。

李后主: 慕容的例子还有没有问题呢？

张华虎: 二者全同。

李后主: 华虎又说对了，这个命题是充分必要条件的命题，不是充分条件命题。

陈清扬: 后件是假言命题的结果部分，否定后件式的推理方式是指，通过给出后件​“今日望”的负命题“今日非望”来得出新命题，前件否定的结果“今夜非​月圆”。

陈清扬: 而且这个应该是充分必要条件假言命题。

慕容患: 我抄的这句话：如果温度降到零度以下，水就会结冰。
慕容患: 如果是月圆之夜，就是皇历的望日。

慕容患: 我是照猫画虎的。

李后主: 慕容患只管抄形式，不管其中的逻辑关系，这样学是学不好的，就是要你​分析其中的逻辑关系的，首先你得分析日常事物和现象之间的联系是什么。

李后主: 要照猫画猫才行。

严仁勇: 照猫画虎----
如果挤公交车的人多，我就坐出租
肯定前件式：今天坐公交车的人少，我就座公交；
否定后件式：今天我没有座公交，因为人太多。

李后主: 仁勇啊，刚说了，让你照猫画猫，你又来画虎了，我们这里不需要虎。

李后主: 肯定前件式中否定了前件。否定后件式中否定的既不式前件也不是后件，​看来照猫画虎也没画成，画得不知道是什么四不像了。

陈清扬: 假言支：一个作为原因的称为“前件”；一个作为结果的称为“后件”。​）比如“如果挤公交车的人多，我就坐出租”，前件是“挤公交车的人多”​，后件是“我就坐出租”。
肯定前件式：因为挤公交车的人多，所以我就坐出租。
否定后件式：我没坐出租，所以挤公交车的人多。

李后主: 清扬：
否定后件式：我没坐出租，所以挤公交车的人不多。

张华虎: 否定后件式：我没坐出租，所以挤公交车的人多。——挤公交的人不多。

陈清扬: 确实，光顾复制了，多谢老师和同学指正。

麻生: 1）肯定前件式：
如果自由门找到服务器，就会打开动态网主页。
他打开了动态网主页，所以自由门找到了服务器。
2）否定后件式：
如果打开了动态网，自由门就找到了服务器。
如果自由门找不到服务器，所以打不开动态网主页。

李后主:华虎和我想到一块了。 大家看看麻生的，帮助麻生修改一下。

齐学玉: 1）肯定前件式：
如果自由门找到服务器，就会打开动态网主页。
自由门找到了服务器，所以打开了动态网主页。

李后主: 学玉把肯定前件式给修正过来了。

陈清扬: 前件：自由门找到服务器，后件（浏览器）会打开动态网主页。
肯定前件：因为自由门找到了服务器，所以（浏览器）打开了动态网主页​。
否定后件：因为（浏览器）没打开动态网主页，所以自由门没找到服务器​。

李后主: 清扬你不能说前件是什么，后件是什么，当然你认为麻生的前提是对的，​但是要注意逻辑形式的严格。

麻生: 我也没画对。

李后主: 没有“如果”两个字来联结这个前件和后件，那么就不是假言条件命题了。

李后主: 麻生，你还要注意你的例子中的最后一句话：
2）否定后件式：
如果打开了动态网，自由门就找到了服务器。
如果自由门找不到服务器，所以打不开动态网主页。
这里不能再用如果了，结论不能还是一个假言条件命题，而是要出现一个​确证的结果了。

麻生: 哦，明白了。

李后主: 所以，麻生的例子修正后的正确形式如下：
如果自由门找到服务器，浏览器就会打开动态网主页。
肯定前件：因为自由门找到了服务器，所以浏览器打开了动态网主页​。
否定后件：因为浏览器没打开动态网主页，所以自由门没找到服务器​。

赵阳光: （1）肯定前件：
如果上不了网，就不能按时上课。
上不了网；
所以，没能按时上课。

（2）否定后件：
如果上不了网，就不能按时上课。
按时上课了；
所以，可以上网。

李后主: 阳光的例子也正确，不过涉及到负复合命题了。

李后主: 不对，我说错了，没有涉及到负复合命题。我也有时犯糊涂啊！呵呵！

李后主: 好的，我们继续看看第4个习题。
4，请列举必要条件假言命题推理，要求同一内容下分别是“否定前件式​”和“肯定后件式”。

李后主: 齐学玉的作业：
只有施行仁政德治，国家才会实现长治久安。
否定前件式：秦朝没有施行仁政德治，所以没有实现长治久安。
肯定后件式：唐朝实现了长治久安，是因为唐朝施行仁政德治。

李后主: 注意要用完整的逻辑形式来表达，所以最后面的一句可以修改为：
唐朝实现了长治久安，所以，唐朝施行了仁政德治。

齐学玉: 没想到还有这么细致的区分啊，谢谢老师指出来。

李后主: 汉语中有“了”的地方，一般都是肯定句，否定句中不出现“了”。所以​，你们要学会使用标准的逻辑形式来表达命题。

李后主: 学玉，仅仅这么一句【唐朝实现了长治久安，是因为唐朝施行仁政德治。​】是没有任何问题的，但是把它放到我们需要的肯定后件式的例子中来就不​符合逻辑要 求了。所以，你们在举例时，要注意同样的意思，必须使用特定的词语和句式（​不能随意使用）才能使它符合一定的逻辑形式。

麻生: 只有上网上才可以登陆QQ
否定前件式：没有连接上网，所以不能登陆QQ。
肯定后件式：登陆了QQ，所以连接上网络了。

李后主: 这样就对了。

陈清扬: 必要假言：中国人只有三退，中国人才能走向未来。
否定前件：因为中国人不三退，所以中国人无法走向未来。
肯定后件：因为中国人能够走向未来，所以是三退的中国人。

李后主: 那么，看看清扬上面举的那个中国人的例子吧！这个例子中后面不要出现​中国人，而是出现“这个中国人”就比较通顺一些。

陈清扬: 谢谢老师指正。

李后主: 中国人只有三退，中国人才能走向未来。
否定前件：这个中国人不三退，所以这个中国人无法走向未来。
肯定后件：这个中国人能够走向未来，所以这个中国人三退了。

清扬再注意一下“了”字的用法。当命题中需要出现肯定句时，你们要学​会使用“了”，不要用因为所以，那样容易把逻辑形式走偏。使用标准的联​结词就不会把逻辑走偏，你这个例子还没有太偏，但是前面学玉讲唐朝的那​个例子，后面那句使用“因为”来联结的句子就走偏了。

陈清扬: 好的，我会再仔细琢磨一下。

严仁勇: 只有推翻了中共，中国才有希望
否定前件：如果不推翻中共，想让中国变强大是不可能的。
肯定后件：中国将来变强大了，是因为推翻了中共。

李后主: 仁勇啊，第2句中又来一个“如果”，想想是什么问题？

齐学玉: 推理是为了得到结论，不是要另一个推理。

麻生: 出现如果，就不是必要条件命题了。

严仁勇: 对！又错了。

李后主: “如果”（这 个词）是假言条件命题的联结词，我们讲假言条件命题推理​，第一句是假言​条件命题，是作为前提的，后面的要分别肯定或者否定它​的一个前件或者后​件， 然后来推理另一个前件或者后件的真假，那么，后​面的肯定否定过程中​，怎么还能出现如果呢？要么是肯定，要么是否定，​板上钉钉的事情，含糊​不得。

李后主: 前面讲的不相容选言命题作为前提的推理中，下面是要肯定或者否定一个​支命题，从而来推理另一个支命题的真假，所以有肯定否定式和否定肯定式​。现在讲的 假言条件命题推理，是要肯定或否定一个件（前件或者是后件）​，来推理另一个件（前件或者后件）的真假。在选言命题和联言命题中，分​支叫做支命题，在假 言条件命题中，分支叫做前件和后件。

慕容患: 我尽量简单，大家不要(*^﹏^*) 我。
水是维持人生命的必需品。
否定前件式：没有水，人的生命不能生存。
肯定后件式：有水，人才能生存。

陈清扬: 慕容的这个命题有点过于简单:P是个简单命题，不是复合命题。

陈清扬: 我想可以改为：
只有保持足够的水分摄入，人才能够生存。
否定前件式：没有足够的水分摄入，人就无法生存了。
肯定后件式：因为这个人生存下来了，所以他保持了足够的水分摄入。

李后主: 陈清扬，后面的一句把“因为”去掉。这样逻辑更严格一些。

陈清扬: 改为：这个人生存下来了，可见他保持了足够的水分摄入。似乎更通顺点​。谢谢老师指正。

李后主: 肯定后件式：
只有保持足够的水分摄入，人才能够生存。
这个人生存下来了，所以他保持了足够的水分摄入。

陈清扬: 水和空气是维持人生命的必需品。我认为也是简单命题，虽然也可以拆开​作为联言命题：
水是维持人生命的必需品，空气也是维持人生命的必需品。
不过恐怕还不是假言复合命题。

李后主: 陈清扬对慕容患的前提的分析是完全正确的。

李后主: 所以，可见，这两个词都行。但是前面使用“因为”这个词来联结就把整​个推理过程淡化了，我们的结论不是光从这个前件中来，而是从作为前提的​条件命题中来的，你明白了吧！

陈清扬: 老师说的很对，这一句令我豁然开朗。

李后主: 结论是由两部分来得出的：
1，前提
2，肯定的前件。
你使用“因为”一词，在逻辑上就给人只有这个前件得出了这个结论。

齐学玉: 明白了，本来以为复合命题推论比较简单。不知道还有这些细节且很重要​的问题。

陈清扬: 这个细节我确实也没有注意到，但也的确很重要。

李后主: 学玉，你上面所犯的错误也在这里。
既然是推理，就是一个逻辑联结相当严密的过程，不能中途插进其它东西​。

齐学玉: 是的，刚才还不是很明白，现在明白了。

李后主: 你们俩都是中途插进了一个原因，把原来的前提给冲淡或者有时候就冲走​了。逻辑是个非常细致的东西，你们要好好去悟。你们不出这些问题，我也不​会讲到这些东西，因为你们出问题了，我才能看出来是什么问题。

唐子: 精确思维就是这样练出来的，不这样我们根本没法讨论问题。

严仁勇: 逻辑课就这样的，这个课对“粗”人是很为难的。

李后主: 所以，你们要多发言，多做作业，这样才能发现大家平时没有注意到的逻​辑问题。

齐学玉: 谢谢老师，又学了一招。

陈清扬: 是啊，这点我想到了下一课《多重复合推理》中可能会更明显，如果老师​现在没指出，可能到那时我们的问题会更多。

李后主: 是的，你们所犯的各种错误都会反过来帮助我们把这个原理或者推理理解​得更透彻。

慕容患: 我也推论了一次，呵呵。

李后主: 我比你们强的地方不在于我不犯错误，而在于我一旦犯了错误，我能在最​短的时间内发现这个错误。我就比你们强这么一点而已。

严仁勇: 能在最​短的时间内发现错误，这也是功底的体现。

唐子: 多出错误有好处的。我学逻辑的时候，就经常犯错误。这种错误只会越犯​越少的。如果不犯，到老还不断地犯。

唐子: 课堂上犯错误，课外就会比较少犯。

李后主: 大家在一起学习真不容易，我们都是能很快接受自己错误的人，所以才能​在一起学习。那些被指出错误而不能很快明白和接受的人，就不能融合在这​里。

慕容患: 我也明白了。有时候习题中出现错误，反而对大家都有益处，所以大胆的发言也是对大​家有益处的。

李后主: 为什么有些人不能明白自己的错误，即使给他指出来，也不明白，我想如​果是太笨的人我们也不屑给他指出，通常都还是聪明人，但是就是不明白，​这种原因，我想是因为他们把自己摆得太高了。

严仁勇: 嗯 后主老师说的这番话，很中听！

慕容患: 学习需要谦卑的心，固执己见是高傲的心在左右。

齐学玉: 越来越感到逻辑需要很精细的思维，学习逻辑对于梳理一下自己的思维是​很有好处的。

唐子: 指出逻辑错误，对于中国男人来说是件要命的事。呵呵……

李后主: 说了几句题外话，我这是感慨啊。以后中共解体了，我们一起开创出来的​这种网络授课方式还要存在的。这种学习方式要成为一个非常重要的学习方​式。用我们 的这种学习方式来改造现有的网络文化，是不是一种好方法呢？​未来，让很多人上网不再浪费在玩游戏和聊天发贴乱骂中，而是来网络课堂​学习，希望未来我们 的学生能多开一些网络课堂引领时代风潮。

李后主: 好的，我们继续看第5个习题。
5，现有充要条件假言命题“当且仅当奉行反人类教义并且违背自然规则​的宗教才是邪教”，请列举出它的四种推理形式下的不同推理过程。

李后主: 齐学玉的作业：
当且仅当奉行反人类教义并且违背自然规则的宗教才是邪教。
肯定前件式：中共奉行反人类教义并且违背自然规则，所以中共是邪教。
否定后件式：儒教不是邪教，所以儒教没有奉行反人类教义并且没有违背​自然规则。
否定前件式：儒教没有奉行反人类教义并且没有违背自然规则，所以儒教​不是邪教。
肯定后件式：中共是邪教，所以中共奉行反人类教义并且违背自然规则。

陈清扬: 肯定前件：因为这个宗教是奉行反人类教义并且违背自然规则的，所以这​个宗教是邪教。
肯定后件：因为这个宗教是邪教，所以这个宗教是奉行反人类教义并且违​背自然规则的。
否定前件：因为这个宗教不是奉行反人类教义并且违背自然规则的，所以​这个宗教不是邪教。
否定后件：因为这个宗教不是邪教，所以这个宗教不是奉行反人类教义并​且违背自然规则的。

李后主: 陈清扬，你把“因为”都去掉再看看。

陈清扬: 这是作业，不过很明显还是没有达到老师的要求。

陈清扬: 去掉因为很容易，不过再发一次会影响后来者的阅读，我就不重发了。

李后主: 知道就行了。

李后主: 辛言的作业：
1）肯定前件式：
当且仅当奉行反人类教义并且违背自然规则的宗教才是邪教；
共产党是奉行反人类教义并且违背自然规则的宗教；
所以，共产党是邪教。
2）否定后件式：
当且仅当奉行反人类教义并且违背自然规则的宗教才是邪教；
儒、释、道不是邪教；
所以，儒、释、道不是奉行反人类教义并且违背自然规则的宗教。
3）否定前件式：
当且仅当奉行反人类教义并且违背自然规则的宗教才是邪教；
儒、释、道不是奉行反人类教义并且违背自然规则的宗教；
所以，儒、释、道不是邪教。
4）肯定后件式：
当且仅当奉行反人类教义并且违背自然规则的宗教才是邪教；
共产党是邪教；
所以，共产党奉行反人类教义并且违背自然规则。

李后主: 这个习题，大家完成的都不错。

齐学玉: 辛言推理的形式很标准。

陈清扬: 辛言的推理确实很标准，我也学到了。

李后主: 学玉，你们是节省版面，把形式省略了。但是，你们一省略形式，就把前提慢慢给忽略了，就在推理中加入一些“​因为”之类的联结词，使前提到结论的逻辑过程出现阻滞现象。

齐学玉: 是的，错误就出在这里，少了完整的推理形式，又想让结论更合理，所以​就加了因为。

李后主: 大家看看，这种推理也是三段形式的，但是不能叫三段论。

陈清扬: 非直言命题，不过修改一下可以改成假言三段论。

李后主: 三段论是有包含大项，中项，小项的命题之间形成的推理形式，不是有三​段的推理就是三段论，必须要有中项联结的三段推理才是三段论。

李后主: 负复合命题的推理，大家自己看一看，作为自学内容，课堂上我们就不讲​了。

李后主: 好的，今天的课程就讲到这里吧！

师生互道晚安。


第四章 复合命题推理(纪要2-2）

授课内容：《形式逻辑》第四章——复合命题推理（下）
上课时间：2008年12月18日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到课老師：唐子
到课同学：蓝睿、李大雄、陈清扬、钱不求、張穀虛、华变天、齐学玉、張香山、 赵阳光、张华虎、杨显刚、严仁勇、麻生、黄豆芽、贺大翔、浩然、罗同
到课同学人数：17人
纪要整理：齐学玉

李后主:大家好。

各位同学：老师好，各位同学晚上好。

李后主: 好的，我们开始上课。今晚的内容好像比较难，我看了一下作业，多是能完成一半作业。我的讲义三天前就上传了，大家有没有仔细研读呢？

陈清扬: 简单构成/破坏的二难例子确实很难举。

齐学玉: 读能读懂，举例子却举不出来。

李后主: 二难推理，我理解是必须要构成二难的选择，或者自相矛盾，或者是哲学​中的二律背反问题，才能称为是二难推理。而把假言选言推理的形式理解为二难推理是不 正确的，然而你们读身边那​些逻辑学教材，很多书上都把二者混为一谈。所以，我就列举一些假言选言推理的有效逻辑形式，但是它们却不属于以​上所说的三种 二难的情况。那么这样的推理怎么能叫二难推理呢？所以，很​多逻辑学教材在这个方面，我认为他们都是错的。

陈清扬: 我理解老师说的第一种二难推理是具有“牵扯到价值判定（道德层面）的​逻辑判定”特点的假言选言推理。

李后主: 我说的是假言选言推理和二难推理不是等价的。 没有讲到什么第一种和第二种的问题。

李后主: 假 言选言推理是由两个充分条件假言命题和一个二支选言命题为前提的演​绎推理。根据结论是直言命题还是选言命题，假言选言推理可以分为简单的和复杂​的两 种；又根据选言前提的选言支分别是肯定假言前提的前件还是否定假言​前提的后件，假言选言推理又分为构成式和破坏式。这样总共可以得到假言​选言推理的四 种形式：简单构成式、简单破坏式、复杂构成式和复杂破坏式​。

李后主: 比如：一个简单构成式的推理如下：
如果p，那么q；
     如果r，那么q；
   或者 p或者r；
     所以，q。

李后主: 如果我们要解体中共，那么我们必须首先三退（从组织上瓦解它）；
如果我们要复兴中华，那么我们必须首先三退（从灵魂上清除党的邪恶印​记）；
我们或者要解体中共，或者要复兴中华；
所以，我们都必须首先三退。

李后主: 这个例子是简单构成式的推理形式，但是它不是二难推理。因为它没有出​现二难的情况啊，所谓二难的情况就是左右为难，我上面归纳了三种情况：​1，二难的选择，2，自相矛盾，3，哲学​中的二律背反问题。

李后主: 那么，我们看一个二难推理的例子：
例如，中世纪一些神学家提出的“上帝全能”的思想，结果被反对者提出​这样一个问题“全能的上帝能否创造出一块连他自己也搬不动的石头？”这​个问题展开来就是一个二难推理，如下：
如果上帝能创造出这样一块石头，那么上帝就不是全能的（因为上帝至少​还有一块石头搬不动），
如果上帝不能创造这样一块石头，那么上帝也不是全能的（因为上帝至少​还有一块石头不能创造），
上帝或者能创造这样一块石头，或者不能创造这样一块石头，
总之，上帝不是全能的。

李后主: 这种形式是：
如果p，那么q；
如果非p，那么q；
所以，q。

張香山: 不管怎么选择，上帝都不是全能的。

李后主: 这是简单构成式中的二难推理形式，叫做归约律，就是从两个相反的命题​出发推出同一个结论。这就构成了一个内在矛盾的关系。所以，我说假言选言推理不一定就是二难推理，二难推理只是假言选言推​理中的一种特殊形式。这是我的观点。

李后主: 这是本次课程的关键点，因为我说了，你们看到的其它逻辑学教材中都是​把二者混为一谈的，那么这里我提出了不同的观点。

李后主: 好了，这是开场我们要交代的一个问题。下面我们通过做习题来进一步理​解这部分内容。

李后主: 6，列举两个简单构成式的假言选言推理，要求其中一个为二难推理。

李后主: 陈清扬的作业：
如果你是学生，那么你应该来学校。
如果你是老师，那么你应该来学校。
你或者是学生，或者是老师；
所以，你得来学校。

李后主: 大家来看这个推理，有什么不妥之处吗？

钱不求: 某人可能不是学生也不是老师

严仁勇: 没问题.符合要求.

齐学玉: 应该是选言支没有穷尽。

李后主: 任何一个推理必须逻辑充分，让人读后感觉到的确是这样，应该是如此，​如何不能给人这样的感觉，那么这个推理肯定有问题。逻辑的表现方式可以通过一定的形 式来体现，但是它不仅仅是形式，它更​是内容，光顾着去符合形式，不顾实际的内容的表达，那么学了逻辑学还是​不能应用到实际中来提高语言的使用水平，那 么，这就是空学了理论，没有​学到家。

钱不求: 问题是不是在于“来学校”的原因没有说清楚？

李大雄: 除了老师和学生外，还有人即不是老师，也不是学生，这部分人就不是一​定要来学校的了。

张华虎: 没看出清扬例子的毛病。也许是不求说的问题吧。

李后主: 是的，同学们看出了这个作业中，选言支没有穷尽。大家要给出一段推理​就必须要让人信服，否则一定是哪个地方出了问题。陈清扬的那个作业就是没有表达出完整的逻辑内容。

陈清扬: 选言命题的选言支穷尽我一直没理解好。

李后主: 再看看陈清扬的下面这个作业：
如果你是白种人，那么你是人类。
如果你是有色人种，那么你是人类。
你或者是白种人，或者是有色人种。
所以，你一定是人类。

李后主: 大家看看，我们平时有这么推理的吗？

張香山: 没有 。一个选言支 包涵了另一个选言支 的错误吧。

严仁勇: 没有,清扬可以说具体一点.

李后主: 难道逻辑就是一种空头的东西，就不是实际了？能这么推理吗？这样理解​逻辑就理解偏了，我告诉大家逻辑就是实际就是有效的内容，它不是远离生​活的东西。你要搞出一个与生活与哲学问题的思考没有关系的形式出来，那​就不是逻辑。

李后主: 用从属关系的概念来构建两个推理，这没有必要。这和我后面讲的循环构​造有点类似，就叫它重复构造吧！

陈清扬: 谢谢老师指正。

李后主: 齐学玉的作业：
（1）如果给他做手术，他会尽快好起来；
如果给他化疗，他会尽快好起来；
或者给他做手术，或者给他化疗；
所以，他会尽快好起来。

李后主: 化疗和手术不同，是两个概念，所以这个推理是有效的。这是一个非二难推理的假言选言推理，是简单构成式。

李后主: 看看学玉的下面这个二难推理的例子：
（2）二难推理：

如果岳云在这场宋、金之战中能活着回来，那么岳飞会欣慰的；（因为对​一个将军来说，保家卫国、凯旋而归是一种荣耀，作为岳云的父亲，岳飞会​欣慰的。）
如果岳云在这场宋、金之战中不能活着回来，那么岳飞会欣慰的；（因为​对一个将军来说，保家卫国、战死沙场是一种荣耀，作为岳云的父亲，岳飞​会欣慰的。）
岳云或者能活着回来，或者不能活着回来；
岳飞都会欣慰的。

李后主: 我想，这不能叫二难了，应该叫二喜了。学玉的这不是二难推理。而且与事实不符合。

李后主: 张华虎的这个例子（非二难推理的简单构成式）也是正确的：
1） 如果复兴中华，就要先解体党文化；（思想道德上）
如果救民于水火，就要先解体党文化。（经济、政治上）
我们或者要复兴中华，或者要救民于水火；
所以，我们必须先解体党文化。

李后主: 辛言的也是正确的：
1）简单构成式：
如果我们要在中国实现主民化，那么必须解体中共；
如果我们要复兴中华文化，那么必须解体中共；
我们或者要在中国实现民主化，或者要复兴中华文化；
所以，我们必须解体中共。

钱不求: 或者你为了学知，你要好好学习
或者你为了求识，你要好好学习
你或者学知，或者求实，
总之你都要好好学习。

如果你是穷人，你吃饭的量只要填饱肚子就可以了
如果你不是穷人，你吃饭的量只要填饱肚子就可以了
你或者是穷人，或者不是穷人
你吃饭的量只要填报肚子就可以了。

李后主: 不求，你的第一个例子是假言选言推理，但是第2个不是二难推理。

李后主: 穷人可以推导出吃饭只要填饱肚子就行了吗？这能推理出来吗？这个条件​句是假的，是假命题。条件句必须要真实啊。前提都不真实，还怎么往后面推呢？只顾整体的面​子，忘了里子了？

李大雄: 如果中共迫于外界压力实施改良，无异于自取灭亡。如果中共坚决不改良​，也无异于自取灭亡。

李后主: 大雄的这个例子可以整理成一个有效的二难推理形式。

齐学玉: 如果中共实施改良，无异于自取灭亡；
如果中共不实施改良​，也无异于自取灭亡；
中共或者实施改良或者不实施改良；
所以中共都会自取灭亡。

齐学玉: 大雄的那个改了下形式。

李后主: 学玉改得正确。大雄举得例子正确。就应该这样寻求有效的事实来举例，​怎么能为举例而举例呢？

李后主: 关于我上面指出的这些问题，其他同学看明白了吗？

钱不求: 如果你是穷人，你吃饭的分量只需要能满足身体需求就可以了
如果你不是穷人，你吃饭的分量只需要能满足身体需求就够了
你或者是穷人，或者不是穷人
你吃饭的分量只需要能满足身体需求就够了

李后主: 呵呵，不求，吃饭满足不满足身体的需要和穷人还是不是穷人没有直接联​系，不能把二者联系在一起，不能理解吗？这不是有效的充分条件命题。

齐学玉: “所谓二难的情况就是左右为难，我上面归纳了三种情况：​1，二难的​选择，2，自相矛盾，3，哲学​中的二律背反问题。”

齐学玉: 开始没有注意到老师这句话，也就没有理解二难推理的实质是要出现左右​为难的情况。

李后主: 好了，我们还是先学一学什么情况下是假的二难推理。假二难推理一般有三种情况，如下：
1，假二难推理的前提不真实
又分为两种情况：一是前提不是真实的充分条件假言命题；二是前提中的​选言命题选言支没有穷尽。

李后主: 例如：
⑴如果你是聪明人，那么就不用学逻辑学（因为聪明人不需要学逻辑学）​；
如果你是笨人，那么也不用学逻辑学（因为笨人学不好逻辑学）；
你或者是聪明人，或者是笨人；
总之，你都不用学逻辑学。

李后主: 这个假二难推理的假言前提不真实，聪明人和笨人不需要学逻辑学都不是​真实的充分条件假言命题。

李后主: ⑵如果天气冷，那么人会难受；
如果天气热，那么人也会难受；
天气或者冷或者热；
所以，人总是会难受。

李后主: 这个假二难推理的选言前提的选言支没有穷尽，因为除了天气热和天气冷​两种情况以外，还有天气不冷不热的情况。

钱不求: 是啊。

李后主: 以上所讲的是前提不真实的情况，大家构建复合命题推理，是在复合命题​的基础上构建起来的，首先要求复合命题正确，才能构建出整体的一组推理​过程。那么二难推理是在充分条件假言命题和选言命题的基础上构建起来的​，首先你必须让那两个复合命题是真命题才行。

李后主: 好的，还有两种情况，我们在完成习题的过程中再去理解。

李后主: 好的，第6个作业题的情况总结一下。除了现场李大雄举出一个二难推理​的例子外，其他同学都没有举出适合的例子。

李后主: 7，列举两个简单破坏式的假言选言推理，要求其中一个为二难推理。

李后主: 陈清扬的：
如果天下雨了，那么地面会湿。
如果天下雨了，那么气温会降低。
地面没湿，或者气温没降低；
所以没下雨。

李后主: 作为一个复杂构成式的例子是正确的。

李后主: 陈清扬的二难推理的例子：
如果中国现在的官员还有为善的空间，（那么为了缓解灾区人民疾苦），​就应该拨款重建灾区。
如果中国现在的官员还有为善的空间，（那么为了款项不被腐败党官层层​瓜分而达不到实际效果），就不应该拨款重建灾区。
所以，中国现在的官员没有为善的空间。

李后主: 这个推理还是很有问题，意思我看出来了，但是逻辑推理的表达没有表达​出来。

李后主: 齐学玉：

如果他的病灶转移了，那么化验指标不会在正常范围之内；
如果病灶转移了，那么他的健康状况会恶化；
或者化验指标在正常范围之内，或者他的健康状况没有恶化；
所以，他的病灶没有转移。

李后主: 学玉的这个例子也算合乎要求。

李后主: （2）二难推理：
在一次明显是有预谋的杀人案中，律师为其当事人辩护。
律师：如果他是杀人犯，那么他会有杀人动机；
如果他是杀人犯，那么杀人凶手和死者将是夫妻关系，而根据各方面的调​查来看，他们夫妻二人感情和睦，也没有经济上或其它方面的纠葛，显然，​他没有杀人动机；
所以他不是杀人犯。

李后主: 这个例子应该在开始时交代案件的基本情况，然后再进行推理，要前提说​明二人是夫妻关系以及很和睦。

李后主: 当然学玉的这个推理形式是正确的。

钱不求: 如果你是好警察，那么你不会欺骗好人
如果你是好警察，那么你不会殴打好人
你欺骗好人，殴打好人
所以你不是个好警察

如果共产党不是邪教，只是一般政党，那么它不会要人入党时发毒誓
如果共产党不是邪教，只是一般政党，那么它不能靠一般的政党形式维持​它的统治，而是让人入党时发毒誓
可见，共产党是邪教

李后主: 呵呵，不求看看你这个命题：
如果共产党不是邪教，只是一般政党，那么它不能靠一般的政党形式维持​​它的统治，而是让人入党时发毒誓

钱不求: 改成：如果共产党不是邪教，只是一般政党，那么它可以靠一般的政党形​式维持​​它的统治，而它靠的却是让人入党时发毒誓。

李后主: 这怎么能推出来呢？你不是在造假，就是在把一般政党改造成邪教。

钱不求: 改成：如果共产党不是邪教，只是一般政党，那么它可以靠一般的政党形​​式维持​​它的统治，而它却不是靠一般的政党形式，是让人入党时发毒​誓。

李后主: 钱不求啊，你的第2句话应该是一个假言命题推出一个结论来，不是推了​一个结论，又列举一个事实，最后以事实取代推导出的结论。

钱不求: 明白了

李后主: 那你直接就说中共不是普通政党，何必这么麻烦呢？逻辑要是这么麻烦，​像过裹脚女人，谁愿意学逻辑呢？你要是这么出去给人家讲逻辑，不都把人​家讲跑了。

李后主: 你们举例子时，好好想想，这样的例子会不会启发人们的思维，不能仅仅​急着完成作业。

李后主: 非二难推理的例子，大家都能找到。
张华虎的下面这个也是对的。
7，列举两个简单破坏式的假言选言推理，要求其中一个为二难推理。
1) 若要成为当今时代优秀的中华儿女，就要先参与解体党文化（思想上）
若要成为当今时代优秀的中华儿女，就要先参与解体中共（经济、组织上​）
这些人或者不能参与解体党文化，或者不能参与解体中共；
所以，这些人不是当今时代优秀的中华儿女。

李后主: 当然略有小问题，可以修改一下：
7，列举两个简单破坏式的假言选言推理，要求其中一个为二难推理。
1) 若要成为当今时代优秀的中华儿女，就一定要参与解体党文化（思想上）
若要成为当今时代优秀的中华儿女，就一定要参与解体中共（经济、组织​上）
这些人或者没有参与解体党文化，或者没有参与解体中共；
所以，这些人不是当今时代优秀的中华儿女。

李后主: 华虎的例子中，先参与，先参与，两个先参与给人矛盾的感觉，逻辑上不​清晰。人们会说，到底是先参与解体党文化，还是先参与解体中共。所以，你们​说话时要注意这些细微的逻辑细节。

杨显刚: 如果共产党不是邪教，只是一般政党，那么它就不会要靠杀戮、迫害、封​锁来限制人民自由民主。
如果共产党不是邪教，只是一般政党，那么它可以靠一般的政党形式维持​​它的统治，让人民像西方那样的自由民主，它既不让人自由民主，又要靠​杀戮、迫害、封锁来维持​它的统治，所以共产党是邪教。

李后主: 杨显刚，你说的完全正确，可是不是我们要的这种推理形式。

杨显刚: 呵呵，答不对题。

李后主: 看看我讲义中的例子;
如果没有神，一切都是随机过程，那么自然界不具有设计和创造的能力；
如果没有神，一切都是随机过程，那么人是自然界随机产生的。因为人具​有设计和创造的能力，因此自然界产生了设计和创造的能力，而没有设计和​创造能力的事物不可能产生出具有设计和创造能力的事物，可见，自然界具​有设计和创造的能力。
因此，一切不都是随机过程，存在着更高级的生命——神。（一切由神来​设计和安排）

李后主: 注意看第2句话，完全都是推理，最后推出自然界具有设计和创造的能力​。这种推理的规律是，内部一定包含一个矛盾，你们要把矛盾在第2个命题​中展开来，推出一个与第一个前提相反的结论来。

李后主: 事实是用来推理的，必须还原到推理中去，才能形成逻辑环节，仅仅一个​事实，它不能成为逻辑的环节，而要成为逻辑的环节，就得依靠你这个逻辑​思维得运用者去使用这个事实。
上面的例子中，我就是使用了“人具有设计和创造的能力”这个事实，然​后根据前面的“人是自然界随机产生的”这个前提，推导出“自然界具有设​计和创造的能力”。
这其中，都是一个环节一个环节往下推导的。

李后主: 你们在推理方面往往把逻辑环节给遗漏掉，不合理的使用了事实，或者不​是把事实融合成一个推理过程中的逻辑环节。这其中微妙之处，需要你们去​慢慢体会。

李后主: 辛言的作业：
2）二难推理：
如果中共讲民主，那么就要开放言论自由；
如果中共讲民主，那么就不要禁止言论自由；
中共或者不开放言论自由，或者禁止言论自由；
所以，中共不讲民主。

李后主: 这不是重复构造吗？这样说话累不累，逻辑是一种智慧，大家要这么说话，逻辑变成什么了？

钱不求: 这样讲话太累了，呵呵。

李后主: 8，列举一个有效的复杂构成式的二难推理。

李后主: 陈清扬：
8，列举一个有效的复杂构成式的二难推理。
如果中国现代的民营企业借高利贷来维持企业运转，那么长远的发展一定​很困难，短期的发展会顺利。
如果中国现代的民营企业不借高利贷来维持企业运转，那么短期的发展一​定很困难，长远的发展会顺利。
或者借，或者不借高利贷；
所以，或者长期，或者短期发展困难。（或者短期，或者长期发展顺利）
（总之，中国民营企业发展都困难/总之，中国民营企业发展都顺利）

李后主: 这个例子还可以。

李后主: 学玉：
8，列举一个有效的复杂构成式的二难推理。
如果他做手术，那么他要承担高昂的手术费；
如果他不做手术，那么他将会出现生命危险；
他或者做手术，或者不做手术；
所以，他或者要承担高昂的手术费，或者会出现生命危险。

李后主: 这个例子也很恰当，是生活中很普遍的二难选择的情况。

钱不求: 如果他说真话，那么他将入狱
如果他不说真话，那么他将内疚
他或者说真话或者不说真话，
他要么入狱，要么内疚。

李后主: 好的，不求的这个例子举得正确。

李后主: 辛言：
8，列举一个有效的复杂构成式的二难推理。
如果胡锦涛顺应天意解体中共（p)，那么中共会反对(不拥护）他（非​q），人民会拥护他（s)；
如果胡锦涛不顺应天意解体中共(非p)，那么人民会反对(不拥护）他​(非s)，中共会拥护他(q)。
胡锦涛或者解体中共(p)，或者不解体中共(非p)；
所以，胡锦涛或者得到人民的拥护(s)，或者得到中共的拥护(q)(​胡锦涛或者得到中共的反对，或者得到人民的反对)。

李后主: 像辛言这个例子，有什么问题呢？就是我讲义中为了让大家理解不同形式​之间的关系，我找出一个前后对称的标准式，但是在举例时，我们一般 不使用标准式，而是使用特殊的一些形式，以使更妥帖的表达一个逻辑含​义。

李后主: 我们可以把辛言的例子改一下：
8，列举一个有效的复杂构成式的二难推理。
如果胡锦涛顺应天意解体中共，那么人民会拥护他，他会成为中华民族的​英雄；
如果胡锦涛不顺应天意解体中共，那么人民会反对他，他会成为中华民族​的罪人；
胡锦涛或者解体中共，或者不解体中共；
所以，胡锦涛或者成为中华民族的英雄，或者成为中华民族的罪人。

李后主: 仁勇:
8，列举一个有效的复杂构成式的二难推理。
如果让儿子上国寨学校，父亲担心儿子会被邪党脑毒洗脑的更彻底；
如果不让儿子上国寨学校，父亲担心儿子将来很难找到工作；
或者让儿子上国寨学校，或者不让儿子上国寨学校；
所以，父亲担心儿子被邪党彻底洗脑，或者担心儿子将来找不到工作。

李后主: 好的，这个例子也很恰当。

李后主: 9，列举一个有效的复杂破坏式的二难推理。

严仁勇: 如果你三退了，你就选择了光明；
如果你跟随中共助纣为虐，你就选择了黑暗；
或者你选择了黑暗，或者你选择了光明；
所以，或者你不三退，或者你不再跟中共助纣为虐了。

李后主: 仁勇的例子比较妥当。

李后主: 当然了，仁勇的例子准确的应该是：
如果你三退了，你就选择了光明；
如果你跟随中共助纣为虐，你就选择了黑暗；
或者你没有选择光明，或者你没有选择黑暗；
所以，或者你不三退，或者你不再跟中共助纣为虐了。

陈清扬: 如果经济危机中的毕业生不继续进修而去找工作，那么就可能避免金融风​暴益加严重时找不到好工作。
如果经济危机中的毕业生继续进修而不去找工作，那么就可能在金融风暴​益加严重时找到一个更好的工作。
或者找得到，或者找不到好工作；
所以，或者去进修，或者不去。

李后主: 清扬，你的例子中“如果......可能”，这是充分假言条件命题吗​？

陈清扬: 确实不充分，谢谢老师指正。

李后主: 清扬的这个例子也不行，没有内部逻辑联系。有什么二难的局面出现了吗​？
9，列举一个有效的复杂破坏式的二难推理。
如果推动基础重工业建设，那么国家的生产能力会提高。
如果人民手中无钱，那么国家的生产能力会降低。
国家的生产能力或者不会提高，或者不会降低；
所以，或者没有推动基础重工业建设，或者人民手中有钱。

李后主: 10，思考题：从前有一个国家有一条奇怪的法律，凡是犯了死罪的人在​临刑前可以选择受刑的方式，要求犯人说一句话，如果说对了，就以绞刑处​死，如果说错了，就以毒酒毒死。有一个聪明的犯人，说了一句话后，获得​了重生。请问犯人说了一句什么样的话？请写出推理过程。

李后主: 这个问题，很多同学都知道该说一句什么样的话，那就是，犯人说：“我​将被毒酒毒死”。

钱不求: 说我要喝毒酒而死。
如果他说对了，那么他应该绞刑，就说明他说得不对
如果他说错了，就应该毒酒而死，就说明他说得是对的

李后主: 那么，下面应该是谁在推理呢？犯人已经说完了。是谁才能决定犯人的生死？

严仁勇: 法律。

钱不求: 法官？

李后主: 呵呵，是不是只有行刑者或者法官才能决定犯人的生死。那么下面的推理​应该是法官来推理了。是犯人的回答使法官陷入二难选择的境地。

杨显刚: 是啊！

李大雄: “我会被毒酒毒死“
如果这句话说对了，就会被处以绞刑，那么这句话就说错了。
如果这句话说错了，就会被毒酒毒死，那么这句话就说对了。

杨显刚: 没办法只好放了。

李后主: 大雄写的也就是这个事情的实质，但是我们能不能把它转化为一个二难推​理的某个形式呢？

陈清扬: 审判者角度：
如果按照法律可以判定“他将会死于毒酒”这话的真假进而依照法律来执​行的话，那么判定毒酒会导致毒酒判决与毒酒判决的依据矛盾。
如果按照法律可以判定“他将会死于毒酒”这话的真假进而依照法律来执​行的话，那么判定绞刑会导致绞刑判决与绞刑判决的依据矛盾。
所以无法按照法律可以判定“他将会死于毒酒”这话的真假，也就无法依​照法律来执行。

李后主: 陈清扬逻辑思路是对的，只是表述有点复杂了。

李后主: 大家看看我写的这个推理过程;
法官或者行刑者的二难选择，推理如下：
假如我用毒酒毒死他，则他说对了，我应该绞死他，那么，这种情况下我​不能杀死他；
假如我用绞刑绞死他，则他说错了，我应该毒死他，那么，这种情况下，​我也不能杀他；
所以，我不能杀死他。

李后主: 我用的形式是简单构成式。

钱不求: 老师的意思是，换一个思考主体？

李后主: 怎么叫换一个思考主体？犯人只说了一句话就被免死，那么不是犯人自己​把自己免死啊，肯定是法官把犯人免死了，那么法官为什么要给犯人免死呢​？就是根据犯人所说的这句话，法官进行了这么一个二难推理，推出无论怎​么样都得给犯人免死。

钱不求: 哦。是啊 这才联系起来，呵呵。

李后主: 所以，这道题是两问，第一问要求回答犯人说了一句什么话。第二问要求​回答法官的推理过程。

钱不求: 是把这个主体先找出来。

黄豆芽: 我认为，可以在推理里面强调这点的。

李后主: 犯人怎么推理的是在他头脑中进行的，他推理的结果是说了那句话，下面​就要法官来根据这句话推理了，这是三个环节。你们写犯人的推理过程可以的，但是最终不要忘了把法官的推理过程写出​来，这才是最重要的。因为二难是法官的二难，不是犯人的二难。

齐学玉: 犯人：你们将用毒酒处死我。

执刑人员：
如果用绞刑，那么就承认了他说的是真话；（显然此时不能承认他说的是​真话，因为他说用毒酒）
如果用毒酒，那么就承认了他说的是假话；（显然此时不能承认他说的是​假话，因为他说用毒酒）
或者不能承认他说的是真话，或者不能承认他说的是假话；
所以或者不能用绞刑处死犯人，或者不能用毒酒处死犯人。（而对于只能​用这两种方式处死犯人的法律来说，显然办不到这一点，所以只好把这个聪​明的犯人放了。）

李后主: 学玉的推理也是主题不清晰。因为主题不在于承认不承认他说真话还是假话，而是判不判他死刑，怎么​判。

李后主: 我这个第10题，也是给后面11题做提示的。好的，我们看第11题。
11，请指出普罗泰戈拉的官司难题的实质。

严仁勇: 主要是二难推理针对的对象不明确，学生付学费是以法律裁决为依据呢还​是以欧提勒士打官司赢输为依据？

法官的正确推理如下：
如果你赢了，那么按照合同，应该付我另一半学费；
如果你没有赢，按照法庭裁决，你也应该付我另一半学费；
或者赢了或者没有赢；
所以，或者按照合同，应该付我另一半学费；或者按照法庭裁决，你也应​该付我另一半学费；

总之，你都必须付我另一半学费。

李后主: 仁勇，付学费是以合同为依据，法官断案也是以合同为依据。这本身不是​问题，而是二者在这个事件中互为矛盾时才产生了这个问题。

李后主: 仁勇，法官是“我”？

李后主: 法官的正确推理如下：
如果你赢了，那么按照合同，应该付我另一半学费；
如果你没有赢，按照法庭裁决，你也应该付我另一半学费；
或者赢了或者没有赢；
所以，或者按照合同，应该付我另一半学费；或者按照法庭裁决，你也应​​该付我另一半学费；

钱不求:找到主体，再从主体出发找到（“按照合同”“法律裁决”）两者中正确​​的判断依据，最终根据这个依据判断哪边是正确的。

李后主: 辛言说：
普罗泰戈拉用了不真实的充分条件假言命题，即“如果你赢了，按照合同​，你应该付我另一半学费”，前件推不出后件，如果欧提勒士赢了官司，就​不应该付另一半学费。
欧提勒士同样了不真实的充分条件假言命题，即“如果我输了，按照合同​，我也不应该付您另一半学费”，前件推不出后件，如果他输了官司，就应​该付另一半学费。

李后主: 辛言这么分析是对的，他看出了这里面的逻辑矛盾。指出了师生二人推理​的逻辑漏洞。

李大雄: 这里同时用到了两个价值判断，一个是法官的裁决，一个是合同。而这两​个判断依据所给出的结论是相背的。对于同一事物，不应同时使用两个不同​的依据。

李后主: 大雄，你说的和辛言说的是一样的。师生二人没有注意他们所用前提中的​矛盾冲突，根本不可能推出他们的结论。

李后主: 那么，这个难题的实质是什么呢？既然是打官司，那么应该由法官来裁决​，不是由他们师生自己来裁决啊。那么，我们就让法官来裁决裁决，假设诸​位同学是法官，你们给裁决一下。呵呵！

李后主: 现在老师把学生告到你们那里了，说学生不履行合同，要求法官给判决。​你们准备怎么判决呢？

黄豆芽: 很简单，判合同为无效合同就是了。

李后主: 合同怎么能是无效合同呢？你这么当法官可不行啊！合同当然是有效合同。同学们好好想想，这个问题的实质就是一个法官的​二难推理。而不是师生的二难推理。结果是法官无法判决，如果法官无法判决，那么就不存在师生二人后面的​推理了。因为不存在谁输谁赢的前提了。

黄豆芽: 好吧，如果承认是有效合同的话，付出一半学费就是了。

钱不求: 如果欧提勒士赢了，按照法庭裁决，他不应该付另一半学费；
如果欧提勒士输了，按照法庭裁决，他应该付另一半学费；

李后主: 不求，你这样判断还是师生的思维，不是法官的思维。

钱不求: 嗯。

杨显刚: 我是法官的话就判学生交完另一半学费。

李后主: 杨显刚，如果你判学生交另一半学费的话，结果那就是学生在这场官司中​输了，那么他不应该交另一半学费。而且我再问你，你判学生交另一半学费​的依据是什 么？学生只有在打赢第一场官司的后才交另一半学费，现在官司还正在打，你​凭什么让学生交另一半学费，法庭断案要依据合同，怎么能随便判呢？

杨显刚: 此学生道德不行，我是以道德来判的。

李后主: 此学生没有违反合同，怎么道德不行。道德不行，有道德的评判，怎么能​随意罚款呢？你这么当法官，非把司法搞乱不可。

齐学玉: 法官：
假如判学生给他钱，那么得判普罗泰戈拉赢，可是按他们的合同，则学生​不用给他钱，那么无法判决；
假如判学生不给他钱，那么得判普罗泰戈拉输，可是按合同规定，则学生​需要给他钱，那么无法判决；
所以将无法判决。

李后主: 我要是法官，我会这么想：
法官是根据合同来断案，所以我遇到了难题：
假如我判老师胜诉，学生败诉，学生交付学费，则根据合同学生不应该交​付学费，那么，我无法裁判；
假如我判学生胜诉，老师败诉，学生不交付学费，则根据合同学生不应该​交付学费，那么，我无法裁判；
所以，我无法裁判。

钱不求: 其实这个问题体现了斗智不守德的尴尬局面。

罗同: 这个案例让我体会到逻辑也是实在的东西。

赵阳光: 这个两难推理很难解决，不过它却有另外一个价值，就是以这个问题为例​来说明要注意不要陷入逻辑的怪圈，要提前预防两难的结果产生。

钱不求: 这里普罗泰戈拉和普罗泰戈拉分别没有注重合同应该照顾学生和学生的尊​师重道，证明没有道德的基础，逻辑不能够乱用，否则就出现两难。

杨显刚: 没错。

唐子: 两难推理的实质是什么？

钱不求: 实质是双方智力相斗？

唐子: 为什么会出现？其逻辑意义是什么？

杨显刚: 因为私利而出现，其逻辑意义是都想得到却都得不到。

唐子: 我们学逻辑的目的：概念明确（定义）、判断恰当（符合要求）、推理符​合逻辑（遵守规则）。紧扣这些，其他的了解就可以了，用不着去执着。

杨显刚: 嗯。

唐子: 逻辑思维是解决静态问题，所以当问题转变成动态的，那就不是逻辑问题​了。

李大雄: 出现两难推理，体现出了逻辑规则的局限性，并不是任何问题都能用逻辑​来解决的。

赵阳光: 两难推理之所以出现，是因为人试图用技术的东西（逻辑、科学等）解决​所有的问题，事实是不可能的。比如现在的人试图用科学解决人类面临的诸​多问题，如战争、地球暖化等，最后却是越弄越乱、越弄越多。

唐子: 二难推理很多都是超逻辑的了，讲这个不是让你去找到解决办法。你解决​不了。前人难道智商就真的不如我们？所以李后主老师说作为法官，懂和遵​守逻辑，就应当放弃判决。这是对的。

唐子: 也就是说，二难推理是逻辑训练，不能够纳入司法审判活动中的。没有法​律裁判可以解决二难推理的逻辑问题。逻辑难题，是思维中的问题，怎么能够纳入实践中去解决呢？这样做的人​，就是不理智。

本次课程结束，师生互道晚安。


第四章 复合命题推理

在上一讲中，我们知道，根据前提到结论的思维进程的不同，非模态推理可分为演绎推理、归纳推理、类比推理。

演绎推理是由一般到个别的推理，是一种必然性推理，根据构成推理的命题形式的不同，它又可分为：简单命题推理和复合命题推理。其中，简单命题推理可分为直言命题推理（直接推理和三段论）；复合命题推理可以分为联言推理、选言推理（相容选言推理、不相容选言推理）、假言推理（充分条件假言推理、必要条件假言推理、充要条件假言推理）和二难推理。我们在第三讲和本章第四讲中学习的都是属于演绎推理的体系。

第一节 联言推理

一，什么是联言推理

1，定义：联言推理就是前提或结论为联言命题，并且根据联言命题的真假性质所进行的推理。

例如：

张三既是在校大学生，又是我们店里的员工。

    所以，张三是我们店里的员工。

   2，联言命题的逻辑性质：当且仅当所有支命题为真，则该联言命题为真。

    3，联言推理的基本形式：分解式联言推理；组合式联言推理

二，分解式联言推理

1，定义：分解式就是由前提中一个命题为真，推出其任一支命题为真的联言推理。

2，结构式：

⑴p并且q

所以p。

⑵p并且q

所以q。

三，组合式联言推理

1，定义：组合式就是由前提中一些支命题为真，推出这些支命题组合成的联言命题为真的联言推理。

  2，结构式

   p ，p

所以，p并且q。


第四章 复合命题推理

第二节 选言推理

一，什么是选言推理

    选言推理就是前提中有一个是选言命题，并根据选言命题选言支之间的关系而推出结论的推理。根据推理前提中选言命题的种类不同，可以把选言推理分为相容选言推理和不相容选言推理。

例如：

     中共要么特赦杨佳，要么杀害杨佳。

     中共没有特赦杨佳，

     所以，杨佳被中共杀害。

二、相容选言推理

    1，定义：前提中有一个相容选言命题，并根据相容选言命题的逻辑性质进行的推理。

    2，相容选言命题的逻辑性质：相容选言命题选言支至少有一支为真才真。

    3，推理规则

     ⑴否定一部分选言支，就要肯定另一部分选言支。

     ⑵肯定一部分选言支，不能因此否定另一部分选言支。

    4，结构式（否定肯定式）

     ⑴ P或者q

     非p

     所以，q

⑵ P或者q

     非q

     所以，p

例如：

    他或者是老师，或者是学生，

    他不是老师，

    所以，他是学生。

三，不相容选言推理

    1，定义：前提中有一个不相容选言命题，并根据不相容选言命题的逻辑性质进行的推理。

    2，不相容选言命题的逻辑性质：选言支只能有一个为真，其余为假。

    3，规则：根据不相容选言命题的逻辑性质，当一个选言命题的一部分为假时，可以推出另一部分为真；同样，当一个选言命题的一个部分为真时，可以推出其余部分为假。因此，它有两条规则。

    ⑴否定一部分选言支，就要肯定另一个选言支。

    ⑵肯定一个选言支，就要否定其它的选言支。

    4，结构式

    （1）否定肯定式

①要么p，要么q；

非p；

所以，q。

②要么p，要么q；

非q；

所以，p。

例如：

     张三要么去踢球了，要么去图书馆看书了，

     张三没有去踢球，

     所以，张三去图书馆看书了。

    （2）肯定否定式。

①要么p，要么q；

p；

所以，非q。

②要么p，要么q；

q；

所以，非p。

例如：

   张三要么去踢球了，要么去图书馆看书了，

    张三去图书馆看书了，

    所以，张三没有去踢球。

    注意：选言推理中的选言支必须穷尽。


第四章 复合命题推理

第三节 假言推理

一，什么是假言推理

    假言推理是前提中有一个假言命题，并根据假言命题的逻辑性质进行的推理。

    例如：

    如果下级法律的规定与宪法相冲突，那就是违宪；

    游行示威法与宪法相冲突；

    所以，游行示威法违宪。

    由于假言命题有三种不同的条件，所以，假言推理分为：充分条件假言推理，必要条件假言推理，充分必要条件假言推理。

二，充分条件假言推理

    1，定义：前提中有一个充分条件假言命题，并根据充分条件假言命题的逻辑性质进行的推理。

    2，充分条件假言判断的逻辑性质：有前件就一定有后件，没有前件不一定没有后件；没有后件肯定没有前件，有了后件不一定有前件。

    3，规则

    （1）肯定前件，就要肯定后件；否定后件，就要否定前件。(必真)

    （2）肯定后件，不能肯定前件；否定前件，不能否定后件。（有真有假）

    4，结构式

    （1）肯定前件式

如果p，那么q；

p；

所以，q。

    例如：

如果下雨了，地面一定会湿；

下雨了；

所以，地面湿了。

（2）否定后件式

如果p，那么q；

非q；

所以，非p。

例如：

如果下雨了，地面一定会湿；

地面没有湿；

所以，没有下雨。

注意：在充分条件假言命题中，前件假时，后件真假不定；后件真时，前件真假不定。因此，在进行充分条件假言推理时，不能用否定前件来否定后件，也不能用肯定后件来肯定前件。否则，推理就不正确。

例如：

（1）如果下雨了，地面一定会湿；

没有下雨；

所以，地面一定不会湿。

【解释：没有下雨，但是洒水车等其它因素也可能使地面湿。所以说地面一定不会湿是错误的。】

（2）如果下雨了，地面一定会湿；

地面湿了；

所以，下雨了。

【解释：地面湿了，并不一定是下雨所致，如上面所述。】

三，必要条件假言推理

1，定义：前提中有一个必要条件假言命题，并根据必要条件假言命题的逻辑性质进行的推理。

2，必要条件假言判断的逻辑性质：有后件就一定有前件，没有后件不一定没有前件；没有前件肯定没有后件，有了前件不一定有后件。

    3，规则

    （1）否定前件，就要否定后件；肯定后件，就要肯定前件。（必真）

    （2）肯定前件，不能肯定后件；否定后件，不能否定前件。（有真有假）

4，结构式

    （1）否定前件式

只有p，才q；

非p；

所以，非q。

例如：

    只有年满十六岁，才负刑事责任，

    那个学生没有年满十六岁，

    所以，那个学生不需要负刑事责任。

（2）肯定后件式

只有p，才q；

p ；

所以，q。

例如：

    只有年满十六岁，才负刑事责任；

    那个学生需要负刑事责任；

    所以，那个学生一定年满十六岁。

注意：在必要条件假言命题中，前件真时，后件真假不定；后件假时，前件真假不定。因此，在进行必要条件假言推理时，不能用肯定前件来肯定后件，也不能以否定后件来否定前件。否则，推理就不正确。

例如：

⑴只有年满十六岁，才负刑事责任；

那个学生年满十六岁了；

所以，他要负刑事责任。

【解释：年满十六岁了，但是人家没有犯罪就不需要负刑事责任，所以这么推理是错误的。】

⑵只有年满十六岁，才负刑事责任；

那个学生不需要负刑事责任；

所以，那个学生没有年满十六岁。

【解释：不需要负刑事责任的原因还可能是人家根本没有犯罪，不见得就是未满十六岁。】

四，充分必要条件假言推理

1，定义：前提中有一个充分必要条件假言命题，并根据充分必要条件假言命题的逻辑性质进行的推理。

2，充分必要条件假言命题的逻辑性质：有前件必有后件，没有前件必没有后件；有后件必有前件，没有后件，必没有前件。

    3，规则：

    ⑴肯定前件，就要肯定后件（必真）；肯定后件，就要肯定前件（必真）。

    ⑵否定前件，就要否定后件（必真）；否定后件，就要否定前件（必真）。

4，结构式

⑴肯定前件式

当且仅当p，才q；

p；

所以q。

例如：

当且仅当具有马列主义世界观的各种思想意识形式才是党文化；

进化论以及进化论思维是马列主义的世界观；

因此，进化论以及进化论思维是党文化。

⑵否定后件式

当且仅当p，才q；

非q；

所以，非p。

例如：

当且仅当具有马列主义世界观的各种思想意识形式才是党文化；

政党政治不是党文化；

所以，政党政治不是马列主义世界观下的思想意思形式。

――――――――――――――――――――

【以上⑴⑵两个形式是具有充分条件性质的推理，注意和充分条件推理的不同之处。】

⑶否定前件式

当且仅当p，才q；

非p；

所以，非q。

例如：

当且仅当具有马列主义世界观的各种思想意识形式才是党文化；

中国古代的朋党现象不具有马列主义的世界观；

因此，中国古代的朋党现象不是党文化。

⑷肯定后件式

当且仅当p，才q；

q；

所以p。

例如：

当且仅当具有马列主义世界观的各种思想意识形式才是党文化；

阶级斗争论是党文化；

因此，阶级斗争论是具有马列主义世界观的思想意识形式。

――――――――――――――――――――――

【以上⑶⑷两个形式是具有必要条件性质的推理，注意和必要条件推理的不同之处。】

五，假言连锁推理（假言三段论）

1，定义：从前提中几个同样性质的假言命题推出一个新的同样性质的假言命题的假言推理，通常又称为假言三段论。

2，规则：要求前提中第一个假言命题的后件必须与第二个假言命题的前件相同。

3，结构式：

⑴充分条件假言连锁推理

如果p，那么q；

如果q，那么r；

所以，如果p，那么r。

例如：

如果你能在未来中国大学学习，你一定能学到人类正统的文化；

如果你学到人类正统的文化，你就可以在未来成为复兴人类正统文化的中坚力量；

所以，如果你能在未来中国大学学习，你就可以在未来成为复兴人类正统文化的中坚力量。

⑵必要条件假言连锁推理

只有p，才q；

只有q，才r；

所以，只有p，才r。

例如：

只有退出中共，不做马列子孙，才能做真正的中华儿女；

只有做真正的中华儿女，才是真正的爱国；

所以，只有退出中共，不做马列子孙，才是真正的爱国。


第四章 复合命题推理

第四节 负复合推理

负复合推理就是根据各种复合命题为假时的情况所进行的推理，其实也就是根据负复合命题的等值命题所进行的推理。

一，负联言命题推理

联言命题的负命题的等值命题为一个选言命题，即“并非[p并且q]”等值于“非p或者非q”，我们可以根据它的等值命题（选言命题）来推理，那么，它的推理形式为（否定肯定式）：

⑴并非[p并且q]； （ ←→非p或者非q）

p；

所以，非q。

⑵并非[p并且q]； （ ←→非p或者非q）

q；

所以，非p。

例如：

“并非[张三和李四都要受到表彰]”； （等值于“或者张三没有受到表彰，或者李四没有受到表彰”。）

张三受到了表彰；

所以，李四没有受到表彰。

二，负选言命题推理

1，负相容选言命题推理

相容选言命题的负命题的等值命题是一个相应的联言命题，既“并非[p或者q]”等值于“非p并且非q”，那么根据联言命题的逻辑性质，它的推理形式为：

并非[p或者q]； （←→非p并且非q）

所以，非p并且非q。

例如：

并非[或者张三受到表彰或者李四受到表彰]；（等值于“张三既没有受到表彰李四也没有受到表彰”）

所以，张三没有受到表彰，李四也没有受到表彰。

2，负不相容选言命题推理

不相容选言命题的负命题的等值命题是一个相应的选言命题，并非[p或者q]”等值于“[p并且q]或者[非p并且非q]”，即﹁（p∨q）←→（p∧q）∨（﹁p∧﹁q），“那么，它的推理形式为（否定肯定式）：

⑴并非[p或者q]； （←→[p并且q]或者[非p并且非q]）

并非[非p并且非q]；

所以，[p并且q]。

⑵并非[p或者q]； （←→[p并且q]或者[非p并且非q]）

并非[p并且q]；

所以，[非p并且非q]。

例如：

并非明天要么天晴要么下雨； （等值于“[明天既不天晴也不下雨]或者[明天既天晴又下雨] ”）

并非明天既天晴又下雨； (否定后面的支命题）

所以，明天既不天晴也不下雨（阴天）。 （肯定前面的支命题）

三，负假言命题推理

1，负充分条件假言命题推理

充分条件假言命题的负命题可以表示为：“并非[如果p，那么q]”，它的等值命题为“p并且非q”。它的推理形式为：

并非[如果p，那么q]

所以，“p并且非q”

例如：

并非[只要付出了，就会有收获]

所以，他付出了，但是没有收获。

2，负必要条件假言命题推理

必要条件假言命题的负命题可以表示为：“并非[只有p，才q]”，它的等值命题为“非p并且q”。它的推理形式为：

并非[只有p，才q]；

所以，非p并且q。

例如：

并非[只有违法了，才会被审判]

所以，胡佳没有违法，但是胡佳被审判。

3，负充要条件假言命题推理

充要条件假言命题的负命题可以表示为：“并非[当且仅当p，才q]”，它的等值命题为一个选言命题“[非p并且q]或者[p并且非q]”。推理形式如下(否定肯定式)：

⑴并非[当且仅当p，才q]； （等值于[非p并且q]或者[p并且非q]）

并非[非p并且q]；

所以，[p并且非q]。

⑵并非[当且仅当p，才q]； （等值于[非p并且q]或者[p并且非q]）

并非[p并且非q]

所以，[非p并且q]。

例如：

并非[当且仅当仓廪实而知礼节]； （等值于“[仓廪实而不知礼节]或者[仓廪不实而知礼节]”）

并非[仓廪实而不知礼节]； （否定前面的支命题）

所以，[仓廪不实而知礼节]。 （肯定后面的支命题）

作业题：

1，请列举一个相容选言命题的推理。

2，请列举不相容选言命题的推理，要求同一内容下分别是“否定肯定式”和“肯定否定式”。

3，请列举充分条件假言命题推理，要求同一内容下分别是“肯定前件式”和“否定后件式”。

4，请列举必要条件假言命题推理，要求同一内容下分别是“否定前件式”和“肯定后件式”。

5，现有充要条件假言命题“当且仅当奉行反人类教义并且违背自然规则的宗教才是邪教”，请列举出它的四种推理形式下的不同推理过程。


第四章 复合命题推理

第五节 多重复合推理

假言选言推理和二难推理

多重复合推理是在基本复合推理的基础上所构造的命题推理，是基本命题推理的综合运用。本节我们介绍假言选言推理和二难推理。一般的逻辑学教材上，把假言选言推理和二难推理混为一谈，其实二者是有区别的，二难推理是一种特殊条件下的假言选言推理，但是假言选言推理不一定都构成二难推理。

一，什么是假言选言推理和二难推理 假言选言推理是由两个充分条件假言命题和一个二支选言命题为前提的演绎推理。根据结论是直言命题还是选言命题，假言选言推理可以分为简单的和复杂的两种；又根据选言前提的选言支分别是肯定假言前提的前件还是否定假言前提的后件，假言选言推理又分为构成式和破坏式。这样总共可以得到假言选言推理的四种形式：简单构成式、简单破坏式、复杂构成式和复杂破坏式。

二难推理是假言选言推理的一种特殊情况，通常是两个假言前提的前件之间或者后件之间互为矛盾关系或者反对关系，使推理的结论出现左右为难的情况，因此叫做二难推理。

    二，假言选言推理的种类

    如前所述，假言选言推理四种形式：简单构成式、简单破坏式、复杂构成式和复杂破坏式。

1，简单构成式：

简单的构成式是指前提中的两个假言命题的前件不同，后件相同，选言命题肯定不同的前件，结论肯定共同的后件。推理形式如下：

     如果p，那么q；

     如果r，那么q；

   或者 p或者r；

     所以，q。

例如：

如果我们要解体中共，那么我们必须首先三退（从组织上瓦解它）；

如果我们要复兴中华，那么我们必须首先三退（从灵魂上清除党的邪恶印记）；

我们或者要解体中共，或者要复兴中华；

所以，我们都必须首先三退。

以上是简单构成式的普通形式，作为前提的两个充分条件假言命题的前件之间可以形成相容关系，所以它们不出现二难推理的情况，如果令r＝非p，则两个假言命题的前件之间构成矛盾关系，此时无论p还是非p，我们都可以推出q，那么q就是必然的。这就是简单构成式中的二难推理（也称归约律），它的逻辑形式可以表达为：

如果p，那么q；

如果非p，那么q；

所以，q。

例如，中世纪一些神学家提出的“上帝全能”的思想，结果被反对者提出这样一个问题“全能的上帝能否创造出一块连他自己也搬不动的石头？”这个问题展开来就是一个二难推理，如下：

如果上帝能创造出这样一块石头，那么上帝就不是全能的（因为上帝至少还有一块石头搬不动），

   如果上帝不能创造这样一块石头，那么上帝也不是全能的（因为上帝至少还有一块石头不能创造），

   上帝或者能创造这样一块石头，或者不能创造这样一块石头，

总之，上帝不是全能的。

[注：上帝当然不是全能的，只是对人类而言，上帝可以办到人类办不到的很多事情。]

2，简单破坏式

简单破坏式是指前提中的两个假言命题的前件相同，后件不同，选言命题否定不同的后件，结论否定共同的前件的二难推理。推理形式如下：

如果p，那么q；

如果p，那么r；

非q或者非r；

所以，非p。

例如：

如果他是一个好学生，那么他会善待其他同学；

如果他是一个好学生，那么他会努力学习；

他或者经常欺负（不善待）其他同学，或者不努力学习；

总之，他不是一个好学生。

以上是简单破坏式的普通形式，作为前提的两个充分条件假言命题的后件（q和r）之间可以形成相容关系，所以它们不出现二难推理的情况。如果令r＝非q，则两个假言命题的后件之间构成矛盾关系，此时从同样一个p出发，既可以推出q，也可以推出非q，即推出一个逻辑矛盾，因此前提是错误的，所以，非p。这就是简单破坏式中的二难推理（也称为归谬律），它的逻辑形式可以表达为：

如果p，那么q；

如果p，那么非q；

所以，非p。

例如，无神论者说没有神，人是自然界物质运动的结果，人的产生是一系列随机过程的结果。我们知道人类可以创造出在自然界仅仅靠随机过程不能产生的复杂事物，比如汽车、飞机、电脑等等，如果我们说把一堆飞机零件或者是一堆自然界的矿物质随机的摆在一起，等着自然界的随机运动，多少时间过去后，它们就会自己组合成一架波音767飞机，我想谁都会认为这很荒谬，不经过设计和精密的筹划和制造，没有设计和创造能力的自然界怎么可以自己组装出一架精密的飞机呢？那么，比飞机精密千万倍不止的人类怎么能被没有设计和创造能力的自然界随机组装和创造出来呢？另一方面，人类本身就具有创造和设计能力，根据前提，没有创造和设计能力的自然界产生了具有创造和设计能力的人类，这在逻辑上怎么可能呢？可见，自然界是具有设计和创造能力的，则自然界是有神的。这个过程也是一个二难推理（归谬法），形式如下：

如果没有神，一切都是随机过程，那么自然界不具有设计和创造的能力；

如果没有神，一切都是随机过程，那么人是自然界随机产生的。因为人具有设计和创造的能力，因此自然界产生了设计和创造的能力，而没有设计和创造能力的事物不可能产生出具有设计和创造能力的事物，可见，自然界具有设计和创造的能力。

因此，一切不都是随机过程，存在着更高级的生命——神。（一切由神来设计和安排）

3，复杂构成式

复杂构成式是指前提中的两个假言命题的前件不同，后件也不同，选言命题肯定不同的前件，结论以选言命题的形式肯定不同的后件的推理。推理形式如下：

如果p，那么q；

如果r，那么s；

或者p，或者r；

所以，或者q，或者s。

注意：这个复杂构成式的两个假言前提前后件都不相同，那么二者就必须要有其它的逻辑联系，如果没有逻辑联系这个假言选言命题就没有意义。而要使这个推理形式有意义，则只能使前提中的两个假言命题的前件互为矛盾关系（或者反对关系），这样一来，这个复杂构成式的有意义推理形式就只能是一个二难推理，这样它才有逻辑意义。

例如：

⑴如果下雨，地面会湿；

如果你吃饭了，你就会有生命活动的基本能量；

或者下雨了，或者你吃饭了；

所以，或者地面湿了，或者你有生命活动的基本能量。

这个推理有什么意义呢？两个假言前提一点逻辑联系都没有。注意，它虽然没有逻辑意义，但是它的逻辑推理形式是有效的。那么，我们再看下面的两个例子：

⑵（如果）原谅你吧，怕你不吸取教训，继续犯错误；

（如果）不原谅你吧，怕你承受不了这个打击，从此消沉下去；

（因此，心里真是左右为难。思维的逻辑过程如下：）

或者原谅你，或者不原谅你；

所以，或者怕你不吸取教训继续犯错误，或者怕你承受不了打击从此消沉下去。

⑶如果听他的话，我担心会受骗；

如果不听他的话，我又担心会失去一次机遇；

（我必须得选择，真是左右为难，很不好选择）

或者我听他的话，或者不听他的话；

所以，或者我担心会受骗，或者我担心会失去一次机遇。

综上，则复杂构成式的有意义逻辑形式（二难推理形式）如下：

如果p，那么q；

如果非p，那么s；

或者p，或者非p；

所以，或者q，或者s。

以上这两个事例中体现出的推理形式在实际应用中多表现为二难选择，表现了人的心理的复杂情绪，就是选择A的话，会出现不愿意看到的结果B，选择[非A]的话，会出现不愿意看到的结果C，所以，无论怎么选择都会很为难。

下面我们再研究一下复杂构成式中的二难推理的逻辑假象，先看下面这个例子：

⑷雅典时期，一个平民的儿子准备出去演说，他父亲表示反对，理由如下：

    如果你演说时说真话，那么富人会反对；

    如果你演说时说假话，那么穷人会反对；

    你演说时或者说真话，或者说假话；

所以，或者富人反对你，或者穷人反对你。（父亲的结论是总之你都会受到反对的）

    儿子针对这个二难选择作了以下修改，构建了一个反面的二难推理形式，如下：

    如果我演说时说真话，那么穷人会拥护我；

    如果我演说时说假话，那么富人会拥护我；

    我演说时或者说真话，或者说假话；

    所以，或者穷人拥护我或者富人拥护我。（儿子的结论是总之我都会受到拥护的）

以上这个推理的假言前提的后件中包含着一对反对关系的概念，即穷人和富人，他们之间互为对立面，即穷人反对的富人拥护，穷人拥护的富人反对。

再看一例：

⑸如果警察听从中共的指挥，人民会仇恨他；

如果警察不听从中共的指挥，中共会仇恨他；

警察或者听从中共的命令，或者不听从中共的命令；

所以，或者人民会仇恨他，或者中共会仇恨他。

那么有人会因此得出一个结论：当警察不好，因为无论怎么做都一定会受到仇恨的。

从对立面来看，上面这个事例也可以这样推理：

如果警察听从中共的指挥，中共会表彰他；

如果警察不听从中共的指挥，人民会表彰他；

警察或者听从中共的命令，或者不听从中共的命令；

所以，或者人民会表彰他，或者中共会表彰他。

那么有人也会因此得出一个结论：当警察好，因为无论怎么做都一定会受到表彰的。

这个例子中，假言前提的后件中也是包含着一对反对关系的概念，中共和人民，中共和人民互为对立面，因此这两个概念会出现两种两两对应的局面：[A中共喜欢的、B人民不喜欢的]；[C中共不喜欢的、D人民喜欢的]。AB实质是一回事（A等于B），CD实质是一回事（C等于D），因此，这个二难选择总共有两种情况，所对应的结果是“选择与人民站在一边，还是选择与中共站在一边”的价值选择，而不是“当警察好还是不好的事实判断”。这个事例中本身蕴涵着二难选择，但是以上的推理却没有表达出这个真正的二难选择，而是运用了对立面的相等关系转移了逻辑内涵而造成一种逻辑假象，所以，以上的⑷⑸中的推理都是假二难推理，凡是假二难推理，都会被击破，像如以上的推理都会被它本身衍生出的推理所击破。

以上事例中所蕴藏的真正的二难推理如下：

⑹如果我演说时说真话，我会得罪富人，但穷人会拥护我；

如果我演说时说假话，我会得罪穷人，但富人会拥护我；

（但是我必须得选择一个服务的对象，选择谁呢？我站在穷人一边还站在富人一边？）

我或者说真话，或者说假话；

所以，我或者得到穷人的拥护，或者得到富人的拥护（也等于或者我罪人富人，或者我得罪穷人）。

以上的推理形式是一个前后对称的标准式，如下（其中q和s是反对关系，非s等于p，非p等于s）：

如果p，那么非q，s；

如果非p，那么非s，q；

或者p，或者非p；

所以，或者s，或者q。

再以一个警察面对中共的镇压命令时的心理活动为例，如下：

⑺如果我执行中共的命令，则我会成为人民的罪人；

如果我不执行中共的命令，则我会受到中共的打压；

（那么，我该怎么做呢？我要么站在人民一边，要么站在中共一边，没有中立的可能。）

或者我执行中共的命令，或者我不执行中共的命令；

所以，我或者成为人民的罪人，或者受到中共的打压（成为对人民的有功之人）。

这个推理其实也是一个前后对称的标准式的简单化，我们可以把它的对称标准式恢复出来，如下：

⑻如果我执行中共的命令，则我会成为人民的敌人，但中共会奖赏我；

如果我不执行中共的命令，则我会成为中共的敌人，但人民会奖赏我；

（那么，我该怎么做呢？我要么站在人民一边，要么站在中共一边，没有中立的可能。）

或者我执行中共的命令，或者我不执行中共的命令；

所以，我或者成为人民的敌人，或者成为中共的敌人（也等于或者中共奖赏我，或者人民奖赏我）。

其实，所有通过不同的语言词汇的运用所达成的简单化推理形式，都可以来自于一个标准式，它们的逻辑含义都是相同的，只是语言表达的方式不同。而假二难推理则是避开了真正的逻辑含义（价值选择），而试图去证明一个片面的所谓事实。

    4，复杂破坏式

   复杂破坏式是指前提中的两个假言命题的前件不同，后件也不同，选言命题否定不同的后件，结论以选言命题的形式否定不同的前件。推理形式如下：

如果p，那么q；

如果r，那么s；

或者非q，或者非s；

所以，或者非p，或者非r。

注意：这个复杂破坏式的两个假言前提前后件都不相同，那么二者就必须有其它的逻辑联系，如果没有逻辑联系这个假言选言命题也就没有意义。而要使这个推理形式有意义，则只能使前提中的两个假言命题的后件互为矛盾关系（或者反对关系），这样一来，这个复杂破坏式的有意义推理形式就只能是一个二难推理，这样它才有逻辑意义。

例如：

⑴如果下雨，地面会湿；

如果你吃饭了，你就会有生命活动的基本能量；

或者地面没有湿，或者你没有生命活动的基本能量；

所以，或者没下雨，或者你没吃饭。

这个推理显然没有逻辑意义，那么再看下面的例子，同样以一个警察面对中共的镇压命令时的心理活动为例，如下：

⑵如果我执行中共的命令，则我会成为人民的罪人；

如果我听从法轮功学员的劝善，则我不会成为人民的罪人；（成为对人民有功之人）

（那么，我该怎么做呢？我要么站在人民一边，要么站在中共一边，没有中立的可能。）

或者我不会成为人民的罪人，或者我会成为人民的罪人；

所以，或者我不执行中共的命令，或者我不听从法轮功学员的劝善。

所以，复杂破坏式的有意义的二难推理形式为：

如果p，那么q；

如果r，那么非q；

或者q，或者非q；

所以，或者非p，或者非r。

其实上面这个例子也可以从前面所说的那种前后对称的标准式中推导出来，也就是说它可以恢复为一个标准式，这样来看，前后对称的标准式其实可以同时充当复杂构成式和复杂破坏式的二难推理的有意义形式。

标准式推理如下：

⑶如果我执行中共的命令，则我会成为人民的敌人，但中共会奖赏我；

如果我不执行中共的命令，则我会成为中共的敌人，但人民会奖赏我；

（那么，我该怎么做呢？我要么站在人民一边，要么站在中共一边，没有中立的可能。）

或者我不想成为人民的敌人，或者我不想成为中共的敌人；（也等于或者中共不会奖赏我，或者人民不会奖赏我）

所以，或者我不执行中共的命令，或者我没有不执行中共的命令。

对称标准式的推理形式如下：

如果p，那么非q，s；

如果非p，那么非s，q；

或者非s，或者非q；

所以，或者p，或者非p。

    三、对错误二难推理的驳斥

前面讲过，有假二难推理的现象，那么如何辨别假二难推理，并且进行有力的反驳呢？假二难推理一般有三种情况，如下：

1，假二难推理的前提不真实

又分为两种情况：一是前提不是真实的充分条件假言命题；二是前提中的选言命题选言支没有穷尽。

例如：

     ⑴如果你是聪明人，那么就不用学逻辑学（因为聪明人不需要学逻辑学）；

     如果你是笨人，那么也不用学逻辑学（因为笨人学不好逻辑学）；

     你或者是聪明人，或者是笨人；

     总之，你都不用学逻辑学。

这个假二难推理的假言前提不真实，聪明人和笨人不需要学逻辑学是不真实的命题。那么驳斥可以采用构造一个反二难推理来进行，如下：

如果你是聪明人，那么就应该来学逻辑学（因为逻辑学可以使你更聪明）；

     如果你是笨人，那么你也应该来学逻辑学（因为逻辑学可以使笨人变得聪明）；

     你或者是聪明人，或者是笨人；

     总之，你都应该学逻辑学。

     ⑵如果天气冷，那么人会难受；

     如果天气热，那么人也会难受；

     天气或者冷或者热；

     所以，人总是会难受。

这个假二难推理的选言前提的选言支没有穷尽，因为除了天气热和天气冷两种情况以外，还有天气不冷不热的情况。因此，可以通过解释其余的选言支来驳斥。

2，假二难推理转变了命题原本的逻辑含义

前面讲过的在二难选择中，把命题中原来蕴藏的价值选择的逻辑含义转化为一个事实判断的逻辑含义，使一个真的二难推理转换为一个假的二难推理。

比如前面举过的事例中，有把站在富人和穷人哪一边的价值选择的逻辑含义转变为从事演讲好不好的工作性质判断的逻辑含义；把站在人民还是中共一边的价值选择转换为当警察好还是不好的工作性质的判断。这样的假二难推理都可以通过构建一个反二难推理来驳斥。

3，循环构造的假二难推理

例如：

如果你犯了罪，你一定会受到法律的制裁；

如果你没有犯罪，你一定不会受到法律的制裁；

或者你犯了罪，或者你没有犯罪；

所以，或者你会受到法律的制裁，或者你不会受到法律的制裁。

这是把一个事实的正反面论述结合起来，它的前提并非两个假言充分条件命题，而是一个假言充分命题和它的对立面命题。这样的前提形成了循环构建的关系，它们不能形成二难推理关系。也就是说，真正的二难推理必须要有两个不同的假言前提。

回想前面讲过的前后对称式，它们和这里出现的循环构造式似乎很相似，因为这个循环式在结构上也是一个对称关系，但是前面讲的对称式中，假言前提的后件包含有两个对立的概念，它们要么在两个假言前提中分别出现，要么以隐含的方式出现，它们构成了必须二选一的局面，所以，那种对称式可以形成有效的二难推理形式。但是循环式中，假言前提的后件只有一个概念，没有形成二选一的局面，所以不构成有效的二难推理，如果非要以二难推理的形式去推导它，只能形成类似于循环论证的结构，可见，这种循环式是一种无意义的假言选言命题推理形式。它的逻辑结构形式如下：

如果p，那么q；

如果非p那么非q；

或者p，或者非p；

所以，或者q，或者非q。

这种逻辑形式明显是同一命题的循环反复的结果，它没有逻辑意义。

总结：

二难推理的情况非常复杂，一般教材上涉及的部分不能概括所有的有效和无效的形式，本章也只是把这些复杂的情况做了一些简单的分类，试图使这里面的规律更清晰一些，形成了以上的这些论述，感觉还是不很清晰。更深刻的规律有待后人继续努力探索。

作业：

6，列举两个简单构成式的假言选言推理，要求其中一个为二难推理。

7，列举两个简单破坏式的假言选言推理，要求其中一个为二难推理。

8，列举一个有效的复杂构成式的二难推理。

9，列举一个有效的复杂破坏式的二难推理。

10，思考题：从前有一个国家有一条奇怪的法律，凡是犯了死罪的人在临刑前可以选择受刑的方式，要求犯人说一句话，如果说对了，就以绞刑处死，如果说错了，就以毒酒毒死。有一个聪明的犯人，说了一句话后，获得了重生。请问犯人说了一句什么样的话？请写出推理过程。

11，请指出普罗泰戈拉的官司难题的实质

古希腊智者普罗泰戈拉办了一所学校，主修法律、哲学、逻辑等课程，专门教学生怎么打官司。为了保证教学质量，普罗泰戈拉和学生签订了一个合同，合同规定，学生入学先交付一半学费，剩下的一半学费等学生毕业后出去打第一场官司赢了后再交付，如果第一场官司输了，则不用付另一半学费。

后来有一个叫欧提勒士的学生，毕业后一直不出庭打官司。于是，普罗泰戈拉找到他要求他出庭打官司，并且告诉他，如果不再不出庭，就把他告上法庭，到那时不论欧提勒士胜诉还是败诉，都必须交付另一半学费。普罗泰戈拉的推理如下：

如果你赢了，按照合同，你应该付我另一半学费；

如果你输了，按照法庭裁决，你也应该付我另一半学费；

你或者赢或者输；

总之，你都必须付我另一半学费。

可是，欧提勒士针锋相对的指出，不论我赢还是输，我都不应该付你另一半学费，推理如下：

如果我赢了，按照法庭裁决，我不应该付您另一半学费；

如果我输了，按照合同，我也不应该付您另一半学费；

或者我赢或者我输；

总之，我都不应该付您另一半学费。


第五章 归纳推理(纪要）

授课内容：《形式逻辑》第五章——归纳推理》
上课时间：2008年12月25日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到课老師：唐子
到课同学：蓝睿、陈清扬、钱不求、張穀虛、夏华、张玉 、唐滨、 赵阳光、黎焕石、严仁勇、麻生、黄野、辛言、曲婉蘭 、張香山、齐学玉
到课同学人数：16人
纪要整理：齐学玉

李后主: 同学们好，开始上课。今天的课程内容很简单。你们有感觉吧！

严仁勇: 内容比较少。

麻生: 嗯，看了一次，容易理解。

陈清扬: 确实比上一课简单很多。

齐学玉: 今天的内容很丰富，西方科学的研究方法好象都用的这种推理。

李后主: 归纳法本身并不难，只是有些例子举起来很麻烦。要说一大堆话。但是都​很实用，大部分都是科学的发现史。

陈清扬: 我学习的时候还连带看了一下我在高中学的数学归纳法，不知道是应该算​到完全归纳还是科学归纳中。

麻生: 特别是加法归纳，就是从1回到100。

陈清扬: 确实举例子要说一大堆话才能体现出来这种思考方式，不过这思考方式本​身倒是不难理解。

李后主: 数学归纳法不能算完全归纳法，我是这么认为的，因为他是利用了演绎推​理。无穷数列的归纳，不可能完全，应该算科学归纳法。

陈清扬: 我也这么认为，至少在我比较初步的理解里，哥德尔不完备性定理似乎说​的就是这个。

李后主: 好，我们结合着事例来学习。

李后主: 先从简单的开始，1，列举一个完全归纳推理的例子。

齐学玉：1，列举一个完全归纳推理的例子。
人眼能识别出赤色，
人眼能识别出橙色，
人眼能识别出黄色，
人眼能识别出绿色，
人眼能识别出青色，
人眼能识别出蓝色，
人眼能识别出紫色，
因此人眼能识别组成太阳光的七种颜色的光。

李后主: 七种色光的来历，就是以肉眼可见来划分的，就叫可见光。

陈清扬: 中共治下，党魁是共产党的管家，只能顺着党的邪劲走；
中共治下，党的干部是极权结构中承上启下的中间阶层，在需要的时候只​能跟党保持一致；
中共治下，花瓶党派是共产党的陪衬，只能跟着党走；
中共治下，群众是供养中共，承受中共剥削的对象；
中共治下，独立见解人士或者无法发出声音，或者被中共迫害；
所以，中共治下每个人都活的不像个有尊严的人。

李后主: 清扬，你列举社会科学中的例子，要注意划分的范围，你上面的这个事例​，很难说它是一个完全归纳。这种例子的完全的一个范围是很难界定的，所以，举例是为了把问题说明​白，你这样一举例，人们越糊涂了。以后还是不举这种难以把握的例子。

陈清扬: 啊，谢谢老师指正。

辛言: 分别列举出九大行星围绕太阳作周期运动，
结论：太阳系中的所有行星都围绕太阳作周期运动。

李后主: 辛言的这个例子说的好。表达的也简单。

麻生: 列出动物、植物、以及人需要水才可以生存。
结论：所有的生命（指人可以理解的生命范围）都需要水才可以生存。

李后主: 麻生的例子也很好。

严仁勇: 空气是由氧气、氮气、二氧化碳、氢气等组成，所以空气是混合物。

李后主: 仁勇的这个例子有什么问题呢？

陈清扬: 归纳推理是以个别或特殊性知识为前提，引出一般性知识的推理。
我觉得仁勇的例子中，前面的个别或特殊性知识所对应的主体，和后面一​般性知识所对应的主体不是同一个类别的。所以不能说是从特殊到一般（的​归纳推理）。

李后主: 对，清扬说的对，后面没有推导出一般性的结论来。

赵阳光: 平房的地基可以打浅一些，楼房的地基要打深一些。所有的房子都是要打​地基的。

麻生: 列举，许多电器用电。
结论：所有的电器都要用电才可以使用。

李后主: 阳光的例子也很好。

李后主: 2，列举一个简单枚举法的例子。

齐学玉: 病人甲的肺是黑的，
病人乙的肺是黑的，
病人丙的肺是黑的，
甲、乙、丙都是五十岁以上的广州人，
所以，五十岁以上的广州人的肺都是黑的。

陈清扬: 我想了两个例子：
中共治下，牛肉有疯牛病、炭疽病污染；
中共治下，鸡肉有禽流感污染；
中共治下，猪肉有猪瘟和口蹄疫污染；
所以中共治下，所有肉类都是受到污染的。

陈清扬: 另一个:
x=1是(x-1)(x-2)(x-3)=0方程的根；
x=2是(x-1)(x-2)(x-3)=0方程的根；
x=3是(x-1)(x-2)(x-3)=0方程的根；
所以所有自然数是(x-1)(x-2)(x-3)=0方程的根。（错​误推理）

李后主: 齐学玉（修改）: 病人甲的肺是黑的，
病人乙的肺是黑的，
病人丙的肺是黑的，
甲、乙、丙都是五十岁以上的广州抽烟人，
所以，五十岁以上的广州人抽烟的肺都是黑的。

李后主: 大家要知道，简单枚举法不是不顾事实啊！归纳不能归纳出一个不是一般性的结论来，不能以偏概全，忘记这个原则​了吗？清扬的那个例子很明显是以偏概全了，因为你列举的那几种受污染的的东​西，是一种事实，但是不是所有的肉类都受污染也是事实。不能与基本事实​违背。

陈清扬: 逻辑重点还是要用在语言中，所以单纯逻辑有效的例子不一定合情合理—​—老师说过几次这个事情了，不过我有时候举例子还是会为逻辑而逻辑。

李后主: 是啊，清扬，上次是演绎逻辑，不能光注重形式，要和实际事物相结合，​这次是归纳逻辑，是要合实际事实相结合。

李后主: 学玉的例子倒是可以符合事实的，我说的是我改了的。因为吸烟人时间长​了肺都是黑的。

辛言: 陈独秀、毛泽东、胡耀邦、赵紫阳（结果省略），
他们曾担任过中共总书记，
中共总书记最后都没有好下场。

李后主: 辛言，这个事实应该用完全归纳法来归纳，不适合用枚举法，因为就那个​几个人，不到十个，在研究中，没有人会只研究其中几个人物就得出结论的​。

辛言: 明白了。

赵阳光: 电视机短路烧坏了，有糊味；
电脑短路烧坏了，有糊味；
冰箱短路烧坏了，有糊味；
凡是因电路故障烧坏的电器都会出现糊味。

李后主: 阳光的这个例子符合事实。

蓝睿: 台式电脑需要操作系统才能启动，
笔记本电脑需要操作系统才能启动，
台式电脑和笔记本电脑都是电脑，
所以所有的电脑都需要操作系统才能启动。

李后主: 篮睿的例子也可以，除了笔记本和台式机应该还有很多工业应用的电脑，​都需要一定平台的操作系统。

严仁勇: 我回家可以坐公交回，
我回家可以骑自行车回，
我回家可以步行回，
所以，我都能回到家。

李后主: 仁勇总是没有把个别的特性和一般的特性统一起来。

赵阳光: 仁勇的结论应该是：我每次能回到家必然选择了一种回家方式。

李后主: 阳光，你说的仁勇的结论也不正确，应该是，所以，我可以采取不同的方​式回家。因为个别性表达的正是不同的方式。

李后主: 阳光，你说的仁勇的结论也不正确，应该是，所以，我可以采取不同的方​式回家。因为个别性表达的正是不同的方式。

李后主: 我回家可以坐公交回，
我回家可以骑自行车回，
我回家可以步行回，
……
所以，我可以采取不同的方式回家。

赵阳光: 明白了

严仁勇: 经老师这样一改，现在明晰了。

李后主: 这样就符合实际也符合归纳逻辑了，其中省略的可以是“仁勇还可以爬着​回家”“翻滚着回家”“自己开车回家”“骑摩托回家”等等。

李后主: 所以，要注意看出一般性的东西是什么，把它归纳出来。

严仁勇: 好的，老师。

李后主: 现在没有毛驴很少见了，要不还可以骑着毛驴回家。人家张果老就是骑着​毛驴回家。还成仙了，可见骑毛驴也不错啊！

陈清扬: 虽然没学过模态推理，不过我想“我每次能回到家必然选择了一种回家方​式。”这是不是模态推理。

李后主: 好的，大家注意了。简单枚举法是因为在实际中没有办法把事物的对象全​部列举，所以只能列举一部分，但是通过这一部分，在现实中大家可以推导​出全部的属 性来，虽然从逻辑上这么推不过去，但是这就是归纳法啊，归纳​法，不完全的归纳法就是这么一种方法，它归纳的是现实中的经验。

李后主: 3，试举分别列举一个求因果五法的例子。
一个一个来看看吧！

李后主: 这些例子举起来很复杂，如果大家对科学史比较熟悉的话，例子就比比皆​是。

李后主: 齐学玉的例子
（1），求同法。

在对一些甲状腺肿大的患者进行病例分析后发现，他们年龄不同，性别不​同，来自不同的地区，但是有一点是相同的，就是他们对海产品如海带的食​用很少，而这些海产品中含有丰富的碘，所以医生推测，缺碘可导致甲状腺​肿大。

李后主: 嗯，不错！

陈清扬: 我举的例子又都是社会科学的例子，虽然可能还是不准确，不过还是发上​来了
求同法：
苏联时期有大清洗；中共时期有大量的政治运动与屠杀；柬共治下有（超​）大（比例的）屠杀；
所以，共产主义思想（中的阶级斗争思想）是导致大屠杀的原因。

李后主: 清扬，你的问题在于这个例子的原因不明晰，因为这是求因果关系的例子​。你要把各个共产主义国家搞屠杀和清洗的原因在前提中用求同法显示出来​。

陈清扬: 谢谢老师指正。

李后主: 通过研究发现，在人类历史上搞大屠杀的政权有这么几个：苏共统治苏联​时期，中共统治中国时期，柬共统治柬埔寨时期，所以，共产主义运动是这​些政权搞大屠杀的原因。

李后主: 看看我这么一修改，是不是明晰多了。

陈清扬: 确实。

赵阳光: （1）求同法：从贪官的经历来看，他们有的家庭本来就很富有，有的做​官前具有高尚的道德水准，甚至有的对贪污是深恶痛绝的。可是当他们进入​拥有绝对权力的政府后，普遍出现了贪污现象，可见不受约束的绝对权力是​出现贪污的重要原因。

李后主: 阳光的例子还可以。

李后主: 求同法
1，内容：求同法又称契合法，是寻求被研究现象出现在若干不同场合，​是否具有某种共同原因的归纳方法。假如被研究现象出现的若干场合中，有​一个情况是这些场合所共有的，那么这个情况就（可能）是被研究现象的原​因。

李后主: 下面我们再看第2个方法吧！

李后主: 求异法
     内容：求异法又称差异法，是将被研究现象置于两个对立的场合下进​行比较考察，在这两个对立场合中，只有一个情况是不同的，其它情况都相​同，然后对比 判断这个差异的情况和被研究现象的因果联系，如果这种情况​引起了被研究对象出现某种结果，而在另一个没有这种情况的场合被研究对​象没有出现这种结果， 那么这种情况就是这种结果的原因。

李后主: 比如说，日本曾对小学生做过一项实验，大体内容为是把学生分成两个班​，其中一个班教授汉字，另一个班不教授汉字，其它的情况都大致相同，经​过一段时间 后测试，发现教授汉字的那个班的学生的平均智商明显得高于没​有教授汉字的那个班的学生。这说明汉字可以使人的思维变得更复杂使人更​聪明，学习汉字是智 商提高的原因。

李后主: 这是我讲义中的例子。好，我们看看同学们列举的例子。

李后主: 齐学玉：
求 异法。把两只体重、品种相同的雄性小白鼠放在两个玻璃杯里，第一个​杯子里没放进去任何东西，第二个玻璃杯里放进一只燃烧的蜡烛，盖上盖子​。同等时间后 观察发现，第一个杯子里的小白鼠活蹦乱跳，第二个杯子里的​小白鼠爬着无力跑动。可以推测燃烧的蜡烛是小白鼠无力跑动的原因。

李后主: 不错，学玉的这个例子中还能体现出我讲义中讲的因果关系的层次问题。​燃烧的蜡烛是原因，但是后面还有更深刻的原因就是氧气的问题。

陈清扬: 求异法：
中国在周朝以前的封建制度，从秦朝至清末皇权一统的制度下，到民国共​和（与僭主）的时期都没有这种人人为近敌的状态；可是同样一片土地，同​样一个民族，共产红朝时代的社会中却充满了这种人人为近敌可怕心态，可​见共产主义（的党文化）是人人为近敌的原因。

李后主: 清扬的这个例子还不错，能说明问题。

辛言: 相同的一块耕地分两部分，分别种了不同品种的玉米，采用相同的管理办​法，产量却不同，所以玉米品种是决定产量不同的原因。

李后主: 辛言的例子也好啊！

赵 阳光: （2）求异法：一般人都有一定的私心存在，都想为自己牟取一些利益，​当自己掌握公众利益的时候都有一些贪婪的想法，这些动机可以导致贪污。​但是，在民 主、法制、司法独立、有新闻监督的国家，贪污现象相对少；在​没有前述特征的独裁国家贪污现象很多。说明民主制度可以有效地防止贪污​，而独裁国家很难遏 制贪污。

李后主: 阳光的例子也不错，求异法寻求原因比求同法更准确一些，在现实中运用​的也更多。

赵阳光: 用求异法可以很好分析中国的社会现象。

夏华: 同样是橘子树，在江南结橘子，在江北结枳。不同环境可以结不同果实。

李后主: 夏华的这个例子道理还可以，只是里面表述的不完整。

李后主: 那么，我们再看下面一个归纳方法。

李后主: 求同求异并用法
  内容：求同求异并用法也称“契合差异并用法”，简称“并用法”、“​契差法”。被研究现象在一些场合出现时有一个共同的情况出现，而被研究​现象在另外一些对立的场合不出现时这个共同的情况也没有出现，可以归纳​出这个情况就是被研究现象的原因。

李后主: 比如把一群鸡分为两组，一组喂食精米，另一组喂食带壳稻谷。经过观察​，喂食精米的一组鸡都得了一种病，两脚无力，不能行走，症状与人得的脚​气病相似。 而另一组喂食稻谷的鸡却不得这种病。由此推断，带壳稻谷中含​有某种精米中所没有的东西，它是避免得脚气病的原因。进一步研究发现，​这种东西就是维生素 B1。

陈清扬: 契差法：
西方企业在中国社会成了腐败的急先锋，在西方社会运作公开透明；中国​企业在中国社会运作行政管理（公关、贿赂）费用很高；到了西方社会却也​能遵守透明运作、公平竞争的规则；
契合：在中国社会的企业都会走向腐败。在西方社会的企业都会走向公开​透明。
差异：中国社会导致企业变得腐败，西方社会导致企业走向公开透明。
契差：所以中国（现在）的社会环境是腐败的源泉；

李后主: 清扬的这个例子不错，两个事例组分成四种场合对比，使结论的更准确了​。

 赵阳光: （3）并用法：中国是独裁制度，美国是民主制度。在社会发展过程中，​中共当局出现了腐败泛滥，而美国政府则比较清廉。由此可见民主制度中有​防止腐败的因素，经过深入分析，这些因素就是民众监督、司法独立、新闻​监督等。

李后主: 阳光的这个例子也是表述上不清晰。在你这个例子中被研究现象是民主制度还是腐败现象，我看不清楚。

赵阳光: 好像没有细致的推理。

李后主: 是的，没有形成一个细致的推理过程，只是一个简单的对比，用作求异法​还可以。缺少求同的因素，或者说这方面的因素没有表达出来。

麻生: 美国也存在腐败，但相对于中共就较少。阳光可以以腐败现象为表述。

張穀虛: 可增加：由此可见民主制度中有​防止腐败的因素，独裁制度是導致腐敗​的最大因素。

李后主: 齐学玉;
求同求异法。

为 了进一步验证以上的结论，某人把十只体重、品种相同的雄性小白鼠分​成两组，每组五只。然后将两组小鼠放在两个玻璃杯里，第一个杯子里没放​进去任何东 西，第二个玻璃杯里放进一只燃烧的蜡烛，盖上盖子。同等时间​后观察发现，第一个杯子里的小白鼠活蹦乱跳，第二个杯子里的小白鼠爬着​无力跑动。求同：第 一个杯子里的小白鼠，它们都在没放蜡烛的杯子里，结​果是它们活蹦乱跳；第二个杯子里的小白鼠都在有蜡烛的杯子里，结果是它​们都无力跑动。求异：第一个 杯子里没有蜡烛，而第二个杯子里有蜡烛，因​此，推测燃烧的蜡烛是小白鼠无力跑动的原因。进一步研究可知，是燃烧的​蜡烛消耗掉了杯子里的氧气，缺氧使小 白鼠无力跑动。

李后主: 大家看看，学玉的这个例子非常清晰。

李后主: 以后大家举例子，适合举自然科学研究中的例子的就不要从社会研究中去​寻找，如果是给别人讲解反而把一个道理或者方法没有能讲清楚。自然科学​的例子的特点就是简明好懂，我们要印证一个道理最好还是先从自然科学中​的现象出发。

赵阳光: 自然科学的例子比社会科学的例子清晰，容易理解。

陈清扬: 我今天为了举社会科学而不是自然科学的例子还花了一番心思，呵呵。

李后主: 归纳法本来就是在实验的基础上发展出来的，它在自然科学中的应用是最​普遍的，我们先把自然科学中的现象把握好了，把逻辑规律掌握纯熟了，再​往社会科学中去应用，那么在社会科学应用中最重要的是划分类别以及鉴定​社会科学中的概念。

夏华: 想起一个实际的问题，比如8个外观相同的球，只有一个重量不同，如何​​用一架天平找出这个重量不同的球。

李后主: 两组分开秤，再分别把两组分成四组秤，再分一次，总共分三次就可以秤​出来了。第2次秤时，平衡的那组淘汰掉。 基本方法就是这样，这其中应用了求同求异法，夏华的这个例子很不错，​很有意思。

赵阳光: 先找出一对可以平衡的球，用其中的一个做标准。再把另外6个分别和做​标准的那个一起称，出现不平衡的时候那个球就是重量不同的。

齐学玉: 夏华的这个题应该还有别的限制条件。

夏华: 同样的外观，同样使用一架天平。

李后主: 总共秤三次，从第2次开始淘汰一组，第3次再秤时就是两个了，随便拿​一个和第2次淘汰掉的（也就是一样的那一组）一个来秤就可以知道哪个是​不一样的。

赵阳光: 老师这个方法可以做到称的次数最少。

齐学玉: 这个题的前提是不是允许称三次，且天平是没有砝码的天平？

夏华: 我忘记是否说了，应该又个前提是一个球是知道是重或者轻。
我主要是说这个例子，符合归纳法。

陈清扬: 我以为老师那个办法不需要知道特殊的球是轻还是重，三次足够了。

李后主: 我再把这个方法给大家表达清晰一点，以数字1～8来代替，假设7为不​同的那个球。
先 分成两组，假设第一组为1234，第2组为5678。其实这个分组​不需要秤，继续分组，12和34一起秤，56和78再一起秤。可以发现​12和34的 天平是平衡的，说明1234都是一样的，那么再秤另一组，​必然不一样（其实这个时候也不要秤了，直接进行下一步），拿出56和7​8中的随便一个和 1234中的随便一个秤一次，就知道56和78是78​这一组有异类，这时才秤了两次。最后再拿78中的随便一个和1234中​的随便一个秤，就知道谁是 7谁是8。

李后主: 这个题目，就是8个球外表一样，其中7个重量相同，一个重量和大家不​同，然后不用砝码用一架天平最少秤几次就能知道哪一个球是异类的。

李后主: 不需要知道是轻还是重。只需要知道不一样，三次我就可以把它找出来。

李后主: 好的，游戏和测试结束了，我们继续看下一个方法。

李后主: 共变法
    内容：共变法是指在被研究现象发生变化的若干场合中，发现其中某​一个情况会随着被研究现象的变化而发生变化，而其它情况不变，则这个情​况是被研究现象的原因。

李后主: 比如，在有空气的玻璃罩里通电击铃，随着抽出空气量的变化，铃声越来​越小。如果把空气全部抽出，则完全听不到铃声了。由此可以断定，空气多​少是发出声音大小的原因，空气的有无是能否听到铃声的原因。

李后主: 共变法的特点是：如果现有条件看不出现象之间的关系，那么可以通过改​变条件来观察现象之间的内部联系，目的在于打破现有的平衡态，在事物运​动变化中来揭示因果关系。

李后主: 那么，大家列举几个共变法的例子来。

陈清扬: 还是社会科学的共变法：
（1986年到2005年）中国的行政开支增长了23倍；
同期全国GDP增长仅为14.6倍；
所以，GDP增长是保证中国（贪污腐败、营私舞弊）行政开支大量增长​的原因（之一）。

李后主: 清扬的这个例子没有显示出共变，应该是一组例子来说明。

齐学玉: 一定量的气体，保持压力不变，随着温度升高气体体积不断增大，温度降​低时气体体积缩小。可知，气体体积大小与温度高低有关。

李后主: 学玉的这个例子显示出了共变的现象。

夏华: 共变的共是什么意思呢？

李后主: 一个情况的变化引起另一个情况的变化。

李后主: 我讲义中说【通过观察发现，某公司的利润随着资金利用率的提高而增长​，而其它情况不变，因此可以得出该公司资金利用率的提高是利润增长的原​因。】这是 一个概括的说法，如果我要说数据就得至少举出两组数据（还是​有点少，只是逻辑上至少需要两组来观察共变，实际中我看至少得三组才行​，两组数据可以观察 到一次共变现象，三组数据就可以观察到两次共变现象​。）。清扬的那个例子举的是数据，就需要用两外几组不同年份的数据来对​比。

赵阳光: 在品种、生长温度、水分相同的条件下，农作物在光照充足的地方产量高​，反之则产量低。可见农作物的生长与太阳照射的因素密切相关。

李后主: 阳光，你的这个例子是求异法。

赵阳光: 应该具体说明光照条件的变化情况和产量的变化情况。而不能笼统地说充足与否。

李后主: 对的，阳光，要求一个条件的改变引起你要研究的现象的改变，那么就构​成共变关系了，通过共变关系揭示事物之间的联系。

赵阳光: 我发现这个例子要用大、小、多、少、高、低等表达具体情况的字词。

李后主: 是的，阳光，变化的结果是要靠这些词来表达出来的。

夏华: 比如不同时段的地铁站人流密度。

李后主: 夏华，这个人流密度和什么有关系，你可以通过几组数据来研究它，从中​发现因果关系。

夏华: 和上下班高峰又关系，同一个地铁站，早高峰人多，中午人少，到晚高峰​人又多了。还有从周一到周日的对比。当然需要做具体试验记录。

李后主: 夏华，时间只是划分了不同的“场合”。引起人流的原因你要从其它现象​中观察。然后观察这个原因的变化与人流的变化之间的关系，或者是正的关​系，或者是反的关系，这样就可以用共变法来揭示出这个原因来。

麻生: 物质保持的形态，是根据其内部分子运动的速度决定的，如果其内部分子​运动快速，其表现可能是液态，钢分子运动速度很快，就变成钢水，如果分​子运动速度变慢，则为固态，可见，物质内部的分子运动速度可以决定物质​形态。

李后主: 麻生的这个例子也可以。可以表述成几组数据表达的的观察结果。

黎焕石: 在跑步时,你的速度越快,你所花的时间就越少,你的速度越慢,你所花​的时间就多,可见,跑步所花的时间跟速度有关系。

李后主: 黎唤石。这个事实不需要这么去研究，直接就观察出来了。

李后主: 电流强度与电压成正比，功率与电阻成反比，这都是一种共变的关系。

李后主: 你们怎么老是摆不脱把逻辑形而上化的倾向呢？要和实际和事实相联系。​和实际相联系就是你不要把很简单的事实搞成很复杂的研究。我们通过科学方法要揭示的是现实中不容易观察的因果关系。

夏华: 逻辑是因为自然科学的发展而发展起来的吧，或者相互影响？

李后主: 逻辑比自然科学要早几千年，根本不是为了自然科学而发展起来的，而是​自然科学是从逻辑中发展起来的。

李后主: 学玉：
概念的内涵小则外延大，增加概念的内涵则概念的外延随之减少，因此概​念内涵与外延间具有反变关系。

李后主: 学玉的这个结论等于是重复。为什么呢？你们想想。我们要什么结论呢？

李后主: 五法是求什么的五法？

齐学玉: 求因果。

赵阳光: 因果联系。

李后主: 麻生刚才的例子只是没有明确指出因果关系，但是他的结论显示了因果关​系，所以还可以。

严仁勇: 求因果的关系。

李后主: 但是学玉的例子揭示出共变关系了，却结论来了个所以，他们二者有反变​关系。等于说所以他们二者有共变关系。

李后主: 因此，概念内涵的增加是概念外延减少的原因。

齐学玉: 看明白了。谢谢老师。结论是为了揭示某种因果关系，而不是说它们之间​是共变关系。做题的时候没有体会出这种差别来。

李后主: 共变关系是为了揭示因果关系，就是找事物之间的内部联系。是为了发现规律。

李后主: 自然科学中这样的事例比比皆是吧！到处都是关系啊，压力和压强的关系​，质量和体积的关系，电流和电压的关系，温度和阳光的关系，等等，到处​都是，从中都可以找出很多事例出来。

黎焕石: 社会越发展,道德越败坏,可见发展是道德变坏的原因之一。

李后主: 黎唤石的这个例子也有问题，那么道德只能变坏没有办法提升了？要么社​会不发展原地不动？

李后主: 好的，我们看看下面一个方法吧！
李后主: 剩余法
：剩余法是已知某一复合情况是另一复合现象的原因，同时又知道这个复​合情况中的某一部分是复合现象中的某一部分的原因，那么，复合情况的其​余部分是复合现象的其余部分的原因。
在 科学研究中经常运用剩余法，比如用光谱仪发现新元素的过程都是剩余​法的应用。光谱分析仪被发明以后，人们用光谱分析仪发现了一大批新元素​，也建立起了 元素与光谱的一一对应关系，所以元素都可以在燃烧或者高压​电击（气态）下发出光线，这些光线在光谱带上都有一个固定的位置，通过​确证已经元素的谱线位 置，剩下的出现在新位置上的谱线就是一种新元素的​光谱。通过这种方法，人们发现了大量的新元素。

夏华: 复合这么解释？

李后主: 就是很多情况综合在一起的，要把它们一一区别开来，谁是谁的，分清楚​。打个比喻，一群孩子站在那里，你和一群老爸过来接孩子，你看着别人把​自己的孩子都接走了，那么剩下的只能是你的孩子了。

李后主: 哪位同学举一个剩余法寻找因果关系的例子？

赵阳光: 汽车在一定速度下的刹车距离可以测量出来，在交通事故鉴定中可以通过​测量刹车距离判断该车出事时的行驶速度。

李后主: 这就像光谱一样啊，每个速度都对应着一条刹车线，查查它的刹车线和哪​个速度对应，就可以把他找出来。但是这和剩余法还是没有扯上关系。因为​只需查它的那个对应速度，和别的东西没有关系。

夏华: 科学家通过一种手段判断某个黑洞的存在，就可以通过这种方式找到其他​黑洞的存在。

李后主: 夏华，不是剩余啊！

夏华: 未知的黑洞对于已知的黑洞不是剩余？

李后主: 看看我刚才的比喻，要其它老爸把自己的孩子一一领走了，剩下的孩子就​是和你有父子关系的孩子。我们把父子关系如果还原为因果关系，就是我们​的剩余法。

夏华: 哦。

李后主: 这就是复合情况啊，是在复合情况中一一排除。

赵阳光: 这个例子复杂。

齐学玉: 这个例子不好举啊。

李后主: 你们的电脑常出问题吗？如果出问题时是一大堆问题时就要用到剩余法了。要寻找这些问题的原因啊！

李后主: 这是剩余法的形式，大家参照这个形式看看自己的是不是这种情况。

赵阳光: 两个坏蛋行凶，一个被抓一个逃跑。受害人说两个人的脸上都被自己分别​挠了五个指甲印，经确认被抓的凶犯确实有五个指甲印。然后另外抓住几个​嫌疑人，寻找到脸上有五个指甲印的就是逃跑的那个坏蛋。

李后主: 阳光的这个例子还可以。把综合的情况中的其中一个情况区别出来了，但是没有显出因果关系。可以再修改修改。

李后主: 五个指印是确定其为凶犯的原因。

赵阳光: 修改：两个坏蛋行凶，一个被抓一个逃跑。受害人说两个人的脸上都被自​己分别​挠了五个指甲印，经确认被抓的凶犯确实有五个指甲印。然后另外​抓住几个​嫌疑人，其中有一个被受害人指认正是他在行凶时挠了他五个指​甲印，这个人就是逃跑的那个凶犯。

李后主: 对了，阳光的这个例子属于一果多因。不是多果多因的综合情况。所以还​是不行的，刚才我也没看仔细。

辛言: 晚上突然停电了，可以有很多原因，如跳闸，短路、线路出问题、大面积​停电等等，经检查这些都没有问题，乘下的原因可能是变压器坏了。

李后主: 辛言。你的例子也是一果多因。

辛言: 弄反了。

夏华: 和添数字游戏有些类似，比如横竖交叉添数字，最后之和相同。

 李后主: 夏华，和添数字游戏不一样，是寻找复杂的综合情况中的某个情况的原因​。

黎焕石: 是不是也叫排除法呀？

李后主: 排除法和剩余法不完全一样，但是很相似。剩余法必须是多因多果的综合情况下，然后排除了其中的几对因果关系后​，剩下的一对就是我们要寻找的因果关系。而排除法可能是一果多因，要排除一些可能原因，最后找到真正的原因。

夏华: 比如，我想把一块刻有古代文字的碑文翻译成现代语言，那么我首先要确​定古代的字母和现代字母的关系，然后才可以翻译，当然也可以翻译其它的​古代文字。

黎焕石: 网大课堂上用绿色显示的是老师的名字，用黑色显示的是可以发言的同学​，用灰色显示的是不可以发言的同学，只有李后主与唐子是显示绿色的，所​以他们两个人是老师。

李后主: 逻辑形式
     复合情况（A、B、C、D）是被研究现象（a、b、c、d）的原因
     A是a的原因
     B是b的原因
     C是c的原因
     所以，D是d的原因。
    3，剩余法的特点——余果求余因

李后主: 这是剩余法的形式，大家参照这个形式看看自己的是不是这种情况。

李后主: 好吧，你们下去慢慢翻阅一些资料去体会吧！举不出来就不举了。

李后主: 今晚的课就到这里。

李后主: 最后提示一下，剩余法的是多果多因的情况下，通过排除其它因果关系，​最后用余果求得余因。

师生互道晚安！


第五章 归纳推理

根据前提到结论的思维进程的不同，非模态推理可分为演绎推理、归纳推理、类比推理。前面两章内容我们讲的推理类型都属于演绎推理，本章我们学习归纳推理。

第一节 归纳逻辑综述

一，什么是归纳推理

    归纳推理是以个别或特殊性知识为前提，引出一般性知识的推理。

归纳推理分为完全归纳推理和不完全归纳推理。比如说：“已知亚洲有河流，非洲有河流，南北美洲有河流，欧洲有河流，大洋州有河流，南极洲有河流，而以上的大陆就是地球上的所有大陆，所以，地球上的所有大陆都有河流。”这是一个完全归纳推理，从已知的个别性前提推导出一个一般性结论。前提的个别性命题是真的，结论的一般性命题也是真的。完全归纳推理是一种必然性推理，在形式上虽然属于归纳推理，但其中却包含有演绎推理的性质。

那么，再看一例：“已知所有的鸡蛋都有蛋黄，所以，凡是鸡蛋都有蛋黄。”这是一个不完全归纳推理。它的结论所断定的知识范围超出了前提所断定的知识范围，在逻辑性质上属于一种可能性的断定，因此，不完全归纳推理的前提与结论之间具有或然性。已知的一些现象在逻辑上并不能保证未知的现象必然遵循这个规律，因此，不完全归纳推理的有效性在历史上一直受到质疑，最有名的就是英国哲学家大卫·休谟对归纳法的因果关系提出的质疑。

    二，归纳推理与演绎推理的关系

    1．两者相互区别

    ⑴思维进程的方向不同。

    演绎推理：从一般到个别；

归纳推理：从个别到一般。

⑵对前提的真实性要求不同。

演绎不要求前提必须真实，归纳则要求前提必须真实。

   ⑶结论断定的知识范围不同。

    演绎推理：结论所断定的范围没有超出前提所断定的范围；

    归纳推理：结论所断定的范围超出前提所断定的范围。

    ⑷前提与结论间的联系程度不同。

    演绎推理：前提与结论之间的联系是必然的，是充分条件的关系，前提蕴涵结论，即只要前提真实，形式正确，结论必然是真实的；

    归纳推理：前提与结论之间的联系是或然的，是必要条件的关系，前提不蕴涵结论，而是被结论所蕴涵着。

    2．两者相互联系

⑴演绎离不开归纳

归纳推理的结论为演绎推理提供了前提，演绎推理的一般性知识的前提，需要借助于归纳推理从具体的经验中概括出来。

⑵归纳离不开演绎

演绎推理为归纳推理提供了指导，归纳推理的可靠度需要运用已知的理论知识对归纳的个别性前提进行分析研究，把握其因果性和必然性，这就要用到演绎推理。

    在实际思维过程中，归纳推理和演绎推理是相互依赖、相互渗透、相互配合的。

    三，归纳推理的种类

    1，根据推理所考察的对象的范围，把归纳推理划分为完全归纳推理和不完全归纳推理；

    2，根据对象和属性之间的联系方式，把不完全归纳推理划分为简单枚举归纳推理和科学归纳推理。

    归纳推理的内容还包括探求因果联系的五种方法（穆勒五法）、典型归纳推理、回溯归纳推理（案情分析的主要工具）等经验归纳推理和初步形式化的“统计归纳法”、“概率归纳法”等。


第五章 归纳推理

第二节 完全归纳推理

一，什么是完全归纳推理

    1，定义

    完全归纳推理是根据一类事物对象中每一个对象都具有（或不具有）某种属性，推出该类对象全体都具有（或不具有）这种属性的推理。见前面的例子。

    2，逻辑结构式

     S1是（不是）P

     S2是（不是）P

     S3是（不是）P

     ……

     Sn是（不是）P

    （S1、S2、S3……Sn是S类的全部对象）

     所以，所有的S是（不是）P

     3，完全归纳推理的特点：必然性。

    由于完全归纳推理是从个别性前提到一般性结论的推论，这使它具有归纳的特性；又由于完全归纳推理的前提和结论之间具有必然性联系，这又使它具有演绎的特性。所以，完全归纳推理乃是联系或然性归纳推理与必然性演绎推理的过渡环节。

    二，完全归纳推理的规则

    1，对于个别对象的断定都是真实的；

    2，被断定的个别对象之和是同一类事物的全部对象。

    三，完全归纳推理的作用

    完全归纳推理的主要作用在于综合。它把有限数量的单称命题综合为一个整体，综合成为具有特定限度的一般性命题，它使人们的认识从个别上升到一般。

    1，认识的作用。

完全归纳推理可以从个别中总结出一般的规律，因此，可以用于认识事物的共性。数学家高斯少年时代异常聪明，有一次老师给他们一群孩子们出了一道计算题，计算一下：1＋2＋3＋4＋……＋97＋98＋ 99＋100 的和。老师心里想着，要加的数目这么多，可得费些功夫呢！而且不留神，答案就会弄错的。可是，没过多大会儿，高斯就举起手并说出了正确的答案。老师感到很吃惊，这孩子从哪儿来的答数呢？高斯有非常敏锐的观察力和归纳的能力，看出这一连串要加的数目（从“1”到“100”）中，第一项和倒数第一项，第二项和倒数第二项，第三项和倒数第三项……每对的和数全都为“101”，即 1＋100＝101，2＋99＋＝101， 3＋98＝101，…… 50＋51＝101，由此可见，从“1”到“100”之间，凡是首尾距离相等的每两项之和都是“101”。根据这个性质，又根据排列成对的序数共有50对，高斯迅速找到了正确答案，即：101×50＝5050。这是应用完全归纳推理的一个非常典型的例子。

2，论证的作用。

为了论证某个一般性的论断，可以列举与此有关的一切对象，然后对其中的每一个别对象一一加以考察与确认，最后通过完全归纳推理，就可以证明这个一般性论断是真实的。比如证明三角形的面积等于1／2ah（a为底边，h为高），我们可以通过证明钝角三角形的面积等于1／2ah，锐角三角形的面积等于1／2ah，直角三角形的面积等于1／2ah，通过完全归纳推理，所有三角形的面积等于1／2ah。

    四，运用完全归纳推理时应注意的问题

    1，完全归纳推理的前提必须是真实可靠的，而且对象必须是完全的。如果遗漏其中的任何一个对象，或有一个前提虚假，都不能得到真实可靠的结论。

2，完全归纳推理不能应用于一个具有无穷对象的类，因为无穷的对象是不能完全归纳出来的。

    五，完全归纳推理与不完全归纳推理的区别

    ①完全归纳推理的前提考察了某类的全部对象，不完全归纳推理的前提只是考察了某类的部分对象。

    ②完全归纳推理的结论范围并未超出前提的范围，而不完全归纳推理的结论超出了-前提的范围。

    ③完全归纳推理的前提与结论之间的联系是必然的，而不完全归纳推理的前提与结论之间的联系不是必然的而是或然的。


第五章 归纳推理

第三节 不完全归纳推理

一，简单枚举归纳推理

  1，定义

    简单枚举归纳推理又叫做简单枚举法，它是根据一类事物对象中部分对象具有（或不具有）某种属性，推出该类对象全体都具有（或不具有）这种属性的推理。简单枚举法要求在列举事物的部分对象时没有遇到反例。简单枚举法是一种最直接的经验归纳，特点就是直观性很强，只具有或然性。

司法断案经常使用简单枚举法进行案情分析，以鉴定死者的身份和死因。例如以硅藻反应鉴定溺水死亡的技术，就是依据已有的溺水死亡的人的肺部都有硅藻反应的经验来推理，由此得出“凡是溺水而死的尸体，其肺部都有硅藻反应”的结论。其推理过程为：

毛某是溺水而死的，其肺部有硅藻反应；

邓某是溺水而死的，其肺部有硅藻反应；

江某是溺水而死的，其肺部有硅藻反应；

……

凡是溺水而死的尸体，其肺部都有硅藻反应。

【经验常识：如果死者是溺水死亡，在溺水过程中必然会吸入大量的周围环境中的水，导致窒息而死亡。由于吸入的水是周围环境中的水，在水中生长的硅藻也必然跟随一同被吸入肺中，最后留存在肺部以及周围的体液环境中，在检验时也能呈现硅藻检验阳性反应。所以，硅藻检验技术是检验溺水死亡的常用技术之一，结合其他溺水死亡的反应特征以及损伤表现，就能判断死者是否是属于溺水死亡以及是否是在死亡后被抛入水中。】

    2，逻辑结构式

     S1是（不是）P

     S2是（不是）P

     S3是（不是）P

     ……

     Sn是（不是）P

    （S1、S2、S3……Sn是S类的部分对象，并且没有出现反例）

     所以，所有的S是（不是）P

    3，简单枚举归纳推理的作用

在研究对象无法穷尽而不能进行完全归纳推理时，简单枚举对某类事物的性质和特征所进行的概括和扩展，仍然是人们探求科学规律和获取新知识的重要手段。但是，由于简单枚举归纳推理的依据是不充分的，其结论也只能是或然的，可靠程度较低。一旦在以后的实践中发现了相反的情况存在，原先的结论就会被推翻。例如：过去有些用简单枚举归纳推理推出的结论，像“天下乌鸦一般黑”，“哺乳动物都是胎生的”等等。由于在日本发现了白色的乌鸦，在澳洲发现了卵生的哺乳动物鸭嘴兽之后，原来的结论就不能成立了。

    4，运用简单枚举归纳推理时应注意的问题

    ⑴应尽量增加枚举的数量，扩展考察的范围，这样才能尽可能地增加结论的可靠性。

   ⑵一旦发现反例，就应该推翻原来带有普遍性的结论。这就是所谓的“证伪”。

    ⑶避免“轻率概括”或“以偏概全”。

    司法工作在使用简单枚举归纳推理时尤其要注意避免犯“轻率概括”的逻辑错误。例如：“凡是犯罪嫌疑人脸红、淌汗、手脚发抖，就一定是做贼心虚”，像这样的用简单枚举归纳推理得出的结论，就是犯了“轻率概括”的逻辑错误。再比如老师看到一个学生迟到了两三次，就批评他说你怎么老是迟到，这也是轻率概括，生活中人们经常习惯于这么概括，但是它不符合逻辑规律。

二，科学归纳推理

    1，定义

科学归纳推理又叫做科学归纳法，它是根据一类事物部分对象与其属性间所具有的因果联系的必然性，推出该类事物的全部对象都具有这种属性的推理。

例如，已知铁可以导电，铜可以导电，铝可以导电，因为铁铜铝都是金属，都有自由电子，因此得出凡是金属都可以导电。

2，逻辑结构式

     S1是P

     S2是P

     S3是P

     ……

     Sn是P

    S1、S2、S3……Sn是S类的部分对象，并且S与p之间有因果必然联系；

    所以，所有的S是P。

    3，比较科学归纳推理与简单枚举推理

⑴共同特点：

    简单枚举推理和科学归纳推理都是不完全推理。它们的共同点是：前提中的个别性知识都只是考察了某类事物的部分对象，并没有考察某类事物的全部对象，但结论所断定的范围都超出了前提已有的知识范围，因此，它们的结论都不具有必然性，其真实性都有待检验。

⑵区别

    ①得出结论的依据不同

    简单枚举法的依据是没有遇到相反的情况；科学归纳法的依据是现象之间的必然性联系。科学归纳推理是比较可靠的不完全归纳推理，但是它与简单枚举法归纳推理并没有什么明确的界线划分，只是研究的深度和对现象之间内部联系的程度上的区别而已。

    ② 提高结论可靠性的途径不同

    简单枚举法是靠增加被考察的对象和扩大被考察的范围来提高其可靠性的。科学归纳法是依靠对前提的深度的科学研究分析而获得结论的，它的可靠程度并不是靠前提的多少来决定的，而是靠是否真正把握了事物之间的因果联系来决定的。比如要认识麻雀的内脏结构和特性，只需要解剖上几只麻雀做系统的分析研究就可以了，不必要靠增加解剖麻雀的数量来增加结论的可靠性，也更不可能把所有麻雀都解剖了。所有科学研究都遵循这个规律，这也是科学归纳法的普遍表现形式。


第五章 归纳推理

第四节 探求因果联系的逻辑方法（穆勒五法）

因果联系：如果某种现象存在，必然引起另一种现象出现，那么这两种现象的联系就叫做因果联系。引起某种现象产生的现象叫做原因，被某现象引发的现象叫做结果。因果现象比较复杂，有一因多果现象，也有一果多因现象，还有互为因果现象。因果循环现象，也叫做反馈现象，分为正反馈和负反馈。如果现象1引发现象2，则现象1为现象2的原因，现象2为现象1的结果，现在现象2的出现又反过来影响现象1，使现象1加强的叫做正反馈，使现象1减弱的叫做负反馈。如无线电发射机一般都是一个正反馈的振荡器，使能量被循环放大发射出去，这是正反馈现象，而电路中用的稳定电压或者频率的一些控制器则是负反馈现象。此外自然和社会系统中也形成了很多反馈现象，我们所说的恶性循环就是一种正反馈现象，某种不好的原因影响到某种不好的结果出现，这种不好的结果的出现又反过来加强了这种不好的原因，所以就构成恶性循环了。当然也有良性循环现象（可以是正反馈也可以是负反馈）。

以下图示中⑴为一般因果关系的过程；⑵为反馈的因果关系的过程。

⑴现象1→现象2 现象1是引起现象2的原因，现象2是现象1引发的结果；

⑵现象1→现象2 现象1和现象2互为因果关系。

↑ ↓

现象2←现象1

古典归纳逻辑中有五种探求因果联系的逻辑方法，简称求因果五法，这些方法是英国人穆勒在总结培根等人的归纳法的基础上提出来的，所以史称“穆勒五法”。这也是科学归纳法所常用的五种归纳方法，在科学研究中被得以普遍的使用。

一，求同法

1，内容：求同法又称契合法，是寻求被研究现象出现在若干不同场合，是否具有某种共同原因的归纳方法。假如被研究现象出现的若干场合中，有一个情况是这些场合所共有的，那么这个情况就（可能）是被研究现象的原因。

比如，当人们在水里搬石头时要比岸上轻得多，在水中可以很容易的托起一个人，船可以浮在水面上很轻松的被拉动，以上现象虽然不尽相同，但都有一个共同的情况是水能产生浮力，这是以上现象的共同原因，是物体在水中变轻的原因。

再比如说，人们观察到石头从山上滚下来，天空会下雨，苹果会从树上掉下来，水是从高处流向低处，这些现象有一个共同的情况是物体从高处往低处运动，那就是地面有吸引力，这是以上各种现象的共同原因。

2，逻辑形式

场合 先行（或后行）情况 被研究现象

⑴ A、B、C a

⑵ A、D、E a

⑶ A、F、G a

     ……… ………… ……

     所以，A是a的原因。

    3，求同法的特点 ——异中求同

求同法是在被研究对象存在的不同的场合中寻找一种共同的情况，把这种情况作为被研究对象的原因，但是这种方法的或然性很大，因为有可能由于认识能力的肤浅，显示出来的这种共同情况也只是更深刻原因导致的一种现象的表现，比如我们现在认识到万有引力并不一定是真实存在的宇宙规律，很有可能是更深刻的宇宙规律在我们这个空间层次的一种现象性的表现。

4，求同法应该注意的问题

⑴各场合是否还有其他共同情况；

要求各个场合当中除了一个情况以外，其他情况都不相同。如果应用时出现了几种共同的情况，那么，必须在这几种共同的情况之间进一步寻找它们的相同因素。

⑵进行比较的场合越多，各场合共有一个不相干现象的可能性就越小，结论的可靠程度越高。如果比较的场合比较少，那么就有可能有一种不相干现象是它们所共有的，那么就会误以为它就是被研究现象的原因，而把真正的原因给削弱或者取代了。

⑶要对比较的各种场合的真实情况进行深入的研究，以避免被表面现象所迷惑，把一个共同的表面现象当作原因，而把隐藏在背后的真正原因给忽略掉。当然这一点受时代和认识水平的局限。

注意：⑵⑶虽然是两个逻辑阶段，但是却可以是同一个认识过程的不同深度和不同层次的表现。多场合的比较在某些情况下（原因隐藏的并不深）能排除掉一些不相干的现象，但是还有一些现象的原因作为本质的联系是隐藏着事物背后的，这需要更深刻的专业研究才能得以发现，科学研究中一些错误的假说或者结论有时候能影响很长时间正是因为本质的因果联系隐藏得很深，而人们的认识水平在当时却没有达到揭示这个因果联系的足够深度。

比如，早期人们以为燃烧现象是由一种燃素的物质引起的，认为一切可燃的物质中都含有一种气态的要素，即所谓燃素，它在燃烧过程中从可燃物中分散出来，与空气结合，从而发光发热。正因为木头中含有这种特别的要素，所以能够燃烧，而石头中不含这种特别的要素，所以不能燃烧。木头燃烧，就是燃素从灰中分离出来，燃烧后，燃素跑掉了，炉膛里剩下的就是灰。这种学说能够解释当时很多观察到的燃烧现象，使人们以为燃烧的原因就是燃素。

燃素说在化学史上几乎统治了１个世纪，但是随着化学的发展，化学家更多地应用定量测定的方法研究化学反应，燃素说开始动摇。随着越来越多的精确化学实验现象被观察到，18世纪法国化学家拉瓦锡找到了燃烧作用的真正原因——氧化，所有燃烧现象的共同情况是必须有氧化剂参与。

科学发展史中这样的例子比比皆是。

二，求异法

    1，内容：求异法又称差异法，是将被研究现象置于两个对立的场合下进行比较考察，在这两个对立场合中，只有一个情况是不同的，其它情况都相同，然后对比判断这个差异的情况和被研究现象的因果联系，如果这种情况引起了被研究对象出现某种结果，而在另一个没有这种情况的场合被研究对象没有出现这种结果，那么这种情况就是这种结果的原因。

比如说，日本曾对小学生做过一项实验，大体内容为是把学生分成两个班，其中一个班教授汉字，另一个班不教授汉字，其它的情况都大致相同，经过一段时间后测试，发现教授汉字的那个班的学生的平均智商明显得高于没有教授汉字的那个班的学生。这说明汉字可以使人的思维变得更复杂使人更聪明，学习汉字是智商提高的原因。

    2，逻辑形式

     场合 先行（或后行）情况 被研究现象

     ⑴ A B C a

     ⑵ － B C －

     所以，A是a的原因。

    3，求异法的特点——同中求异

    求异法的特点是同中求异，通过排除两个场合的许多现象中的相同情况，找出相异之处，从而找到被研究现象的原因。与求同法相比，它具有很大的优越性，因为它是一种比较积极的方法，人们可以在实验中人为地创造先行条件，降低其结论的或然性程度。

4，求异法应该注意的问题

    ⑴两个场合中的其他情况必须相同，不能再出现其它差异情况。

如某学生一上课便头痛，一下课就不疼了，他就认为自己头痛的原因是上课引起的，然而事实却是因为他上课和下课戴眼睛和不戴眼镜的不同情况引起的，所以这位学生运用差异法得出的因果关系是错误的。

⑵两个场合中出现的惟一的不同情况的层次问题。

这和上面求同法中讲的问题是一致的，虽然找出了一个不同的情况所导致了被研究现象的出现，但是真正原因有可能是隐藏在这个情况内部的，由于认识水平的局限不能被进一步揭示出来。

三，求同求异并用法

    1，内容：求同求异并用法也称“契合差异并用法”，简称“并用法”、“契差法”。被研究现象在一些场合出现时有一个共同的情况出现，而被研究现象在另外一些对立的场合不出现时这个共同的情况也没有出现，可以归纳出这个情况就是被研究现象的原因。

比如在农业生产中发现，种植大豆豌豆蚕豆等豆类植物时，不需要给土壤施氮肥，而土壤中的含氮量却会增加，但在种植小麦玉米水稻等非豆类植物时则没有这种现象。经过研究发现，这些豆类植物的根部都有根瘤，而其它植物都没有。于是得出结论，豆类植物的根瘤能使土壤的含氮量增加。推理过程如下：把以上的豆类植物编为一组，称为正面事例组，把非豆类植物编为一组，称为反面事例组，在正面事例组中，只有一个共同的情况就是它们都长有根瘤，其它情况则不尽相同，这样用求同法求得一个结果；在反面事例组中也只有一个共同的情况，就是都没有根瘤，这样用求异法也求得一个结果。在这个基础上比较正反事例组，可以得出结论：豆类植物的根瘤是土壤含氮量增加的原因。

再比如把一群鸡分为两组，一组喂食精米，另一组喂食带壳稻谷。经过观察，喂食精米的一组鸡都得了一种病，两脚无力，不能行走，症状与人得的脚气病相似。而另一组喂食稻谷的鸡却不得这种病。由此推断，带壳稻谷中含有某种精米中所没有的东西，它是避免得脚气病的原因。进一步研究发现，这种东西就是维生素B1。

    2，逻辑形式

     场合 先行（或后行）情况 被研究现象

     （正面场合）

⑴ A、B、C a

     ⑵ A、D、E a

     ⑶ A、F、G a

     …… ……………… ……

     （反面场合）

⑴ —、D、H —

     ⑵ —、B、I —

     ⑶ —、G、J —

     …… ……………… ……

     所以，A是a的原因。

3，求同求异的特点

既识同又辨异，两方面的结合使因果关系的或然性进一步降低。

    4，求同求异并用法应注意的问题

    ⑴正、负两组的事例越多，结论的可靠程度大；

    ⑵对于负事例组的场合应选择与正事例组场合较为相似的来进行。

    四，共变法

    1，内容：共变法是指在被研究现象发生变化的若干场合中，发现其中某一个情况会随着被研究现象的变化而发生变化，而其它情况不变，则这个情况是被研究现象的原因。

比如通过观察发现，某公司的利润随着资金利用率的提高而增长，而其它情况不变，因此可以得出该公司资金利用率的提高是利润增长的原因。

再比如，在有空气的玻璃罩里通电击铃，随着抽出空气量的变化，铃声越来越小。如果把空气全部抽出，则完全听不到铃声了。由此可以断定，空气多少是发出声音大小的原因，空气的有无是能否听到铃声的原因。

    2，逻辑形式

     场合 先行（或后行）情况 被研究现象

     （1） A1、B、C a1

     （2） A2、B、C a2

     （3） A3、B、C a3

     …… ……………… ……

     所以，A是a的原因。

3，共变法的特点

如果现有条件看不出现象之间的关系，那么可以通过改变条件来观察现象之间的内部联系，目的在于打破现有的平衡态，在事物运动变化中来揭示因果关系。

    4，共变法应注意的问题

    ⑴与被研究现象a发生共变的情况应当是惟一的。

   ⑵现象之间的共变关系有一个限度，一旦超出这个限度，共变关系可能就不存在了。因为事物的某种存在形态是有一定限制的，超出这个限制就会使事物发生质变。

    五，剩余法

  1，基本：剩余法是已知某一复合情况是另一复合现象的原因，同时又知道这个复合情况中的某一部分是复合现象中的某一部分的原因，那么，复合情况的其余部分是复合现象的其余部分的原因。

在科学研究中经常运用剩余法，比如用光谱仪发现新元素的过程都是剩余法的应用。光谱分析仪被发明以后，人们用光谱分析仪发现了一大批新元素，也建立起了元素与光谱的一一对应关系，所以元素都可以在燃烧或者高压电击（气态）下发出光线，这些光线在光谱带上都有一个固定的位置，通过确证已经元素的谱线位置，剩下的出现在新位置上的谱线就是一种新元素的光谱。通过这种方法，人们发现了大量的新元素。

    2，逻辑形式

     复合情况（A、B、C、D）是被研究现象（a、b、c、d）的原因

     A是a的原因

     B是b的原因

     C是c的原因

     ————————————————————————————

     所以，D是d的原因。

    3，剩余法的特点——余果求余因

    4，剩余法应注意的问题

    ⑴必须确认复杂现象的一部分（a、b、c）是某些情况（A、B、C）引起的，而且剩余部分（d）不可能是这些情况（A、B、C）引起的；

    ⑵复杂现象的剩余部分，不一定是个单一的情况，还可能是个复杂情况。

小结：求因果五法的作用

求因果五法，在不同程度上都使用了消除归纳法。所谓消除归纳法就是由前提中的几个简单命题构成的相容析取命题出发，通过否定这个析取命题的其它支，从而找出唯一未被否定的那个支。该方法在本质上属于相容选言推理的否定肯定式，结论相对于前提来说是必然得出的。具体来说，求同法是消除B、C、D、E、F、G情况与a现象的因果联系后，归纳得出A情况是a现象的原因。求异法是在消除B、C情况后，得出结论的。求同求异并用法是两次（正反面的情况各运用一次）运用求同法，再运用求异法得出结论的。共变法是消除B、C情况与a现象的共变关系后得出结论的。剩余法是在消除A、B、C情况与d现象的因果联系后得出结论的。由于求因果五法引入了演绎（消除归纳法），因此比简单枚举归纳推理提高了因果联系的可靠性。

    但是求因果五法依然是或然性推理，它的可靠性依然取决于两个因素：一，正确地划出有关情况的范围；二，研究分析有关的情况，正确地得出结论。但这两点不是求因果五法本身所能解决的，还需要具体的科学研究中解决，它是一个认识能力的实际问题，而不仅仅是一个逻辑推理的思维问题。


第五章 归纳推理

第五节 溯因归纳推理和假说演绎推理

一，溯因归纳推理

溯因归纳推理又称回溯法，是一种由果求因的归纳推理，从结果出发运用一般规律性知识，推测事件发生的原因的推理方法。

比如路灯灭了，人们可能会推测是灯泡坏了，或者是线路断了；电话打不通了，人们会推测可能是电话坏了，或者是线路有问题。这都是生活中常见的溯因推理。

溯因推理首先运用的充分条件假言推理的无效形式，就是肯定后件来推前件的真假，因此，它不是一个有效的演绎推理形式，因为如果灯泡坏了，路灯肯定要灭，但是路灯灭了不一定就是灯泡坏了。现实世界的因果关系是相当复杂的，有一果多因，一因多果，从结果往回推，只能推出或然的原因。为了提高溯因推理的可靠性，可以通过猜测尽可能多的原因，然后通过试错法来筛选，如假设某个原因是对的然后检测它应该出现的结果，如果结果不符合假设，则假设的原因错误，此时运用了充分条件假言推理的有效形式否定后件式，这样逐个检验试错，最后筛选出真正的原因。

我们平时的故障检修就是运用这个逻辑方法的。比如电脑黑屏了，可能是CPU的问题（又要检测是不是风扇的问题），可能是显卡的问题（包括驱动的问题，显卡芯片的问题），可能是内存的问题，也可能是主板的问题，这都需要分别检验这些部件，一项一项的排除，最后找到真正的原因。

这个推理方法的局限性在于，猜测到的可能的原因有很多不能通过检验来排除，这样就使原因的推测中依然停留在或然性的猜测层面上。

二，假说演绎推理

假说演绎推理是创立一个假说，假设这个假说是正确的，然后通过这个“正确”的前提（假说）出发，运用演绎推理的形式去推导出一些结论来解释这个世界上所存在的现象。科学研究中对未知事物的探索通常会采用这个逻辑形式，它是创立科学理论的重要方法。比如说魏格纳发现南美洲的东海岸与非洲的西海岸能吻合在一起，他通过对比其它大陆的形状，根据当时的地学理论提出了大陆漂移假说。这个假说可以解释地学以及其它方面的很多现象，因此，它的可靠性进一步被得以确认。

假说演绎推理的假说前提的可靠性需要通过它的预测性来检验，就是通过这个假说要推导出一些未知的现象，然后在实践中观察到这种现象的出现来确认假说的可靠性。但是这个推理过程是充分条件假言推理的肯定后件式，是无效推理，因为后件真实，并不一定导致前件（假说前提）必然真实。因此，假说演绎推理的可靠性需要通过大量的推导现象来支持。

在预测现象出现后，要确认预测现象就是假说的结果，即要确认假说是预测现象的原因，此时又要用到溯因归纳推理，要对导致预测现象出现的各种可能的原因进行分析和筛选，因此，假说演绎推理它必须得借助于溯因归纳推理做基础。

我们知道达尔文的进化论也是一种假说，以进化论为前提的生物进化树就是假说演绎推理，与很多科学假说不同的是，进化论所预测的现象一个都没有出现，因此，它的可靠性根本没有通过任何验证。

作业题：

1，列举一个完全归纳推理的例子。

2，列举一个简单枚举法的例子。

3，试举分别列举一个求因果五法的例子。


第六章 类比推理(纪要）

授课内容：《形式逻辑》第六章——类比推理
上课时间：2009年1月8日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到课老师：唐子
到课同学：蓝睿、陈清扬、钱不求、水心澜、贺大翔、郑彬 、唐滨、 赵阳光、黎焕石、严仁勇、诸葛明心、黄野、辛言、罗同 、張香山、华变天、李大雄、齐学玉
到课同学人数：18人
纪要整理：齐学玉

李后主: 同学们晚上好，我们开始上课吧！

李后主: 本次课程的内容不多。也没有多少难度。类比推理是一种和演绎以及归纳推理有区别的另一种推理类型。 广泛应用于科学研究以及司法断案的领域，也是我们思维中经常使用的一​种逻辑形式。

李后主: 三种推理的不同特点如下：
① 演绎推理：由一般性前提到个别性结论。
② 归纳推理：由个别性前提到一般性结论。
③ 类比推理：由个别性前提到个别性结论。

李后主: 但是，我在讲义中讲了，类比推理的从个别到个别的过程中又一个中间环​节，就是个别上升为一般，由一个一般性的思维充当两个个别事物的联结纽​带。

李后主: 这是大家要重点去理解的。好的，我们通过作业来学习把握这章的主要内容。

李后主: 1，列举一个类比推理的科学发现或者科学发明的事例。

李后主: 看看杨尚的：
1，列举一个类比推理的科学发现或者科学发明的事例。
答：瓦特因为看到水壶中的水被烧开后，蒸汽能顶起壶盖，于是想到蒸汽​是能产生力的，进而有了发明蒸汽机的设想。

杨尚: 是的，谢谢老师替我上传了。

李后主: 这个例子有什么问题没有？大家想一想。

齐学玉: 这个好象没有应用类比推理吧，就是对蒸汽能产生动力的直接应用。

赵阳光: 蒸汽顶起壶盖和蒸汽驱动蒸气机是同一类型的，两者没有中间的连接纽带。

陈清扬: 我也认为没有明确地体现出类比，因为我觉得这两个事情就是一个原理，​或者说是“是”而不是“像”。

杨尚: 是否可以算作同一属下的种的类比呢？

李后主: 这个例子反正比较勉强。瓦特从水壶盖的运动联想到了蒸气机的运动，从这一点上来看有类比推理​的逻辑存在其中。但是如果按照杨尚的原来的表达，就会体现出 从个别现象找到一般性的原​理，然后利用一般性的原理去创造新的设备。这个过程中，类比推理的逻辑​就比较弱。所以，如果大家要把一个逻辑过程明显的表达 出来，还需要靠语句上的措​辞的合理使用来达成。

杨尚: 明白了，老师。

杨尚: 改：水壶中的水被烧开后，蒸汽能顶起壶盖的现象－－瓦特从中总结出蒸​汽能产生力和能量，可以作功－－应用这一原理发明了蒸汽机。

李后主: 杨尚，你也可以直接说壶盖的运动和蒸气机的运动两个事物的类比就行了​，而且的确是从一个个别事物或者现象中推导出另一个个别事物或者现象的​推理过程。

张华虎: 伽里略根据吊灯晃动发现钟摆定律，制出挂钟。

李后主: 张华虎说的吊灯和钟摆这个例子很恰当。

赵阳光: 举例：生物病毒也是一种生物，它的生长运行会破坏正常的生物机体。电​脑程序中某些破坏性的程序也会破坏正常程序的运行，所以这种程序也算是​病毒。

李后主: 阳光说的这句话，只是说明了生物病毒和电脑病毒的相似性，只是类比了​而已，没有突出类比的推理过程。

李后主: 凡是科学中利用类比的原理发明或者发现了什么新的东西，都在其中体现​了类比推理的过程，就是既然此物的这个现象能达到这个效果，那么我做一​个类似的东西也能达到这个这个效果。科学发明中有这样的逻辑存在其中，​因此，类比推理就存在其中。

李后主: 陈清样的例子：
1，列举一个类比推理的科学发现或者科学发明的事例。
苹果砸到牛顿头上（苹果与地球互相吸引）——万物互相吸引（万有引力​定律）——月球以引力作为向心力环绕地球——据此测得月球质量。

陈清扬: 我作业的例子修改了一下：
流星锤靠绳索来保持向心力——月球环绕地球——存在某种机制来吸引（​认为存在万有引力）——据万有引力定律测得月球质量。

李后主: 陈清扬，你的修改后的例子也只是类比而已，不是推理。没有修改前的原来的作业中的例子中倒有类比推理的逻辑存在，只是你也​没有完整的把它表达出来。

陈清扬: 确实不好明确的表达，谢谢老师指教。

李后主: 要举一个科学发现或者发明的例子，大家首先要阅读这个方面的全面的资​料，这个过程不一定是一种逻辑方法存在其中，很可能是多种逻辑方法存在​其中，那么 就把我们需要学习的逻辑方法找出来，只把这个我们所正在探讨​的逻辑方法找出来，准确的表达出来就行了。这就需要我们完整的把握一段​科学的历史过程。

李后主: 齐学玉的例子：
作业：
1，列举一个类比推理的科学发现或者科学发明的事例。

事例：外科无菌术的发明。
外 科手术普遍应用于临床以后，治疗手段提高之际外科医生们也为术后高​死亡率而感到不安。一日英国外科医生，无菌术的发明者约瑟夫·李斯特看​到了一篇这样 的报道：如果把没有加热过的肉汤放置在露天里，肉汤很快就​会腐败；而如果把肉汤煮沸并与空气隔绝，肉汤则可以长期保存。所以说细​菌繁殖是导致肉汤腐败 的主要原因。这篇报道的作者是法国微生物学家巴斯​德。李斯特想到了手术后病人常因为伤口感染而死亡，所以他推测细菌是当​时术后高死亡率的主要原因。于 是李斯特建立了一套完整的灭菌法，无菌术​开始应用到外科临床。

李后主: 学玉的这个例子中也存在着类比推理，就是肉类的腐败和伤口的感染，然​后根据煮沸的肉汤的现象推导出手术中的消毒措施，这里缺少了最重要的东​西，就是手术中消毒的方法就是加热或者沸水消毒。这样才是完整的推理过​程。

李后主: 大家要从一段资料中迅速找到所要寻找的逻辑过程，并把它准确的表达出​来，你们做作业就要求把这个逻辑过程简单准确的表达出来。这就是大家需​要提高的能力。所以，大家可以先引用资料然后再分析其中的逻辑过程，也​可以在引用资料中把逻辑过程描述出来。

陈清扬: 这时候觉得自己头脑中的资料库与分析、表达能力都有欠缺了。

李后主: 类比推理的例子在现实中有很多，你随便翻一本逻辑学教材，都可以找到​很多事例，我们希望大家通过看了别人列举的事例后，自己学会从资料中寻​求逻辑线索。这样大家的能力就提升了。以后就可以当老师了。

赵阳光: 有必要补充一下科学史的知识，其实分析关系并不难，只是想不到可用的​实例。

李后主: 阳光缺乏的是史实，有些同学缺乏的可能是史识。大家都有专长。

李后主: 好的，我们看看第2个作业。

李后主: 陈清扬的作业
2，列举一个机械类比的错误推理事例。
西方谚语“它看起来像鸭子，走起路来像鸭子，叫起来也像鸭子，那它一​定就是个鸭子。”
不过放到今天很可能是个玩具鸭子。
很多词的意义都被共产党歪曲，同一个词放在中国国寨和正常社会中实际​意义相差很大。这些词都可以引导人做出错误的机械推理，因为这些谬误的​确很隐蔽，误导人作出机械推理并不意外。
比如拿中国党文化社会中的词“新闻媒体”、“多党制”、“革命”、“​人民”等还有很多，类比正常社会的词，却没有注意到其中的内涵完全不同​，故为机械类比。

李后主: 还可以，这些事例中人们不看本质，只看表象，算是机械类比推理。

李后主: 齐学玉：
2，列举一个机械类比的错误推理事例。
达尔文在观察了人与猴子有许多相似之处以后，认为人与猴子有共同的祖​先，人是由猴子进化来的。

李后主: 学玉的这个例子很妥当。很有代表性。人和猴子有一大堆的属性上的相似，所以，猴子的祖先也就是人的祖先。​这种推理显然是机械式的类比推理。

李后主: 人和猴子有一大堆的属性上的相似，所以，猴子的祖先也就是人的祖先。​这种推理显然是机械式的类比推理。

杨尚: 当代很多国人常用“弱肉强食、适者生存”的动物丛林法则来作为生活的​指导准则，忽视了人类社会与动物的丛林社会有本质不同，这一法则适用于​丛林野生动物，却不能用在人类社会，二者的类比也是机械类比。

赵阳光: 马列主义看到了动物世界弱肉强食的现象，又看到了人与动物在生理上的​相似之出，推理出了人的斗争思想。这里他忽视的了人与动物的根本区别在​于人有精神和思想，而动物没有这一点，所以这个推理史错误的，属于机械​类比 。

赵阳光: 打字慢了点，例子被杨尚抢先用了 ，呵呵。

李后主: 杨尚的这个例子在阳光这里更明显的突出了其中的类比推理的逻辑，当然​是机械式的类比。机械类比推理是人们对错误的类比推理的一种称呼，它其实就是哲学中的​机械论的一种表现。现实中人们由于对一种事物或者现象的认识不清楚，经常会犯机械式的类​比推理的错误。

郑彬: 比如天鹅我们看到的都是白的，那么我们认为所有的天鹅都是白的。

李后主: 郑彬，你说的那叫做归纳推理，是不完全归纳法！

李后主: 从个别推导出一般。

李后主: 好的，这个现象的列举先到这里吧！我们看看第3个问题吧！

李后主: 杨尚的作业
3，仿生学的逻辑依据是什么？
仿生学的逻辑依据是生物与人类新发明之间所具有的相同的科学原理（包​括数学、物理、化学、信息技术原理等）。

李后主: 杨尚的这个回答基本上正确的。但是还可以更精确。

李后主: 齐学玉的作业
3，仿生学的逻辑依据是什么？
仿生学应用了逻辑中的类比推理：生物因具有某种结构而具有某种功能，​因此，以生物的这种结构为模板仿造出的具有相似结构的工具也应该具有这​种功能。

李后主: 大家看看，学玉的这个回答就更接近答案。

赵阳光: 学玉这个回答非常清晰地把其中的逻辑过程表达出来了 。

赵阳光: 仿生学的逻辑依据是以生物属性为依据推理出非生物的功能，使非生物具​有生物的一些功能特性。

李后主: 阳光，你表达的还是不明晰。

赵阳光: 是，有表没里，不太清晰。

李后主: 仿生学的逻辑依据最简单的表达就是：相同的结构应该具有相同的功能。

李后主: 看看我的答案吧，这里面没有什么生物和非生物的，就是最简单的逻辑思​维线索。

杨尚: 明白了。

陈清扬: 老师的表达很简明。

李后主: 那么，陈清扬的下面这个回答，作为对仿生学的一定角度下的一种解释和​描述倒是不错。
仿 生学是从物理（或者化学）的角度模仿生物的构造，来制造同样（物理​原理的）人造物品的学问。虽然表面上看仿生学模仿的是生物外形，但实质​上是在把握物 理原理的基础上，仿照生物的系统构造，并非只停留在外形的​层面上，这个“深于外形层面”的物理原理即为仿生学的逻辑依据。

李后主: 那么，仿生学中的类比推理过程就是这样的：它和它结构相同，那么它和​它的功能也应该相同。

李后主: 类比推理是一种或然性的推理，推理结果并不一定正确。这一点和归纳推​理是相似的。那么，我们下面看一看模型方法。

李后主: 模型方法很显然是一种类比推理方法。也是科学研究中大量使用的方法。大家熟知的模型有些什么？可以说说。

陈清扬: 桌面游戏ADnD的D20骰子模型，理论物理方面的口袋夸克模型等等​。

杨尚: 比如售楼处的沙盘模型、军事上的沙盘模型、拍电影时用的模型、玩具模​型等等。

李后主: 大家要注意，是模型方法，不是模型本身。是运用模型进行类比推理研究的应用例子。

赵阳光: 汽车的撞击试验，用假人作模型，来推断交通事故中人的受伤害程度。

李后主: 阳光这个例子很好。

齐学玉: 化学中的分子模型，用来研究分子结构。

李后主: 学玉说的也对，分子模型，原子模型以及其它的粒子系统的模型都是科学​研究中的类比推理应用。

杨尚: 比如要测试一座建筑的抗震强度，可以先用与该建筑相同的材料做成小型​的建筑模型，通过人造震动来测试数据以推导该建筑的抗震数据。

李后主: 杨尚说的那些例子也不错。

黎焕石: 用白鼠做试验,以确定人的用药量。

李后主: 焕石说的也对，医学用的动物试验，就是和人体的系统做对比的，模拟人​体对药物的可能的反应。

陈清扬: 桌面游戏ADnD的D20骰子模型是用20面骰子的随机性来模拟战斗​的命中、伤害等，是利用了随机性来简化实际战斗；口袋夸克模型是利用低​能夸克的禁闭性来简化计算——都是简化实际过程。

李后主: 清扬举得这两个例子应该也是没问题的，只是我没有玩过，所以不懂。

陈清扬: :老师用词挺贴切的，我对这两个模型的感觉真的就是“玩”。

李后主: 好的，大家对模型并不陌生，那么大家想一想，为什么要使用模型。
4，总结一下运用模型方法的各类情况。也就是在什么情况下才运用模型​方法？

杨尚: 在两种情况下通常运用模型方法。（一）当实践中会面临较大的失败成本​时，为了提高成功率人们通常会先用模型进行提前实验，比如：
1.运用模型方法进行实物模拟：比如要测试一座建筑的抗震强度，可以​先用与该建筑相同的材料做成小型的建筑模型，通过人造震动来测试抗震数​据。
2.运用模型方法进行过程模拟：比如在沙盘上模拟战争过程推测实际战​争的胜负，比如用计算机设计的程序，模拟飞行训练过程，来训练飞行员。
（二）当实践已经发生，需要重新审视该过程时，可以运用模拟实验，比​如司法断案。

李后主: 齐学玉：
4，总结一下运用模型方法的各类情况。也就是在什么情况下才运用模型​方法？

（1）面对复杂系统时的科学研究。因为在现有条件下无法对原系统进行​直接研究，所以应用模型方法对复杂系统进行研究，揭示其所蕴涵的规律。
（2）司法断案。由于无法还原案件的整个过程，所以应用模型方法对案​件进行复原，揭示案件的真实情况。
（3）模拟战争。在战争之前按照制定的作战方案模拟可能的战斗过程，​以达到避免战争的发生，或发现作战方案疏漏的目的。

赵阳光: 在不能或不方便让实体演示一次事件发生过程的时候一般会用到模型方法​。比如科学试验，实体演示的代价很高，这时可以设计模型来演示。另外如​判案，事实已经发生且没人知道过程，这时可以用模型来模拟事件发生的实​况。

李后主: 陈清扬：
4，总结一下运用模型方法的各类情况。也就是在什么情况下才运用模型​方法？
无法（或很难）进行实际验证；对需要验证的事物有一定的了解并且做出​了理论假设。

李后主: 杨尚和学玉重点在于揭示应用模型的各个领域，陈清扬则是一句话去概括​。阳光是总的概括加领域的分析。大家都说出了一定的应用领域和应用的原因。

罗同: 在什么情况下才运用模型​方法？1、降低成本，2、避免危险，3、预知未来。

郑彬: 我觉得就像房产模型:一节约成本,二不影响事实情况一样清楚.

李后主: 郑彬，房产模型的类比推理意义不大。

李后主: 还有一种模型叫做理想模型，就是在实际中无法存在的，但是为了研究的​方便，要假设它存在。这种模型大家还能想起一些吗？

杨尚: 柏拉图的理想国和理念论不知算不算？

陈清扬: 《社会契约论》中的人的“自然状态”，进一步说“共产主义”可能也是​。

齐学玉: 理想气体研究中用的真空模型。

赵阳光: 共产党的人民公社算不算？

李后主: 理想国应该算一种模型，是社会模型，但是理念论不是模型。此外洞穴理​论也是一种思想模型。学玉说的“理想气体”就是这样一种理想模型。不是真空模型，而是理想气体。

李后主: 共产主义算是一种理想模型，是一种社会模型。

罗同: 永动机。

李后主: 永动机不是模型，只是一种设想，没有任何结构。共产主义，理想国，它都有一套机制在其中，都可以形成一个社会模型，​理想气体有理想气体的属性和基本状态，也是有结构的，但是永动机什么都​没有，只是人类的空想而已。

李后主: 我给大家提示了这个理想模型，是为了补充大家刚才所列举的应用模型方​法的领域。就是说，为了研究中的方便，要构建一个现实中不存在的理想的状态，这​就 是理想模型。理想气体就是这样一个理想模型，此外弹性碰撞研究中的理​想的弹性球体，机械运动研究中的理想平面等等，都是理想模型。大家学物理和化学时曾 经学过很多这样的理想系统，它们都是理想模型。​通过这些理想模型中的现象的总结，我们去和实际中的现象去类比，对实际​中的现象进行预测。

杨尚: 应用模型是为科学（自然与社会科学）做验证的，是现实中存在的；理想​模型是引领科学（自然与社会科学）前进的，是只存在于理想状态中的。老​师可以这么认为吗？

李后主: 杨尚，你划出了一个“应用模型”的概念和“理想模型”做对比，其实你​可以把模型化为“理想模型”和“非理想模型”就行了。

杨尚: 好的。

赵阳光: 平行线也是一个理想模型，用来研究几何问题，而实际中并没有绝对的平​行线。

李后主: 平行线是理想模型，是数学几何学中的理想模型。甚至点，线，面都是理​想模型。物理学中的质点。也是理想模型。

李后主: 这样看看，我们对模型的应用是非常广泛的，也是非常复杂的，我们应用​模型来研究现实中的事物，这其中都需要运用类比推理的逻辑。

赵阳光: 理想模型就是为了实体研究的方便来作参考的，实际并不存在。

唐子: 我们这里谈论的理想模型，都是限于地球而言啊。这点我们要清楚。是在一个层次范围内的思维。

李后主: 当然，都是人类的知识啊！当然是局限于地球人类的知识。

赵阳光: 是的，是在地球这个层次上说这个问题。

杨尚: 呵呵，我正想提这个问题呢？

李后主: 好的，这个问题我们就先讨论到这里吧！ 下面看看谁能举几个司法断案中应用模型做对比的例子。

杨尚: 好像有交警在分析复杂交通事故的案子时，有重新模拟事故发生现场以获​取办案参考的事例。呵呵，不过代价比较大，很少用到的。

陈清扬: 这问题我还真没想出实际接触过的例子。

赵阳光: 《大宋提刑官》中应该有的是例子，可惜我不经常看电视剧 ，呵呵。

李后主: 这方面主要是看大家平时的阅读了。没关系，我想，大家学了这节课以后再去阅读各种资料时就会注意收集这​些方面的事例了，或者从中发现了一些我们学过的逻辑方法。

李后主: 我讲义中有一个错别字，大家修改一下
【于是他们不得不展开深入的调查。一位法庭科学家根据那位48岁妇女​的身高和体重，动手做了几个一模一样的假人模特，】讲义中写的是家字，​应该是假字。

李后主: 今晚的课程就到这里了！

杨尚: 谢谢后主老师。

赵阳光: 老师辛苦！


第六章 类比推理

根据前提到结论的思维进程的不同，非模态推理可分为演绎推理、归纳推理、类比推理。前面我们已经学过了演绎推理和归纳推理，本章我们学习类比推理。

先回顾一下三种推理的区别：

① 演绎推理：由一般性前提到个别性结论。

② 归纳推理：由个别性前提到一般性结论。

③ 类比推理：由个别性前提到个别性结论。

类比推理表面上看不属于演绎推理和归纳推理，但实际上却是二者思维逻辑的综合运用，它的完整思维过程实际为：个别→一般→个别，第一个箭头的过程是归纳过程，第二个箭头的过程是演绎过程，这是一个完整的逻辑过程。如果没有从“个别到一般”的思维阶段，是不可能直接过渡到从“个别到个别”的，人们看到一个个别现象，都会思考它的一般性的表现形式，因此才会产生与另一个现象的类比，这其中“一般性”是联系两个“个别性”的中间环节。从“个别→个别”只是对类比推理的结果所进行的简单化表达形式，但它并不是一个完整的逻辑过程。

比如：“这本书有页码，那么那本书也应该有页码。”这个推理中隐含着一个中间环节就是“所有书都有页码”，属性的相似性是通过一般性来联结的。

    一，什么是类比推理

类比推理，是根据两个或两类对象在一系列属性上的相同或者相似，推出它们在其它属性上也相同或者相似的推理方法。其逻辑结构式表达为：

    A事物和B具都有属性A1，A2，A3，…，An；

    A事物还具有属性A(n+1)；

所以，B事物也具有属性A(n+1)。

比如上面所提到的书的例子，这本书和那本书有很多相似的属性，比如都有书页，都有封面，都是纸质的，都是同一历史时期的，而这本书上还标有页码，因此，那本书上也应该有页码。

二，类比推理的特征

1，从表现形式上看，类比推理不同于演绎推理和归纳推理，是从特定事物推导到另一特定事物的独立的一种逻辑推理过程，但是正如前言所说，它实际是两种推理过程的综合。

2，从推理的结果上看，类比推理是一种或然性推理。类比推理的结论所断定的范围超出了前提，因此是或然性的结论。从这个方面来看，它和归纳推理比较类似。

三，提高类比推理结论可靠性的方法

1，前提中所提供和确认的相同属性或者相似属性愈多，那么结论的可靠性程度也就愈大（从相同属性的量上来考察）。

比如，在医学上试验新药时常常以猴子来做试验，原因在于猴子在身体结构上和人类的相似属性比较多，结论的可靠程度也较高。载人航天实验时，以狗和猩猩做前驱，也是因为哺乳动物与人类的相似属性比较多。

2，前提中所提供和确认的相同属性或者相似属性与类推的属性之间相关程度愈高，那么结论的可靠性程度也就愈大（从相同属性的质上来考察）。

前提中所提供的相同属性或者相似属性与类推属性必须具有本质的联系，否则仅仅依据一些表面上的联系就会犯“机械类比”的错误。如根据台湾国民党由威权党改变为民主政党推断出中共也会改良，这是不了解中共和国民党在本质是完全不同的两类事物，前者是邪教，后者是一个政党，因此政党可以由威权党改良为民主政党，而邪教不可能通过政治运动来改良。根据中共有政党的一些特征，而把中共当作政党，同时根据其它政党的演变过程，推断中共的演变过程，这正是不明白事物的本质区别而犯的机械类比错误的表现。

四，类比推理的应用情况分类

1，同类事物的不同个体之间的类比推理应用

在同一个大类的不同个别事物之间，就是在概念上具有属种关系的同一属的各个种事物之间，根据一些事物的某种属性，去推断另一些事物的某种属性。在科学研究中类比推理是非常普遍的一种逻辑手段和逻辑方法，被广泛的应用。

【科学资料：1871年，俄国化学家门捷列夫正式公布了元素周期规律。他在周期表中排列了当时已知道的六十三种元素，中间留下许多空白。他在锌和砷之间留下两个空格，预言存在类铝和类硅。在他预言以后四年，1875年法国化学家布瓦博德朗在研究闪锌矿德时候，用光谱分析法发现一种新元素，称为镓。镓就是门捷列夫预言的类铝，一切都和预言的一样，只是比重不同。然而，门捷列夫坚信自己是正确的，他写信给巴黎科学院，断言镓的比重应该是5.9左右，而不是4.7。布瓦博德朗大为惊讶，他想办法重新提纯，测得镓得比重是5.94，证实了门捷列夫的预言。镓称为化学史上第一个在预言后被发现的元素。 】

在以上的资料中，门捷列夫根据元素周期表中的同一族类的一些元素的属性去推断另一些元素的属性，运用了类比推理。

在农业研究中，人们对不同地方的环境进行研究，找出环境因素大体相似的两个地方，于是推断对一个地方的特色植物移植到另一个环境大致相似的地方也可以正常生长，这成为农业移植的重要依据。

2，不同类事物之间的类比推理应用

这种情况是在没有处于同一属的事物之间进行的类比推理，在仿生学中应用最为明显。

比如在仿生学研究中，通过研究生物在某个方面的属性，然后按照它的结构仿制出一种机器，使这种机器在一定程度上实现这个生物的某种功能，这是在生物和非生物之间进行的类比推理的应用。仿生学从古到今一直很发达，比如我国相传鲁班看到锯齿草的齿牙可以划破皮肤，发明了木工锯；人们根据鸟的结构发明了滑翔机；在一战期间，人们从毒气战幸存的野猪身上中获得启示，模仿野猪的鼻子设计出了防毒面具；科学家根据青蛙眼睛的特殊构造研制了电子蛙眼，用于监视飞机的起落和跟踪人造卫星；苍蝇的复眼包含4000个可独立成像的单眼，能看清几乎360，范围内的物体，在蝇眼的启示下，人们制成了由1329块小透镜组成的一次可拍1329张高分辨率照片的蝇眼照像机，在军事、医学、航空、航天上被广泛应用； 仿照水母耳朵的结构和功能，设计了水母耳风暴预测仪，这种预测仪能提前15小时对风暴作出预报，对航海和渔业的安全都有重要意义；萤火虫可将化学能直接转变成光能，且转化效率达100%，而普通电灯的发光效率只有6%，人们模仿萤火虫的发光原理制成的冷光源可将发光效率提高十几倍，大大节约了能量；昆虫学家研究发现，苍蝇的后翅退化成一对平衡棒，当它飞行时，平衡棒以一定的频率进行机械振动，可以调节翅膀的运动方向，是保持苍蝇身体平衡的导航仪，科学家据此原理研制成一代新型导航仪——振动陀螺仪，大大改进了飞机的飞行性能，可使飞机自动停止危险的滚翻飞行，在机体强烈倾斜时还能自动恢复平衡，即使是飞机在最复杂的急转弯时也万无一失；苍蝇的嗅觉特别灵敏并能对数十种气味进行快速分析且可立即作出反应，科学家根据苍蝇嗅觉器官的结构，把各种化学反应转变成电脉冲的方式，制成了十分灵敏的小型气体分析仪，目前已广泛应用于宇宙飞船、潜艇和矿井等场所来检测气体成分，使科研、生产的安全系数更为准确、可靠；蜜蜂复眼的每个单眼中相邻地排列着对偏振光方向十分敏感的偏振片，可利用太阳准确定位，科学家据此原理研制成功了偏振光导航仪，早已广泛用于航海事业中…等等。

五，模拟方法在科学研究和司法断案中的应用

模拟方法是科学研究中最主要的研究手段，是用一种模型代替原型来探索原型的结构、功能以及其演化过程，试图揭示原型的某个层次的内在规律。这是类比推理在科学研究中的一项非常重要的方法。

模拟方法也有很悠久的历史，从古到今在军事指挥方面，人们会制作一个地理环境以及军事部署的沙盘模型，用以模拟实际的战争进展状况。而在战国时期墨子为了阻止楚国攻宋，和公输班进行了一场攻防的模拟战争，用以显示武力攻宋所要遭致的失败。近代以来的科学研究在面对复杂系统时多采用模拟方法，如航空航天研究中的风洞就是对大气环境的模型，各种型号的飞行器都要制成一定比例的模型在风洞中试验；载人航天研究中用水箱来模拟太空环境，神七太空漫步就是充分利用了这一模型；在宇宙研究中，人们运用模型来模拟宇宙的起源，如正在运行的欧洲强子对撞机的工作原理就是将高度活跃的质子以超快速度撞击到一起，上演微缩版的“宇宙大爆炸”以探索宇宙起源的规律；在大型水库的建造中，人们也用模型来计算大坝的垮塌条件；计算机技术兴起后，运用计算机来模拟各类复杂系统的科学手段越来越先进，天气预报、天体运行、航空航天飞行器训练以及各类特殊车辆和机械的操作训练、模拟战争演练…等等。

此外，在司法断案中，为了复原一个案件可能的过程，经常使用模型来模拟案件过程，试图揭示案件的真实情况，以达到分辨真假，找出犯罪元凶的目的。

【案例1】烧猪断案

三国时期，张举任句章县（今浙江省宁波市鄞州区南一带）县令。

一日，张县令正在批阅公文，忽然有一对老年夫妇拄着拐杖，步履蹒跚地前来报案：昨晚，他们家的房屋突然失火，身强力壮的儿子居然没有跑出来，被活活烧死。他们怀疑是儿媳妇与奸夫合谋杀人灭迹，因为她平日就不守妇道，行为不端。

张县令叫人传来老人的儿媳妇讯问。这位20多岁的少妇看上去颇有几分姿色，身穿素衣，一到大堂就号啕大哭。她听了二位老人的申诉，气愤地反驳道：“你们说我有奸夫，奸夫是谁？你们说我谋杀亲夫，又有何证据？”二位老人悲伤至极，张了张嘴，却又说不出什么来。少妇见状，凄惨地哭泣道：“我的命真苦啊，年纪轻轻就死了丈夫，还被人怀疑品行不端。这以后的日子怎么过呀，还不如死了算了！”随即，她头朝墙壁猛撞过去。好在一旁的差役眼明手快，急忙一把拉住她。但接下来，她哭得更加厉害。

张县令扫了一眼堂下的二位老人和少妇，心想，眼下一点证据也没有，少妇又矢口否认谋害亲夫，切不可妄下结论，先去看看现场、验了尸首再说。

火灾现场凌乱不堪，瓦砾遍地，还未完全烧毁的断枋残柱仍在冒着青烟。因为尸体已被烧得面目全非，验尸时并未发现什么可疑之处。张县令仿佛想起了什么，掰开死者的嘴看了看口腔里面。

接下来，他令人架好一大堆柴禾，点起熊熊大火，又让人买来两头猪，一头杀死丢入火中，另一头则活活丢入火中。那头活猪在烈火中凄厉地嚎叫了几声，便不再有动静。在场围观的乡亲们都被张县令匪夷所思的举动惊呆了。不一会儿，张县令让人将两头猪从火堆中扒了出来，然后叫围观的人群中几个胆大的汉子上前掰开死者和两头猪的嘴巴，看看里面是否有烟灰。

几个胆大的汉子按照张县令的要求，分别上前一一察看。

“有烟灰吗？”张县令问。

“死者和被杀死后烧烤的猪，口里没有烟灰，活烤的猪口里有些烟灰。”众汉子的答案完全一致。

“你们知道死者口里为什么没有烟灰吗？”张县令继续问。

“因为他也像那头猪一样，是被人杀死后再放入火中的。”人群中有人高声答道。

大家开始交头接耳议论起来。此时，人们对张县令烧猪断案的独特举措才恍然大悟。

死者的妻子早已停止了哭泣，脸上写满惊恐。

“大胆恶妇，竟敢谋害亲夫。给我拿下！”张县令喝道。

面对如山的铁证，少妇只得如实供述了与奸夫合谋杀死亲夫，然后纵火烧屋焚尸灭迹的犯罪事实。

【案例2】：模拟坠楼

70年代初，在美国马里兰州巴尔的摩市，一位名叫艾丽丝.西格的妇女从她的61米高的房顶阳台上落地身亡。邻居都认为她是忍受不了丈夫经常的殴打而跳楼自杀的，警方也准备听信这种说法。那位丈夫却声称妻子的死是一次意外。“她当时正在摆弄出了故障的空调”，他说，“从阳台栏杆上失足坠楼”。后来警方获悉西格先生是他妻子10万美元保险单的受益人，而且如果当事人自杀，保单将失效。于是他们不得不展开深入的调查。一位法庭科学家根据那位48岁妇女的身高和体重，动手做了几个一模一样的家人模特，又安排了一台摄像机。那几个假人模特分别被从那座阳台上跌下、推下和扔下。摄像机摄录的结果表明，假如西格夫人是因意外坠落，那么她的身体落地后距离楼房的墙脚不会超过3.2 米；假如她是自己跳下去的，那么这个距离不会大于4.3米。而事实上，她的尸体被发现时离楼房有5米。面对这个证据，她的丈夫不得不供认是自己在酒后的逛怒状态下把妻子从阳台上扔了下去。

作业：

1，列举一个类比推理的科学发现或者科学发明的事例。

2，列举一个机械类比的错误推理事例。

3，仿生学的逻辑依据是什么？

4，总结一下运用模型方法的各类情况。也就是在什么情况下才运用模型方法？

5，试着找一个古今司法断案中的模拟方法应用案例。


第七章 逻辑学基本原理(纪要2-1）

授课内容：《形式逻辑》第七章——矛盾律和排中律（上）
上课时间：2009年2月19日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到课老师：唐子
到课同学：华变天 夏华 赵阳光 严仁勇 張穀虛 蓝睿 麻生 安哲
到课同学人数：8人
纪要整理：安哲

李后主： 今天我们讲的是逻辑学的原理，第一个原理是同一性原理，就是保持思想（包括概念和命题）的一致性，在对话中不能前后不一致。
李后主： 同一性的要求分解开来可以分为概念的同一性，命题的同一性，思想的同一性。同一性也就是在使用这些概念命题和思想主题时要有确定性的表达。
李后主： 我们从概念的同一性开始学习，讲义中的内容大家都已经看了，概念的用法有四种复杂的情况，我们以前学过一种集合概念和非集合概念的区别。
李后主： 今天，我们看看其它三种情况，请大家注意，这些复杂的用法都是同一个词语在不同语境和不同要求下表达不同概念的情况。

李后主： 首先看看抽象概念和具体概念的区别。
李后主： 1，列举一个普遍性概念（抽象概念）和特殊性概念（具体概念）混淆的推理例子。
李后主： 我们先看看夏华的作业：
【这个世界所有事物都是在运动的，和尚参禅打坐的时候没有运动，所以这个世界不是所有事物都在运动。
第一个运动是属于哲学范畴，指世界万物时刻在改变流动的性质，第二个运动是属于物理范畴，指物体的位移。】
李后主： 这个例子列举的非常好，对两个运动的概念的辨析也很精确。

严仁勇： 在一切事物中都存在着正负相互对立的关系（抽象概念）；在数的体系中有正负数（具体概念）。
李后主： 仁勇表达的不是很清晰，正负的概念是什么？你先慢慢考虑吧！

李后主： 看看蓝睿的作业：
【任何两个事物都处在相互作用或者相互影响之中，但我说的话却对小明不起任何作用，由此可见不是任何两个事物都处在相互作用或者相互影响之中。

这 个推理中前面的“作用”是抽象的概念，它表示事物之间相互对立相互影响的指向。两个事物之间通过直接或间接的关系，确定彼此的指向，和对对方的影响，从而 带动事物形成统一的整体或网络，任何两个事物都处在相互作用或者相互影响之中，是一个基本的哲学原理。而后一个作用是一个具体概念，表达人和人语言交流过 程产生的结果。我说的话对小明没有产生影响，并不反应我们语言交流过程中没有相互作用。所以上论的哲学原理并没有错。以上推理错误根源是抽象概念和具体概 念混用，违背了概念同一性的要求。】
李后主： 【它表示事物之间相互对立相互影响的指向。】－－这句话修改一下：【它表示事物之间相互影响的指向。】不一定就是对立，要讲对立就得讲统一。也可以说表示事物之间对立统一的相互影响的关系。但是这么说还不如直接说相互影响就可以了。
李后主： 蓝睿的这两个作用的概念的辨析也符合我们要的。

李后主： 陈清扬找的和夏华找的概念是一样的，但是夏华解释了两个运动的概念的区别。
【一切事物都在运动着，可是李四天天坐在电脑前不运动，所以“一切事物都在运动着”是错误的。】

李后主： 阳光，你举得这个矛盾的概念的这些用法上的区别，属于我讲的狭义和广义的区别，我讲义中界定过的。你再看看讲义。
【矛盾是事物的普遍存在状态，但张三夫妻两人感情很好，从不闹矛盾，可见矛盾并不是事物存在的普遍状态。】
赵阳光： 好的。

李后主： 【看问题不能停留在表面，还要通过分析本质。小明表面上平静，其实心里很慌张。】
杨尚举得这个表面的概念也是有抽象和具体的区别，例子符合要求，但是没有做出概念的解释。
李后主： 第一个表面是指事物外部的条件和因素，而第二个表面是一个具体概念，表示一个人的面部表情。当然了杨尚也没有指出这两个概念怎么样才容易混淆。

李后主： 我们看看下面一种情况。
李后主： 2，至少找出一个可以区分出广义概念和狭义概念的词语，并指出它们的外延的划分范围。
蓝睿： 关系：广义指事物之间的相互关联和联系，互为作用的纽带。狭义指事物间简单的因果关连。
李后主： 大家注意，这个广义和狭义概念的区分，主要是在概念的外延方面的区别。和抽象和具体概念的区别是不完全相同的，大家慢慢去体会。
李后主： 一个抽象概念可以对应很多很多的具体概念，这些概念的内涵和外延的区别都很大。
而一个广义概念一般和一个狭义概念相对应，广义和狭义是成对出现的，主要在外延上划分出这种区别，内涵上稍有不同。

李后主： 阳光的作业
【例：如“生活”，既可以作为广义概念用，也可以作为狭义概念用。作为广义概念时，泛指人生在世的一切活动；作为狭义概念时，特指人在物质层面的活动，如衣食住行。】阳光说的这个生活的概念的确可以分为广义和狭义的理解。

李后主： 陈清扬说的这个例子也算数。这是学术上常见的一种划分方法。
【广义的孔孟之道是包括原儒、思孟儒学、荀子、古今文经学、南北学、玄学、道学、理学、心学等多流派在内的儒家思想；狭义的孔孟之道则指孔子与孟子的儒家思想。】

李后主： 夏华的作业
【传 统上，在爱因斯坦刚刚提出相对论的初期，人们以所讨论的问题是否涉及非惯性参考系来作为狭义与广义相对论分类的标志。随着相对论理论的发展，这种分类方法 越来越显出其缺点——参考系是跟观者有关的，以这样一个相对的物理对象来划分物理理论被认为不能更好的反映问题的本质。目前一般认为，狭义与广义相对论的 区别在于所讨论的问题是否涉及引力（弯曲时空），即狭义相对论只涉及那些没有引力作用或者引力作用可以忽略的问题，而广义相对论则是讨论有引力作用时的物 理学的。用相对论的语言来说，就是狭义相对论的背景时空是平直的，即四维平凡流型配以闵氏度规，其曲率张量为零，又称闵氏时空；而广义相对论的背景时空则 是弯曲的，其曲率张量不为零。】
严仁勇： 夏华说的很专业。
李后主： 通过对广义和狭义概念的辨析，大家就会知道在我们日常的会话或者看别人的文章中，要精确的把握对方的思想。就得读懂里面的概念的内涵和外延的真正指向。遇到需要区分狭义和广义概念的情况时，要知道对方使用的是狭义还是广义概念。
赵阳光： 是的，这样就可以避免思维的混乱和一些不必要的争执。

李后主： 蓝睿的作业
【关系。广义指事物之间的相互关联和联系，互为作用的纽带。狭义指事物间简单的因果关连。】
这 个关系没有广义和狭义的区分，有抽象和具体的区分，抽象的关系就是相互作用，相互联系，和作用，联系是一回事，而具体的关系就有很多很多种了。所以，你们 要知道，概念很复杂，把概念能搞清楚了，思维能力就提高了。在概念的使用中。还有一种更复杂的情况是引申的概念，因为一个词可能不止引申出一种概念，很可 能引申出几种不同概念，比如我们以前遇到的土壤这个词，我专门讲过一次课，就是引申了两种概念。而牛客人先生就是没有搞清楚这两个引申义是不相同的。
严仁勇： 是，这也就是唐教经常给我们说的要用概念思维 。

李后主： 那么，大家看看，生活中还有一些什么样的引申概念。
3，至少找出一个词语被引申使用的例子，并指出词语的原义和引申义。
李后主： 杨尚的作业。
【恐龙。原义是一种动物，现代人引申为形容男人貌丑。】
其实，据我了解，应该一般是指女人相貌丑。

李后主： 阳光的作业
【例：“流氓”一词原意指居无定所的人，后来引申为地痞、恶霸、不讲信用者，以及两性关系违背道德伦理的人和行为】
这个词的确是引申义。
赵阳光： 是的，这样就可以避免思维的混乱和一些不必要的争执。

李后主： 陈清扬的作业
【电子“海洛因”指的是电子游戏，用于描述沉迷电子游戏的人的沉迷原因。其中海洛因一词原指一种（通过改变人体机能而让人上瘾的）毒品，引申为（通过声光、情节等感官刺激来主宰人的思维进而对其产生极度迷恋的）娱乐物品。】
李后主： 海洛因，和电子海洛因，这两个概念中，第2个不是第1个的引申。
李后主： 这是一种比喻的用法，比喻和引申不完全一样。引申是形成了固定含义的一个新的概念，与原来的概念相比发生了很大的概念，而比喻是把一个概念原有的含义在一个新的领域里使用，用那个概念的一部分特征来描述新的领域的某些事物的特征。
严仁勇： 共产党对“封建”一词变异，也算是引申。
李后主： 是的，仁勇说的也算是吧，不过变异的成分比引申的成分更多。
严仁勇： 那么变异词义能不能算引申？
李后主： 算是引申的表现，但是我们所说的引申是词义正常的发生转移，而变异的是非正常的情况，是故意的歪曲词义。
赵阳光： 引申词的原意和引申意有一定联系，而变异词则是与原意完全相反。
張穀虛： 強盜自己的頭和他們團夥的頭。
李后主： 谷虚说的是什么意思啊。
李大雄： 强盗的头颅和团伙的头目
李后主： 头目有引申义，是领导的意思。

李后主： 蓝睿的作业
【腐败，原意有机物的腐化过程。引申为大部分的不道德的行为。】
也正确。
赵阳光： “腐败”是个典型的含有引申意的例子。

李后主： 夏华的作业
【打酱油，原意就是去卖酱油的意思。后引申多指网络上不谈政治，不谈敏感话题，就用此话回帖而已。】
这也是个新的引申概念。
李后主： 在引申义的情况下，需要注意是一个原义对应多种引申义的情况，如以上的土壤的例子，这些不同的引申义实际上是不同概念，在使用中最容易出现混淆。

李后主： 比如“土壤”原义是指地壳中的表层固体颗粒状物质，后来引申为“良好的环境”、“产生一定问题的根源”等几个新义。
李后主： 今天大家回过头来理解一下概念引申中最复杂的情况，就是一个词语引申为几个不同的意义，形成了不同的概念，同样一个词的土壤，在不同语境中出现时（引申情况下），概念完全不同。
李后主： 大家把握了这种情况，以后看文章时就会多一个心眼，会仔细辨析里面的概念的真实含义，就会使自己的思维更清晰更发达。
李后主： 关于土壤这个词的讲解，大家可以去参考以前上过的那次课的纪要。
水心澜： 我曾经看过一篇文章叫《天才需要什么样的土壤》，从这标题看，“土壤”该就是“环境”的意思，也就是《天才需要什么样的环境》，可以这样理解吧
李后主： 水心澜，是的。这个语境中土壤是代表良好的环境。
李后主： 如果说要消灭产生什么什么问题的土壤，那么这里的土壤就是指产生问题的根源了。
严仁勇： 还比如说 对CCTV的引申，CCTV本来就是中央电视台的英文缩写，但现在就引申为说谎、丑恶的别名的词了，经常听见有人说：“做人不能太CCTV啦”
李后主： 就是在上下文中不能随意偏离这个主题思想的基本内容，使论述出现“转移论题”或者“偷换论题”的情况。

李后主： 好，我们看看今晚最后一个要讲的主题，思想主题的同一性。
李后主： 4，在你的生活中找一段转移论题的对话例子。
李后主： 这种例子大家生活在中国大陆简直是随处可见。
李后主： 陈清扬的作业：

甲：神七上天的录像其实是下水录像。
乙：怎么知道的？
甲：从不可随意更改却被提前的发射日期、返回舱的奇怪阴影、“宇航员”的奇怪漂浮方式、宇航服的奇怪脐带这些疑点可以让人们产生怀疑；大陆海洋背景的静止证明了录像的环境不是在宇宙中；在录像中的气泡则证明了这是一个水下作业。
乙：这又是反华势力的借口吧？
对话论题从神七的录像真伪被乙转移到了反华势力的借口。

李后主： 赵阳光的作业：
甲：共产党整天骂资本主义国家这不好那不好，现在看还是资本主义国家好。
乙：资本主义不适合中国，我看还是社会主义好。
甲：资本主义国家实行民主制度，讲究主权在民、三权分力、新闻自由。这种制度下，民众的自由没有过多的限制，可以最大程度地发挥每个人的创造力，有效地提高经济和科技实力。而且监督制度能落到实处，民众可以监督官员，遏制腐败，防止社会财富被贪污和浪费。
乙：资本主义国家再好有什么用，中国以前还不是被它们欺负嘛。
在本例中，所谈论的问题是社会制度对一个国家的作用，以分辨那种制度对一个国家更好。而乙理屈词穷时回避了问题，把话题转移到国家的历史恩怨中去了，偷换了概念。

李后主： 杨尚的作业：
甲：中共是毫无道德可言的，视道德如粪土。
乙：中共不道德，难道其他国家的政府就道德吗？哪里都没有净土。
甲：道德的理想状态是不存在的，关键是对于合乎道德的行为，中共不是做不到，或者做的不足，而是根本就不想做。这和其他国家的政府标榜正当的信仰，人道，博爱等美德，只是做的不足是有本质不同的。
乙：中国现在的钱比较好赚，所以很多人都回国了。
李后主： 以上同学找的事例都反映出了对话中转移论题的情况。

張穀虛： 甲：你看過九評了，你願意退黨嗎？
乙：退黨有什麽意義？
甲：中共是集邪惡于一身的邪教，它反天、反地、反人類，終究會被天滅，退黨就是為了抹去你曾經入黨、團、隊留在自己身上獸印---為邪教所發的誓言而自救。
乙：我明白了，可是退黨了可以發財嗎？
李后主： 谷虚的这里事例也符合我们要求的情况。

李后主： 关于同一性的原理，我先讲解到这里。
李后主： 大家有什么疑惑需要解答的吗？

赵阳光： 关于逻辑课，我想说说自己的一点想法——
赵阳光： 其实逻辑课程的理论并不复杂，稍微有所思考之后都可以看明白。但为什么还市场犯逻辑错误，原因并不是不懂逻辑原理，而是运用不熟练。而这个熟练的过程，就是一个反复反复练习的过程。
赵 阳光： 在拳击比赛中，一些动作从理论上说是非常简单的。比如头部的躲闪动作，用理论解释就是：用脖子带动头部向一侧移动十公分左右，以避开对方的来拳，避免被打 击。可就是这个理论上及其简单的动作，拳击运动员要经过无数此的训练，才可以在比赛时抓住不到一秒的时间完成。这就体现了反复训练的重要性。
严仁勇： 好，阳光说的也有道理！
赵阳光： 这个感想，不仅想说给大家听，同时也是说给自己听。李老师几次给我指出回答中的逻辑错误，其实犯的都是些低级错误，本不该犯的，可仍然犯了，这就体现出了训练不足。因此，逻辑课重在训练，希望我们自己多加重视，共勉！
張穀虛： 是的，課程上的作業看起來理解了，可是用的時候就發現不了。
李后主： 是一个反复思考的过程,养成思考的习惯。
严仁勇： 谢谢阳光的交流，有启发！
赵阳光： 拳不离手，曲不离口，理不离脑

張穀虛： 問：老師概念的同一性的這兩种情況：普遍性概念与特殊性概念的混淆和概念的引申义所产生的问题我還不是很清楚。如何具體的區分？
李后主： 这两个很容易区分啊，引申意义与原来的意义偏离10万8000里，而抽象和具体概念的区别只是抽象层次的区别。
李后主： 运动和运动，如果一个是抽象概念，一个是具体概念，那么，意思相差只在于抽象度方面。
李后主： 腐败的本义和它的引申义的意思相差可不是抽象度方面的相差。
李后主： 抽象度就是抽象程度。
李后主： 引申意义是从比喻开始，最后形成一个固定的新概念。
李后主： 而抽象和具体概念的区别不是比喻，就是层次的不同啊！
李后主： 大家能体会吗？

赵阳光： 腐败的本意和引申意是不是抽象层次上的差别呢？
李后主： 阳光，当然不是了。
李后主： 你们现在不知道抽象层次是什么吗？
李后主： 第一节课就讲过这个问题啊。
赵阳光： 有点模糊了
李后主： 第一讲 概念和定义
一，什么是概念
2，概念的层次性（逻辑的抽象层次）
(23：24：57) 李后主： 概念就是类的划分，我们研究类的关系，首先遇到的就是层次关系，事物是层次性存在的，类具有层次性，也就是说概念具有层次性。比如“商品”这一概念，我们 看看这个概念可能具有的层次序列，商品{电器商品[电视机、冰箱、空调、洗衣机、电吹风……]，纺织商品[衣服、被子、床单、窗帘、毛巾……]，机械商品 [汽车、拖拉机、飞机、轮船、摩托车、自行车……]……}。我们可以把商品的内涵界定为“用来交换的物品”，那么电器商品、纺织商品、机械商品……等等都 可以是“用来交换的物品”，它们就都可以是“商品”这一概念的外延，而冰箱、空调、轮船、汽车、衣服、被子……等等也可以是“商品”的外延。这个外延还可 以继续发展下去，比如我们把中括号里的一些外延继续分化，如汽车（小轿车、大轿车、卡车、赛车、各种工程车……），飞机（歼击机、轰炸机、运输机、民航客 机；直升机、固定翼飞机……），电视机（模拟电视机、数字电视机；液晶屏电视机、显像管电视机；彩色电视机、黑白电视机……）。概念的层次性在一些逻辑学 书中被称为属种关系，把上下两个层次的概念分别称为属概念和种概念。
李后主： 现在看清楚了吧！
安哲： 看到

赵阳光： 明白了，“腐败”的原意和引申意并不是属种概念的关系，因此不是抽象层次不同的关系。
李后主： 有一些词语，在运用的时候，它的抽象层次是不同的，比如，运动，作用，联系，变化等等，这些都是哲学上使用的可以作为最高抽象层次的词语，但是它们在一些场合却不是作为哲学名词来使用的，因此产生了概念的使用中的抽象和具体的区别。
李后主： 是的，属种关系是抽象和具体的基本关系，而比喻和引申没有这个关系。
李后主： 真正要注意区别的是广义和狭义的情况与抽象和具体的情况有可能会分不清楚，主要看外延的划分上来区别的。

李后主： 今天就到这里了。
李后主： 最后说点题外话，希望大家发贴时能学会相互包容，学会平和的态度。


第七章 逻辑学基本原理(纪要2-2）

授课内容：《形式逻辑》第七章——矛盾律和排中律（下）
上课时间：2009年3月5日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到课老师：唐子
到课同学：张华虎 张玉 赵阳光 华变天 張穀虛 窦夸功 李大雄 白鹭 辛言 蓝睿 欧阳静雪 文豪士 張香山
到课同学人数：13人
纪要整理：張穀虛

李后主:大家好，我们现在开始上课！

今晚我们主要看一下矛盾律和排中律的相关内容。矛盾律的特征是二者必须否定一个，不能同时肯定。排中律的特征是二者必须肯定一个，不能同时否定。
矛盾律要求不要犯两可的错误，排中律要求不犯两不可的错误
现在我们通过习题来学习。

1，请列举一个犯了自相矛盾错误的例子。
大家有做过作业的可以贴上来。

赵阳光: 例：我反对共产党的统治，但是现在由于出台了《劳动法》使我增加了工?资，所以也可以说我不反对共产党的统治。在本例中，“反对共产党的统治” 这个命题是表明反对共产党拥有统治中国的权力，而出台《劳动法》是共?产党为了延缓自己的寿命对劳工阶层做出了一点让步，并不是交出自己的统?治权力。既 然没有交出统治权力，则没有形成“不反对共产党统治”的理由?，在理由不成立的前提下说“我不反对共产党的统治”无疑是跟自己的主张?相矛盾的。

李后主: 杨尚的作业：
“中国是个讲人权的国家，从来不侵犯人权。有些地方官员侵犯人权只是?个别现象。”

李后主: 阳光的例子和杨尚的例子都很好。

赵阳光: 例2：伪外交部发言人说：中国是新闻自由的国家，中国的新闻监督事业?在我党的领导下取得了长足的发展，这些年来中国的新闻自由度进一步加大?。
新闻自由的重要标志是不能受某个党派的领导，在“我党的领导下”却大?言不惭地说中国有新闻自由，当然是前后矛盾的。

李后主: 阳光把这种逻辑错误的原因也分析得很到位，就是对“反对共产党”这个大概念的内涵上发生偏移而导致的。阳光的第2个例子没有明显的逻辑矛盾的地方。不能把自己理解的内容当作表达出来的使用。

赵阳光: 修改一下：中国是有新闻自由的国家，媒体从业人员会在党和政府的管理下做好新闻报道。

李后主: 比如我改一下为：“中国是新闻自由的国家，但中国的新闻监督事业必须在我党的领导和管理下发挥作用，不能脱离这个国情。”

赵阳光: 老师这样表述比较好地把矛盾的地方表达出来了。

李后主: 阳光修改的这个句子差不多可以表达出矛盾的地方了，但是我修改的更明显。

赵阳光: 这句话越看越像秦刚的话，呵呵。

李后主: 所以说，大家举例子一定要注意把需要表达的逻辑内容明显的表达出来。

李后主: 愿意清除党文化却不愿意退党的。
这是钱不求同学的例子，他讲出了一种矛盾的情况。

蓝睿的例子：中国虽然有部分人口没有脱贫，但不影响中国已经摆脱贫困的事实。

赵阳光: 不求说的是思想矛盾的例子，这样的情况比比皆是。比如，他痛恨共产党，但听说你做着解体党文化、解体共产党的事情时，却说你时吃饱了撑的。

李大雄: “我拥护共产党，但是反对共产党的暴政。”这个是不是可以算？

李后主: 大雄的也算。
好的，我们看看第2个习题。
【思考题1】
甲：“所有的统治者都镇压人民”。
乙：“有的统治者就不镇压人民”。
丙：“你俩说的都不对，统治者对犯罪的惩罚不能叫做镇压。”
请问：丙是否犯了逻辑错误？犯了什么样的逻辑错误？

衡量逻辑错误，就是用我们所学过的基本逻辑规律来衡量，违反了基本逻辑规律就是犯了逻辑错误。那么这个题目中，首先我们要知道甲乙两句话是什么逻辑关系？这种逻辑关系下的逻辑规律是什么？

回顾以前学过的知识，甲是全称肯定命题（SAP），乙是特称否定命题（SOP），二者的逻辑关系是矛盾关系，那么在矛盾关系下的基本逻辑规律就是两个命题必然一个为真，一个为假，不可能同时为真，也不可能同时为假。

赵阳光: 丙犯了两个逻辑错误
（1） 两个互相矛盾的命题不能同时为真，也不能同时为假，而是必有一真，同时必有一假。丙说的话的前半部分把甲乙两人互相矛盾的命题都否定了，他在论证这个命题时违背了矛盾律的基本要求。
（2） 甲乙两人谈的话题是“统治者是否镇压人民”，而丙谈的是“什么样的行为”是镇压，他犯了偷换概念的逻辑错误。

李大雄: 甲和乙谈的是镇压的问题，丙把话题转移到了对犯罪的惩罚。

李后主: 所以丙说“你俩说的都不对”，把甲乙两个命题都否定了，显然是违反了基本的逻辑规律，犯了“两不可”的逻辑错误，犯了违反排中律，因为必须在两个命题中得肯定一个。

李后主: 大家先看看我的。

李后主: 如果丙说：“你俩说得都对”，那么就是违反了矛盾律，因为在矛盾关系下，必须得否定一个。也就是说对矛盾关系下的两个命题的真假的判断，既可能违背矛盾 律，也可能违背排中律，关键是看违背者是犯了“两可”还是“两不可”的错误，如果犯了“两可”的错误（而事实上至少得否定一个），则是违反了矛盾律，如果 犯了“两不可”的错误（而事实上要求至少肯定一个），则违背了排中律。

关于矛盾律和排中律的情况，这个例子可以帮助大家区分清楚，同样是 矛盾关系的命题下，必须一真一假的情况下，怎么样是违背了排中律，怎么样就是违背了矛盾律，想必大家应该清楚了。至于例句中并所说的“统治者对犯罪的惩罚 不能叫做镇压”这个理由，是属于转移论题了，是违背了同一律。这个例子我讲完了，大家对照一下自己的作业，看看有没有错误的地方，错在哪里了。

阳光看出自己错在哪里了吗？

李后主: 钱不求：
丙犯了逻辑错误，主要是转变话题的错误。偷换概念。
甲乙是相互矛盾的关系，不能同时为假。

不求同学看出了不能同时为假，但是却没有明白如果有人让二者同时为假的话则是犯了违反排中律的错误。

阳光说丙违反了矛盾律，此处不是违反了矛盾律，而是违反了排中律。

李大雄: 丙违背了排中率，而不是矛盾率。

李后主: 是啊，大雄说对了。
这个问题，大家看明白的话，我们看下一个问题。

李后主: 大家要说话啊，这个问题弄明白了吗？我退出了吗？还是在线？为什么没有人说话？

辛言: 看明白了，矛盾律不能同时肯定，必须否定一个，排中律不能同时否定，必须肯定一个。

李后主: 我都以为我掉了。好的，看下一个问题吧！

【思考题2】
甲：“我们班所有的同学都三退了。”
乙：“我们班所有的同学都没有三退。”
丙：“你们俩都说错了。”
请问：丙是否犯了逻辑错误？
大家把这道题做一做吧！

蓝睿: 服务器不好用，有点跟不上。

李大雄: 丙没有犯逻辑错误，如果班上可以只有部分人三退，丙的结论就是正确的。

李后主: 张华虎的作业
答：丙可能没有犯逻辑错误。甲乙所言为互为反对关系的两个命题。二者不能同真，却可以同假。

赵阳光: 丙没有犯逻辑错误。假设事实是“我们班的一部分同学三退了”，则甲乙两人的说法都有错误，丙的说法就是成立的。丙的说法符合了矛盾律中“相互反对的两个命题之间不能同时为真，但可以同时为假，其中必有一假”的逻辑要求，没有犯逻辑错误。

李后主: 这个问题是考察丙有没有犯逻辑错误，因为甲乙两个人说的话互为反对关系，必有一假，也可能都是假的。那么，丙的话是可能中的一种情况，因此没有犯逻辑错误，但是却有可能犯了事实上的错误。
逻辑错误就是出现了逻辑上的不可能，只要逻辑上有可能，就没有犯逻辑错误。
比如中共可能在09年垮台，这个推论不会犯逻辑错误，因为这种可能性是存在的，但是有可能会犯事实上的错误，因为中共今年要是不垮台的话，这个推论就错了。

我们这里研究的是逻辑错误，大家懂得了各种逻辑错误的表现，那么说话和写作中的逻辑性就加强了。

李后主: 4，请列举一个犯了模棱两可错误的例子。

这也是让大家举一个犯排中律错误的例子。模棱两可就是两不可的意思，混淆了两端之间的界限，没有一个明确的态度。

赵阳光: 甲：你认同让孩子小时候上各种培训班吗？
乙：我说不清楚？
甲：那你的态度是反对吗？
乙：我也说不清楚。

李后主: 阳光的这个例子很好。模棱两可就是这种情况，需要他明确表态时，模模糊糊不表态。

张华虎的这个例子也很有意思：
沙漠绝境中，一和尚、一屠夫，一县官。偶遇一小羊，屠夫要杀羊活命，和尚反对杀生。县官则说，你们两个的意见，我都反对。——县官犯了模棱两可的错误。

赵阳光: 这样就成了也反对杀羊，也反对不杀羊。

李后主: 欧阳静雪的作业
甲:你们那边治安还好吧?
乙:应该还好吧~~
甲:听说你们那边民警冲突?
乙:好像是的

李后主: 大家看看欧阳同学的这个例子是什么情况

欧阳静雪: 4，请列举一个犯了模棱两可错误的例子。
甲:你们那边治安还好吧?
乙:应该还好吧~~
甲:听说你们那边民警冲突?
乙:好像是的

李后主: 是不是模棱两可的例子？

张玉: 是。

赵阳光: 是矛盾，不是模棱两可。

李后主: 呵呵，张玉终于看到一个能回答了的问题了，结果还是回答错了。
阳光说对了，以上欧阳所举的例子中的对话是犯了自相矛盾的错误。

李后主: 我们把欧阳静雪的例子改一改，看看能不能改成一个犯模棱两可错误的例子。

张玉: 是不是把民警改成“警民”？

蓝睿: 甲：你看过九评后对中共的感觉是好是坏。
乙：我不知道。

李后主: 甲:你们那边治安还好吧?
乙:不能说不好吧~~
甲:那么是好了?
乙:也不能说好吧！

李大雄: 甲:我们那边治安好，警民关系融洽。
乙:我们那边治安不好，常发生警民冲突。
丙：你们二个说的都不对。

李后主: 大雄改的也不错。

李后主: 蓝睿举得例子也符合要求，也是模棱两可的情况。

李后主: 大家的例子互相参照起来，各自的思维方式都可以互相补充和提高了。

赵阳光: 甲:你们那边治安还好吧?
乙:应该还好吧~~
甲:那样还不错。
乙:也很难说。

李后主: 阳光的，我再改改
甲:你们那边治安还好吧?
乙:应该还不错吧~~
甲:那就是很好了。
乙:不过，这也很难说。

那么，我们这个问题就先说到这里，看看下一个问题，比较难的。
【思考题3】
请问下面两句话是否犯了逻辑错误？如果犯了逻辑错误，是什么错误？
A假如“天打雷就下雨”为假，则“天打雷没下雨”也为假。
B要说如果天打雷就下雨这不对，但是要说天打雷却不下雨恐怕也不正确。
C假设“我们班的一些人三退了”为假，则“我们班的一些人没有三退”也为假。

一个一个来看，先看看A。

欧阳静雪: 请问下面两句话是否犯了逻辑错误？如果犯了逻辑错误，是什么错误？
A假如“天打雷就下雨”为假，则“天打雷没下雨”也为假。
矛盾的命题，根据排中律，两者不能同时为假但可以同时为真其中必有一真,也就是天打雷要么是下雨了,要么就是没下雨.
B要说如果天打雷就下雨这不对，但是要说天打雷却不下雨恐怕也不正确。
对
C假设“我们班的一些人三退了”为假，则“我们班的一些人没有三退”也为假。
下反对关系，不能同时为假，但可以同时为真，其中必有一真.或者是只有一部分人三退了

李后主: 欧阳同学先别忙。先跟着我的思路来一点一点的分析这个句子。

李大雄: “天打雷就下雨”，“天打雷没下雨”，二者必有一真。如果说二者均为假，则犯了违反排中律的错误。

欧阳静雪: 哦

李后主: A句中一个复合命题和它的负命题的关系。

具体的说是充分条件假言命题和它的负命题的关系。那么充分条件假言命题的真假是当前件为真时看后件的真假。大家回顾一下以前学过的知识。

A 例中的前后两个命题分别是：“天打雷就下雨”（这是个简写的充分条件假言命题，完整的是“如果天打雷，就一定会下雨”）和“天打雷没下雨”（“天打雷了， 但是没有下雨”），后者是前者的负命题，正好是互为矛盾关系的两个命题，因此，如果同时否定二者，就犯了两不可的错误，违背了排中律。
这里需要注意的是充分条件假言命题的负命题不再是一个充分条件假言命题，而是一个联言命题。"天打雷就下雨"这是一个充分条件假言命题，而“天打雷没下雨”这是一个联言命题，后者是前者的负命题。后者是对前者的否定。但是B句的情况和A句的不一样。

以上的讲解大家看明白了吗？关于A句的讲解大家看明白了吗？

蓝睿: 看明白了。

赵阳光: 明白

李后主: 我再补充一下“天打雷没下雨”等价于“虽然天大雷了，但是没有下雨。”这是一个联言命题。那么。我们看看B句。

B例中的前后两个命题分别是：“要说如果天打雷就下雨这不对”（如果天打雷，就一定会下雨。这句话不对。）和“要说天打雷却不下雨恐怕也不正确”（如果天打雷，就一定不会下雨。这句话也不对。）注意，括号中对前后两句话的等效表达。

大 家注意，前后两个命题都是充分条件假言命题。看括号中前后两句话的等效表达，前者是对“一个充分条件假言命题的肯定句”的否定，后者是对“一个充分假言条 件命题的否定句”的否定，充分条件假言命题的肯定句和否定句之间不构成矛盾关系，而应该是反对关系，在反对关系下，两个命题可以同时为假。

B句的实际情况中，前后两句话的确都可以为假，因为天打雷了，不一定就下雨，那么，就判断它一定会下雨，或者一定不会下雨，都可能是判断错误，都可能是假的。所以说，这个句子没有犯两不可的错误，没有违反排中律。

好了，大家看看，实际情况正是如此，大家仔细把B的原话琢磨琢磨，原话中的前后两句都是充分条件假言命题，都是讲了对它们二者的判断所发生错误的可能性。

还原回去，就是：
1，“如果天打雷，就一定会下雨。”这个命题是错误的。
2，“如果天打雷，就一定不会下雨。”这个命题也是错误的。
可见，对两个命题的真假做出的判断本身是正确的。所以，这两句话没有违背逻辑错误。
很多人一不小心就以为这两句话放一起是违背了排中律，是模棱两可，实际上却不是这种情况，我已经把真正犯模棱两可错误的情况在A中表现出来了。

赵阳光: 这个确实比较复杂

李后主: 大家看明白了吗？B是我从一本参考书上翻出来，这本教材上是把它当作犯了模棱两可错误的例子来举的，但是实际上作者在这里列举错误。

赵阳光: 命题是错误的，对命题的判断是正确的。

李后主: 一句话中它表达的是什么逻辑含义是需要我们用审慎的思维去分析的，分析错了，就会犯逻辑错误。
阳光，原话可见简单的表达成一个形式就是【这个命题是错误的，那个命题也是错误的】。
而红蓝两个命题的确是错误的，那么关于红蓝两个命题真假的判断就是对的啊！就是人家判断对了啊！

赵阳光: 是这样

李后主: 比如：“1＋1＝3，这是错误的；2＋3＝6，这也是错误的。”这两个对数学计算的结果的真假的判断本身是正确的。

张玉: 明白了。

李后主: 大家现在去看看B句中是不是对两个充分条件假言命题真假的判断？而这两个判断本身都是正确的。
判断1，【“如果天打雷，就一定会下雨。”这个命题是错误的。】
判断2，【“如果天打雷，就一定不会下雨。”这个命题也是错误的。】

辛言: 他指出了两个命题都是错误的，所以他没有犯逻辑错误。

张玉: 嗯
窦夸功: 对。

李后主: 所以人家说的很对，没有犯逻辑错误。我手上这本书的作业把判断1和判断2当作了后者是前者的负命题，当作了矛盾关系，我刚才讲了，不是矛盾关系，是反对关系。因此，这两个命题可以都假！本身也都是假的。

好 的，这下我相信大家都清楚了，那么我们看看C。这个很简单，我是为了帮助大家理解A，同时区别出B，构建了两个直言命题，构成了下反对关系。C的情况是 SIP和SOP两个命题构成的关系，我们知道这两个命题构成下反对关系，也就是说其中必有一真，不可能同时为假，但可以同时为真。那么C这句话把两个互为 下反对关系的命题同时否定了，也是犯了“两不可”的错误，违反了“排中律”。

从A和B的对比中，我们看到，要达到说话精确的逻辑性：1，必须思维上不犯逻辑错误，能辨别出复杂的逻辑结构；2，必须使用精确的语句来表达出来，在表达中不犯逻辑错误。

李大雄: 假如【“如果天打雷，就一定会下雨。”这个命题是错误的。】，则【“如果天打雷，就一定不会下雨。”这个命题也是错误的。】。
原题中加上了“假如......则.......”，这不就成了一个命题了吗？而二者之间没有这种联系。

李后主: 大雄说的对，如果按照你那样构建成一个命题，但还是一个假命题，因为两个互为反对关系的命题，必有一假，可以都假，因此前者错误，推不出后者错误，而前者正确，可以推出后者错误。

李后主: 好的，我们看看最后一个习题。
【思考题4】
请总结一下哪些情况的判断和选择不能中立？

李后主: 也就是必须是要明确选择一方的，不能模棱两可的时，一般有哪些情况。

欧阳静雪: 对待正与邪不能选择中立~

赵阳光: （1）正邪善恶的判断不能中立（矛盾关系）。如：你是否认同中共镇压法轮功？这时只能选择正或者选择邪，不可能既要正也要邪，也不可能既不要正也不要邪。
（2）性别选择不能中立（矛盾关系）。如：男孩和女孩之间，你更喜欢哪一方？这时如果认为“我哪一个都不喜欢”，这个人就有点问题；如果认为“我更喜欢不男不女的”，那就是十足的变态。

李后主: 欧阳说出了一种情况，就是正邪不两立，必须要选择站在哪一边，放弃正义的一边，就等于选择了邪恶。

辛言: 对与错的判断不能中立。

李后主: 是的，辛言也说出了一种情况，对与错。但是这个要具体一些，有些情况可以判断对错，有些情况不能判断对错。
而正与邪是在任何情况下都存在的判断，我们找这种判断。

窦夸功: 片状物的正面与反面不能中立（片状物不会直立的）

李后主: 窦夸功同学没有归纳出一种普遍的情况。

窦夸功: 真 善 美 与 假 恶 丑 也应该是绝对对立的吧

李后主: 我以前写过一篇文章《在法轮功问题上如何保持“中立”》
http://www.epochtimes.com/gb/7/4/25/n1689351.htm

其中专门论述了四种不能保持中立，必须做出选择，就是不能模棱两可的情况。

李后主: 1，道德原则不可以中立（善恶正邪不可以不分）

善恶的区分是人类社会得以生存发展的道德基础，什么是善、什么是恶，这不但是不能回避的重大原则问题，其判断的标准也更是不能被随意篡改和混淆的伦理根基。

2，法律裁判不可以中立（是非对错不可以不辨）

法 律是基于道德原则、以“多方立场”构建起来的调整社会关系的强制约束性制度，法律以条文的形式规定了一个社会成员不可以做什么、以及违禁以后将会得 到哪些强制性惩罚的一系列规则与警示，它是调整社会冲突、保证社会公平、维护社会稳定的纲领性原则。人们在社会关系中必然形成利益上的冲突，解决这些 冲突，判断这些冲突的是非曲直正是法律义不容辞的责任，如果法律在评判社会事件、解决社会冲突、约束人们恶性行为的过程中，也保持中立，而任由违法犯 罪活动毫无顾忌的到处蔓延，那么社会将如何正常运作呢？

3，履行社会责任不可以中立（社会道义不可以不问）

有一些社会责 任不是靠法律来规定的，而是由道义来规定的，这部份社会责任主要被赋予了公共知识份子。所谓的公共知识份子其实是个现代术语，在我国历史 上，知识份子必然是公共的，传统知识份子修齐治平，所学的学问就是治国平天下的儒家伦理学，就是要以替天行道、维护社会道义为己任。公共知识份子在制 定国家公共政策、抨击时政、针砭时弊、维护正义方面发挥着特殊的作用，是代表社会良知的最重要的一支力量。

窦夸功: 对法律裁判不可以中立 是非常认同非常认同的

李后主: 在社会事务中公共知识份子不仅不可以保持“中立”，而且应该始终站在道义的立场上，为社会伸张正义，维护社会公共利益。

另一方面，不是公共知识份子的普通百姓，在公共事务方面，基于道义的原则，也应该对为他们维护正义、争取权利的公共知识份子或者某个维权团体表示道义上的支持，在维护道义方面，也是不可能中立的。

4，维护国家利益不可以中立（国家利益不可以不顾）

李后主: 天下兴亡，匹夫有责。自古以来，无论是居庙堂之高，还是处江湖之远，爱国都是一个社会最普遍的情感。

国 家利益是大是大非的问题，是与个人的命运息息相关的重大利益问题，因此，爱国是每个国民必须履行的义务，在维护国家利益方面，只有维护者和出卖者、而 没有“中立者”。比如在外敌入侵时，有守土抗敌的英雄，有投敌卖国的国贼，即使是平民百姓，也都会在这场侵略与反侵略的战争中表明自己清晰的态度，以 自己力所能及的力量参与到这个重大社会事件中来，而不可能有对此不闻不问的局外人和“中立者”。

如果今天的中国人能知道这四个不能中立的原则，而在这四个领域选择了正义的正确的道义的祖国的一方的话，我们的中华就有希望了，事实上，今天的中国人民正确觉醒，越来越多的人开始做出了他们应该的选择。

窦夸功: 其实，邪党教育他们的党徒也是用了这个不能中立的原则的。比如：党性高于一切（党利益高于一切）。

赵阳光: 不能中立的领域，都是大是大非的原则性问题。

窦夸功: 可悲的是，现在邪党对国人的洗脑，就是用了这种绝对的方式来进行的。”非敌既友“”敌人反对的就是我们拥护的，敌人拥护的就是我们反对的“。

李后主: 邪党都是歪曲这些原则，党的利益取代国家和民族的利益。

窦夸功: 是的。用这种思想教育起来的年轻人都热血沸腾，愤青就是这种被欺骗煽动的年轻人。

李后主: 对，我讲的是大是大非的，最重要的几个不能中立的领域。还有很多不能中立的日常生活中的选择，就是一些二选一的情况，没有第三种选择的情况。比如，你到底明天去不去爬山？这只能选择去或者不去。

以上四个原则后面三个是逻辑上有中立的选择，但是道义上社会原则上不允许选择中立。

窦夸功: 哦，这个我想大家都理解透彻了吧。请老师继续讲下去吧。

李后主: 今天就讲这里了。

李后主: 希望大家逻辑思维能更进一步，眼界能更开阔一些，没有报名参与校刊任务的同学，有条件的请尽快报名参与，并进入收集资料阶段。

大家互道晚安！


第七章 逻辑学基本原理

第一节 逻辑学的四大基本规律

逻辑的基本规律也就是思维的基本规律，一般可以归纳为四类，分别为同一律、矛盾律、排中律、充足理由律。这些规律体现在思维所进行的任何一种推理或论证的过程之中，它们规范着我们的思维运动，使我们的思维体现出理性应有的正常状态，是不同思想之间的交流和沟通得以顺利进行的基础，因此把这些规律称为逻辑的基本规律。下面我们分别论述这些基本的逻辑规律的表现。

一，同一律

同一律的内容表达为：在同一思维进程中，每一个思想必须与其自身保持同一性。也就是说，在同一思维进程中，所用的概念、命题以及所表达某个思想必须具备确定性，不能在上下文中随意的变化其内容的规定性。公式表达为：“A就是A”。这里的A表达的是某个概念、命题或者某个思想。

1，概念的同一性

概念的同一性是指在同一思维进程中，某个概念必须具有确定的内涵和外延，不能在上下文中随意的改变一个概念的内涵和外延，使之出现“概念混淆”或者“偷换概念”的情况。

要保持概念的同一性就得学会精确的使用概念，一般来讲在使用概念中容易出错的地方存在四种情况：①集合概念和非集合概念的混淆，②普遍性概念与特殊性概念的混淆（或者可以叫做抽象概念与具体概念的混淆，这是由于不注意区分概念的不同抽象层次而导致的概念误用），③概念的广义用法与狭义用法的混淆，④概念的引申义所产生的问题。

关于第①种情况，我们在第一章的讲义中已经讲过，此处不再赘述。

第②种情况是指同一个词语在不同抽象层次具有表述不同的内涵和外延的功能，因此它实际上表述了不同概念，不注意这种情况下概念的区别，那么在哲学研究中就无法彻底领悟一个哲学原理的普遍性。这些词语大多是在哲学研究中出现的，常见的诸如“联系”、“物质”、“运动”、“变化”、“静止”……等等，都是同一个词语在不同抽象层次具有不同内涵和外延的一些概念。我们通过下列事例来加深理解。

【事例1】哲学原理告诉我们，事物都处在普遍联系之中，但是我和小明好久没有联系了，所以，事物并非都处在普遍联系之中。

在以上这个推理中，前提中的第一个“联系”是最抽象的概念，它表明了事物之间存在着相互作用或者相互影响的关系。宇宙中的任何事物都处在和其它事物的相互作用和相互影响之中，因此彼此之间形成一个相互作用和相互影响的网络。具体的两个事物之间有的是直接发生相互作用，有的是通过它事物间接发生相互作用，因此，可以推出任何两个事物都处在相互作用或者相互影响之中，这是一个基本的哲学原理。而第二个“联系”则是一个比较具体的概念，它表达的是人和人之间处在相互交往或者交流的状态之中（交往和交流是一种具体的特殊的相互影响或者相互作用的关系）。我和小明虽然好久没有相互交往或者交流了，但是我们之间却处在事物的普遍联系的网络之中，存在着不同层次不同范围的相互作用和相互影响（或者直接或者间接），所以我和小明处在普遍联系之中，哲学原理并没有错。以上这个推理的错误在于把同一个词语在不同抽象层次下表达的不同概念混为一谈，把普遍性概念和特殊性概念当作同一个概念来使用，违背了概念同一性的要求。

第③种情况也是同一个词语表达不同概念的情况。一些词语在表达概念时由于外延使用范围的不同，而有了广义和狭义的区分，产生了概念的广义用法和狭义用法的区别。比如我们最常见的“文化”一词就有广义和狭义之分，广义的文化是指与人的活动有关的一切事物和现象，分为物质层面、制度层面和精神层面，分别叫做物质文化、制度文化和精神文化，而狭义的文化则专指精神现象，我们平时讲的传统文化中的文化就是狭义用法，主要指精神层面的道德、信仰、价值观、思想体系等精神现象。再如“矛盾”也有广义与狭义的区分，广义的矛盾是指宇宙间事物普遍存在的对立统一关系，而狭义的矛盾则只是指对立的关系，不包括统一的关系。

概念的狭义与广义的区分主要是为了更精确的描述事物，以及在研究问题时的方便，它是在大致相同的抽象层次上基于不同范围的外延而划分的。

第④种情况是概念在长期的使用中内涵和外延发生转移的情况，演变成一种同一词语下概念的原义和引申义的关系。概念的引申义是在原有词义的基础上通过比喻的使用而产生的一种词义的新义，因此也就是产生了一个（或者几个）新的概念。比如“土壤”原义是指地壳中的表层固体颗粒状物质，后来引申为“良好的环境”、“产生一定问题的根源”等几个新义。再如“鉴”本义是镜子，后来引申为“可以作为警戒和教训的事情”。

在引申义的情况下，需要注意是一个原义对应多种引申义的情况，如以上的土壤的例子，这些不同的引申义实际上是不同概念，在使用中最容易出现混淆。

2，命题的同一性

命题的同一性是指在同一思维进程中，某个命题的内容和逻辑属性必须具备确定性，不能在上下文中随意改变一个命题的基本内容和其逻辑属性，使思维出现“自相矛盾”的情况。比如一个命题是肯定还是否定，一个命题所表现的内容是逻辑真值还是假值，在上下文中是不能随意改变的。命题的同一性其实就是下面要讲的矛盾律中揭示的逻辑规律，这里叫做命题的同一性，那里叫做不矛盾律，这个问题我们在下面再论述。

3，思想的同一性

思想的同一性是指在同一思维进程中，某一些命题联合起来所表达的某个主题思想必须具备确定性，在上下文中不能随意偏离这个主题思想的基本内容，使论述出现“转移论题”或者“偷换论题”的情况。

例如，我曾经听到过这样的一段对话。

甲：周星驰的电影虽然感觉不太正经，但实际上他的人品要比成龙好。

乙：我看周星驰不是什么好东西，还是成龙的人品好。

甲：周星驰在电影艺术中经常代表草根阶层说话，反映他们对生活的理想和追求，重要的是他敢于面对政治的压力，不拍马屁，敢于在电影艺术中讽刺中共的残暴统治。而成龙则经常屈服于中共，为中共粉饰太平。所以，成龙的人格不如周星驰。

乙：那有什么用啊，人家成龙挣的钱多。

在以上的对话中，本来是讨论周星驰和成龙谁的人品好（不是谁的电影好），结果乙在讨论中把问题转移到谁挣的钱多的领域，偏离了讨论的主题，这属于转移论题，违背了思想的同一性要求。

转移论题是党文化洗脑后的中国人民一个普遍的思维现象，表现为他们根本不是在探讨一个问题的真理性，而是随意发表意见和下结论，且不经过论证，一旦别人经过论证反驳后，他们马上会发表另外一个意见来“支持”先前的意见，而根本不管这两个意见在这个话题中有没有逻辑的关联性。

作业题：

1，列举一个普遍性概念（抽象概念）和特殊性概念（具体概念）混淆的推理例子。

2，至少找出一个可以区分出广义概念和狭义概念的词语，并指出它们的外延的划分范围。

3，至少找出一个词语被引申使用的例子，并指出词语的原义和引申义。

4，在你的生活中找一段转移论题的对话例子。

二，矛盾律

矛盾律（也就是不矛盾律），它表达的是在同一思维进程中，两个互相否定的思想（互相矛盾或者互相反对）不能同时为真，其中必有一假。公式表达为：“A不能是非A”。其中A通常表达的可以是一个概念、命题或者一个思想，而非A表示与A相对立（互相矛盾或者互相反对）的概念、命题或者思想。所以，我们可以通过概念、命题以及思想三方面来掌握矛盾律的要求。

1，概念方面

矛盾律要求在同一思维过程中，不能同时用两个互相矛盾或互相反对的概念指称同一个对象。不能说一个对象既是这样，又是那样，前后形成相互对立的概念。例如：“民主就是主权在民，人人平等，由人民来当家作主的政治制度”，“民主就是对一个阶级的内部民主和对另一个阶级的专政，人民民主就是人民民主专政”。在这个例子中，前后两个命题中关于民主的定义相互对立，也就是关于民主的概念是前后矛盾的。今天的中国人在这方面经常容易犯错误，他们所使用的一个事物的概念总是前后不一致，有时候甚至前后矛盾，但是他们自己不承认，他们会说思想是自由的，每个人对一个事物的“概念”都是不一样的，把思想的自由（社会权利）和遵守逻辑规律和思维规律（自然法则）混为一谈。（注意：这里面，他们有可能不知道什么叫做概念，把概念当作了观念的同义词。）

在概念方面违反矛盾律的要求也可以看作是一种违背同一律的情况，就是概念在使用过程中发生了转移，失去了对概念确定性规则的遵守，使转移后的概念和原来的概念成为全异的关系（相矛盾或者相反对的关系）。也就是说，违背了矛盾律必然违反同一律，而违反同一律不一定违反矛盾律。

回顾一下第一讲中的内容，概念的矛盾关系和反对关系是概念基本关系中的全异关系，前面同一性部分讲的抽象概念和具体概念的混淆属于概念真包含关系之间的混淆，广义和狭义的区别也可以划分到真包含关系之中，原义和引申义之间的差异则可能是交叉关系也可能是全异关系。而矛盾律中概念的方面只涉及概念的全异关系。

    2，命题方面（二者必须否定一个）：

在命题方面，矛盾律要求在同一思维过程中，对于两个互相矛盾或互相反对的命题不能同时都肯定，而必须否定其中的一个命题。这方面的基本知识，我们在前面讲命题部分时都讲过了，包括直言命题的对当关系中的矛盾和反对关系，以及复合命题的负命题与它的原命题之间的关系（矛盾关系）。

⑴相互矛盾的命题

相互矛盾的命题是指两个命题之间不能同时真，也不能同时假，而是必有一真，必有一假。以下是相互矛盾的命题：

“我们班所有的同学都捐了款”与“我们班的有些同学没有捐款”；

“中共是邪教”与“中共不是邪教”；

“他既是科学家又是教授”与“或者他不是科学家，或者他不是教授”。

“如果下雨了，路面就湿”与“下雨了，但是路面没有湿”。

“只有努力学习，才能考上大学”与“不努力学习，也能考上了学”。

⑵相互反对的命题

相互反对的命题是指两个命题之间不能同时为真，但可以同时为假，其中必有一假。以下是相互反对的命题：

“我们班的所有同学都捐了款”与“我们班的所有同学都没有捐款”；

“我们的这个同学没有捐款”与“我们班的所有同学都捐了款”；

“我们的这个同学捐了款”与“我们班的所有同学都没有捐款”；

矛盾律要求：凡是相互对立的命题（矛盾或者反对），我们必须否定其中的一个，而不能同时都肯定。

3，思想方面（不能自相矛盾，否则犯了“两可”的错误）

把概念和命题的部分结合起来，就形成了矛盾律对一段思想内容的逻辑要求，就是要求其主题在同一思维过程中不能出现前后相互对立的情况，或者对于前后相互对立的主题必须否定其中的一个，而不能出现都肯定的情况，否则就犯了“自相矛盾”或者“两可”的逻辑错误。以下是犯了自相矛盾错误的例子：

⑴中共在今年必然灭亡，当然也可能苟延残喘到明年。

⑵小王刚刚参加工作，还不到四年。

⑶一个中共党员说：“我从来都不关心政治，我只是个普通老百姓。”（既是中共党员，就是执政党，已经参与了政治，就不能说自己不关心政治，而且他也许只是普通党员，但却绝非普通老百姓。）

⑷过去几年，我国所有的适龄儿童都接受了义务教育，但是有些贫困地区的孩子由于资金缺乏，还需要交一些额外的费用。

⑸殃视说：“善心最终会修出一个杀心来”。

⑹既可以说世界上先有鸡，也可以说世界上先有蛋。

【思考题1】

甲：“所有的统治者都镇压人民”。

乙：“有的统治者就不镇压人民”。

丙：“你俩说的都不对，统治者对犯罪的惩罚不能叫做镇压。”

请问：丙是否犯了逻辑错误？犯了什么样的逻辑错误？

【思考题2】

甲：“我们班所有的同学都三退了。”

乙：“我们班所有的同学都没有三退。”

丙：“你们俩都说错了。”

请问：丙是否犯了逻辑错误？

4，关于辩证矛盾和逻辑矛盾的区别

以上我们讲的矛盾是逻辑矛盾，就是我开头讲广义概念和狭义概念时举过的例子中所说的狭义矛盾的情况，它仅仅表明一种对立和冲突的关系，而辩证矛盾则表示既对立又统一的一种关系，所以可以视为广义的矛盾。辩证矛盾是事物存在的基本状态，是一种客观的规律，是普遍存在的，不能被人为的改变的，而逻辑矛盾则是人们思维中主观所犯的思维错误，是可以被纠正的。辩证矛盾的例子如下：

光以及所有微观粒子都具有波粒二象性，既有连续性又有离散性。

运动就是物体在同一瞬间，既在同一个地方，又不在同一个地方。

生命运动既是同化的过程，也是异化的过程，是同化和异化的对立统一过程。

三，排中律

排中律表达的是在同一思维进程中，两个互相矛盾或者具有下反对关系的思想不能同时为假，其中必有一真。公式表达为：“或者A或者非A”。其中A通常表达的可以是一个概念、命题或者一个思想，而非A表示与A互相矛盾的概念、命题（或者互为下反对关系）或者思想。同样，我们可以通过概念、命题以及思想三方面来掌握排中律的要求。

   1，概念方面：

排中律要求对任一对象，或者用A这一概念去反映它，或者用非A这一概念去反映它。而不能同时用两个具有矛盾或反对关系（在概念的基本关系中没有下反对关系）的概念指称同一个对象。在概念方面，它和矛盾律的要求是基本一致的，都可以看作是同一律对概念的基本要求中的一种特殊情况。例子见前面矛盾律部分。

    2，命题方面（二者必须肯定一个）：

排中律要求在同一思维过程中，对具有矛盾关系和下反对关系的命题不应该都否定，而必须肯定其中一个是真的。

⑴相互矛盾的命题

相互矛盾的命题是指两个命题之间不能同时真，也不能同时假，而是必有一真，必有一假。

（举例略，见前面矛盾律部分）

⑵具有下反对关系的命题

具有下反对关系的命题是指两个命题之间不能同时为假，但可以同时为真，其中必有一真。以下是具有下反对关系的命题：

“我们班的一些人三退了”和“我们班的一些人没有三退”。

“我们班的一些人三退了”和“我们班的小张没有三退”。

“我们班的一些人没有三退”和“我们的小刘三退了”。

3，思想方面（不能中立，否则犯了“两不可”的错误）

把概念和命题的部分结合起来，就形成了排中律对一段思想内容的逻辑要求，就是要求其主题在同一思维过程中，在没有中间选项的二选一的情况下（具有矛盾关系或者下反对关系的主题）不能既否定这个，又否定那个，而必须选择一个，即必须肯定一个情况。违反排中律的要求就会犯“模棱两可”（也就是“两不可”）的错误。所谓的“模棱两可”是指对事物的认识这样也可以，那样也可以，含含糊糊，没有一个明确的态度或主张。以下是犯了“模棱两可”错误的例子：

⑴甲：你准备好参加明天的登山活动了吗？

乙：我没想好。

甲：那你是不准备参加了？

乙：我也没有想好。

⑵甲：听说昨天你那里雷打得好响啊，下雨没有？

乙：好像下了点。

甲；才下了一点？

乙：好像又没下。

⑶《射雕英雄传》中的片断

【陆冠英心中一动，想起她曾出过那点头摇头的主意，说道：“小姐，你若是嫌弃陆某，那就摇摇头。”此话说罢，心中怦怦乱跳，双眼望着她一头柔丝，生怕她这个千娇百媚的脑袋竟会微微一动。过了半晌，程瑶迦自顶至脚，连手指头也没半根动弹。陆冠英大喜，道：“姑娘既然允了，就请点点头。”哪知程瑶迦仍是木然不动。陆冠英固然焦急，黄药师更是大不耐烦，说道：“又不摇头，又不点头，那算甚么？”】

此时，程瑶迦自然是犯了两不可的逻辑错误，不能给出一个明确的回答，让黄陆二人烦躁和紧张，当然后来程瑶迦还是给出了一个明确的选择。【程瑶迦轻声道：“不摇头，就……就……是点头了……”这几个字细若蚊鸣，也亏得黄药师内功深湛，耳朵极灵，才总算听到了，若是少了几年修为，也只能见到她嘴唇似动非动而已。】

⑷甲：对于法轮功反迫害你怎么看待？

乙：我既不认为是正确的，也不认为是错误的，我保持中立，不发表意见。

（注：道德和是非评判中没有中立，或者是对，或者是错，必须有一个评判结果。）

⑸既不能说世界上先有鸡，也不能说世界上先有蛋。

【思考题3】

请问下面两句话是否犯了逻辑错误？如果犯了逻辑错误，是什么错误？

A假如“天打雷就下雨”为假，则“天打雷没下雨”也为假。

B要说如果天打雷就下雨这不对，但是要说天打雷却不下雨恐怕也不正确。

C假设“我们班的一些人三退了”为假，则“我们班的一些人没有三退”也为假。

【思考题4】

请总结一下哪些情况的判断和选择不能中立？

注意：概念之间的反对关系和命题之间的反对关系是不同的。命题之间的反对关系多是通过具有真包含关系的一些概念构成的命题之间形成的一种逻辑关系。

四，充足理由律

充足理由律表达的是在同一思维进程中，一个思想被确定为真应该具备一些什么样的逻辑条件，这些逻辑条件就叫做充足的理由。用公式表达为：A真，因为B真并且B能推出A。

在上述公式中，A表示一个被确定为真的论题，而B可以是一个命题，也可以是很多命题，它可以用来确证A为真，称为理由或者论据。A被确证为真是因为B真，并且B可以推导出A，所以B是A的充足理由。

充足理由律的两个逻辑要求

1，理由必须真实。理由不真实，就犯了理由虚假的错误。

有这样一个笑话：甲乙两人打架，甲把乙的鼻子咬下来了，乙把甲告到县衙，县官审案询问时，甲说是乙是自己把自己的鼻子咬下来的，县官说鼻子长在嘴巴上面怎么可能够得着呢？甲辩解道：他是站在板凳上咬下来的。

中共司法机构草芥人命创造了诸如“俯卧撑”、“躲猫猫”、“撞墙自杀”、“自焚升天”……等等许多虚假的理由来掩盖自己对中国人民犯下的惊天罪行。

2，理由与推断之间要有必然的联系。违反了这个要求，就犯了“推不出”的错误。

⑴论据和论题不相干

例如：

我智商低是因为我家太穷。

我学习不好是因为我的脑袋小，所以脑子不够聪明。

你们不要相信他的话，他因为偷窃被关过。

我们的产品深受用户欢迎，因为只有1％的投诉率，所以有99％的受欢迎率。

⑵论据不足

例如：

如果经常上网玩游戏，会影响视力，我不上网玩游戏，所以我视力不会下降。

你神色紧张，小偷一般都神色紧张，所以你一定是小偷。

英雄难过美人关，我难过美人关，所以，我是英雄。

如果下雨了，地面一定会湿，地面湿了，所以下雨了。

只有年满十六岁，才负刑事责任，那个学生年满十六岁了，所以，他要负刑事责任。

作业题：

1，请列举一个犯了自相矛盾错误的例子。

2，请做【思考题1】

3，请做【思考题2】

4，请列举一个犯了模棱两可错误的例子。

5，请做【思考题3】

6，请做【思考题4】


第八章 论证与反驳(纪要）

授课内容：《形式逻辑》第八章——论证与反驳
上课时间：2009年03月12日　北京时间晚8：30
上课地点：李后主教室
授课老师：李后主
到课老师：唐子
到课同学：窦夸功 張穀虛 麻生 贺大翔 曲婉蘭 轩辕精灵 张华虎 华变天 蓝睿 李大雄 赵阳光 水心澜 張香山 张玉 欧阳静雪 唐滨
到课同学人数：16人
纪要整理：張穀虛

李后主: 今晚是逻辑课的最后一章的内容。内容上传的较晚，可能很多同学准备得时间仓促了。
今晚的内容比较抽象，需要有很多事例结合着讲解，可是时间太紧，我还没来得及去分析很多的事例。只好先讲一讲原理，以后再慢慢完善。

那么好吧，我们从理论上看看论证和反驳是一个什么样的逻辑过程。

首先就是论证的含义和概念。什么是论证，因为以前的教材中都是把论证和证明是等价的，而且有的教材把论证当成是肯定性的证明，而反驳当成是否定性的证明，这些观念我都认为有问题，所以都进行了修正。

我们从我们汉语的词汇蕴涵的意思去分析，论证中有一个论字，那就是和语言逻辑有关的证明方法。而证明的意思则是通过某种“证实”的方法而使道理明晰，那么证实的方法中就可以分类，论证是其中的一种证实道理的方法，而还有“实证”（通过实践去证明）也是一种证实的方法。
我们平时说的证明和证实，这两个词的意思比较接近。

赵阳光: 论证是通过逻辑去证明，实证是通过事实来证明。

麻生: 证明一词，在数学的逻辑中常用。

李后主: 证而明，证而实，就是通过“证”使道理明晰，或者通过“证”找到实在的道理。

李后主: 阳光，实证是通过实践去证明，这里面又可分为内证和外证。

窦夸功: [证而明，证而实，就是通过“证”使道理明晰，]---->[我们平时说的证明和证实，这两个词的意思比较接近]

李后主: 证明可以分为实证（包括内证和外证）和论证。
实证就是用科学实验的观察分析方法（外证）或者修炼体悟的内省内证方法（内证）探求真理的过程；而论证则是通过逻辑的方法探求真理的过程。这就是证明，论证，实证三者的关系。

李后主: 实证和证实，不是一样的，这个要区分开来。实证是一种证明方法，而证实则是通过各种证明方法去追求那个实在，或者那个实在的道理。

麻生: 嗯，一字的前后顺序决定着表达的意思不同，区别很大。

窦夸功: 连中国人都不容易搞懂的，外国人能急白眼的。呵呵

李后主: 在这样一个概念体系中，证明的方法中才包含了修炼的这种方法。其实，我们中国的文字本身就是逻辑非常严格的。

赵阳光: 一个是名词一个是动词。

李后主: 一般人说神的存在怎么证明啊，他们说不能证明，那是在他们的证明的概念中，证明就是外实证和论证，缺少了内证。所以在他们看来神的存在是证明不出来的，而实际上是可以通过内证的方法证明出来的。

窦夸功: 如果[证实（证明）]是一种产品，[实证]就是生产[证实（证明）]产品的一种技术（方法）

李后主: 夸功的比喻比较贴切！

李后主: 数学中经常说证明那个定理啊，这个证明实际上是论证，但是论证也是证明的一种，所以数学中使用证明这个词本身是没有错误的。但是，不能证明当作论证的同义词。

赵阳光: 证明包括论证，但论证不等于证明。

李后主: 我们在逻辑学中学习论证的方法，其实就是一种逻辑方法，大家自己想想就清楚了，我们说的论证啊，反驳啊，哪一个不是逻辑的东西呢？而实证则是实践中去验证，那就不是逻辑方法了。

李后主: 好的，证明，论证，和实证（内证和外证），大家应该分得清楚了。

李后主: 那么，我们下面看看论证。
论证的定义：人们在思维过程中通过逻辑形式证明一个思想（观点）的正确性或者虚假性的过程就叫做论证。

窦夸功: “论”有理论的意思，所以“论”证通常是和思维、逻辑有关的。

李后主: 有些书中说论证是证明一个思想正确性的逻辑过程，而反驳则是证明一个思想的虚假性，其实，这种分法比较机械了，我们的论点本身就包含肯定性结论和否定性结论，比如这样的题目《关于什么什么不可能达到什么什么目的的证明》。
 比如《关于三峡工程不可建的论证》，这种论证本身就是证明三峡工程可建是个虚假的，不实的观点。

窦夸功: 我认为：论证是通过逻辑形式肯定一个观点（论题），而反驳是通过逻辑形式否定一个（对方的）观点（论题）。老师看我这种表述如何

李后主: 夸功，我就是要否定这种认识的。

李后主: 辩论中有正方和反方，都在论证自己的观点的正确，对方的观点的错误，那么能把正方当作论证过程，而反方当作反驳过程吗？正确的应该都是双方都在论证自己的观点的过程中同时反驳对方的观点。
因此论证和反驳不是靠一个观点的正反面来划分的，而是由论辨双方的论辨目的来划分的。

正确的应该是————双方都在论证自己的观点的过程中，同时反驳对方的观点。所以说，我们国内的这些教材中，对一些基本概念的理解本身都有很多问题，这样教学生学生学得就比较机械。

赵阳光: “论证是证明一个思想正确性的逻辑过程，反驳则是证明一个思想的虚假性”——这个说法是不符合事实的。说明一个思想是错误的，也需要一个论证的过程；一个说法是否在反驳另一个说法是相对而言的，对的批判错的是反驳，错的反对对的也是反驳。

李后主: 阳光说的好，我也正要说这个观点，正确和错误是通过论证的过程中体现出来的，不是前提性的就规定了的。

窦夸功: [关于三峡工程不可建的论证]，这个论题，要么肯定“三峡工程不可建”是正确的（肯定），要么否定”三峡工程不可建“是错误的（否定），所以我觉得老师说的教材上的说法不合适也是不合适的。（李后主: 夸功，你把一分为二误用了。）

赵阳光: 夸功，“关于三峡工程不可建的论证”这个题目，已经点明了作者的观点，就是“三峡工程不可建”，题目下的正文是对这个观点的证明过程。这个题目里面，没有包含“三峡工程可建”的观点。

張穀虛: 论证和反駁在證明過程中是一個系統的過程。

窦夸功: 同意[论证和反駁在證明過程中是一個系統的過程。]

李后主: 反驳就是对一个已有的论证过程的否定。反驳是相对于一个论证而言的，反驳和论证是一对对立统一的范畴，论证中的基本规律也就是反驳中的基本规律。
二，论证的结构
一个完整的论证过程包括论点、论据和论证方式（对论据的使用方式），这是论证组成的三要素。
这里面主要掌握，论证方式是指论点和论据的联系方式，即论证中的推理形式。

麻生: 这段内容需要大家通过写文章来不断的完善自己在这方面的逻辑能力。

李后主: 论据如何可以证明论点，这就需要论证过程中推理形式必须是符合逻辑规律的有效推理形式，它包含了我们以前学过的所有的大小逻辑原理和逻辑规律，如同一律、 矛盾律、排中律，演绎、归纳、类比以及它们内部的各种具体的逻辑推理形式，一个论证过程就是这些逻辑原理和规律的具体应用，并通过论证方式表现出来。

下面我们看看论证中的方法。
论证的方法包括两个层面的内容：从论据的使用方法上可以分为直接论证和间接论证；从逻辑推理形式上可以分为演绎论证、归纳论证和类比论证。我们以前学过的演绎推理，归纳推理，这里我们说的是演绎论证，归纳论证，二者还是有点区别的。

窦夸功: 演绎论证、归纳论证和类比论证，我认为三者的说服能力是逐渐递减的（以前的课没听，只是知觉判断）（李后主: 夸功，三者的说服力的关系可以作为一个研究项目去研究，希望你有兴趣的话去研究一下。）

李后主: 任何论证首先都是一个推理的过程，是推理的具体应用，但论证比推理更为复杂，而推理则是论证的工具，是使论证得以成立的逻辑保障。论证包含了推理，是各种 推理过程的综合应用。以前学的推理，都是为了我们在论证中使用的，真正的目的在于论证。而论证中如何使用好这些推理形式，并且不出现问题，则体现我们的逻 辑思维水平。

好的，下面我们看看具体的论证方法。

麻生: 是的，这就需要大家多实践，多写文章，才会进一步完善自己逻辑思维水平。

窦夸功: 回想今天下午看讲义，感受一下讲义中举的例子，我现在突然得出这个观点的：李后主: 任何论证首先都是一个推理的过程，是推理的具体应用，但论证比推理更为复杂，而推理则是论证的工具，是使论证得以成立的逻辑保障。

李后主: 直接论证————这种论证方法是最常见的，我们平时所见的大部分论证过程都是直接论证。
就是从论题出发，为论题的真实性提供直接的理由，用真实的论据直接证明论题的真实性。要明白什么是直接论证，我们看看间接论证就了解了。

间接论证————就是指利用与原论题相对立（相矛盾或者相反对）的命题（反论题），通过排除这些对立命题来确立原论题真实性的论证方法。间接论证一般又可分为反证法和排除法（又叫选言证法）。

我讲义中举的反证法的例子：
如果光没有质量，则光不会产生压力。
光产生了压力（事实论据），所以“光有质量”。

以上例子的完整逻辑结构为：
如果光没有质量，则光不会产生压力。
光产生了压力（事实论据），所以“光没有质量”是个假命题。
根据排中律，则它的矛盾命题为真，即“光有质量”为真。
―――反证法在数学中经常出现。我们上学时应该运用过很多了。

作业中也要求大家列举一个反证法的例子，大家有没有准备好的。

赵阳光: 例：如果共产党没有残害国家和人民，则不会出现“解体中共”的呼声。
现在“解体中共”的呼声很高，说明共产党残害国家和人民是真实存在的。

李后主: 阳光的例子不错！阳光的例子也是个省略结构，大家在使用省略结构时，一定要知道它的完整结构是什么，因为逻辑环节是体现在完整结构之中的。阳光的例子的完整结构：
如果共产党没有残害国家和人民，则不会出现“解体中共”的呼声。
现在“解体中共”的呼声很高，说明“共产党没有残害国家和人民‘是个假命题。
根据排中律，它的矛盾命题为真，即”共产党残害国家和人民“是真实存在的。

窦夸功: 因为科学无法证明神的不存在，所以说没有神是错误的。

張穀虛: 如果大雁不是侯鳥，它應該呆在北方過冬。
冬天大雁飛到南方去了，所以大雁是侯鳥。

李后主: 谷虚的例子也很好。反证法的例子其实是很多的。

看看这个方法————排除法（选言证法）就是在一个可以穷尽的选言命题中，确立其中的一个选言支为论题是，然后通过否定论题以外的其它选言支从而确定论题为真的一种证明方法。其实这种方法在我们论证中经常出现在有很多选项时的情况。

李后主: 比如现在讲解体中共的道路，大家在争论中提出很多道路，有人要证明自己的道路是正确的，可行的，那么就得通过把别人提出的道路都否定掉的方式来达到自己的 论证目的。还有在很多方案的选择中，也是这样，要证明自己的方案可行，就得把别人的方案否定掉，这都是选言证法的应用。

李后主: 下面我们看看另一个层面的论证方法，以论证中的推理形式来划分的论证方法。

李后主: ⑴演绎论证
演绎论证是从一般原理出发去推导个别性的结论，因此这种方法适用于理论论据的论证。

比如，看我讲义中的例子。
要论证“中国古代的朋党现象不是党文化”这个论题，则我们可以先构建一个基本的理论——”当且仅当具有马列主义世界观的各种思想意识形式才是党文化“，然后利用这个基本原理或者理论去推理，得出如下推理过程：
当且仅当具有马列主义世界观的各种思想意识形式才是党文化；
中国古代的朋党现象不具有马列主义的世界观；
因此，中国古代的朋党现象不是党文化。

顺便问一下，如果大家要反驳这个论证过程，应该从哪里去反驳？

赵阳光: 从“党文化中有朋党现象”这一点。

張穀虛: 找出黨文化下的意識形態與中国古代的朋党现象的思想不同。

轩辕精灵: 中国古代的朋党现象不是党文化

李后主: 谷虚，使用意识形式，不要使用意识形态。

張穀虛: 找出黨文化下的意識形式與中国古代的朋党现象的思想相同。（改）

窦夸功: 要反驳，从老师事先构建的基本理论[当且仅当具有马列主义世界观的各种思想意识形式才是党文化]来反驳。

李后主: 我问大家如何反驳上面这个论证过程。反驳吗，当然是不赞同这个观点，要寻找对方论证的可能的攻击点。

蓝睿: 找出具有马列主义世界观的各种思想意识形式但不是党文化的特例，就能证明。

赵阳光: 朋党也是党，因此朋党文化也是党文化。从这一点。

李后主: 好的，大家发言先到此为止。

李后主: 夸功是从构建的基本理论上开始寻找反驳的突破口的，这个基本思路是对的。因为上面的论证中，第2个前提是一个事实论据，古代朋党现象没有党文化，这是基本 事实，那时候还没有中共，哪来的党文化呢？所以这个事实推不翻，而推理形式是正确的，只能从第一个前提，基本的理论那里寻找反驳的突破口了。
蓝睿的思路也是如此。
谷虚的思想到底是想从事实论据上突破，还是想推翻第一个前提的基本理论，我还是没有看清楚。
阳光的思想就是直接去从新定义党文化这个概念了，当然这样去反驳也是一种方法，是更根源的方法，但是除非对方在基本的关键词的定义上出现问题，否则，这种反驳只会给自己带来问题。

通过上面的事例，我们把反驳的一些感性的东西也给大家展示出来的，我们继续看下面的内容。

赵阳光: 我用的是以前牛客人的方法，但自己知道这样是站不住脚的。

張穀虛: 找出黨文化下的意識形式與中国古代的朋党现象的思想相同。---這個是我的觀點，從事實論證出發，我發現我錯了。

李后主: 修改一下：【夸功是从构建的基本理论上开始寻找反驳的突破口的，这个基本思路是对的。因为上面的论证中，第2个前提是一个事实论据，古代朋党现象不具有马 列主义世界观，这是基本事实，那时候还没有马列，哪来的马列主义世界观呢？所以这个事实推不翻，而推理形式是正确的，只能从第一个前提，基本的理论那里寻 找反驳的突破口了。】因为第2个前提的谓项是马列主义世界观，不是党文化。

⑵归纳论证
归纳推理的特点是从个别到一般的推理，在论证过程中适用于事实论据的举例论证。

朋友，古人说过这样一句话：“君子不立于危墙之下”。当然这不是说君子贪生怕死，而是说君子决不应该去做愚蠢的牺牲品；所以古人又说：“良禽择木而栖，良臣择主而事。”
殷商末年，殷纣王腐败，人心所背，微子曾多次劝谏，纣王根本不听，于是微子又劝纣王的大忠臣比干不要对纣王抱什么幻想了，唯一的选择是远离他，以保自身。比干不听劝告，还要为纣王效力，结果被剖心而死。我们想想，比干这样死去，值不值得！
春秋时期，当越王勾践得势之时，范蠡也象当年的微子劝比干一样的劝说为勾践卖命多年的文种：还是离开的好，鸟尽弓藏啊，（这时范蠡自己已经逃离了）而文种并不相信这个忠告，最终被勾践逼杀。而明智的范蠡却做了富翁。
还有后来的韩非子和李斯，他们都趋之若鹜的到了秦国，可结果怎么样呢？一心为了秦国的韩非子只落得个被迫自杀的下场；为秦国效劳四十多年的李斯则更惨，被腰斩和灭族。
再 举个现代的例子：胡适是中国现代的文化巨子。他在1949年要离开北京的时候，他的小儿子胡思杜执意不走，说我没干过什么对不起共产党的事情，我怕什么？ 我不走。胡适夫妇没办法，就只好任其所选吧。胡思杜受欺骗，当时盲目的爱共产党，还曾经写信给胡适，说这边很好，劝父亲回来，说北京大学校长的位置还在等 着您呢。共产党也在不遗余力的“统战”胡适。当然胡适对共产党的本性的认识是毫不含糊的，他说：“我们早知道，在共产主义国家里，没有言论的自由；现在我 们更知道，连沉默的自由，那里也没有。”他当然不会自投罗网。到了1957年，在“反右派斗争”中，胡思杜就是理所当然的“右派”了。就因为他是胡适的儿 子，表现的再积极也不行。最后，胡思杜只有在绝望中上吊自杀了，只留下一篇凄凉文字作为历史的见证。
假如比干、文种听从了劝告，假如韩非子、李斯不去秦国，假如胡思杜当年也随父而行的话，事情又将是如何的呢？ “君子不立于危墙之下”，这又是一句多么意味深长的嘱咐啊。

 归纳论证的方法大家经常使用，我想是大家最喜欢也最熟悉的一种论证方法吧！

⑶类比论证
类比推理是从个别到个别的推理，期间省略了复杂的演绎或者归纳推理过程，在论证中适当使用可以起到一目了然的作用。

赵阳光: 归纳论证相对简单，用得比较多。

窦夸功: 归纳论证——归纳推理的特点是从个别到一般的推理，在论证过程中适用于事实论据的举例论证。
我认为，[一般]的结论的得出是[个别]的累计产生的，所以举的例子（[个别]）越多越有说服力

李后主: 归纳从逻辑结构上没有演绎那么严格，但是在实践中似乎更能打动人。

窦夸功: 归纳论证和类比论证一般比较具体，通俗易懂的。

李后主: 所以，这个说服力的问题啊，在实践中的说服力和我们从逻辑推理的严格的角度上看的似乎还是不一样，窦夸功同学如果要钻研这个问题，实践中的说服力，人们的心理是如何和逻辑形式形成一个结合点的，这个问题可就很大了，研究出来了估计也是学术前沿的成果了。

窦夸功: 老师的话让我很受启发。说服力和逻辑严密性不是一个概念。前者是效果，后者是过程。

李后主: 从实践效果上来看，我感觉归纳论证说服里最强，类比次之，而演绎似乎最不容易打动人。

窦夸功: 同意老师的观点。

李后主: 夸功终于知道说服力和逻辑严密是两回事了。这就是理性和感性的区别，人们接受一个事物不见得是通过理性来认识的，我想大多数人是喜欢感性认识的。

李大雄: 归纳论证的方法多采用的是不完全归纳，单从逻辑角度并不能有效证明论题的正确性，然而它却有着从心理学方面感染人的作用。

赵阳光: 说服力是一个动态的概念，无法从论证形式上说明谁更有用。归纳推理容易打动人，是因为这种方法可以让人的脑子少赚几圈，不用做复杂的思考，因为人都有一些图省事的倾向。（李后主: 阳光说的对！人们的接受力其实有一个习惯就是脑子转得越少，越容易接受。）

李后主: 感性是生活的需要，而理性则是通向真理的道路。我们经常讲要大家要理性思维，就是要大家学会分析文章中的理性的东西，提高自己，从而学会真正的搞学术研究。大雄就是太感性了，把我转贴的理性较强的资料当作什么不良的政治引导去质问了。

窦夸功: 在实践中，二者结合，效果会更好。

窦夸功: 呵呵，我可能与大雄师兄一反。我是从小受党文化影响极其深的人。所以当初看九评和解体党文化时一直是用理性思维思考的。

張穀虛: 正因爲不完全歸納法對感性的刺激作用，共產黨在信息封鎖的囯寨經常可以迷惑人心，比如説到腐敗，就說美國、歐洲許多國家都有腐敗。

李后主: 好得，我们看看下面一个问题，论证中的原则。

李后主: 这些原则就是我们平时所学的逻辑的基本规律和基本原理在论证的各个环节中的具体要求和体现。关于论题的规则——论题必须明确且论题必须保持同一，违反这条规则，就要犯“论题不明”或者“偷换论题”或者“混淆论题”的逻辑错误。

关于论据的规则
    ⑴论据必须真实
    违反这条规则，就要犯“虚假理由”的逻辑错误。
    ⑵论据的真实性不能依靠论题来证明
    违反这条规则，就要犯“循环论证”的逻辑错误。

关 于论证方式的规则——论证必须遵守各种推理形式的逻辑规则。违反这条规则，就会在论证过程中，使论据与论题之间没有推论关系，就要犯“推不出”的逻辑错 误。“推不出”的逻辑错误可能包括：“论据与论题不相干”、“论据不足”等逻辑错误。前面讲过，论证是各种推理的综合，大家看看论证过程中的从论题到论据 到论证方式的各个环节，都在体现着逻辑的各种基本规律的制约。

那么，关于论证的问题，我最后讲的是论证中的困难点。
1，理论的创立
在 论证中有一些道理是引用现成的，而很多时候则需要论证者自己总结一些道理，那么在讲道理时，道理不能清晰的讲透彻，不能做到没有逻辑漏洞，使道理的总结比 较粗疏，这样在利用这个道理进行演绎推理时，推出的结论就可能有偏颇，或者根本的错误。比如刚才我提问大家那个论证从那里去反驳，有同学首先就想到从第一 个前提的基本理论上去反驳。事实论据一般情况如果不是太失实的话，就没有留下多少反驳余地，而理论的表述则由于表述者理论功底与逻辑思维能力的差距而表现 出不同的状况，有可能会留下很多反驳的余地。所以，这是方面是实践中需要提高的一点！

2，事例的筛选
在进行举例论证时，该使用什 么的事实论据，需要精心的筛选，这个事例最好是具备单一的功能，就是能比较充分的支持了你的论题，而不能同时对论题的对立面也形成一定程度的支持，否则就 会给反驳方提供了机会。这是一个使用事例的基本的原则，如果选择最好的事例，这需要实际中去锻炼。

窦夸功: [不能同时对论题的对立面也形成一定程度的支持]，这句话说得极好！！

赵阳光: 那次我在论坛上举“邓小平的政治智慧”作为反驳刘因全的例子，就存在这样的问题，这个例子对对方的观点也有一定的支持。（李后主: 哈哈，你反应倒是瞒快的！）

李后主: 事例的选择也是很关键的，比如上次赵阳光批驳刘因全先生时，进行类比论证时把例子使用的非常不好，实际效果是帮了对方。

李后主: 3，类比中的划分
要想使用好类比论证，对两类事物的相似性就要做充分的研究，这是一个划分的功夫，怎样从各类现象中（特别是社会现象的比类是最难的）划分出充分相似的类别，是进行类比论证首先需要解决的问题，类比不当，会给反驳方留下有利的反驳机会。

李后主: 我想很多人在类的划分中的问题也是很突出的。划分其实是我们讲概念时和定义相联系的一个东西。要先划分了类别，才能下定义，归纳概念的内涵。所以这是一个思维能力的基础。

窦夸功: 类比有横向类比和纵向类比之分。而共匪就喜欢用纵向类比。比如说人民生活水平，就说解放后和改革后。比如说民主水平，就说文革期间和现在对比。其实这个是陷阱。

李后主: 说来说去，一切的问题其实都还是在基础的地方。划分，下定义，概念的使用。等等。

李后主: 夸功说的不错，共匪类比时是有意误导。

我讲课，说话，写文章，大家发现有什么特点，最明显的特点是什么？

唐滨: 千里之行始于足下。只有基础扎实了才能写出具有说服力的文章。

蓝睿: 逻辑清晰。

張穀虛: 老師的特點是：先下定義把概念講清楚再開始分析問題。

窦夸功: 我初步感觉是基本功扎实。

張香山: 邏輯性強，一環緊扣一環。

李后主: 就是先从划分开始，进行概念的规范和界定。比如今天这堂课，一开始先谈证明，论证，实证。把这几个概念说清楚了，再往下讲。

赵阳光: 有些像建金字塔，下面的基座很牢固，上面的塔尖就非常安稳。

窦夸功: 阳光师兄的比喻很好。

李后主: 整个讲义中涉及到的概念辨析，我都得仔细推敲，不断修改，直到前后之前没有逻辑漏洞了，才敢拿出来讲。不管我讲的前人讲过没有，但是因为我讲的逻辑上严谨，所以就敢推翻前人的一些结论。

欧阳静雪: 我缺的就是这个,以前写文章最讨厌写议论说明文体了~~

李后主: 这就叫做理性论证。我希望大家写文章也摆，反驳别人的文章也摆，都能从逻辑上构建严谨的体系，这样自然而然就能反驳成功。

李后主: 我希望大家写文章也罢，反驳别人的文章也罢，

李后主: 好，下面我们简单讲一下反驳！
前 面也提到过，反驳就是对一个已有的论证过程的否定。反驳是相对于一个论证而言的，反驳和论证是一对对立统一的范畴，论证中的基本规律也就是反驳中的基本规 律。但是比较论证而言，反驳还有自己特别的规律。论证和反驳是相对于两个对立方的观点而言的，这方在论证，它的对立方就是在反驳。而不是根据正确和错误划 分的。

所以论证和反驳从广义上来讲，都是一回事。————这个结论就是我推翻一般的逻辑教材上的观点的新看法。

反驳中的特殊规律
论 证和反驳的目的不同，论证是需要把一个论题的真实性通过逻辑形式证明清晰，需要通过论据和推理，因此是非常复杂的一个过程。而反驳的目的只需要证明被反驳 的论证过程有问题就可以了。因此，反驳的过程比论证简单，反驳可以通过反驳论据、反驳论证中的推理形式来达到对原论题的否定。

 反驳的基本方法：1，对比法；2，寻找逻辑漏洞法。

1，对比法
⑴在反驳事实论据时，可以通过真假的对比，让假的论据现形。
比如，在自焚真相的资料中，通过对比真烧伤病人的情况，证明了焦点访谈的节目中包裹严密的烧伤病人是造假现象。
⑵在反驳理论论据时，可以通过建立更完善的逻辑严谨的理论来对比出原论题的理论论据的缺陷。

对比法主要是反驳论据！

2，寻找逻辑漏洞法
在反驳论证方式时，可以通过寻找对方的逻辑漏洞来证明他的推理形式的错误。一个人在论证中可能犯各种逻辑错误，如“循环论证”、论据与论题不相干”、“论据不足”、“转移论题”、“理由虚假”……等等，这需要我们用清晰的思维把它们辨析出来。

最后，反驳中的问题还是由于自己的逻辑思维不严谨，自己犯了逻辑错误，而造成了无效的反驳。

李后主: 无效反驳的一些可能的形式，我在讲义中也列举了一些。如：
1，反驳了一个虚假的概念
2，反驳了一个虚假主题
3，反驳了一个虚假的逻辑属性
4，反驳了一个虚假的命题关系
5，反驳了一个正确的推理形式

那么，论证与反驳，谁胜谁负，其实就看谁的逻辑和理论水平高了，就像比武一样，武学书读得再多，也见的武功就高，就像王语嫣一样，头脑中装了一部武功百科全书，但是什么武功都不会。也不见得武功就高，所以，要通过理性的思考去锻炼出逻辑水平出来！

窦夸功: 举例：英国抗议者抗议温道：”剑桥大学怎么能和独裁者为伍？“
温家饱反驳说：“这种卑劣的伎俩阻挡不了中英两国人民的友谊”这个应该属于反驳了一个虚假的概念吧？

李后主: 夸功说的对，温混淆了概念！

赵阳光: 中共的人对外讲话是都是自说自话的，它们都不敢直面对方的问题。

李大雄: 把剑桥大学和独裁者的友谊转移成为了两个国家的友谊。

李后主: 人家反对的是独裁者，不是反对中国，温故意混淆这两个概念，反驳了一个自己设计的（因此是虚假的）概念。

华变天: 有些党魁们的逻辑能力还是有的,就是在党文化控制下,要说些连自己都不相信的话.

赵阳光: 以后温家宝如果不被判死刑的话，就给它的牢房里放本逻辑书看。這句话雖是说笑。确实中共并不是没有逻辑能力，而是做坏事或掩饰坏事时有意地去混淆一些概念 为自己言行自圆其说。当它们在自己的法律框架内欺压百姓时逻辑性是非常强地，有前提有结果，有因为有所以。而做了坏事被人置疑时就混淆概念了，前言不搭后 语、驴唇不对马嘴。

李后主: 好的，今晚我就讲这里了！

各位老師、同學互道晚安！


第八章 论证与反驳

前言 什么是证明

证明就是通过逻辑或者实验的方法使一个道理或者一个规律明晰起来的过程。证明可以分为实证（包括内证和外证）和论证。

实证就是用科学实验的观察分析方法（外证）或者修炼体悟的内省内证方法（内证）探求真理的过程；而论证则是通过逻辑的方法探求真理的过程。论证和实证的方法在实践中可以互相掺杂使用，论证中需要实证中的事实来作为论据的一部分，而实证过程中需要运用逻辑推理来进行可行性的分析。

本章我们主要探索关于论证的学问，就是学习“逻辑证明”过程中所蕴涵的基本规律和原理。论证其实就是充足理由律的具体应用过程，在其中也体现着形式逻辑的其它三个基本原理，也就是说充足理由律和同一律、矛盾律、排中律不是并行的四个基本规律，前者的内容中包含着后面的三个原理。

第一节 论证

一，论证的定义

论证的定义：人们在思维过程中通过逻辑形式证明一个思想（观点）的正确性或者虚假性的过程就叫做论证。

二，论证的结构

一个完整的论证过程包括论点、论据和论证方式（对论据的使用方式），这是论证组成的三要素。

1，论点也就是论题，是指通过论证要确立起来的主题，论题需要传达出的基本信息是——“要证明什么”。论题是一篇论文（或是一个论证过程）中的主题思想，在论证过程中必须要明确的表达出来，论题可以在论证的开头提出来，也可以在结尾总结出来。

比如：『马克思主义是否该全盘否定，不是根据他的只言片语，而是根据核心理论和主要理论及其逻辑基础。马克思主义的核心理论和主要理论都是错的，马克思主义的逻辑基础——辩证逻辑也是错的。因此，必须全盘否定马克思主义！』这个段落中论述的主题是“必须全盘否定马克思主义”，这也就是作者的基本论点。

2，论据也就是论证中的证据，它是用来支持和说明论点的，用以确证论点的正确性，论据所要传达的是——“用什么来证明”——的信息。论据一般可以分为事实论据和理论论据，事实论据是指一些已经被确认了的关于社会事实和自然事实的命题，而理论论据是指一些表述了基本的逻辑规律、科学原理以及伦理规范的命题。我们平时所说的摆事实讲道理，就是指要给出关于论点的事实论据和理论论据。

论据在实际使用中可以形成三种组织形式（论据的使用方式）：如先提出理论后摆事实论证；或者先摆事实后形成理论；或者一边摆事实一边总结归纳为理论（和文学课上的夹叙夹议有些类似）。论据之间如何组织是非常灵活的，根据论证需要而自由选取和组合。

3，论证方式是指论点和论据的联系方式，即论证中的推理形式。论据如何可以证明论点，这就需要论证过程中推理形式必须是符合逻辑规律的有效推理形式，它包含了我们以前学过的所有的大小逻辑原理和逻辑规律，如同一律、矛盾律、排中律，演绎、归纳、类比以及它们内部的各种具体的逻辑推理形式，一个论证过程就是这些逻辑原理和规律的具体应用，并通过论证方式表现出来。可见，论证方式所要解决的是——“怎样证明”——的基本问题。

三，论证和推理的关系

论证和推理之间的区别在于：

①推理是先有前提后得出结论，而论证是先有论题后寻找论据、组织论据；

②推理要求形式有效而并不要求前提为真，而论证则要求论据必须为真。

任何论证首先都是一个推理的过程，是推理的具体应用，但论证比推理更为复杂，而推理则是论证的工具，是使论证得以成立的逻辑保障。论证的结构与推理之间具有一定的相关性，一般来讲，论题相当于推理的结论，论据相当于推理的前提，论证方式相当于推理的逻辑形式。论证包含了推理，是各种推理过程的综合应用。

四，论证的方法

论证的方法包括两个层面的内容：从论据的使用方法上可以分为直接论证和间接论证；从逻辑推理形式上可以分为演绎论证、归纳论证和类比论证。

1，论据的使用方法

⑴直接论证

   直接论证就是从论题出发，为论题的真实性提供直接的理由，用真实的论据直接证明论题的真实性。它不需要借助于反论题做逻辑中介，也就是不需要通过反论题这一环节。

我们平时所接触的论证过程大多都是直接论证。

⑵间接论证

间接论证是指利用与原论题相对立（相矛盾或者相反对）的命题（反论题），通过排除这些对立命题来确立原论题真实性的论证方法。间接论证一般又可分为反证法和排除法（又叫选言证法）。

①反证法

反证法是通过确定与论题相矛盾的命题（反论题）为假，然后根据排中律（不能同假）的要求，证明原论题为真的证明方法。

确立一个命题为假的方法通常是先假设这个命题为真，然后推出一个自相矛盾的结论或者推出一个与事实相反的结论，从而证明了假设是错误的，则这个命题为假。

举例，要用反证法证明光有质量，思维过程如下：

“有质量的物质才会形成压力”（这是个基本前提，是个必要条件假言命题。）→“某物没有质量，则某物不会产生压力”（否定前件式的推理过程）。→转化为“光没有质量则光不会产生压力” →因为光有没有质量是需要证明的论题，我们用反证法假设光没有质量，则上述的命题又转化为一个充分条件假言命题“如果光没有质量，则光不会产生压力。”→最后使用事实论据（光产生了压力）来推翻这个假设。反证法如下：

如果光没有质量，则光不会产生压力。

光产生了压力（事实论据），所以“光没有质量”是个假命题。

根据排中律，则它的矛盾命题为真，即“光有质量”为真。

以上是一个完整的反证法推理过程，一般应用中，论证程序可以简化，把第二步和第三步合并，如：

如果光没有质量，则光不会产生压力。

光产生了压力（事实论据），所以“光有质量”。

   ②排除法（选言证法）

    选言证法一般是在一个可以穷尽的选言命题中，确立其中的一个选言支为论题是，然后通过否定论题以外的其它选言支从而确定论题为真的一种证明方法。

例如：

    对待历史文化遗产应采取批判继承的态度。对待历史文化遗产态度，或者是全盘继承，或者是虚无主义，或者是批判继承。全盘继承，不分精华和糟粕，不能推陈出新，不利于文化的发展，这种态度是不可取的。虚无主义，割断了历史，违背了文化发展的规律，同样不利于文化的发展。只有批判继承，去其糟粕，取其精华，才能促进文化的繁荣。

【后注：本来我不想使用这个很多参考书上都使用的这个例子，因为这种说法实在是没什么意思，可是我实在是感觉到心焦力衰，有不想支撑下去的感觉，也实在是没有精力继续在浩淼的网络中寻找有价值的例子。所以，就请各位同学原谅了。作为一个阶段的真实历史情况，就把这段话留在教材中了。】

2，论证中的推理形式

⑴演绎论证

演绎推理的特点是只要前提正确，根据正确演绎规律推演出来的结论是无可置疑的，它是从一般原理出发去推导个别性的结论，因此这种方法适用于理论论据的论证。

例如，要论证“中国古代的朋党现象不是党文化”这个论题，则有如下论证（充分必要条件假言命题的推理，否定前件式的推理）：

当且仅当具有马列主义世界观的各种思想意识形式才是党文化；

中国古代的朋党现象不具有马列主义的世界观；

因此，中国古代的朋党现象不是党文化。

第一个前提是阐述了一个基本的理论或者规律，接下来运用这个理论或者规律来推理得出所有论证的论题。

⑵归纳论证

归纳推理的特点是从个别到一般的推理，在论证过程中适用于事实论据的举例论证。

『事例：

君子不立于危墙之下

文／陈明

【明慧网二零零八年十一月三日】朋友，古人说过这样一句话：“君子不立于危墙之下”。当然这不是说君子贪生怕死，而是说君子决不应该去做愚蠢的牺牲品；所以古人又说：“良禽择木而栖，良臣择主而事。”

殷商末年，殷纣王腐败，人心所背，微子曾多次劝谏，纣王根本不听，于是微子又劝纣王的大忠臣比干不要对纣王抱什么幻想了，唯一的选择是远离他，以保自身。比干不听劝告，还要为纣王效力，结果被剖心而死。我们想想，比干这样死去，值不值得！

春秋时期，当越王勾践得势之时，范蠡也象当年的微子劝比干一样的劝说为勾践卖命多年的文种：还是离开的好，鸟尽弓藏啊，（这时范蠡自己已经逃离了）而文种并不相信这个忠告，最终被勾践逼杀。而明智的范蠡却做了富翁。

还有后来的韩非子和李斯，他们都趋之若鹜的到了秦国，可结果怎么样呢？一心为了秦国的韩非子只落得个被迫自杀的下场；为秦国效劳四十多年的李斯则更惨，被腰斩和灭族。

再举个现代的例子：胡适是中国现代的文化巨子。他在1949年要离开北京的时候，他的小儿子胡思杜执意不走，说我没干过什么对不起共产党的事情，我怕什么？我不走。胡适夫妇没办法，就只好任其所选吧。胡思杜受欺骗，当时盲目的爱共产党，还曾经写信给胡适，说这边很好，劝父亲回来，说北京大学校长的位置还在等着您呢。共产党也在不遗余力的“统战”胡适。当然胡适对共产党的本性的认识是毫不含糊的，他说：“我们早知道，在共产主义国家里，没有言论的自由；现在我们更知道，连沉默的自由，那里也没有。”他当然不会自投罗网。到了1957年，在“反右派斗争”中，胡思杜就是理所当然的“右派”了。就因为他是胡适的儿子，表现的再积极也不行。最后，胡思杜只有在绝望中上吊自杀了，只留下一篇凄凉文字作为历史的见证。

假如比干、文种听从了劝告，假如韩非子、李斯不去秦国，假如胡思杜当年也随父而行的话，事情又将是如何的呢？ “君子不立于危墙之下”，这又是一句多么意味深长的嘱咐啊。

前苏联的亚戈达是斯大林“大清洗运动”中以处死别人为专业的大红人，可是谁知他的下场也象被他处死的那些老布尔什维克一样悲惨；而且他的接班人叶左夫的结局也是一样；还有贝利亚等，以及在清洗中被杀害的接近两千万的苏共党员、苏联民众，不都是葬身于“危墙之下”的吗？

中共的头头们遭殃的更多，中共自己也一直吹嘘其党内斗争多么残酷。比如刘少奇一夜之间从国家主席被批成“叛徒、内奸、工贼”，直到悲惨的死亡。比如李立三、李达、彭德怀、赵紫阳，甚至于江青、陈伯达、姚文元、王洪文等等，等等，这些人他们的悲剧结局，不管他们给共产党做了什么，多么的“辉煌”一时，其结果都是一样的，都是悲剧。只要他选择了共产党，那么这种惨剧的发生就是必然的，就仅仅是个时间问题和形式的问题了。

中国人在一次又一次的政治运动中，在一次又一次的颠倒黑白、制造仇恨与血流成河的惨剧之中，不都是被绑架在共产主义的红色“危墙之下”的吗？在水灾中，在萨斯瘟疫中，在矿难车祸中、在爱滋病、肝炎、口手足病、禽流感之中，在地震中、在时刻都有被抢劫、打杀、偷盗的危险里，以及防不胜防的毒奶粉、毒大米、毒面粉、地沟油的重重包围之中，在瞒和骗、抢与夺、打与杀、恐怖与伪装的“中国特色的社会主义”社会里生活的我们，试问谁没在“危墙之下”呢？

那么，怎么办？很简单，那就是“君子不立于危墙之下”， 那就是赶快离开它，不要当比干、文种，更不能成了胡思杜。

良禽尚可择木而栖，良臣可以择主而事，我们为什么就不能择路而行呢？那么如何择路怎样而行呢？那就请让我们读读《九评共产党》这本旷世奇书吧，这样共产党的真相我们就会大白。』

以上这篇文章中，作者开门见山的给出了论题为“君子不立于危墙之下”，然后是对论题的解释说明。接下来是引用大量的事实论据来摆事实论证，其中运用了不完全归纳推理，通过引述从古到今大量的历史经验的教训，使论点的可靠性得以增强，起到了警示世人的作用，达到了论证的目的。

⑶类比论证

类比推理是从个别到个别的推理，期间省略了复杂的演绎或者归纳推理过程，在论证中适当使用可以起到一目了然的作用。

例如：辛灏年先生用满清的改革开放和中共的改革开放做类比，证明了中共的改革开放和满清有着特征上的相似，都是为了维护自己的统治而不愿意走向政治改良，因此最终都会被革命的风暴所淹没。

再如：用前苏联和东欧共产党垮台前的败象和今天中共的败象做类比，证明中共也正在解体。

五，论证的规则

   1，关于论题的规则——论题必须明确且论题必须保持同一

    违反这条规则，就要犯“论题不明”或者“偷换论题”或者“混淆论题”的逻辑错误。

    2，关于论据的规则

    ⑴论据必须真实

    违反这条规则，就要犯“虚假理由”的逻辑错误。

    ⑵论据的真实性不能依靠论题来证明

    违反这条规则，就要犯“循环论证”的逻辑错误。

    3，关于论证方式的规则——论证必须遵守各种推理形式的逻辑规则。

    违反这条规则，就会在论证过程中，使论据与论题之间没有推论关系，就要犯“推不出”的逻辑错误。“推不出”的逻辑错误可能包括：“论据与论题不相干”、“论据不足”等逻辑错误。

六，论证中的难点

1，理论的创立

在论证中有一些道理是引用现成的，而很多时候则需要论证者自己总结一些道理，那么在讲道理时，道理不能清晰的讲透彻，不能做到没有逻辑漏洞，使道理的总结比较粗疏，这样在利用这个道理进行演绎推理时，推出的结论就可能有偏颇，或者根本的错误。

2，事例的筛选

在进行举例论证时，该使用什么的事实论据，需要精心的筛选，这个事例最好是具备单一的功能，就是能比较充分的支持了你的论题，而不能同时对论题的对立面也形成一定程度的支持，否则就会给反驳方提供了机会。这是一个使用事例的基本的原则，如果选择最好的事例，这需要实际中去锻炼。

3，类比中的划分

要想使用好类比论证，对两类事物的相似性就要做充分的研究，这是一个划分的功夫，怎样从各类现象中（特别是社会现象的比类是最难的）划分出充分相似的类别，是进行类比论证首先需要解决的问题，类比不当，会给反驳方留下有利的反驳机会。


第八章 论证与反驳

第二节 反驳

一，定义

反驳就是对一个已有的论证过程的否定。反驳是相对于一个论证而言的，反驳和论证是一对对立统一的范畴，论证中的基本规律也就是反驳中的基本规律。但是比较论证而言，反驳还有自己特别的规律。

二，反驳的基本规律

1，和论证相同的规律

反驳和论证在大的范畴下都是一回事，都是一种“论证”（广义概念），只是相互之间构成了反对关系，一般讲的论证是肯定一个命题，而反驳则是否定这个命题，但是都算一种广义上的论证过程，因此论证所遵循的逻辑规律和原理，反驳也要遵循。

2，反驳中的特殊规律

论证和反驳的目的不同，论证是需要把一个论题的真实性通过逻辑形式证明清晰，需要通过论据和推理，因此是非常复杂的一个过程。而反驳的目的只需要证明被反驳的论证过程有问题就可以了。因此，反驳的过程比论证简单，反驳可以通过反驳论据、反驳论证中的推理形式来达到对原论题的否定。

例如：

08宪章背后有中共的鬼影。

某人支持了08宪章。

所以，某人是中共的鬼影。

以上这个推理过程中（把它可以看作是一个论证过程），要论证的论题是“某人是中共的鬼影”，但是其中的推理过程是无效推理，因此可以通过否定它的推理形式而否定这个论题。这是反驳中反驳论证方式的例子。

再比如：中共歪曲法轮功教人杀人自焚，并且制造出很多所谓的“事实”论据，我们只需要把这些所谓的“事实”否定掉就可以反驳到中共的这种侮蔑行径。这是反驳中反驳论据的例子。

以上是反驳的最简单形式，当然，反驳中也可以建立自己所认同的论题，这样反驳中就有了肯定的主题，驳论和立论就结合起来，反驳中同时也有了自己的肯定性论证过程。很多文章其实就是从一个反驳开始，通过反驳错误的观点，然后再建立起正确的观点和理论。

三，反驳的基本方法

1，对比法

⑴在反驳事实论据时，可以通过真假的对比，让假的论据现形。

比如，在自焚真相的资料中，通过对比真烧伤病人的情况，证明了焦点访谈的节目中包裹严密的烧伤病人是造假现象。

⑵在反驳理论论据时，可以通过建立更完善的逻辑严谨的理论来对比出原论题的理论论据的缺陷。

2，寻找逻辑漏洞法

在反驳论证方式时，可以通过寻找对方的逻辑漏洞来证明他的推理形式的错误。一个人在论证中可能犯各种逻辑错误，如“循环论证”、论据与论题不相干”、“论据不足”、“转移论题”、“理由虚假”……等等，这需要我们用清晰的思维把它们辨析出来。

四，反驳中的问题——无效反驳

反驳中由于反驳者本身的思维差距或者思维出现的错误，而导致了无效反驳，主要有以下现象：

1，反驳了一个虚假的概念

对于一个词语的概念，由于思维能力的差距，每个人的理解本身都有些差距。更由于概念在集合和非集合、广义和狭义、抽象和具体、以及引申意义等方面一系列的复杂表现，人们对概念使用方面也有很大的差距，在阅读时如果不能辨析清楚对方的词语在具体语境中所表达的概念的基本内涵和外延，那么在概念理解上就会产生很大的差距，就会对这个概念表达的观点产生误解，以自己所理解的概念去反驳对方的概念（对方的概念中本身不是这个意思），从而导致了反驳的无效。

2，反驳了一个虚假主题

没有抓住对方文章（或者思想）的主题思想，在概括别人文章的主题（论题）产生了偏离，这样反驳的就是一个自设的主题，也是一个虚假的主题，这就有点自言自语的味道了！

3，反驳了一个虚假的逻辑属性

没有辨析出对方语句中的逻辑属性。比如把可能性的联系当成必然性的联系去反驳；把必要条件假言命题的推理当成充分条件假言命题的推理去反驳；把否定属性的命题当作负命题去反驳……等等。

4，反驳了一个虚假的命题关系

没有辨析出对方语句中的命题之间的正确关系，如矛盾关系、反对关系、下反对关系等，没有辨析出对方是否违反了矛盾律或者排中律，而导致了对一个虚假命题关系的反驳。

5，反驳了一个正确的推理形式

如果一个推理形式本身是正确的，而由于反驳者没有辨析出来，而认为是错误的，那么反驳中也会构成无效反驳。

总结：

反驳和论证是相辅相成的，要想把反驳能力提高，关键的还是把握逻辑的基本原理和基本规律，提高对概念的理解力和对事物的精确划分能力。

作业：

1，请简单论证一下『 “暴力”与“谎言”是中共的两大统治支柱』

2，请写出一段有效的反驳，对下面这句段话中的论题进行否定。

『马克思的学说从逻辑上看非常严密，理论推导完美得无懈可击，仅仅因为这一点就征服了无数的知识分子。马克思学说的错误不在于其逻辑，而是在于其理论前提的偏狭与错谬。』

3，列举一个反证法的例子。

4，请找一个无效反驳的例子。